Différences

Ci-dessous, les différences entre deux révisions de la page.

Lien vers cette vue comparative

Les deux révisions précédentes Révision précédente
Prochaine révision
Révision précédente
avocats_sur_ubuntu [Le 20/03/2018, 17:33]
109.190.218.202 [Installation driver Clef]
avocats_sur_ubuntu [Le 21/03/2018, 09:51] (Version actuelle)
109.190.218.202 [Nouvelle Clef]
Ligne 24: Ligne 24:
 ===== Installation de la clef de sécurité ===== ===== Installation de la clef de sécurité =====
  
-==== Reconnaissance ​Clef ====+==== Reconnaissance ​matérielle de la clef ====
  
 Il faut [[:​tutoriel:​comment_installer_un_paquet|installer]] les utilitaires initialement requis (pcsc-tools) et pcscd qui sont complétés par libpcsc-perl. **[[apt>​pcsc-tools,​pcscd,​libpcsc-perl|pcsc-tools pcscd libpcsc-perl]]** Il faut [[:​tutoriel:​comment_installer_un_paquet|installer]] les utilitaires initialement requis (pcsc-tools) et pcscd qui sont complétés par libpcsc-perl. **[[apt>​pcsc-tools,​pcscd,​libpcsc-perl|pcsc-tools pcscd libpcsc-perl]]**
Ligne 32: Ligne 32:
 sudo pcsc_scan sudo pcsc_scan
 </​code> ​ </​code> ​
-La clé doit être listée dans le retour de commande. ​FIXME Sinon?+La clé doit être listée dans le retour de commande. Sinon, c'est qu'il y a un problème au niveau de la détection de la clef. Soit la clef est défectueuse,​ soit c'est le lecteur, mais vous ne pourrez pas aller plus loin dans l'​installation.
  
-==== Installation driver ​Clef====+==== Installation ​du driver ​de la clef====
  
 <note tip>Ici il est question de paquets pour architecture 64bits. Choisissez ceux correspondant à votre [[:​architecture materielle]]</​note>​ <note tip>Ici il est question de paquets pour architecture 64bits. Choisissez ceux correspondant à votre [[:​architecture materielle]]</​note>​
  
-=== Ancienne Clef ===+== Ancienne Clef ==
  
 Il faut installer le driver Gemalto **libclassicclient**. Néanmoins, celui-ci nécessite une dépendance plus ancienne que la version actuellement disponible dans les distributions GNU/Linux ; Il s’agit donc d’une faille de sécurité qui n’a pas été corrigée par Gemalto à ce jour, ce qui est très regrettable. ​ Il faut installer le driver Gemalto **libclassicclient**. Néanmoins, celui-ci nécessite une dépendance plus ancienne que la version actuellement disponible dans les distributions GNU/Linux ; Il s’agit donc d’une faille de sécurité qui n’a pas été corrigée par Gemalto à ce jour, ce qui est très regrettable. ​
Ligne 48: Ligne 48:
 <note important>​Respectez l'​ordre indiqué pour que l'​installation se déroule sans blocage.</​note>​ <note important>​Respectez l'​ordre indiqué pour que l'​installation se déroule sans blocage.</​note>​
  
-=== Nouvelle Clef ===+== Nouvelle Clef ==
  
 La nouvelle clé est une //IDGO 800// qui nécessite de nouveaux drivers. La nouvelle clé est une //IDGO 800// qui nécessite de nouveaux drivers.
   * Pour Ubuntu [[:​trusty|14.04]],​ vous trouverez **libidprimepkcs11_1.2.3_amd64** fourni que pour cette version [[https://​sharing.oodrive.com/​easyshare/​fwd/​link=fo_d2iYx2cA6_D6.4WvK9B|là]]. ​   * Pour Ubuntu [[:​trusty|14.04]],​ vous trouverez **libidprimepkcs11_1.2.3_amd64** fourni que pour cette version [[https://​sharing.oodrive.com/​easyshare/​fwd/​link=fo_d2iYx2cA6_D6.4WvK9B|là]]. ​
   * Pour Ubuntu 16.04, il faut [[:​tutoriel:​comment_installer_un_paquet#​installer_un_paquet_isole|installer isolément]] toute une série de dépendances disponible sur [[http://​packages.ubuntu.com/​|Ubuntu packages]]   * Pour Ubuntu 16.04, il faut [[:​tutoriel:​comment_installer_un_paquet#​installer_un_paquet_isole|installer isolément]] toute une série de dépendances disponible sur [[http://​packages.ubuntu.com/​|Ubuntu packages]]
-    - [[https://​packages.ubuntu.com/​trusty/​libboost-system1.54.0|libboost-system1.54.0_1.54.0]] +    - [[https://​packages.ubuntu.com/​trusty/​libboost-system1.54.0|libboost-system1.54.0]] 
-    - libboost-filesystem1.54.0 +    - [[https://​packages.ubuntu.com/​trusty/​libboost-filesystem1.54.0|libboost-filesystem1.54.0]] 
-    - libboost-serialization1.54.0 +    - [[https://​packages.ubuntu.com/​trusty/​libboost-serialization1.54.0|libboost-serialization1.54.0]] 
-    - libboost-thread1.54.0_1.54.0 +    - [[https://​packages.ubuntu.com/​trusty/​libboost-thread1.54.0|[libboost-thread1.54.0]] 
-    - libwxbase3.0 +    - [[https://​packages.ubuntu.com/​trusty/​libwxbase3.0-0|libwxbase3.0]] 
-    - libwxgtk3.0 ​+    - [[https://​packages.ubuntu.com/​trusty/​libwxgtk3.0-0|libwxgtk3.0]] ​
 <note important>​Respectez l'​ordre indiqué pour que l'​installation se déroule sans blocage.</​note>​ <note important>​Respectez l'​ordre indiqué pour que l'​installation se déroule sans blocage.</​note>​
  
Ligne 102: Ligne 102:
  
 == retour d'​experience == == retour d'​experience ==
-  * Cela a été le cas pour moi ([[:​utilisateurs:​kiceki]]) de 2012 à 2017.+  * Cela a été le cas pour moi ([[:​utilisateurs:​kiceki]]) de 2012 à 2018.
  
 ===== Problèmes connus ===== ===== Problèmes connus =====
Ligne 123: Ligne 123:
  
 ---- ----
-//​Contributeurs principaux : kiceki ​- kiceki[at]kopikol[dot]net //+//​Contributeurs principaux : kiceki
  
  • avocats_sur_ubuntu.1521563619.txt.gz
  • Dernière modification: Le 20/03/2018, 17:33
  • par 109.190.218.202