Différences

Ci-dessous, les différences entre deux révisions de la page.

Lien vers cette vue comparative

Les deux révisions précédentes Révision précédente
Prochaine révision
Révision précédente
calibre [Le 11/03/2015, 20:11]
L'Africain [Calibre]
calibre [Le 28/02/2018, 11:45] (Version actuelle)
bcag2 bascule des installations pour limiter les installations à partir du dépôt officiel !
Ligne 14: Ligne 14:
  
 Pour créer des [[:ebook]] vous pouvez choisir [[:​Scenari-Book:​]] ou [[:Sigil]], ou bien rédiger votre document avec [[:​LibreOffice]] et convertir votre fichier avec Calibre. Pour créer des [[:ebook]] vous pouvez choisir [[:​Scenari-Book:​]] ou [[:Sigil]], ou bien rédiger votre document avec [[:​LibreOffice]] et convertir votre fichier avec Calibre.
- 
-{{ http://​lh3.ggpht.com/​_lG58t3XWd3c/​Swsdjw8oNkI/​AAAAAAAAABU/​Rt_GKIaVfBw/​s800/​main.png?​400}} 
- 
  
 <note important>​ <note important>​
Ligne 28: Ligne 25:
 ===== Installation ===== ===== Installation =====
  
-<note important>​ [[http://​calibre-ebook.com/​download_linux|La page de téléchargement de Calibre pour Linux du site officiel]] déconseille d'​utiliser la version présente par défaut dans les distributions,​ celle-ci étant très en retard sur le développement du logiciel.+<note important>​ [[https://​calibre-ebook.com/fr/​download_linux|La page de téléchargement de Calibre pour Linux du site officiel]] déconseille d'​utiliser la version présente par défaut dans les distributions,​ celle-ci étant très en retard sur le développement du logiciel.
 De ce fait, nous recommandons fortement l'​installation depuis le binaire (nécessite GLIBC 2.10 ou supérieur, et xdg-utils et python ≥ 2.6 pré-installés).</​note>​ De ce fait, nous recommandons fortement l'​installation depuis le binaire (nécessite GLIBC 2.10 ou supérieur, et xdg-utils et python ≥ 2.6 pré-installés).</​note>​
  
-==== Depuis les dépôts ==== 
-Il vous suffit d'​[[:​tutoriel:​comment_installer_un_paquet#​paquet_present_dans_les_depots|installer le paquet]] **[[apt>​calibre|calibre]]**. 
- 
-Pour avoir une version plus à jour, vous pouvez utiliser aussi les dépôts [[getdeb]], ce qui évite de passer par le binaire. 
 ==== Depuis le binaire ==== ==== Depuis le binaire ====
  
-Le développement de **Calibre** est très actif et de nouvelles versions, qui corrigent des bogues et ajoutent de nouvelles fonctionnalités (ainsi que le support des dernières liseuses électroniques),​ sont fréquemment publiées. Pour installer la toute dernière version disponible, ​collez cette commande dans un [[:terminal]] :+Le développement de **Calibre** est très actif et de nouvelles versions, qui corrigent des bogues et ajoutent de nouvelles fonctionnalités (ainsi que le support des dernières liseuses électroniques),​ sont fréquemment publiées. Pour installer la toute dernière version disponible, ​rendez-vous sur la page officielle de téléchargement pour GNU/​Linux:​\\ 
 +[[https://​calibre-ebook.com/​fr/​download_linux]]
  
-<code bash>​sudo python -c "​import sys; py3 = sys.version_info[0] > 2; u = __import__('urllib.request' ​if py3 else '​urllib',​ fromlist=1); exec(u.urlopen('​http://​status.calibre-ebook.com/​linux_installer'​).read()); main()"</​code>​+ou bien, collez cette commande dans un [[:​terminal]] : 
 +<code bash>sudo -v && wget -nv -O- https://​raw.githubusercontent.com/​kovidgoyal/​calibre/​master/​setup/​linux-installer.py | sudo python -c "​import sys; main=lambda:sys.stderr.write('Download failed\n'); exec(sys.stdin.read()); main()"</​code>​
 Il vous suffira d'​appuyer sur entrée si vous souhaitez que le logiciel s'​installe dans /opt, sinon vous pouvez préciser un autre emplacement. Il vous suffira d'​appuyer sur entrée si vous souhaitez que le logiciel s'​installe dans /opt, sinon vous pouvez préciser un autre emplacement.
  
Ligne 46: Ligne 41:
  
 N'​oubliez pas d'​installer les dépendances comme c'est précisé plus bas. N'​oubliez pas d'​installer les dépendances comme c'est précisé plus bas.
 +<note important>​L'​installation des dépendances n'est nécessaire que pour installer Calibre depuis le code source.</​note>​
 ^Nom sur le site ^Nom probable du paquet| ^Nom sur le site ^Nom probable du paquet|
 |python| ​ python| |python| ​ python|
Ligne 72: Ligne 68:
 <code bash>​sudo apt-get install python python-imaging python-qt4 python-mechanize imagemagick xdg-utils python-lxml python-dateutil python-cssutils python-beautifulsoup python-dns libpoppler43 libpodofo* libwmf* python-chm libicu48 libmtp9 python-netifaces psutils python-cssselect</​code>​ <code bash>​sudo apt-get install python python-imaging python-qt4 python-mechanize imagemagick xdg-utils python-lxml python-dateutil python-cssutils python-beautifulsoup python-dns libpoppler43 libpodofo* libwmf* python-chm libicu48 libmtp9 python-netifaces psutils python-cssselect</​code>​
  
-En 14.04 : +Sous Ubuntu ​14.04 : 
 <code bash>​sudo apt-get install python python-imaging python-qt4 python-mechanize imagemagick xdg-utils python-lxml python-dateutil python-cssutils python-beautifulsoup python-dns libpoppler44 libpodofo* libwmf* python-chm libicu52 libmtp9 python-netifaces psutils python-cssselect</​code>​ <code bash>​sudo apt-get install python python-imaging python-qt4 python-mechanize imagemagick xdg-utils python-lxml python-dateutil python-cssutils python-beautifulsoup python-dns libpoppler44 libpodofo* libwmf* python-chm libicu52 libmtp9 python-netifaces psutils python-cssselect</​code>​
 +
 +==== Depuis les dépôts ====
 +Il vous suffit d'​[[:​tutoriel:​comment_installer_un_paquet#​paquet_present_dans_les_depots|installer le paquet]] **[[apt>​calibre|calibre]]**.
 +
 +Pour avoir une version plus à jour, vous pouvez utiliser aussi les dépôts [[getdeb]], ce qui évite de passer par le binaire.
 +
 ===== Utilisation ===== ===== Utilisation =====
  
Ligne 116: Ligne 118:
 ===== Voir aussi ===== ===== Voir aussi =====
  
 +  * **(fr,en)** [[https://​calibre-ebook.com/​fr|Site officiel de Calibre]]
   * **(fr)** [[wpfr>​Calibre (logiciel)]]   * **(fr)** [[wpfr>​Calibre (logiciel)]]
   * **(fr)** [[http://​liseweb.fr/​BLOG/​calibre-pour-creer-des-fichiers-epub-a-destination-du-iphoneipod-touch|Calibre,​ pour créer des fichiers .epub à destination du iPhone/iPod Touch]]   * **(fr)** [[http://​liseweb.fr/​BLOG/​calibre-pour-creer-des-fichiers-epub-a-destination-du-iphoneipod-touch|Calibre,​ pour créer des fichiers .epub à destination du iPhone/iPod Touch]]
   * **(fr)** [[http://​tutocalibre.free.fr|Tutoriels Calibre en français]],​ merci à Alixe et à tous les contributeurs du site   * **(fr)** [[http://​tutocalibre.free.fr|Tutoriels Calibre en français]],​ merci à Alixe et à tous les contributeurs du site
-  * **(en)** [[http://​calibre-ebook.com/​|Site officiel de Calibre]] 
  
 ---- ----
  
 //​Contributeurs : [[utilisateurs:​Bionet]] (l'​auteur).//​ //​Contributeurs : [[utilisateurs:​Bionet]] (l'​auteur).//​
  • calibre.1426101108.txt.gz
  • Dernière modification: Le 11/03/2015, 20:11
  • par L'Africain