Contenu | Rechercher | Menus

Pour faire fonctionner l'enregistrement du son pour Ubuntu Hardy

Solution facile

Si ça marche pas

Faire pareil que le lien ci-dessus, puis lors de l'étape "ensuite on double-clique sur l'applet "Contrôle de volume" puis dans le menu "Edition/préférence" on coche "Digital" et "Digital Input Source" et c'est tout !" et bien tout cocher puis activer dans l'onglet enregistrement mux et mux1, dans paramètres cocher Line in as output, et dans option, mettre Digital Mic 1

Si la solution ci-dessus ne fonctionne pas

Je n'ai pas du tout compris ce que j'ai fait mais maintenant le dell vostro 1700 a les micros qui fonctionnent !

Bon quelques infos sur la configuration de mon dell vostro

00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller

Sigmatel High Definition Audio CODEC

Ce que j'ai fait :

Ceci est peut-être facultatif ou inutile car ça tout seul ça marchait pas : Code:

sudo gedit /etc/modprobe.d/alsa-base

Tout à la fin rajouter

Code:

options snd-hda-intel model=dell-laptop position_fix=0

(et bien mettre position_fix=0 et non pas =auto car sinon le son ne fonctionne plus du tout !!! et ceci contrairement aux remarques dit par le gars dans le lien plus bas).

Ensuite grâce au lien suivant :

https://help.ubuntu.com/community/HdaIntelSoundHowto (vers No mic working, rest OK: After installing …)

J'ai pas tout fait ce qu'il a dit, mais seulement :

- aller dans la console taper : alsamixer

- avec les fleches droite gauche, aller sur "Front" et mettre la valeur à 94<>94 (avec les fleches haut bas)

- appuyer sur F4

-Pour le 1er <capture> mettre 100<>100 (je crois qu'il est ainsi par défault)

-Pour le 2ème <capture> à droite, mettre 93<>93.

-appuyer sur echap

-redémarrer l'ordi

-normalement c'est bon, la prise micro fonctionne ainsi que les 2 petits micros intégrés à côté de la webcam.

J'ai tellement bidouillé que j'ai peut-être fait d'autres choses, mais je crois que le fait de bidouiller l'alsamixer suffit.

A ce propos des tutos pour en savoir plus sur alsamixer : http://www.siteduzero.com/tuto-3-29400- … -noob.html

http://www.gentoo.org/doc/fr/alsa-guide.xml (vers le milieu de la page)

http://man.developpez.com/man1/alsamixer.1.php

Aussi si vous avez toujours des problèmes, vous pouvez aller voir dans Système > Préférences > Son et là, j'ai tout par défault sauf : Capture du son : ALSA : Advanced… et Pistes de mixer par défault Périphérique : HDA Intel (Alsa mixer).

Vous avez modifié alsamixer, et le son ne fonctionne plus

Voici la commande à entrer dans la console pour remettre la configuration d'alsamixer défaut :

alsactl restore

Autres commandes pratiques

Pour sauvegarder la configuration que vous avez réalisé dans alsamixer :

alsactl store

Faire fonctionner l'enregistrement du son via la prise micro

De façon générale, la bonne reconnaissance des périphériques audio (et donc des micro (intégrés ou micro casque) dépend davantage du modèle de carte son renseigné au noyau (via le module de son). Sur cette page (http://www.kernel.org/doc/Documentation/sound/alsa/HD-Audio-Models.txt) se trouve la liste des modèles que vous pouvez essayer en fonction du chipset de votre carte. Vous pouvez connaître le chipset en tapant alsamixer et en regardant ce qu'il y a en face de 'Chip'. Pour mon Dell Vostro 1700, j'ai une carte son HDA Intel 82801H (ICH8 Family) avec un chip SigmaTel STAC9205. On voit dans la liste en question que 3 modèles de carte sont supportés: dell-m42, dell-m43 et dell-m44. Pour tester, il faut ajouter la ligne dans /etc/modprobe.d/alsabase.conf : options snd-hda-intel model=dell-m44 position_fix=0

Pour mon Vostro 1700, c'était la dell-m44. Peut-être que ça change parfois. Ensuite, les réglages dans alsamixer pour régler les volumes peuvent aider, mais ce n'est pas la partie la plus touchy.

pour Ubuntu Juanty

Valable notamment si vous avez HDA intel STAC9205

- installation de KMix (le contrôleur de volume par défaut d'ubuntu semble parfois ne pas prendre en compte certains réglages avec HDA intel STAC9205 (à vérifier)).

- Réglage suivant :

[img]http://imagik.fr/uploads/62379[/img]

Remarques :

  • Cocher Mute sur Analog Loopback (sinon on entend le micro dans les hauts parleurs de l'ordi) ;
  • Cocher Mute sur Line in as Output (sinon ça n'enregistre pas sur le micro extérieur)
  • Dans Digital Input Source : Mettre Analog Inputs pour obtenir l'enregistrement du micro extérieur (Digital Mic 1 correspond aux micros intégrés).
  • S'assurer d'avoir coché Capture (sinon ça n'enregistre pas)
  • Régler Mux de manière à ce que les enregistrements ne soient ni trop faibles, ni trop forts.

Remarque :

1. il n'est pas nécessaire de lancer qtJackctl pour que ça fonctionne.

2. Voilà des réglages qui fonctionnent avec audacity (je n'en ai pas essayé d'autres depuis que ça marche avec le micro extérieur, mais avec ça pas de problèmes : Lecture ALSA Pulse ; Enregistrement : ALSA: HDA Intel STAC92xx Analog (hw:0,0)

Cf. http://forum.ubuntu-fr.org/viewtopic.php?id=319281

pour Kubuntu Hardy avec KDE 4

Menu K > Kmix

Cliquer sur Configuration > Configurer les cannaux > Tout cliquer pour que tout soit visible. Appuyer alors sur OK.

Ensuite, tout à droite pour Digital Input Source, il faut mettre Digital Input Source.

Pour le reste :

- Le curseur Mux et Mux2 peut-être tout en bas (cela ne change rien).

- Le curseur Digital doit être bien élevé (plus il est élevé plus l'enregistrement via le micro sera fort).

- Le curseur Capture 2 n'a pas d'incidence sur le micro (prise).

- Le curseur Capture doit être élevé (plus il est élevé plus l'enregistrement via le micro sera fort).

Ces tests ont été réalisés avec Audacity. Pour qu'il n'y ait pas de problèmes, j'ai du aller dans Edition > Préférences > et pour les périphériques Lecture et Enregistrement, j'ai du mettre ALSA:default.


dell_vostro_1700.txt · Dernière modification: Le 25/08/2010, 18:00 par 193.190.255.195
Le contenu de ce wiki est sous licence : CC BY-SA v3.0