Contenu | Rechercher | Menus
Selon les tags présents sur cette page, celle-ci est ancienne et ne contient plus d'informations sur une des versions supportées d'Ubuntu.
Apportez votre aide…

Dell XPS M1330

En un coup d'œil

Le tableau suivant récapitule la prise en charge du matériel de portable par les différentes versions d'Ubuntu. Il utilise les notations suivantes :

  • Fonctionne après config : Fonctionne après quelques manipulations
  • Fonctionne immédiatement : Fonctionne immédiatement
  • Pas testé : Pas d'informations disponibles
  • Ne fonctionne pas : Ne fonctionne pas
Version Installation Carte graphique Son Wifi Bluetooth Firewire Webcam Touchpad Raccourcis multimédia Autres
"Feisty Fawn" - 7.04 Live-CD Fonctionne après config Fonctionne après config Fonctionne immédiatement Pas testé Pas testé Fonctionne après config Fonctionne immédiatement Fonctionne immédiatement Fonctionne après config
"Gutsy Gibbon" - 7.10 Live-CD
04/2008: Machine livrée par Dell avec Ubuntu Gutsy préinstallé + CD officiel Gutsy joint =)
Fonctionne immédiatement Fonctionne immédiatement Fonctionne immédiatement Fonctionne immédiatement Ne fonctionne pas Fonctionne immédiatement Fonctionne immédiatement Fonctionne immédiatement Fonctionne après config
"Hardy Heron" - 8.04 Live-CD Fonctionne immédiatement Fonctionne immédiatement Fonctionne immédiatement Fonctionne immédiatement Ne fonctionne pas Fonctionne immédiatement Fonctionne immédiatement Fonctionne immédiatement Fonctionne après config
"Intrepid Ibex" - 8.10 64bits dev branch 8.04.1 updated to 8.10 dev Fonctionne immédiatement Fonctionne immédiatement Fonctionne immédiatement Fonctionne immédiatement Pas testé Fonctionne immédiatement Fonctionne immédiatement Fonctionne immédiatement Fonctionne après config
"Karmic Koala" - 9.10 9.10 Fonctionne immédiatement Fonctionne immédiatement Fonctionne immédiatement Fonctionne immédiatement Fonctionne après config Fonctionne immédiatement Fonctionne immédiatement Fonctionne immédiatement Fonctionne après config
"Maverick Meerkat" - 10.10 10.10 Fonctionne immédiatement Fonctionne immédiatement Fonctionne immédiatement Fonctionne immédiatement Fonctionne après config Fonctionne immédiatement Fonctionne immédiatement Fonctionne immédiatement Fonctionne après config
"The Natty Narwhal" - 11.04 64bits Live-CD Fonctionne immédiatement Problèmes avec le volume du micro Fonctionne immédiatement Fonctionne immédiatement Camera pas testée mais disque dur aucuns problèmes Fonctionne immédiatement Fonctionne immédiatement Fonctionne immédiatement Pas testé
"Oneiric Ocelot" - 11.10 32bits Live-CD Fonctionne immédiatement Fonctionne immédiatement Fonctionne immédiatement Fonctionne immédiatement Pas testé Fonctionne immédiatement Fonctionne immédiatement Fonctionne immédiatement Pas testé

Utilisateurs du Wiki possédant cet ordinateur, fonctionnel :

Cet ordinateur portable n'est a priori pas tatoué.

Installation

Vous pouvez également utiliser l'image disque (DVD) d'Ubuntu 7.10 Gutsy fournie par Dell qui résout plusieurs problèmes listés ci-dessous, et ensuite passer à Ubuntu 8.04 Hardy par le gestionnaire de mises à jour.

–>http://linux.dell.com/wiki/index.php/Ubuntu_7.10#Download_Dell_Ubuntu_Image

–>http://linux.dell.com/wiki/index.php/Ubuntu_8.04#Dell_OS_Factory_Recovery_8.04.1_DVD_ISO

Problèmes liés à la carte graphique NVidia GeForce 8400M GS

Depuis Oneiric Ocelot, le driver libre Nouveau supporte la 8400M GS pour la 2D et la 3D. Il ne devrait plus y avoir de problèmes et les informations suivantes sont par conséquent obsolètes

Lancer le Live-CD

Le pilote standard nvidia ne prend pas encore en charge cette carte graphique. Durant l'installation depuis le Live-CD, il faut donc utiliser le pilote vesa. Pour celà, il suffit de choisir l'option "Démarrer Ubuntu en mode graphique sans echec"

Le problème ne semble pas apparaître avec Gutsy : en démarrant Ubuntu depuis le Live-CD, le pilote vesa sera normalement utilisé. Après installation sur disque dur, le système proposera l'installation du pilote nvidia-glx-new via le gestionnaire de pilotes propriétaires.

Résoudre le problème durablement

Pour tirer parti des capacités de votre carte graphique, vous pouvez consulter cette page (conseillé), ou utiliser Envy, pour installer les derniers pilotes propriétaires.

Edit: Vous pouvez installer le package nvidia-glx-new qui est parfaitement fonctionnel sur cette configuration. Vous pouvez utiliser pour cela le "Restricted Drivers Manager" qui installera normalement pour vous le bon pilote pour assurer la compatibilité avec votre carte, ou alors bien sur utiliser Synaptic en sélectionnant le paquet "nvidia-glx-new", puis en tapant dans un terminal "sudo nvidia-xconfig"

Problèmes de surchauffe avec la Nvidia 8400GS M

La carte graphique Nvidia 8400GS M livrée avec les portables XPS m1330 est parfois défectueuse. En effet, la puce Nvidia chauffe de façon inhabituelle. Ce problème peut être réglé en mettant à jour le BIOS du portable, ou en installant le dernier pilote propriétaire pour la puce. Ce problème de surchauffe fait monter la température de la puce jusqu'à une température de 65°C sans qu'elle ne soit solicitée. Le problème est connu de Dell et peut vous proposer un remplacement de la carte mère (et donc de la puce graphique) si votre ordinateur est encore sous garantie et que des problèmes apparaissent.

Problèmes liés au pilote Nvidia et le taux de rafraichissement

Symptômes

Aprés l'installation des pilotes Nvidia, le taux de rafraichissement de l'écran reste bloqué à 50 Hz (au lieu des 60).

Le probléme existe sur Hardy.

Résoudre le problème

Editer le fichier /etc/X11/xorg.conf et rajouter dans la section "Device" :

    Option         "DynamicTwinView" "false"

La section "Device" devra donc ressembler à :

Section "Device"
    Identifier     "Videocard0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce 8400M GS"

    Option         "DynamicTwinView" "false"

EndSection

Sauvegarder et relancer le serveur X : CTRL + ALT + BACKSPACE. Maintenant le taux de rafraichichement doit bien etre à 60 Hz (Systeme → Préférence → Résolutions de l'écran)

Problèmes liés au controleur SATA Intel

(Aucun problème avec 8.04 Hardy, aucune manipulation nécessaire.)

Le problème se manifeste tout d'abord lors de l'utilisation du Live-CD (voir les symptômes ci-dessous). Il semble que le problème soit lié au controleur SATA Intel intégré (sans certitude).

C'est le module pour la gestion du lecteur dvd qui pose réellement problème. (il faut utiliser le module ata_piix pour le kernel 2.6.22) (Syx)

Le problème ne semble plus apparaître avec Gutsy et aucune manipulation particulière n'est nécessaire.

Symptômes

Lors du lancement du Live-CD, le chargement s'interrompt, et apparaît un texte ressemblant à celui-ci :

BusyBox v1.1.3 (Debian 1:1.1.3-3ubuntu3 (Built-in shell (ash)
Enter 'help' for a list of built-in commands.

/bin/sh: can't access tty; job control turned off
(initramfs) 

Lancer le Live-CD

  • Au menu de lancement du Live-CD, à l'aide de la touche F6, rajoutez l'option de lancement suivante :
break=top
  • Lancez le Live-CD (Touche Entrée)
  • Lorsqu'apparaît le message d'erreur (voir symptômes), tapez les commandes suivantes :
modprobe piix
exit

(Note : Le M sur un clavier anglais est sur la touche virgule/interrogation)

Avec certains kernels il faut charger le module ata_piix, donc :

modprobe ata_piix
exit
  • Le chargement se poursuit sans problème

Résoudre le problème durablement

  • Quand vous avez terminé votre installation à l'aide du Live-CD, ne redémarrez pas tout de suite. Ouvrez un terminal. Je suppose dans la suite que la partition où Ubuntu est installé est /dev/sda3, et que GRUB est installé dans le MBR (option par défaut), ou dans cette même partition. Tapez les commandes suivantes :
sudo mkdir target                                 # Création d'un point de montage
sudo mount /dev/sda3 target                       # Montage de l'install neuve
sudo chroot target                                # Changement de racine
sudo echo piix >> /etc/initramfs-tools/modules    # Ajout de piix dans les modules
sudo update-initramfs -u                          # MAJ de GRUB
sudo nano /boot/grub/menu.lst                     # Edition de la conf de GRUB
  • Le contenu du fichier /boot/grub/menu.lst apparaît dans la console. Descendez au niveau des entrées du menu GRUB. Repérez celle qui correspond à Ubuntu et supprimez la commande break=top si elle se trouve sur la ligne kernel. Votre entrée Ubuntu doit ressembler à ceci désormais :
title           Ubuntu, kernel 2.6.20-16-generic
root            (hd0,2)
kernel          /boot/vmlinuz-2.6.20-16-generic root=UUID=cb8927de-1b14-4e53-b4e3-d64c000bcc7d ro quiet splash locale=fr_FR
initrd          /boot/initrd.img-2.6.20-16-generic
quiet
savedefault
  • Tapez la commande exit. Vous pouvez maintenant redémarrez votre ordinateur.

Installation avec le CD alternate

L'installation d'Ubuntu Feisty est tout à fait possible avec le CD alternate. Après l'installation, il faudra cependant corriger les problèmes de la carte graphique et du contrôleur SATA. Pour cela on procédera d'une façon similaire aux sections précédentes, à savoir installer les pilotes graphique avec Envy, et charger le module piix (rajouter une ligne "piix" (sans les guillemets) dans /etc/modules).

Problème de son

Symptômes

La carte son est bien reconnue, le contrôleur de volume fonctionne correctement, mais le son n'est pas fort même s'il est au maximum.

Résoudre le problème

Il suffit de rajouter la ligne suivante à la fin du fichier /etc/modprobe.d/alsa-base.conf :

options snd-hda-intel model=dell-bios

Bien que n'étant pas la recommandation selon la documentation, model=3stack ou model=5stack fonctionne également

Edit: Fonctionne directement après installation de Ubuntu Gutsy Tribe 5.

Lecteur d'empreinte

Un "lsusb" doit vous donner la ligne suivante (entre autres):

Bus 005 Device 004: ID 0483:2016 Thomson Microelectronics Fingerprint Reader

Pour pouvoir utiliser ce lecteur d'empreinte, il faut installer Thinkfinger, comme expliquer sur ce lien : https://wiki.ubuntu.com/ThinkFinger

Comme indiqué sur le lien, il faut utiliser la version 0.2.2, car la version 0.3 ne permet pas encore (bug ?) de pouvoir utiliser le lecteur d'empreinte pour la fenetre de connexion ou pour sudo et gksudo.

note: lorsque gksudo est lancé, la fenêtre demandant le mot de passe ou l'empreinte via le lecteur n'apparait pas, cependant en passant son doigt enregistré sur le lecteur l'application se lance sans problème. Ceci est du à un bug connu de thinkfinger

Natty (11.04)

Il suffit d'installer thinkfinger-tools et libpam-thinkfinger

sudo apt-get install thinkfinger-tools libpam-thinkfinger

Et de lancer cette commande:

sudo /usr/lib/pam-thinkfinger/pam-thinkfinger-enable

D'utiliser tf-tools –acquire et tf-tools –verify pour ajouter une empreinte et vérifier.

Webcam integrée

(Aucun problème avec 8.04 Hardy, aucune manipulation nécessaire.)

La webcam integrée apparait bien via "lsusb" :

Bus 007 Device 003: ID 05a9:2640 Omnivision Technologies, Inc.

Symptômes

La commande suivante "dmesg | grep uvcvideo" renvoie des lignes similaires à celles-ci:

uvcvideo: Found UVC 1.00 device Laptop Integrated Webcam (05a9:2640)
uvcvideo: Failed to query (135) UVC control 1 (unit 0) : -32 (exp. 26).
uvcvideo: Failed to initialize the device (-5).

Le module qui gère la webcam n'est donc pas adapté à ce modèle, elle n'est donc pas fonctionnelle sous Feisty.

Le module intégré à Gutsy semble fonctionnel, malgré des problèmes de plantages sous certaines conditions.

Symptômes identiques sous Interpid.

Résolution

Le projet v4l-dvb nécéssaire au fonctionnement de la webcam se trouve maintenant sur http://linuxtv.org/

1. Téléchargez l'archive contenant les sources du projet dans votre dossier personnel:

wget http://linuxtv.org/hg/v4l-dvb/archive/tip.tar.gz

2. Décompactez-la:

tar -xvf tip.tar.gz

3. Placez-vous dans le dossier décompacté:

cd v4l-dvb*

4. Lancez la compilation:

make

5. Lancez l'installation:

sudo make install

Pour finir, redémarrez l'ordinateur (vous devriez voir la led de la webcam clignoter durant le démarrage). Lancez Ekiga ou Cheese pour vérifier que cela fonctionne (dans les paramètres, choisissez V4L2).

Carte réseau Ethernet

(Aucun problème avec 8.04 Hardy, aucune manipulation nécessaire.)

La ligne de "lspci" concernant la carte réseau est la suivante sous Feisty :

09:00.0 Ethernet controller: Broadcom Corporation Unknow device 1713 (rev 02)

Le module "tg3" devrait permettre de la supporter, cepandant je n'arrive pas à avoir du réseau via cette interface.

note: La DEL jaune indiquant l'activité réseau reste allumée en permanence, même en l'absence de connexion.

Le passage en 2.6.22 corrige le problème (Syx)

Pas de problème après installation sous Gutsy.

Wifi

Certaines versions du Dell XPS M1330 ont une puce de marque Intel (les chanceux :p), d'autres de marque Broadcom …

Pour connaître votre marque, tapez donc 'lspci | grep -i network', dans un terminal/console…

Broadcom

0c:00.0 Network controller: Broadcom Corporation BCM4328 802.11a/b/g/n (rev 03)

Comme nous le restitue la commande 'lspci', nous avons donc affaire au chipset BCM4328 … celui-ci n'est pas encore supporté par le pilote libre 'bcm43xx'.

Faites selon notre documentation bcm4328

Intel

Pro Wireless 3945

(Aucun problème avec 8.04 Hardy, aucune manipulation nécessaire.)

La carte wifi Intel® Pro Wireless 3945 802.11a/b/g fonctionne directement sans problème. Cependant, il arrive que le module propriétaire (installé par défaut par ubuntu et dans la distribution fournie par Dell) boucle et fasse augmenter la charge de la machine et empêche l'utilisation du Wi-Fi. Il n'est alors plus possible d'utiliser la commande rmmod pour désactiver le module. Il est préférable d'utiliser la commande modprobe -r qui semble mieux s'en sortir.

En cas de plantage du module propriétaire, la solution consiste à utiliser le module libre iwlwifi :

  • Aller dans Système > Administration > Gestionnaire de pilotes propriétaires.
  • Décocher la case “Intel PRO/Wireless 3945 Network Connection driver for Linux” et confirmer.
  • Editer le fichier /etc/modules (avec sudo) et ajouter à la fin la ligne suivante :
iwl3945

Enfin, éditer le fichier /etc/udev/rules.d/70-persistent-net.rules (avec sudo) et modifier la ligne qui se termine par :

NAME=”eth1″

en

NAME=”wlan0″

Redémarrer. La LED ne fonctionnera plus mais la connection sera plus stable.

Pour faire fonctionner la LED du WIFI , il suffit d'installer le paquet linux-backports-modules-'version du noyau'-generic

Next-Gen Wireless

La carte Intel Next-Gen Wireless-N est supporté en 2.6.22 mais après l'obtention d'une ip via dhcp le module iwl4965 plante. (Syx)

Compatibilité de la carte Next-Gen Wireless-N avec Ubuntu Gutsy. Elle fonctionne directement après installation et est compatible WPA. (Legion.nux)

Bluetooth

Fonctionnel sous Gutsy. Bluetooth Manager et son Bluetooth Applet sont automatiquement ajoutés au panel Gnome.

Parfois il est impossible d'activer la carte Bluetooth à l'aide de Bluetooth Applet. Ce problème se produit lorsque votre carte a été désactivée dans le BIOS du portable ou lorsqu'elle a été désactivée dans Windows si vous avez un Dual-Boot.

La solution est simplement de la réactiver dans Windows ou dans le BIOS. Pour accéder au BIOS, tapotez la touche F2 lors de l'affichage du logo Dell au démarrage.

Firewire / SC-MMC / Memory Stick

Les périphériques gérés par le contrôleur Ricoh fonctionnent partiellement :

Etat Commentaires
Firewire :-( R5C832 IEEE 1394 Controller : détecté, non supporté
SD/MMC :-) R5C822 SD/SDIO/MMC/MS/MSPro Host Adapter : détecté, supporté
Memory Stick :-( R5C592 Memory Stick Bus Host Adapter : détecté, non supporté

Le lecteur de carte SD/MMC fonctionne sans problème avec 8.04 Hardy, aucune manipulation nécessaire. Une carte SD est vue comme périphérique /dev/mmcblk0 et ses partitions comme /dev/mmcblk0p1.

Retour d'expérience FireWire

Ceci est à confirmer, mais pour ma part, je posséde un camescope minidv JVC. En utilisant le module "raw1394" et en positionnant les droits à 777 sur le device /dev/raw1394, je peux piloter mon camescope.

Il n'est surement pas nécessaire de changer les droits, mais je n'ai pas testé avant le changement; donc c'est à vérifier.

Pour ma part je suis sous ubuntu hardy, avec les dernières mises à jour en date et le logiciel Kino.

Si quelqu'un peut tester de son coté, m'est possible de récupérer les videos de mon camescope et de le piloter (avance rapide, lecture, stop, pause, acquisition…)

Il faut ajouter son utilisateur au group disk: sudo adduser Utilisateur disk

Divers

La télécommande fournie avec le portable fonctionne après l'installation pour quelques commandes telles que l'augmentation ou la diminution du son, le changement de programme pour les lecteurs multimédia, et quelques autres commandes.

La télécommande fonctionne sous Ubuntu mais ne semble pas fonctionner sous Xubuntu

!!!!!!!!!!! ATTENTION !!!!!!!!!!!

si vous avez grub au démarrage et si vous n'avez pas configuré le bouton dell media direct, N'APPUYEZ PAS DESSUS !!!!!!!!!!

il va formater votre table des partitions

Cette information ne devrait-elle pas être plus visible et surtout apporter une solution ?

Et si on a configuré Dell MediaDirect avant l'installation de GRUB, ces derniers fonctionnent-ils toujours ?

Sources

Autre tutorial en français



Le contenu de ce wiki est sous licence : CC BY-SA v3.0