Contenu | Rechercher | Menus

Différences

Ci-dessous, les différences entre deux révisions de la page.

Lien vers cette vue comparative

Les deux révisions précédentes Révision précédente
Prochaine révision
Révision précédente
eclipse_subversive [Le 16/02/2009, 11:20]
213.95.41.13
eclipse_subversive [Le 21/05/2010, 21:54] (Version actuelle)
quent57 Petite modif (nom paquets maj)
Ligne 1: Ligne 1:
-{{tag> travail_collaboratif ​développement ​eclipse}}+{{tag> travail_collaboratif ​programmation ​eclipse}}
  
 ====== Subversive ====== ====== Subversive ======
 +
  
 **Subversive** est un greffon permettant d'​utiliser [[Subversion]] (SVN) avec [[Eclipse]]. **Subversive** est un greffon permettant d'​utiliser [[Subversion]] (SVN) avec [[Eclipse]].
 +
 +Il existe aussi [[eclipse_subclipse | subclipse]]
 +
  
 ===== Principales fonctionnalités ===== ===== Principales fonctionnalités =====
Ligne 13: Ligne 17:
   * Gérer les conflits   * Gérer les conflits
  
-===== Installation =====+===== Installation ​(dans Eclipse 3.5 - Galileo) ​=====
  
 ==== Pré-requis ==== ==== Pré-requis ====
Ligne 22: Ligne 26:
 ==== Ajout des greffons dans Eclipse ==== ==== Ajout des greffons dans Eclipse ====
  
-<​note>​Ce tutoriel a été réalisé avec Eclipse Ganymede (version 3.4), pas encore disponible dans les paquets Ubuntu. Pour le trouver, rendez-vous sur la page de [[http://​www.eclipse.org/​downloads|téléchargement Eclipse]].</​note>​ 
  
-Eclipse a besoin de deux greffons pour pouvoir utiliser la technologie SVN. Il faut donc commencer ​par ajouter ​un site pour les greffons ​d'​Eclipse.+Eclipse a besoin de deux greffons pour pouvoir utiliser la technologie SVN 
 +  * Un greffon de base pour disposer de Subversive (**Subversive SVN Team Provider**) 
 +  * Un connecteur SVN (**SVNKit**),​ réalisé ​par la communauté Polarion 
 + 
 + 
 +=== Ajout du greffon Subversive SVN Team Provider === 
 + 
 + 
 +  - Aller dans le **Menu Aide** -> **Install New Software** . 
 +  - Puis ajouter ​**http://​download.eclipse.org/​technology/​subversive/​0.7/​update-site/** 
 +  - Sélectionner alors la ligne qui contient cette URL dans **Work with** : 
 +  - Puis dérouler **Subversion SVN Team Provider Plugin (Incubation)** 
 +  - Et cocher **Subversive SVN Team Provider (Incubation)** et **Subversive SVN Team Provider Localization (Optional) (Incubation)** 
 +  - Enfin cliquer sur **Suivant** ​pour installer ce greffon. 
 + 
 + 
 +=== Ajout du greffon SVNKit === 
 + 
 +  - Aller dans le **Menu Aide** -> **Install New Software** . 
 +  - Puis ajouter **http://​www.polarion.org/​projects/​subversive/​download/​eclipse/​2.0/​update-site/​** 
 +  - Sélectionner alors la ligne qui contient cette URL dans **Work with** : 
 +  - Puis dérouler **Subversion SVN Connectors** 
 +  - Et cocher **SVNKit 1.3.2 Implementation (Optional)**  
 +  - Enfin cliquer sur **Suivant** pour installer ce greffon. 
 + 
 + 
 + 
 + 
 +Enfin redémarrez Eclipse lorsque c'est terminé. 
 + 
 +Pour vérifier que tout s'est bien passé, allez dans Window -> Preferences -> Team -> SVN -> onglet **SVN Connector** 
 + 
 +{{ subversive_03.png }} 
 + 
 +Si aucun connecteur n'est disponible, c'est que l'​installation n'a pas fourni ​les résultats escomptés. 
 + 
 + 
 +==== Créer un projet depuis un dépôt SVN ==== 
 + 
 +Ici nous créerons un projet C++ depuis un dépôt vide, la procédure est cependant similaire avec d'autres langages ou pour récupérer un projet déjà existant. 
 + 
 +Menu **Fichier** -> **Nouveau** -> **Autre** ... (File -> New -> Other...) 
 + 
 + 
 +Dans la fenêtre qui s'​affiche,​ sélectionnez **SVN** -> **Project from SVN** 
 + 
 +{{ subversive_04.png }} 
 + 
 +Laissez-vous guider pour l'​étape suivante : saisissez l'URL de votre dépôt SVN, votre login et mot de passe, puis cliquez sur **Suivant**. 
 + 
 +Dans la fenêtre suivante, on vous demande de choisir une version du dépôt, à vous de choisir en fonction de vos besoins. Cliquez sur **Terminer**. 
 + 
 +Eclipse ​vous demande alors dans quel projet il doit poser les fichiers du dépôt. Vous pouvez aussi demander la création d'un nouveau projet en choisissant l'​option **Check out as a project configured using the New Project Wizard**. Cliquez sur Finish. 
 + 
 +Cette fois, demandez un projet C++ (ou Java, Python, Ruby, etc. selon cas) et laissez-vous guider par la procédure standard de création de projet. Eclipse va automatiquement récupérer les fichiers sur le dépôt et les insérer dans le nouveau projet... 
 + 
 +Codez..compilez !
  
-Menu Help -> Software Updates -> Available software -> Add Site...+===== Désinstallation =====
  
-Saisissez l'URL suivante : [[http://​www.polarion.org/​projects/​subversive/​download/​eclipse/​2.0/​update-site/​]]+Pour supprimer ces greffons, il suffit de retourner dans le gestionnaire de mises à jour d'Eclipse.
  
-{{ subversive_01.png }}+Menu Help -> Software Updates... -> onglet **Installed Software**. Sélectionnez les deux greffons et cliquez sur Uninstall.
  
-Ensuite, cliquez sur **Manage Sites...** et cochez la ligne suivante : [[http://​download.eclipse.org/​technology/​subversive/​0.7/​update-site/​]]+===== Voir aussi =====
  
-Vous venez de sélectionner ​les deux sites utiles ​pour installer les greffons SVNCliquez sur OK pour fermer cette fenêtre puis sur **Refresh** afin qu'​Eclipse connaisse le contenu de ces sites.+Vous pouvez consulter ​les sites suivants ​pour obtenir un complément d'​information...
  
-Ouvrez l'arborescence ​des deux sites et cochez les cases correspondant aux greffons Subversive :+  * **(en)** [[http://​www.eclipse.org/​subversive/​|Page officielle du projet sur le site d'Eclipse]] 
 +  * **(en)** [[http://​www.polarion.com/​products/​svn/​subversive.php?​src=eclipseproject|Listes ​des sites de MAJ sur Polarion]]
  
-{{ subversive_02.png }}+----
  
-Puis lancez l'​installation en cliquant sur **Install...** et redémarrez Eclipse lorsque c'est terminé.+//​Contributeurs :  
 +  [[utilisateurs:​guigouz|Guigouz]],​ 
 +  [[utilisateurs:​quent57|quent57]]//​
  
-==== Lancer un projet depuis un dépôt SVN ==== 


Le contenu de ce wiki est sous licence : CC BY-SA v3.0