Contenu | Rechercher | Menus

Ceci est une ancienne révision du document !


Subversive

Subversive est un greffon permettant d'utiliser Subversion (SVN) avec Eclipse.

Principales fonctionnalités

  • Parcourir un dépôt
  • Ajouter un projet dans un dépôt et récupérer un projet depuis un dépôt
  • Synchroniser un projet afin de visualiser les changements
  • Faire les opérations courantes : commit, update, merge, revert, etc.
  • Gérer les conflits

Installation

Pré-requis

Ajout des greffons dans Eclipse

Ce tutoriel a été réalisé avec Eclipse Ganymede (version 3.4), pas encore disponible dans les paquets Ubuntu. Pour le trouver, rendez-vous sur la page de téléchargement Eclipse.

Eclipse a besoin de deux greffons pour pouvoir utiliser la technologie SVN. Il faut donc commencer par ajouter un site pour les greffons d'Eclipse.

Menu Help → Software Updates → Available software → Add Site…

Saisissez l'URL suivante : http://www.polarion.org/projects/subversive/download/eclipse/2.0/update-site/

Ensuite, cliquez sur Manage Sites… et cochez la ligne suivante : http://download.eclipse.org/technology/subversive/0.7/update-site/

Vous venez de sélectionner les deux sites utiles pour installer les greffons SVN. Cliquez sur OK pour fermer cette fenêtre puis sur Refresh afin qu'Eclipse connaisse le contenu de ces sites.

Ouvrez l'arborescence des deux sites et cochez les cases correspondant aux greffons Subversive :

Puis lancez l'installation en cliquant sur Install… et redémarrez Eclipse lorsque c'est terminé.

Pour vérifier que tout s'est bien passé, allez dans Window → Preferences → Team → SVN → onglet SVN Connector

Créer un projet depuis un dépôt SVN

Ici nous créerons un projet C++ depuis un dépôt vide, la procédure est cependant similaire avec d'autres langages ou pour récupérer un projet déjà existant.

Menu File → New → Other…

Dans la fenêtre qui s'affiche, sélectionnez SVN → Project from SVN

Laissez-vous guider pour l'étape suivante : saisissez l'URL de votre dépôt SVN, votre login et mot de passe, puis cliquez sur Next. Dans la fenêtre suivante, on vous demande de choisir une version du dépôt, à vous de choisir en fonction de vos besoins. Cliquez sur Finish.

Eclipse vous demande alors dans quel projet il doit poser les fichiers du dépôt. Vous pouvez aussi demander la création d'un nouveau projet en choisissant l'option Check out as a project configured using the New Project Wizard. Cliquez sur Finish.

Cette fois, demandez un projet C++ (ou Java, Python, Ruby, etc. selon cas) et laissez-vous guider par la procédure standard de création de projet. Eclipse va automatiquement récupérer les fichiers sur le dépôt et les insérer dans le nouveau projet…

Codez… compilez !

Désinstallation

Pour supprimer cette application, il suffit de supprimer son paquet. La configuration de l'application sera conservée ou supprimée selon la méthode de désinstallation que vous choisirez.

Voir aussi

Vous pouvez consulter les sites suivants pour obtenir un complément d'information…


Contributeurs : Guigouz



Le contenu de ce wiki est sous licence : CC BY-SA v3.0