Différences

Ci-dessous, les différences entre deux révisions de la page.

Lien vers cette vue comparative

Les deux révisions précédentes Révision précédente
Prochaine révision
Révision précédente
ffdiaporama [Le 08/01/2017, 21:03]
Toobuntu [Depuis les dépôts Ubuntu]
ffdiaporama [Le 24/03/2018, 14:32] (Version actuelle)
90.26.65.18 [Pré-requis]
Ligne 1: Ligne 1:
-{{tag>Precise ​Trusty diaporama montage_vidéo}}+{{tag>Bionic ​Trusty ​Xenial ​diaporama montage_vidéo }}
 ---- ----
- {{ :​logoffdiaporama.png?​150|}}+ {{ :​logoffdiaporama.png?​100|}}
 ====== ffDiaporama : Créateur de film ====== ====== ffDiaporama : Créateur de film ======
    
Ligne 25: Ligne 25:
   * ffDiaporama permet de régler tous les paramètres de génération de vidéo (codec, bitrate, etc.) et contient également une base de données d'​équipements avec plus de 50 profils pré-définis (iPod, iPhone, tablette Android, etc.)   * ffDiaporama permet de régler tous les paramètres de génération de vidéo (codec, bitrate, etc.) et contient également une base de données d'​équipements avec plus de 50 profils pré-définis (iPod, iPhone, tablette Android, etc.)
 </​note>​ </​note>​
 +
 +^ Distributions ^ Versions ^ Remarques ^
 +| Bionic | 2.1 dans les dépôts | N'est pas traduit |
 +| Xenial | 1.5 dans les dépôts \\ 2 Compilation ou paquets externes | Traduit \\ N'est pas traduit |
 +| Trusty | 1.5 dans les dépôts \\ 2 Avec un ppa | Traduit \\ N'est pas traduit |
 +
 ===== Pré-requis ===== ===== Pré-requis =====
    
   * Disposer des [[:​sudo|droits d'​administration]].   * Disposer des [[:​sudo|droits d'​administration]].
   * Disposer d'une connexion à Internet configurée et activée.   * Disposer d'une connexion à Internet configurée et activée.
- +  * Activer les dépôts Universe.
  
 ===== Installation ===== ===== Installation =====
  
-==== Depuis les dépôts Ubuntu ====+==== Installer la version des dépôts Ubuntu ====
  
 Pour l'​installer la version présente dans les dépôts, il suffit d'​[[:​tutoriel:​comment_installer_un_paquet|installer le paquet]] **[[apt>​ffdiaporama|ffdiaporama]]** Pour l'​installer la version présente dans les dépôts, il suffit d'​[[:​tutoriel:​comment_installer_un_paquet|installer le paquet]] **[[apt>​ffdiaporama|ffdiaporama]]**
  
-//(A noter :​**ffdiaporama** n'est pas disponible dans les dépôts officiels pour [[:​precise|Precise 12.04]]. Dans ce cas, utiliser le [[#Depuis un PPA|PPA ci-dessous]])//​ \\ 
  
 +==== Installer la version 2 Par compilation sur Ubuntu 16.04 ====
  
-==== Installer ​la version 2 sur Ubuntu 16.04 Xenial ​====+Les ppa ne diposent pas de la version 2 pour Xenial ​!
  
-<​note><​note important>​Sous ​Ubuntu 16.4 Xenial il n'y a que la version 1.5 qui est disponible dans les dépôts, les ppa ne diposent pas de la version 2 pour Xenial !</note><​/note>+Pour installer la version 2 stable sur Ubuntu 16.04 par la compilation suivre ​les indications ​ [[https://forum.ubuntu-fr.org/​viewtopic.php?​pid=21578487#​p21578487|suivantes]] données sur le forum.
  
-Pour installer ​la version 2 stable ​sur Ubuntu 16.04 par la compilation ​suivre les indications données ​sur le forum : [[https://forum.ubuntu-fr.org/​viewtopic.php?​pid=21578487#p21578487]]+ 
 +**Pour la compilation étapes à suivre (traduction du site)** 
 + 
 +Aller ici [[https://​github.com/​JonasCz/​ffdiaporama-1604-builds]] cliquer sur Clone or download (les fichier sont patchés) 
 + 
 +Décompresser l'​archive dans ce dossier seul le dossier ffDiaporama-source nous concerne. 
 +Installer le dépendances nécéssaires à la compilation. 
 + 
 + 
 +<​code>​sudo apt-get install libqt5multimedia5-plugins libtag1-dev libssh-dev libssl-dev libcurl4-openssl-dev libcurlpp-dev libcurlpp0 libqgsttools-p1 libqt5multimediaquick-p5 qtmultimedia5-dev build-essential libavcodec-dev libavdevice-dev libavfilter-dev libavformat-dev libavresample-dev libexiv2-dev libflac-dev libswscale-dev qt5-image-formats-plugins qt5-qmake libqt5quickwidgets5 libsdl-image1.2-dev libsdl-mixer1.2-dev qt5-default qttools5-dev-tools qttools5-dev libqt5svg5-dev libqt5help5 libqt5sql5-sqlite</​code>​ 
 + 
 +Pour la compilation aller dans le dossier **.../​ffdiaporama-1604-builds-master/​ffDiaporama-source/​ffDiaporama/​src/​ffDiaporama** 
 +    
 + 
 +<​code>​qmake ffDiaporama.pro /​PREFIX=/​usr 
 +make</​code>​ 
 + 
 +Installation:​ 
 + 
 +<​code>​sudo make install</​code>​ 
 + 
 + 
 + 
 + 
 +Pour les ressources **/​ffDiaporama-source/​ffDiaporama_rsc** 
 +    
 + 
 +<​code>​qmake ffDiaporama_rsc.pro /​PREFIX=/​usr 
 +make install</​code>​ 
 + 
 +==== Installer ​la version 2 sur Ubuntu 16.04 sans compilation ​==== 
 + 
 +Une autre possibilité pour installer la version 2 stable ​sur Ubuntu 16.04 \\ 
 +[[http://ffdiaporama.tuxfamily.org/Forum/​viewtopic.php?​pid=4557#p4557]] voir le topic de phd21 
 + 
 +=== Les paquets à télécharger === 
 + 
 +ffdiaporama_2.2-1_amd64.deb 
 +https://​docs.google.com/​uc?​id=0B7SC-EcWrCpacGJyVGEzRHN1VE0&​export=download 
 + 
 +ffdiaporama-rsc_2.2-1_amd64.deb 
 +https://​docs.google.com/​uc?​id=0B7SC-EcWrCpaNFdVZGRRd2RXOWM&​export=download 
 + 
 +installer le fichier deb rsc en premier
  
  
Ligne 50: Ligne 99:
  
  
-==== Depuis un PPA ==== +==== Depuis un PPA pour Ubuntu 14.04 ==== 
-<note important>​Installer un paquet hors des dépôts officiels peut présenter un risque d'​instabilité de votre système.</​note>​+ 
 +Pour installer la **ffdiaporama version 2** sur [[:​trusty|Ubuntu 14.04]] utiliser le ppa ci dessous.
  
 === Version stable === === Version stable ===
Ligne 69: Ligne 119:
   * Pour utiliser Openclipart,​ [[:​tutoriel/​comment_installer_un_paquet|installez le paquet]] **[[apt>​ffdiaporama-openclipart]]**   * Pour utiliser Openclipart,​ [[:​tutoriel/​comment_installer_un_paquet|installez le paquet]] **[[apt>​ffdiaporama-openclipart]]**
  
- 
----- 
  
 === Version en développement === === Version en développement ===
  • ffdiaporama.1483905785.txt.gz
  • Dernière modification: Le 08/01/2017, 21:03
  • par Toobuntu