Différences

Ci-dessous, les différences entre deux révisions de la page.

Lien vers cette vue comparative

Les deux révisions précédentes Révision précédente
ffmpeg [Le 29/05/2018, 09:29]
bcag2 [Exemples de conversions] Réaliser une rotation d'une vidéo
ffmpeg [Le 24/06/2018, 20:12] (Version actuelle)
L'Africain Nettoyage
Ligne 8: Ligne 8:
 **FFmpeg** est une application de lecture et encodage de vidéo. Très puissante comme son alter ego [[Mencoder]],​ il assure en [[;​commande_shell|ligne de commande]] la possibilité de convertir les fichiers vidéo d'un format à un autre, dont le **mts** et m2ts. **FFmpeg** est une application de lecture et encodage de vidéo. Très puissante comme son alter ego [[Mencoder]],​ il assure en [[;​commande_shell|ligne de commande]] la possibilité de convertir les fichiers vidéo d'un format à un autre, dont le **mts** et m2ts.
  
-<​note>​Pour la [[:​versions|version d'​Ubuntu]] [[:trusty|Trusty ​14.04]], **FFmpeg** a été remplacé par son [[wpfr>​fork]] [[:​avconv|avconv]]. **FFmpeg** a cependant été réintégré depuis la version [[:​xenial|Ubuntu  16.04]] si bien que **FFmpeg** et **avconv** sont désormais deux applications à part entière.</​note>​+<​note ​importante>Pour la [[:​versions|version d'​Ubuntu]] [[:​trusty|14.04]],​ **FFmpeg** a été remplacé par son [[wpfr>​fork]] [[:​avconv|avconv]]. **FFmpeg** a cependant été réintégré depuis la version [[:​xenial|Ubuntu  16.04]] si bien que **FFmpeg** et **avconv** sont désormais deux applications à part entière.</​note>​
  
 ===== Utilisation graphique ===== ===== Utilisation graphique =====
Ligne 27: Ligne 27:
   * [[http://​sourceforge.net/​projects/​outreel/​files/​|Outreel]] - Une autre interface graphique pour FFMpeg.   * [[http://​sourceforge.net/​projects/​outreel/​files/​|Outreel]] - Une autre interface graphique pour FFMpeg.
  
-=====Pré-requis===== 
-  * Disposer des [[:​sudo|droits d'​administration]];​ 
-  * Disposer d'une connexion à Internet configurée et activée. 
  
 ===== Installation ===== ===== Installation =====
  
 ==== Via les dépôts officiels==== ==== Via les dépôts officiels====
-<note important>​__[[:​trusty|Particularité pour Ubuntu Trusty 14.04]]:​__\\ +
-**FFmpeg** n'est pas disponible dans les [[:​depots|dépôts officiels]] pour [[:​trusty|Trusty 14.04]]. Il est remplacé par son [[wpfr>​fork]] [[:avconv]] (présent dans le paquet **libav-tools**). Si vous souhaitez utiliser **FFmpeg** à la place de [[:avconv]] il est possible de l'​installer [[#Via un PPA pour Trusty 14.04 uniquement|depuis un PPA]]. +
-</​note>​+
 [[:​tutoriel:​comment_installer_un_paquet|Installer le paquet]] **[[apt>​ffmpeg|ffmpeg]]** [[:​tutoriel:​comment_installer_un_paquet|Installer le paquet]] **[[apt>​ffmpeg|ffmpeg]]**
  
-__Note__: \\ FIXME : N'est plus d'​actualité,​ mpeg4 est maintenant pris en charge et la désinstallation des paquets ci-après provoquera la désinstallation des éventuelles applications vidéos utilisant l'​encodeur. \\ <​del>​les packages par défaut ne contiennent pas les codecs les plus classiques comme "​mpeg4",​ pour cela il faut [[:​tutoriel:​comment_installer_un_paquet|installer spécifiquement]] **[[apt>​libavcodec54,​libavdevice53,​libavformat54,​libavutil52,​libpostproc52,​libswscale2,​ffmpeg|libavcodec54 libavdevice53 libavformat54 libavutil52 libpostproc52 libswscale2 ffmpeg]]**</​del>​ +====Via un PPA pour Ubuntu ​14.04 uniquement====
- +
-====Via un PPA pour Trusty ​14.04 uniquement==== +
-<note important>​Les [[:​PPA|dépôts PPA]] sont des [[:​dépôts]] non-officiels et installer un paquet hors des [[:​dépôts]] officiels peut présenter un risque d'​instabilité pour votre système. </​note>​+
  
 Pour utiliser **FFmpeg** sous [[:​trusty|Ubuntu Trusty 14.04]] : Pour utiliser **FFmpeg** sous [[:​trusty|Ubuntu Trusty 14.04]] :
Ligne 49: Ligne 41:
   - [[:​tutoriel:​comment_installer_un_paquet|Installez le paquet]] **[[apt>​ffmpeg]]**. ​   - [[:​tutoriel:​comment_installer_un_paquet|Installez le paquet]] **[[apt>​ffmpeg]]**. ​
   - :!: __Attention__:​ Le [[:PPA]] **mc3man/​trusty-media** contient de très nombreux autres paquets médias de versions supérieures. Si vous ne souhaitez pas de mise à jour vers des versions supérieures de ses paquets lors de la prochaine mise à jour de votre système, [[:​ppa#​suppression_d_un_ppa|supprimer ce PPA]] de vos sources de logiciels.   - :!: __Attention__:​ Le [[:PPA]] **mc3man/​trusty-media** contient de très nombreux autres paquets médias de versions supérieures. Si vous ne souhaitez pas de mise à jour vers des versions supérieures de ses paquets lors de la prochaine mise à jour de votre système, [[:​ppa#​suppression_d_un_ppa|supprimer ce PPA]] de vos sources de logiciels.
-Ou bien dans un [[:​terminal]],​ saisir les [[:​commande_shell|commandes]] suivantes : <​code>​sudo add-apt-repository ppa:​mc3man/​trusty-media 
-sudo apt-get update 
-sudo apt-get install ffmpeg</​code>​ 
-Puis si vous souhaitez retirer le [[:PPA]] **mc3man/​trusty-media** de vos sources de logiciels: <​code>​sudo add-apt-repository -r ppa:​mc3man/​trusty-media</​code>​ 
  
  
 À noter que le binaire fourni par ce PPA (depuis la version 2.7.8) prend en compte les filtres x265 et fdk_aac (codec AAC de Fraunhofer).  ​ À noter que le binaire fourni par ce PPA (depuis la version 2.7.8) prend en compte les filtres x265 et fdk_aac (codec AAC de Fraunhofer).  ​
  
-==== Par compilation ==== 
-<note important>​ 
-Cette méthode permet d'​installer la toute dernière version de FFmpeg, mais celle-ci provenant du serveur [[git|Git]],​ elle est toujours en développement,​ ce qui signifie qu'​elle peut se révéler instable. L'​utilisation de cette version est donc à vos risques et périls.</​note>​ 
- 
-Il peut être intéressant de compiler FFmpeg afin de bénéficier des dernières optimisations et de manipuler des formats qui n'​étaient pas encore supportés. Par exemple pour les vidéos haute définition encodées avec x264 qui demandent beaucoup moins de ressources dans les dernières versions. (Voir le [[http://​ffmpeg.mplayerhq.hu/​changelog.html|changelog]] de FFmpeg) 
-Pour les détails de la compilation,​ rendez-vous à la page : [[tutoriel:​comment_compiler_ffmpeg|Comment compiler FFmpeg]]\\ 
- 
- 
-==== FFmpeg et le support AAC ==== 
-Référez-vous à la méthode par compilation : [[tutoriel:​comment_compiler_ffmpeg|Comment compiler FFmpeg]]\\ 
-Et voilà, la version compilée devrait permettre de compresser vos vidéo pour la  PSP. 
  
 ===== Utilisation ===== ===== Utilisation =====
  • ffmpeg.txt
  • Dernière modification: Le 24/06/2018, 20:12
  • par L'Africain