Différences

Ci-dessous, les différences entre deux révisions de la page.

Lien vers cette vue comparative

Les deux révisions précédentes Révision précédente
gmencoder [Le 24/08/2013, 22:26]
178.194.54.95 [Gmencoder] m
gmencoder [Le 19/01/2017, 20:06] (Version actuelle)
L'Africain Maj de la page
Ligne 1: Ligne 1:
-{{tag>Hardy Intrepid Jaunty ​audio vidéo }}+{{tag>Xenial ​audio vidéo }}
 ---- ----
  
Ligne 11: Ligne 11:
 Mencoder est développé de concert avec Mplayer et permet de convertir et d'​encoder des fichiers vidéos dans un grand nombre de format. Mencoder est développé de concert avec Mplayer et permet de convertir et d'​encoder des fichiers vidéos dans un grand nombre de format.
  
-<​note>​Gmencoder n'est plus mis à jour depuis 2003, il ne supporte donc aucun des meilleurs codecs de notre époque ... +<​note>​Gmencoder n'est plus mis à jour depuis 2003, il ne supporte donc aucun des meilleurs codecs de notre époque ... Mais fonctionne tout de même. Si vous n'​êtes pas satisfait regardez ​plutôt ​du côté ​d'​[[Avidemux]] pour le transcodage ou d'[[Handbrake]] pour le passage DVD->​.avi.</​note>​
-Dans cette optique je vous conseille ​plutôt d'utiliser ​[[Avidemux]] pour le transcodage ou [[Handbrake]] pour le passage DVD->​.avi</​note>​+
  
 {{ gmencoder.png?​260}} {{ gmencoder.png?​260}}
  
 __**Attention :**__ Cette application n'est pas traduite (elle est en anglais). __**Attention :**__ Cette application n'est pas traduite (elle est en anglais).
 +
 +===== Pré-requis =====
 + 
 +  * Disposer des [[:​sudo|droits d'​administration]].
 +  * Disposer d'une connexion à Internet configurée et activée.
  
 ===== Installation ===== ===== Installation =====
- 
- 
-====Avec un Paquet deb ==== 
- 
-J'ai créé un paquet pour pouvoir installer avec toutes ces dépendances Gmencoder. 
- 
 Téléchargez [[http://​ppa.launchpad.net/​fabien-beosfrance/​ubuntu/​pool/​universe/​g/​gmencoder/​gmencoder_0.1.0-1~getdeb2_i386.deb|Le paquet pour Ubuntu 32bits]] ou [[http://​ppa.launchpad.net/​fabien-beosfrance/​ubuntu/​pool/​universe/​g/​gmencoder/​gmencoder_0.1.0-1~getdeb2_amd64.deb|Le paquet pour Ubuntu 64bits]] et [[:​tutoriel:​comment_installer_un_paquet|installez le]]. Téléchargez [[http://​ppa.launchpad.net/​fabien-beosfrance/​ubuntu/​pool/​universe/​g/​gmencoder/​gmencoder_0.1.0-1~getdeb2_i386.deb|Le paquet pour Ubuntu 32bits]] ou [[http://​ppa.launchpad.net/​fabien-beosfrance/​ubuntu/​pool/​universe/​g/​gmencoder/​gmencoder_0.1.0-1~getdeb2_amd64.deb|Le paquet pour Ubuntu 64bits]] et [[:​tutoriel:​comment_installer_un_paquet|installez le]].
  
Ligne 30: Ligne 28:
 <note important>​Pour ceuX qui tenteraient sans succès d'​utiliser gmencoder pour redimensionner un film (scale), il est normal que le logiciel installé depuis le paquet debian ne fonctionne pas ! <note important>​Pour ceuX qui tenteraient sans succès d'​utiliser gmencoder pour redimensionner un film (scale), il est normal que le logiciel installé depuis le paquet debian ne fonctionne pas !
 En effet, il manque un fichier de configuration qui donne à gmencoder la liste des filtres à utiliser pour redimensionner (Le menu déroulant est vide...). On trouve dans le README de la version 0.1.0 une note indiquant qu'il faut fournir ce fichier de configuration soit dans /​etc/​gmencoder_opts soit dans $HOME/​.gmencorer/​gmencoder_opts Par ailleurs, un exemple de fichier est donné et se trouve dans le répertoire etc de l'​archive suivante : [[http://​tutuxclan.free.fr/​debs/​gmencoder_0.1.0.orig.tar.gz]] </​note>​ En effet, il manque un fichier de configuration qui donne à gmencoder la liste des filtres à utiliser pour redimensionner (Le menu déroulant est vide...). On trouve dans le README de la version 0.1.0 une note indiquant qu'il faut fournir ce fichier de configuration soit dans /​etc/​gmencoder_opts soit dans $HOME/​.gmencorer/​gmencoder_opts Par ailleurs, un exemple de fichier est donné et se trouve dans le répertoire etc de l'​archive suivante : [[http://​tutuxclan.free.fr/​debs/​gmencoder_0.1.0.orig.tar.gz]] </​note>​
- 
- 
-=====Par Compilation ​ ===== 
- 
-==== Pré-requis ==== 
- 
- * Avoir [[:​tutoriel:​comment_installer_un_paquet|installé le paquet]] **[[apt://​mencoder|mencoder]]** puisque Gmencoder s'​appuie entièrement dessus. 
- 
- * Avoir [[:​tutoriel:​comment_installer_un_paquet|installé les paquets]] **[[apt://​build-essential,​checkinstall,​libgnomeui-dev|build-essential,​ checkinstall,​ libgnomeui-dev]].** 
- 
- * Avoir téléchargé les sources depuis le **[[http://​sourceforge.net/​project/​showfiles.php?​group_id=77186|site officiel]].** 
- 
-==== compilation ==== 
- 
-Décompressez [[archivage|l'​archive]] en tapant dans un [[terminal|terminal]] : 
- 
-<​code>​ tar -zxvf gmencoder-0.1.0.tgz</​code>​ 
- 
-Placez-vous dans le dossier. 
-<​code>​cd gmencoder-0.1.0</​code>​ 
- 
-Et lancez la compilation en tapant ces lignes dans l'​ordre siuivant. 
-<​code>​./​configure</​code>​ 
- 
-<​code>​make</​code>​ 
- 
-<​code>​sudo checkinstall </​code>​ 
  
  
 ===== Utilisation ===== ===== Utilisation =====
- +Lancez ​l'application via le [[:​unity#​tableau_de_bord_dash|tableau de bord]] (Unity) ou via le [[:​terminal]] (toutes versions d'​Ubuntu) ​avec la [[:​commande_shell|commande]] suivante : <​code>​gmencoder</​code>​
-==== Lancer Gmencoder ==== +
-Une fois l'installation terminée vous pouvez lancer Gmencoder ​avec la commande : +
-<​code>​gmencoder</​code>​ +
- +
-ou si vous avez installé le paquet .deb vous pouvez aussi utiliser le raccourci : **Applications->​Son et Vidéo->​Gmencoder**.+
  
 ==== Quelques conseils ==== ==== Quelques conseils ====
  • gmencoder.txt
  • Dernière modification: Le 19/01/2017, 20:06
  • par L'Africain