Contenu | Rechercher | Menus
Selon les tags présents sur cette page, les informations qu'elle contient n'ont pas été vérifiées depuis Ubuntu 10.04 LTS.
Apportez votre aide…

Imprimante Epson AcuLaser CX11 et C1100

Pré-requis

Installation par compilation

Dans la suite de l'article, «impr_filtre» est à remplacer par "ALCX11-filter-1.1", "ALC1100-filter-1.2", …

Téléchargez le source du pilote sur le site Avasys pour les imprimantes Laser Multifonction ou Laser n/b ou couleur.

Vous devez aller en bas de page ( Form for download ) pour cocher votre modèle et répondre au petit questionnaire.

Choisissez le fichier source du pilote CUPS (Epson-«impr_filtre».tar.gz)

Installez le paquet libcupsys2-dev ou à partir de la version 10.04 ( Lucid ), le nouveau paquet libcups2-dev qui contient libcupsys2.

Ouvrez un terminal et déplacez vous dans le répertoire où se trouve le pilote téléchargé, puis décompressez-le et installez-le :

cd /chemin_vers_le_repertoire_des_Téléchargements
tar -zxvf Epson-«impr_filtre».tar.gz
cd Epson-«impr_filtre»
./configure --prefix=/usr
sudo make install

Le pilote est maintenant installé. Utilisez alors le gestionnaire d'imprimantes de Gnome ou KDE pour ajouter l'imprimante. Qu'elle soit connectée en USB ou par un câble réseau, celle-ci devrait être détectée automatiquement au début de la procédure. Lors de la sélection du pilote, choisissez Epson comme constructeur, puis retrouvez votre modèle.

Particularité Ubuntu 7.10

Pour que l'imprimante fonctionne sur Ubuntu 7.10 (Gutsy), il faut passer apparmor en mode "warning" pour Cups :

sudo aa-complain cupsd

Particularité Ubuntu 8.04 LTS

Pour que l'imprimante fonctionne sur Ubuntu 8.04 LTS (Hardy), il faut installer le paquet libstdc++5 et passer apparmor en mod "warning" pour Cups :

sudo aa-complain cupsd

Particularité Ubuntu 10.04 LTS

Pour que l'imprimante fonctionne sur Ubuntu 10.04 LTS (Lucid), il faut installer le paquet libstdc++5 qui se trouve dans les backports officiels.

Installation par les paquets .deb

C1100 à partir de Ubuntu 10.04

Les paquets Avasys sont fournis que en .rpm ( Turbo/RedHat/Fedora ) que l'on peut transformer soit-même à l'aide de alien.

Mais des paquets déjà convertis, sont mis à disposition sur www.hunny.be :

epson-alc1100-filter-cups_1.2-1_i386.deb

epson-alc1100-filter_1.2-1_i386.deb

Satisfaction des dépendances :

  1. Le nouveau paquet libcups2 qui contient libcupsys2 est pré-installé.
  2. Les paquets ghostscript, glibc (Ubuntu 10.11 : paquet libpthread-stub0), sed, grep, gawk, bc le sont aussi.
  3. Les paquets psutils et libstdc++5 (que ne remplace pas, dans ce cas, le nouveau paquet libstdc++6) sont à installer :
  • soit par le gestionnaire de paquets Synaptic en les sélectionnant.
  • soit en mode Terminal
    sudo aptitude install psutils
    sudo aptitude install gcc-3.3-base libstdc++5

32 bits

Installer ces 2 paquets :

  • soit dans Nautilus, par l'installateur de paquets, en double-cliquant sur chaque fichier situé dans le répertoire de téléchargement.
  • soit en mode Terminal :
    cd /chemin_vers_le_repertoire_des_Téléchargements
    dpkg -i epson-alc1100-filter_1.2-1_i386.deb
    dpkg -i epson-alc1100-filter-cups_1.2-1_i386.deb

Ajouter l'imprimante en sélectionnant Epson puis le modèle C1100.

64 bits

Ne faites pas l'installation automatique, vous auriez un message d'erreur.

Éteignez votre imprimante.

Ensuite, dans un terminal, placez vous dans votre répertoire de téléchargement :

cd /home/moi/Téléchargements/pilotes/epson

Pour avoir l'adresse exacte, clic droit sur le fichier, puis propriétés, vous copiez l'emplacement.

Puis faites une installation en force :

sudo dpkg --force-architecture --force-depends -i libstdc++5_3.3.6-24ubuntu1_i386.deb
sudo dpkg --force-architecture --force-depends -i epson-alc1100-filter-cups_1.2-1_i386.deb
sudo dpkg --force-architecture --force-depends -i epson-alc1100-filter_1.2-1_i386.deb

Allumez l'imprimante, tout doit fonctionner.

Voir aussi


Contributeurs : mike2, Michka B

Basé sur « The Epson AcuLaser CX11NF Colour Laser MFD with Linux » par Rodney Gedda

et sur les réponses de Marc Higgins sur le forum Ubuntu Epson Aculaser C1100 driver problem


imprimante_epson_al-cx11.txt · Dernière modification: Le 07/01/2012, 12:06 par Michka B
Le contenu de ce wiki est sous licence : CC BY-SA v3.0