Différences

Ci-dessous, les différences entre deux révisions de la page.

Lien vers cette vue comparative

Les deux révisions précédentes Révision précédente
Prochaine révision
Révision précédente
libreoffice_problemes [Le 16/05/2018, 22:45]
boboll [Virgule et pavé numérique]
libreoffice_problemes [Le 09/08/2020, 20:43]
eagle08 [Crash à cause de java]
Ligne 1: Ligne 1:
-{{tag>​bureautique}}+{{tag>​bureautique ​libreoffice problème}} 
 ---- ----
  
 ====== Résoudre les problèmes rencontrés avec LibreOffice ====== ====== Résoudre les problèmes rencontrés avec LibreOffice ======
-{{ libreoffice.png| Logo de LibreOffice}}+{{  ​https://​pia.fr/​wp-content/​uploads/​2018/​04/​logo-travaux.jpg?​120|logo travaux}} 
 +{{  https://​www.iltr.fr/​images/​panoramique/​office.jpg?​290|Logo des suites ​LibreOffice ​et Microsoft Office}}
  
 Cette page propose des solutions aux problèmes rencontrés lors de l'​utilisation de [[:​libreoffice|LibreOffice]]. Cette page propose des solutions aux problèmes rencontrés lors de l'​utilisation de [[:​libreoffice|LibreOffice]].
Ligne 9: Ligne 11:
 ===== Problèmes de sécurité ===== ===== Problèmes de sécurité =====
  
-Consultez la liste [[https://​wiki.documentfoundation.org/​FR/​Advisories-fr|sur la page officielle]], et appliquez les mises à jours de versions recommandées.+Consultez la page « [[https://​wiki.documentfoundation.org/​FR/​Advisories-fr|Advisories-Fr — Messages et bulletins de sécurité]] », et appliquez les mises-à-jour de versions recommandées.
 Cette page permet aussi le signalement d'un problème de sécurité. Cette page permet aussi le signalement d'un problème de sécurité.
  
-===== Généralité ​=====+===== Généralités ​=====
  
-Certains problèmes ​sont dus à des corruptions de fichiers de configurations,​ renommez ​//~/.config/​libreoffice//​ en //~/.config/libreoffice_old//. Au prochain démarrage de LibreOffice,​ le programme recréera les fichiers de configurations contenus dans //~/.config/​libreoffice//. Cela est souvent plus efficace que de désinstaller/​réinstaller le logiciel.+Les bugs pour Ubuntu ​sont répertoriés dans [[https://bugs.launchpad.net/ubuntu/+source/​libreoffice|Launchpad]] (en).
  
-De plus Ubuntu fournit un LibreOffice allégé: le module Base est absent, certaines extensions (Presenter Console, PDF import, Report Builder...) n'​y ​sont pas présentes par défaut ​à la différence du fichier fourni par The Document Foundation (la version 4.0 en intégrera certaines par défaut((https:​//​wiki.documentfoundation.org/ReleaseNotes/4.0/fr#​Extensions)) )Vous trouverez dans le [[:​libreoffice#​installation|chapitre ​de cette page]] une liste plus détaillée.+Certains problèmes ​sont dus à des corruptions de fichiers de configuration\\ 
 +Renommez ''​~/.config/libreoffice''​ en ''​~/.config/libreoffice_old''​\\ 
 +Au prochain démarrage de LibreOffice, ​le programme recréera les fichiers ​de configuration contenus dans ''​~/​.config/​libreoffice''​. Cela s'​avère souvent bien plus efficace que de désinstaller / réinstaller le logiciel.
  
-Enfin, il est souvent possible d'​ajouter un [[:​ppa]] ​pour obtenir une version plus récente de LibreOffice. Lors de la sortie d'​Ubuntu,​ la version de LibreOffice est souvent ​jeune (version x.y.2) et la communauté francophone conseille une utilisation à partir de la x.y.3 voir la x.y.4((https://​wiki.documentfoundation.org/​ReleasePlan#​Summary))((http://​fr.libreoffice.org/​libreoffice/​info-generales/​)) +De plus, l'​image ISO d'​Ubuntu ​ basique est livrée avec une version de la suite LibreOffice concentrée sur les modules essentiels :  
-Pour installer le ppa suivez le chapitre, ​<<[[:​libreoffice#​via_le_ppa| installer le ppa]]>> ​de la page sur LibreOffice.+  * le module Base est absent, certaines extensions : 
 +    * Presenter Console,  
 +    * PDF import,  
 +    * Report Builder...)  
 +ne sont pas inclus, à la différence du fichier fourni par The Document Foundation. \\ 
 +La version 4.0 én intégrait par exemple certains par défaut(([[https://​wiki.documentfoundation.org/​ReleaseNotes/​4.0/​fr#​Extensions|Extensions de LibreOffice version 4]])). \\ 
 +Vous trouverez dans le [[:​libreoffice#​installation|chapitre de cette page]] une liste plus détaillée. 
 + 
 +Enfin, il est souvent possible d'​ajouter un [[:ppa|dépôt PPA]] afin d'obtenir une version plus récente de LibreOffice. ​\\ 
 +Lors de la sortie d'​Ubuntu,​ la version de LibreOffice est souvent ​issue d'une branche très récente, exemple d'​une ​version x.y.2. \\ 
 +La communauté francophone conseille une utilisation à partir ​d'une version ​de type x.y.3, voire la x.y.4(([[https://​wiki.documentfoundation.org/​ReleasePlan#​Summary]] [[http://​fr.libreoffice.org/​libreoffice/​info-generales/​]])) 
 +Pour installer le ppasuivez le chapitre, ​« [[:​libreoffice#​via_le_ppa| installer le ppa]] » de la page sur LibreOffice.
  
 ===== Problèmes hérités de OpenOffice.org ===== ===== Problèmes hérités de OpenOffice.org =====
Ligne 27: Ligne 42:
 ==== Virgule et pavé numérique ==== ==== Virgule et pavé numérique ====
  
-(Problème rencontré avec : LibreOffice ​3.5.sous Ubuntu ​12.04 LTS et LibreOffice 4.2 et 4.3 sous Ubuntu 14.04 LTS) +Le problème est toujours présent dans LibreOffice ​6.0.sous Ubuntu ​**18.04 LTS**
 +  
 Dans le tableur Calc, la touche de séparateur décimal du pavé numérique donne un point au lieu d'une virgule (voir [[https://​bugs.launchpad.net/​ubuntu/​+bug/​188342|sur Launchpad]]). Dans le tableur Calc, la touche de séparateur décimal du pavé numérique donne un point au lieu d'une virgule (voir [[https://​bugs.launchpad.net/​ubuntu/​+bug/​188342|sur Launchpad]]).
  
-Ce bug concerne la configuration de clavier « Français (variante) » ​qui est celle installée par défaut.+Ce bug concerne la configuration de clavier « Français (variante) ». Il s'agit de celle installée par défaut.
  
 Ce bug ne concerne pas les configurations « Français » et « Français (variante obsolète) » (testé pour Ubuntu 12.04 LTS et 14.04 LTS). Ce bug ne concerne pas les configurations « Français » et « Français (variante obsolète) » (testé pour Ubuntu 12.04 LTS et 14.04 LTS).
  
-Si l'une des deux dernières configurations vous convient voici comment changer de configuration clavier :+<​note>​ 
 +Si l'une des deux dernières configurations vous convientvoici comment changer de configuration clavier :
   * Aller dans //​Paramètres Système → Saisie de texte//   * Aller dans //​Paramètres Système → Saisie de texte//
   * Cliquer sur le bouton « + » pour ajouter le clavier « Français » et supprimer le clavier « Français (variante) » à l'aide du bouton « - »   * Cliquer sur le bouton « + » pour ajouter le clavier « Français » et supprimer le clavier « Français (variante) » à l'aide du bouton « - »
 +</​note>​
  
-Si vous souhaitez utiliser la configuration par défaut « Français (variante) » lire ce qui suit.+Si vous souhaitez utiliser la configuration par défaut « Français (variante) »lire ce qui suit.
  
-Trois méthodes sont proposées ci-dessous. Les deux premières (au choix) permettent de rétablir la virgule. La 3e permet de faire en sorte que le point soit interprété comme séparateur décimal.+Trois méthodes sont proposées ci-dessous. ​\\ 
 +Les deux premières (au choix) permettent de rétablir la virgule. La troisième ​permet de faire en sorte que le point soit interprété comme séparateur décimal.
  
-=== 1re méthode : par le menu « Système » (recommandé) ​===+=== Première ​méthode : par le menu « Système » ===
  
-== Unity sur Ubuntu 18,04 ==+Cette méthode est recommandée
  
-Les options ne sont plus disponible ​dans //​Paramètres système// ​(Gnome a été « simplifié »…).+== Gnome sur Ubuntu 18.04 == 
 + 
 +Les options ne sont plus disponibles ​dans //​Paramètres système// ​Gnome a — en effet — été « simplifié »…
  
   * [[:​tutoriel:​comment_installer_un_paquet|Installez le paquet]] **[[apt>​gnome-tweak-tool]]** ;   * [[:​tutoriel:​comment_installer_un_paquet|Installez le paquet]] **[[apt>​gnome-tweak-tool]]** ;
Ligne 54: Ligne 74:
   * ouvrir "​options supplémentaires d'​agencement"​   * ouvrir "​options supplémentaires d'​agencement"​
   * développer //​Comportement de la touche Suppr. du clavier numérique//​ ;   * développer //​Comportement de la touche Suppr. du clavier numérique//​ ;
-  * sélectionnez l'​option « Touche obsolète avec point » (permet d'​avoir une virgule avec LibreOffice et un point ailleurs ; avec « Touche obsolète avec virgule », la virgule est partout). 
  
-== Unity sur Ubuntu 14.04 LTS et 16.04 LTS==+À partir d'ici, il existe deux solutions : 
 + 
 +__**Solution n°1**__ : 
 +  * sélectionnez l'​option « Touche obsolète avec point » : permet d'​avoir une virgule avec LibreOffice et un point dans les autres applications;​ 
 +  * modifier les options de libre office comme indiqué à la 3e méthode 
 + 
 +__**Solution n°2**__ : 
 +  * sélectionnez l'​option « Touche obsolète avec virgule » : permet d'​avoir une virgule à la place du point dans toutes les applications. Ne nécessite pas de modification des options de LibreOffice. 
 + 
 + 
 +== Unity sous Ubuntu 14.04 LTS et 16.04 LTS==
  
-Les options ne sont plus disponible ​dans //​Paramètres système// (Gnome a été « simplifié »…).+Les options ne sont plus disponibles ​dans //​Paramètres système// (Gnome a été « simplifié »…).
  
   * [[:​tutoriel:​comment_installer_un_paquet|Installez le paquet]] **[[apt>​gnome-tweak-tool]]** ;   * [[:​tutoriel:​comment_installer_un_paquet|Installez le paquet]] **[[apt>​gnome-tweak-tool]]** ;
   * lancer gnome-tweak-tool ("​Outil de personnalisation"​);​   * lancer gnome-tweak-tool ("​Outil de personnalisation"​);​
-  * aller sur l'​onglet « Typing » ("Saisie"​) ​;+  * aller sur l'​onglet « Typing » —{« ​Saisie ​»} ;
   * développer //​disposition du pavé numérique//​ ;   * développer //​disposition du pavé numérique//​ ;
   * sélectionnez l'​option « Obsolète ».   * sélectionnez l'​option « Obsolète ».
  
-== Unity sur Ubuntu 12.04 LTS == +== Le bureau ​MATE ==
- +
-  * Aller dans //​Paramètres système → Agencement du clavier// (bouton en haut à droite, ​ premier choix) ; +
-  * cliquer sur le bouton « Option… » ; +
-  * développer //​disposition du pavé numérique//​ ; +
-  * sélectionnez l'​option « Obsolète ». +
- +
-== MATE ==+
  
   * Allez dans le menu //Système → Préférence → Clavier//, onglet « Agencements » ;   * Allez dans le menu //Système → Préférence → Clavier//, onglet « Agencements » ;
Ligne 79: Ligne 101:
   * cliquer sur le bouton « Options de l'​agencement… » ;   * cliquer sur le bouton « Options de l'​agencement… » ;
   * développez //​Comportement de la touche de suppression du clavier numérique//​ ;   * développez //​Comportement de la touche de suppression du clavier numérique//​ ;
-  * sélectionnez l'​option « Touche obsolète avec point » (permet d'avoir une virgule ​avec LibreOffice et un point ailleurs ; avec « Touche obsolète avec virgule »la virgule ​est partout).+  * sélectionnez l'​option « Touche obsolète avec point » ;  
 +    * l'​option ​permet d'obtenir ​une virgule ​dans LibreOffice et un point partout ​ailleurs ;  
 +    * l'​option ​« Touche obsolète avec virgule » provoque l'​activation de la virgule ​de façon globale.
  
-=== 2e méthode ​par Xmodmap ===+== Le bureau Xfce =
 +Pour [[:18.04]] et [[:19.10]], il n'y a pas d'​option disponible dans l'​agencement du clavier. Par ailleurs l'​usage de l'​utilitaire //​gnome-tweaks//​ est sans effet dans cet environnement. 
 +Cependant, il existe une solution en éditant le fichire //​~/​.profile//​ 
 + 
 +Dans un terminal, tapez la commande : 
 +<code bash>​nano ~/​.profile</​code>​ 
 +ou utilisez votre [[:éditeur de texte]] favori. 
 +Ajouter la ligne dans le fichier : 
 +  
 +<code bash>​setxkbmap -option ''​ -option kpdl:​comma</​code>​ 
 +puis se déconnecter et rouvrir la session. 
 + 
 +=== Deuxième méthode à laide du fichier ​Xmodmap === 
 + 
 +Installer et configurer un fichier ''​.Xmodmap''​ afin de corriger la définition du clavier. \\ 
 +Vous pouvez : 
 +  * [[https://​bugs.launchpad.net/​ubuntu/​+bug/​188342/​comments/​2|récupérez le fichier sur Launchpad]] ; 
 +  * [[:​tutoriel:​comment_modifier_un_fichier|créez un fichier ''​.Xmodmap''​]] dans votre **Dossier Personnel** et insérez-y le contenu suivant : <file bash .Xmodmap>​
  
-Utilisez un fichier « .Xmodmap » pour corriger la définition du clavier. Vous pouvez : 
-  * Récupérez le fichier sur Launchpad : [[https://​bugs.launchpad.net/​ubuntu/​+bug/​188342/​comments/​2|un commentaire du rapport de bug]] ; 
-  * [[:​tutoriel:​comment_modifier_un_fichier|créez un fichier]] //​.Xmodmap//​ dans votre **Dossier Personnel** et insérez-y le contenu suivant : <file bash .Xmodmap>​ 
 #!/bin/bash #!/bin/bash
 val=`xmodmap -pke | grep "​keycode 91 = KP_Delete KP_Decimal"​` val=`xmodmap -pke | grep "​keycode 91 = KP_Delete KP_Decimal"​`
 echo $val echo $val
-if [ -n "​$val"​ ] +  ​if [ -n "​$val"​ ] 
-then +  then 
-xmodmap -e '​keycode 91 = KP_Delete comma'​ +    xmodmap -e '​keycode 91 = KP_Delete comma'​ 
-else +  else 
-xmodmap -e '​keycode 91 = KP_Delete KP_Decimal'​ +    xmodmap -e '​keycode 91 = KP_Delete KP_Decimal'​ 
-fi +  fi 
 </​file>​ </​file>​
-Rendez ​ce fichier exécutable (avec Nautilus, clic droit → propriétés → Permissions → Exécuter comme un programme). + 
-Lancez ​le script dans une console : +  * rendez ​ce fichier exécutable (avec Nautilus, clic droit → propriétés → Permissions → Exécuter comme un programme). 
-<​code>​+  * lancez ​le script dans une console : 
 +<​code ​bash>
 cd ../.. cd ../..
 home/​nom_dutilisateur/​.Xmodmap home/​nom_dutilisateur/​.Xmodmap
 </​code>​ </​code>​
-Si tout s'est bien passé, automatisez le script au démarrage : en faisant une recherche avec le mot clé "​Démarrage"​ dans votre [[:​unity#​tableau_de_bord_dash|tableau de bord]], puis ajoutez :+ 
 +Si tout s'est bien passé, automatisez le script au démarrage :  
 +en faisant une recherche avec le mot clé "​Démarrage"​ dans votre [[:​unity#​tableau_de_bord_dash|tableau de bord]], puis ajoutez :
   * Nom : Virgule LO   * Nom : Virgule LO
   * Commande : **home/​nom_dutilisateur/​.Xmodmap**   * Commande : **home/​nom_dutilisateur/​.Xmodmap**
Ligne 108: Ligne 149:
 [[http://​www.commentcamarche.net/​forum/​affich-374916-open-office-et-la-virgule#​14|Source]] [[http://​www.commentcamarche.net/​forum/​affich-374916-open-office-et-la-virgule#​14|Source]]
  
-=== 3e méthode ===+=== troisième ​méthode ===
  
-<​note>​À la différence des méthodes précédentes, ​cette méthode ​ne remplace pas le point par une virgule, elle utilise le point comme séparateur décimal.</​note>​+<​note>​À la différence des méthodes précédentes, ​celle-ci ​ne remplace pas le point par une virgule, elle utilise le point comme séparateur décimal.</​note>​
  
 Elle a été proposée [[http://​www.forum-openoffice.org/​forum/​viewtopic.php?​p=36080|sur le forum]]. ​ Elle a été proposée [[http://​www.forum-openoffice.org/​forum/​viewtopic.php?​p=36080|sur le forum]]. ​
-Elle est à utiliser si la touche décimale (le point) du pavé numérique est mal interprétéec'​est-à-dire considérée comme un point et non comme un séparateur décimal (virgule en France). Dans LOfaire //Options → Paramètres linguistiques → Langues// :+Elle est à utiliser si la touche décimale (le point) du pavé numérique est mal interprétée ​c'​est-à-dire ​lorsqu'​elle est considérée comme un point et non comme un séparateur décimal (virgule en France). ​ 
 + 
 +Dans LibreOfficesélectionner ​//Options → Paramètres linguistiques → Langues// :
   * Interface utilisateur : //par défaut//   * Interface utilisateur : //par défaut//
   * Environnement linguistique : //Anglais (Royaume-Uni)//​   * Environnement linguistique : //Anglais (Royaume-Uni)//​
Ligne 121: Ligne 164:
  
 <note help>Les dates seront également modifiées en conséquence pour s'​adapter à l'​affichage anglais du Royaume-Uni tel que défini dans l'​environnement linguistique.</​note>​ <note help>Les dates seront également modifiées en conséquence pour s'​adapter à l'​affichage anglais du Royaume-Uni tel que défini dans l'​environnement linguistique.</​note>​
 +
 <note tip>​L'​environnement linguistique //Français (Suisse)// fait la même chose, et il offre une meilleure compatibilité quant aux formats de dates. On peut en outre dans le tableur sélectionner les formats de date, monétaires ou numérique pour qu'ils s'​affichent à la française en choisissant dans l'​option de cellule la langue française(FR). <note tip>​L'​environnement linguistique //Français (Suisse)// fait la même chose, et il offre une meilleure compatibilité quant aux formats de dates. On peut en outre dans le tableur sélectionner les formats de date, monétaires ou numérique pour qu'ils s'​affichent à la française en choisissant dans l'​option de cellule la langue française(FR).
 Un autre avantage de cette méthode est de pouvoir garder un agencement de clavier //​France-autre//​ qui permet, entre autre, un accès simple aux caractères œ et Œ.</​note>​ Un autre avantage de cette méthode est de pouvoir garder un agencement de clavier //​France-autre//​ qui permet, entre autre, un accès simple aux caractères œ et Œ.</​note>​
  
-==== Autocorrection : suffixe des nombres ordinaux non pris en compte ​====+===== Erreur de lecture d'un fichier enregistré avec mot de passe =====
  
-Problème rencontré ​avec LibreOffice 3.5.3 sous Ubuntu 12.04 LTS.+La gestion du chiffrement des fichiers (enregistrement ​avec mot de passe) a changé depuis ​LibreOffice 3.5. LibreOffice ​3.5 peut ouvrir les fichiers enregistrés avec mot de passe dans une version antérieure. Par contre, **les fichiers enregistrés avec mot de passe par une version 3.5 ne peuvent être ouverts qu'​avec une version 3.4.5 ou supérieure**. 
 +Si vous avez LibreOffice 3.4.4 ou antérieure,​ cela ne fonctionnera pas, il faut installer une version supérieure.
  
-Une option d'​autocorrection est présente pour transformer en exposant les suffixes des nombres ordinaux. +===== Autres erreurs de lecture =====
-Exemples : 1er, 2nd, 2e, 3e… Ier, IIe, IIIe… XXIe…+
  
-Elle n'a jamais fonctionné ​(confirmé pour LibreOffice 3.5.3 et 4.0.1). Voir bug [[https://bugs.launchpad.net/​ubuntu/​+source/​libreoffice/​+bug/​992807|sur launchpad]] et la discussion [[http://​forum.ubuntu-fr.org/​viewtopic.php?​id=901811|sur le forum]]+Lors de l'ouverture de classeur ​(fichier **ods** ​et **odt**), si vous rencontrez le message d'​erreur suivant ​\\ 
 +**Erreur de lecture une erreur inconnue s'est produite**, cela peut-être dû à un fichier corrompu suite à une mise-à-jour depuis OpenOffice ou une installation incomplète\\ 
 +Il existe deux solutions différentes selon l'​origine du problèmeVérifiez le fonctionnement de la solution choisie en ouvrant de nouveau le fichier incriminéSi votre problème n'est pas résolu, appliquer la solution suivante.
  
-Pour LibreOffice 4.3.4 (version du PPA) sous Ubuntu 14.04, fonctionne partiellement :+=== Nettoyez votre profil utilisateur ===
  
-fonctionnent ​1er, 2e, 3e... 123e...+  - Fermez LibreOffice et le « Démarrage rapide » si vous l'avez installé ; 
 +  - [[:fichier_cache|Affichez les fichiers caché]] de votre répertoire personnel et renommez le répertoire ''​.config/​libreoffice''​ en ''​.config/​oldlibreoffice''​ ou supprimez-le\\ 
 +Si le problème n'est pas corrigé, appliquez la solution suivante.
  
-ne fonctionnent pas : 1ère, 2nd, 2ème, 3ème… Ier, IIe, IIIe… XXIe…+=== Réinstallez LibreOffice ===
  
-===== Erreur de lecture d'un fichier enregistré avec mot de passe ===== +[[:​tutoriel:​comment_supprimer_un_paquet|Supprimez le paquet]] **''libreoffice''​** et toutes ses dépendances pour les réinstallerConsultez ​les rubriques [[:​libreoffice#​desinstallation|désinstallation]] et [[:​libreoffice#​installation|installation]] ​de cette page pour obtenir plus d'​informations\\ 
-La gestion du chiffrement des fichiers (enregistrement avec mot de passe) a changé depuis LibreOffice 3.5. LibreOffice 3.5 peut ouvrir ​les fichiers enregistrés avec mot de passe dans une version antérieurePar contre**les fichiers enregistrés avec mot de passe par une version 3.5 ne peuvent être ouverts qu'​avec une version 3.4.5 ou supérieure**. +Suite à cette manipulationvotre problème sera très certainement résoluDans le cas contraire, consultez [[http://​user.services.openoffice.org/​fr/​forum/​index.php|la communauté francophone de LibreOffice]].
-Si vous avez LibreOffice ​3.4.4 ou antérieure,​ cela ne fonctionnera pas, il faut installer une version supérieure.+
  
-===== Erreur ​de lecture/​écriture d'un fichier enregistré avec mot de passe (profil avec chemin absolu dans Firefox) ​===== +===== Blocage sur la bannière ​de présentation ​=====
-<​note>​Concerne LibreOffice versions inférieures à 3.5.4. Le problème est annoncé corrigé lors du passage à la version 3.5.4 sous Ubuntu - À vérifier FIXME</​note>​ +
-Problème décrit sur le [[http://​forum.ubuntu-fr.org/​viewtopic.php?​pid=9331071#​p9331071|forum]]. +
-Suivi du bug (en) : [[https://​bugs.freedesktop.org/​show_bug.cgi?​id=45171|ici]]. +
-Pour corriger le problème pour les versions antérieures à 3.5.4. voici comment procéder :+
  
-=== Méthode 1 (sous Gnome) ​=== +==== la version 3.3 ====
-Créer un lien symbolique dans **/​~/​.mozilla/​firefox** qui pointe vers le répertoire du profil distant. (Par exemple dans Nautilus il suffit de cliquer-milieu glisser le répertoire puis choisir "lier ici"​.) +
-Exemple : toto : lien pointant vers /​media/​partition-de-données-partagées/​toto/​.mozilla/​firefox/​toto +
-Puis modifier **profiles.ini** pour pointer (en relatif) vers ce lien : +
-<​file>​ +
-  [Profile0] +
-  Name=toto +
-  IsRelative=+
-  Path=toto </​file>​+
  
-=== Méthode 2 (sous KDE) === 
-Avec le gestionnaire de fichiers **Dolphin** ou **Konqueror**,​ déplacez-vous dans le dossier du profil de Firefox, par défaut c'est le dossier ​ **~/​.mozilla/​firefox**. 
-Si vous ne voyez pas vos dossiers cachés, alors copier « **~/​.mozilla/​firefox** » et coller dans la barre d'​adresse de votre gestionnaire de fichiers et appuyez sur la touche « Entrée » pour vous déplacer dans ce répertoire. 
-Vous devriez voir dans ce répertoire et le fichier « **profiles.ini** ». 
-[[:​tutoriel:​comment_editer_un_fichier|Éditez le fichier]] avec la commande: <​code>​ kate ~/​.mozilla/​firefox/​profiles.ini</​code>​ 
-Dans la section « **[Profile0]** », adaptez comme ce qui suit :<​file>​ 
-  IsRelative=1 
-  Path=rene 
-</​file>​ 
-Évidemment vous remplacez le « **Path=rene** » par « **Path=votre_nom_de_compte_de_firefox** » et qui sera aussi le nom du lien symbolique que nous allons maintenant créer. 
-Toujours avec le gestionnaire de fichiers **Dolphin** ou **Konqueror**,​ faites un clic du bouton droit de la souris sur un espace libre pour afficher les options du menu contextuel. 
-Dans le menu contextuel, ​ placez le pointeur de la souris sur le sous-menu « **Créer un nouveau...** » et dans le sous-menu qui apparaît, aller cliquer sur l'​option « **Lien de base vers un fichier ou un dossier...** ». 
-Dans la boîte de dialogue « **Créer un lien symbolique** » qui apparaît, entrez dans le champ « **Nom de fichier :** », le nom entré précédemment pour le « **Path=...** ». Dans mon cas c'est « **rene** » et pour vous c'est « **votre_nom_de_compte_de_firefox** ». C'est le nom que portera le fichier de lien symbolique dans votre répertoire « **~/​.mozilla/​firefox/​** ». 
-Toujours dans la boîte de dialogue « **Créer un lien symbolique** », dans le champ « **Saisissez l'​emplacement du fichier ou du dossier :** », coller le chemin de votre répertoire de compte de Firefox qui devrait ressembler à « **~/​.mozilla/​firefox/​rene** » ou cliquer sur l'​icône au bout du champ pour sélectionner votre répertoire avec le gestionnaire de fichiers. 
-Il ne reste plus qu'à créer le lien symbolique par un clic sur le bouton « **OK** ». 
-Dès maintenant, vous pouvez de nouveau ouvrir et enregistrer vos fichiers LibreOffice avec mot de passe. 
  
-===== Autres erreurs de lecture ===== +Constaté avec la version 3.3 depuis les paquets fournis sur le site.
-Lors de l'​ouverture de classeur (fichier **ods** et **odt**), si vous rencontrez ​le message d'​erreur suivant : **Erreur de lecture une erreur inconnue s'est produite** cela peut être dû à un fichier corrompu du à un problème ​site à une mise à jour depuis OpenOffice ou une installation incomplète. +
-Il existe deux solutions différentes selon l'​origine du problème. Vérifiez le fonctionnement de la solution choisit en ouvrant de nouveau le fichier incriminé. Si votre problème n'est pas résolu, appliquez la solution suivante.+
  
-=== Nettoyez votre profil utilisateur === +Lors de la tentative de lecture d'un fichier sur [[:NFS]], la bannière de présentation ​de LibreOffice se lance et le système plante 
-  - Fermez LibO et le « Démarrage rapide » si vous l'avez installé ; +[[:​tutoriel:​comment_modifier_un_fichier|Ouvrez le fichier]] '':​usr/​lib/​libreoffice/​program/soffice'' avec  les [[:​sudo|droits d'​administration]] et commentez ​la ligne suivante ​(mettre un # devant la ligne) : <file bash>​export SAL_ENABLE_FILE_LOCKING</​file>​
-  - [[:fichier_cache|Affichez les fichiers caché]] de votre répertoire personnel ​et renommez ​le répertoire //.config/**libreoffice**// en //.config/​**oldlibreoffice**//​ (ou supprimez le). +
-Si le problème n'est pas corrigé, appliquez ​la solution ​suivante.+
  
-=== Réinstallez LibreOffice ​=== +===== Publipostage impossible =====
-[[:​tutoriel:​comment_supprimer_un_paquet|Supprimez le paquet]] **libreoffice** et toutes ses dépendances pour les réinstaller. Consultez les rubriques [[:​libreoffice#​desinstallation|désinstallation]] et [[:​libreoffice#​installation|installation]] de cette page pour obtenir plus d'​informations. +
-Il y a de très fortes chances que votre problème soit entièrement résolu. Si ce n'est pas le cas, consultez [[http://​user.services.openoffice.org/​fr/​forum/​index.php|la communauté francophone de LibreOffice]].+
  
-===== Blocage sur le '​splash screen'​ ===== +LibreOffice dans la version ​pré-installée avec Ubuntu, ne semble pas contenir ​les outils nécessaires au publipostage
-Constaté avec la version ​3.3 depuis ​les paquets fournis sur le site+Afin de pouvoir profiter pleinement des ressources ​de publipostageil faut [[:​tutoriel:​comment_installer_un_paquet|installez ​le paquet]] **[[apt>​libreoffice-base]]**.
-Lors de la tentative ​de lecture d'un fichier sur [[:NFS]]le //splash screen// de LibreOffice se lance et tout //​freeze//​. ​[[:​tutoriel:​comment_modifier_un_fichier|Ouvrez ​le fichier]] **/​usr/​lib/​libreoffice/​program/​soffice** avec  les [[:​sudo|droits d'​administration]] et commentez la ligne suivante (mettre un # devant la ligne) : <​file>​export SAL_ENABLE_FILE_LOCKING</​file>​+
  
-===== Publipostage impossible ===== +Dans certains cas de figure, la procédure d'​installation produit une configuration défectueuse. \\ 
-LibreOffice dans la version pré-installée avec Ubuntu ne semble pas contenir les outils nécessaires au publipostage+Le module Base fonctionne, éxcepté ​la gestion des rapports\\ 
-Pour pouvoir profiter pleinement des ressources de publipostage il faut [[:​tutoriel:​comment_installer_un_paquet|installez le paquet]] ​**[[apt>​libreoffice-base]]**.+Il peut dès lors s'​avérer nécessaire d'​effectuer une installation globale "hors PPA". \\ 
 +Voir https://forum.openoffice.org/​fr/​forum/​viewtopic.php?​f=9&​t=48561
  
-Cette installation s'​avère défectueuse. Base fonctionne, sauf les rapports. Il faut reprendre totalement l'​installation "hors PPA". Voir https://​forum.openoffice.org/​fr/​forum/​viewtopic.php?​f=9&t=48561+===== Présentation - Impress ​le son dans les fichiers Powerpoint =====
  
-===== Présentation - Impress : son dans les fichiers PPS ===== +Si vous recevez des diaporamas par e-mail (souvent des fichiers ​''​.pps'' ​créés avec Microsoft Powerpoint) vous n'​entendrez pas de son si vous avez une installation standard d'​Ubuntu.
-Si vous recevez des diaporamas par e-mail (souvent des fichiers .pps créés avec Microsoft Powerpoint) vous n'​entendrez pas de son si vous avez une installation standard d'​Ubuntu.+
  
 En effet, certains paquets supplémentaires sont nécessaires pour cette fonctionnalité mais ne sont pas installés par défaut car certains composants sont non libres (ou moins libres) : En effet, certains paquets supplémentaires sont nécessaires pour cette fonctionnalité mais ne sont pas installés par défaut car certains composants sont non libres (ou moins libres) :
Ligne 207: Ligne 219:
  
 <​note>​ <​note>​
-Pour certains PPS, l'​installation du paquet [[apt>​gstreamer0.10-ffmpeg]] semble résoudre les problèmes de son.((Solution trouvée sur http://​forums.linuxmint.com/​viewtopic.php?​f=47&​t=169539))+Pour certains ​fichiers au format ''​*.PPS''​((Microsoft Powerpoint)), l'​installation du paquet [[apt>​gstreamer0.10-ffmpeg]] semble résoudre les problèmes de son.((Solution trouvée sur http://​forums.linuxmint.com/​viewtopic.php?​f=47&​t=169539))
 </​note>​ </​note>​
-===== Fonction ​"​Envoyer par email" ne fonctionne pas =====+ 
 +===== La fonction ​"​Envoyer par email" ne fonctionne pas =====
 (Fonction accessible par le menu Fichier > Envoyer ou par un bouton de la barre d'​outil principale.) (Fonction accessible par le menu Fichier > Envoyer ou par un bouton de la barre d'​outil principale.)
  
-L'​erreur ​dit que Libreoffice ne trouve pas le client mail, c'est visiblement dû à un mauvais paramétrage du client mail par défaut.\\+L'​erreur ​stipule ​que Libreoffice ne trouve pas le client mail, c'est visiblement dû à un mauvais paramétrage du client mail par défaut.\\
 Ou bien un nouveau courriel s'​ouvre bien mais la pièce jointe ne s'y trouve pas (LibreOffice 4.0.1. sous Ubuntu 12.04). Ou bien un nouveau courriel s'​ouvre bien mais la pièce jointe ne s'y trouve pas (LibreOffice 4.0.1. sous Ubuntu 12.04).
  
 Résolution : aller dans le menu **Outils > Options > Internet > E-mail**.\\ Résolution : aller dans le menu **Outils > Options > Internet > E-mail**.\\
-Saisissez ''​thunderbird''​ ou utilisez ​le bouton qui permet de naviguer pour trouver un autre exécutable (par exemple dans /usr/bin puis sélection de "​thunderbird"​). ​Validez ​par OK.+  * Saisissez ''​thunderbird''​ ou  
 +    * utiliser ​le bouton qui permet de naviguer pour trouver un autre exécutable (par exemple dans ''​/usr/bin'', ​puis  
 +  * sélectionner ​"​thunderbird"​). ​ 
 +  * Valider ​par OK.
  
-===== Tableur ​Calc URL brisée ​si saisie ultérieure en utilisant la touche majuscule =====+===== Tableur Calc URL brisée ​lors de la saisie ultérieure en utilisant la touche majuscule =====
  
 Constaté dans LibreOffice Calc 4.0.1 sous Ubuntu 12.04, toujours présent dans 4.3.4 sous Ubuntu 14.04. Constaté dans LibreOffice Calc 4.0.1 sous Ubuntu 12.04, toujours présent dans 4.3.4 sous Ubuntu 14.04.
  
-Dans une cellule ou une URL a été saisie (et transformée en hyperlien), si on rajoute **par la suite** du texte dans la cellule **en utilisant la touche majuscule dans la zone de saisie**, l'URL perd sa qualité ​d'url OU se trouve brisée et parfois ​une partie du texte s'​insère au milieu de l'URL.+Dans une cellule ou une URL a été saisie (et transformée en hyperlien), si on rajoute **par la suite** du texte dans la cellule **en utilisant la touche majuscule dans la zone de saisie**, l'URL perd sa qualité ​de lien dynamique ou bien se brise. Il peut arriver qu'une partie du texte saisi par la suite  ​s'​insère au milieu de l'hyperlien.
  
-{{:​libreoffice:​bug-libo344-calc-url.png?​200 | }}+{{:​libreoffice:​bug-libo344-calc-url.png?​500 |illustration du bogue « texte dans un hyperlien »}} \\ 
 +\\ 
 +\\ 
 +Dans l'​exemple ci-contre, le texte ajouté après le lien dynamique est <​espace>​HORREUR<​espace>​123456. Les chiffres se sont insérés au milieu du lien.
  
-Dans l'​exemple ci-contre le texte ajouté après l'URL est <​espace>​HORREUR<​espace>​123456. Les chiffres se sont insérés au milieu de l'​URL. +On en discute sur le forum :  
- +[[http://​forum.ubuntu-fr.org/​viewtopic.php?​id=790181|« Bug LibreOffice Calc : texte s'​insère au milieu des URL »]] \\ 
-On en discute sur le forum : [[http://​forum.ubuntu-fr.org/​viewtopic.php?​id=790181|topic dédié]] +\\ 
-<note tip>​Contournement : effectuer la saisie directement dans la cellule (mode saisie activé par un double-clic dans la cellule).</​note>​+\\ 
 +<note tip> 
 +Contournement : effectuer la saisie directement dans la cellule (mode saisie activé par un double-clic dans la cellule). 
 +</​note>​
  
 ===== Les commentaires ne sont pas visibles dans un tableur xls ===== ===== Les commentaires ne sont pas visibles dans un tableur xls =====
-{{:​libreoffice:​commentaires_libreoffice_bug.png?​150|}}{{ :​libreoffice:​commentaires_libreoffice_bug_selection.png?​150|}}Les commentaires dans les fichiers au format xls (format de fichier créé par excel) ne sont pas visibles. La couleur du commentaire est blanche sur un fond jaune. Il faut corriger la couleur de la police du commentaire.+{{:​libreoffice:​commentaires_libreoffice_bug.png?​150 ​ |}}{{ :​libreoffice:​commentaires_libreoffice_bug_selection.png?​150|}}Les commentaires dans les fichiers au format xls (format de fichier créé par excel) ne sont pas visibles. La couleur du commentaire est blanche sur un fond jaune. Il faut corriger la couleur de la police du commentaire.
  
 [[https://​bugs.launchpad.net/​ubuntu/​+source/​libreoffice/​+bug/​1022640|[Upstream] VIEWING: Comments are not readable (shown in white over yellow)]] ​ [[https://​bugs.launchpad.net/​ubuntu/​+source/​libreoffice/​+bug/​1022640|[Upstream] VIEWING: Comments are not readable (shown in white over yellow)]] ​
Ligne 241: Ligne 263:
 javaldx failed! ​ javaldx failed! ​
 Warning: failed to read path from javaldx Warning: failed to read path from javaldx
-terminate called after throwing an instance of '​com::​sun::​star::​uno::​RuntimeException'</​code>​ +terminate called after throwing an instance of '​com::​sun::​star::​uno::​RuntimeException'​ 
-Il vous faut redonner le bon propriétaire au dossier ​//.config/​libreoffice/ ​//. Pour cela tapez dans un [[:​terminal]] la ligne suivante ​(remplacer ​user par votre nom d'​utilisateur)+</​code>​ 
-<​code>​sudo chown user:user -R .config/​libreoffice/</​code>​+ 
 +Il vous faut redonner le bon propriétaire au dossier ​''​.config/​libreoffice/​''​\\ 
 +Pour celatapez dans un [[:​terminal]] la ligne suivante ​en remplaçant ''​user'' ​par votre nom d'​utilisateur. 
 +<​code ​bash>sudo chown user:user -R .config/​libreoffice/​ </​code>​
  
 ===== « Fichier → Assistants » n'​ouvre aucune fenêtre ===== ===== « Fichier → Assistants » n'​ouvre aucune fenêtre =====
Ligne 258: Ligne 283:
  
 =====Pas de correction orthographique===== =====Pas de correction orthographique=====
-Si votre correcteur orthographique ne fonctionne pas automatiquementvérifiez en premier lieu que l'​icône avec le logo **ABC** est bien activée, ​sinon vérifiez que les paquets suivants sont bien [[:​tutoriel:​comment_installer_un_paquet|installés]] ​ **[[apt>​hyphen-fr,​ mythes-fr, hunspell-fr]]**.+Si votre correcteur orthographique ne fonctionne pas automatiquement 
 +  - vérifiez en premier lieu que l'​icône avec le logo **ABC** est bien activée, 
 +  - puis vérifiez que les paquets suivants sont bien [[:​tutoriel:​comment_installer_un_paquet|installés]] ​**[[apt>​hyphen-fr,​mythes-fr,​hunspell-fr]]**.
  
 =====Impossible de créer un lanceur sur le bureau ===== =====Impossible de créer un lanceur sur le bureau =====
Ligne 269: Ligne 296:
 Si vous rencontrez des lenteurs par exemple pendant la saisie du texte, il est possible qu'il faille augmenter l'​allocation de la mémoire pour LibreOffice.\\ Si vous rencontrez des lenteurs par exemple pendant la saisie du texte, il est possible qu'il faille augmenter l'​allocation de la mémoire pour LibreOffice.\\
 Pour cela allez dans **Outils -> Options -> Mémoire** et dans **Utiliser pour LibreOffice** passez de 20 à 96. Pour cela allez dans **Outils -> Options -> Mémoire** et dans **Utiliser pour LibreOffice** passez de 20 à 96.
 +
 +Concernant Libreoffice 6 : un bug a fait disparaitre cet option, il faut y aller manuellement comme indiqué dans le rapport de [[https://​bugs.documentfoundation.org/​show_bug.cgi?​id=110448|bug]].
  
 ===== Impossible d'​ouvrir un document à distance ===== ===== Impossible d'​ouvrir un document à distance =====
  
-Un problème existe sous [[:Xfce]] et peut être d'​autres environnements,​ il est impossible d'​ouvrir un document qui n'est pas local (exemple : réseau SMB).+Un problème existe sous [[:​Xfce]] ​et [[:Lxde]] (et peut être d'​autres environnements), il est impossible d'​ouvrir un document qui n'est pas local (exemple : réseau SMB).
  
-Pour corriger ce problème il suffit d'​installer le paquet **[[apt>​libreoffice-gnome]]**.+Pour corriger ce problème il suffit d'​installer le paquet **[[apt>​libreoffice-gnome]]** ​(n'a pas fonctionné sous lxde, à tester ou trouver une autre solution). 
 + 
 +=====Sous Ubuntu 18.04, si LibreOffice 6 Writer ne se lance pas===== 
 +Constaté en septembre 2018 sur un Xubuntu 18.04 (mis à niveau depuis 16.04) : LibreOffice 6.0 (l'​écran menu) se lance, mais après avoir cliqué sur Writer tout se ferme. Idem sous Terminal, aucun message d'​erreur. Note: les autres modules de LibreOffice (ex: Calc) fonctionnent. 
 + 
 +Contournement:​ désactiver Java. Pour cela lancer Libreoffice,​ menu "​Outils",​ "​Options",​ puis sous la section LibreOffice cliquer "​Avancé"​. Désélectionner "​Utiliser un environnement Java" (10.x dans notre cas). 
 +=====Erreur d'​affichage Unknown Application===== 
 +Sous Ubuntu 18.04 avec Unity 7 LibreOffice 6 affiche en haut à droite **Unknown Application**. Pour résoudre ce problème, il est necessaire de modifier le lanceur :​ 
 +  * [[:​tutoriel:​comment_modifier_un_fichier|Ouvrez le fichier]] **/​usr/​share/​applications/​libreoffice-writer.desktop** avec les [[sudo|droits d'​administration]] (à faire pour tous les modules de la suite, calc, draw, etc), 
 +  * Modifiez la ligne ''​exec''​ pour qu'​elle ressemble à ceci ''​Exec=env XDG_CURRENT_DESKTOP=Unity libreoffice --writer %U''​ adaptez ceci à chaque module de LibreOffice. 
 +Le rapport de bug se trouve sur cette [[https://​bugs.documentfoundation.org/​show_bug.cgi?​id=119328|page]]. 
 + 
 + 
 +===== Le format de papier par défaut est « Lettre » au lieu d'A4 ===== 
 +Sous [[LibreOffice]] 6.4 avec [[Xubuntu]] [[19.10]], le format par défaut est le format américain « Lettre » de 27,9 × 22 cm (utilisé en Amérique du nord, dans la plupart des pays d'​Amérique centrale, au Chili et aux Philippines) au lieu du format international d'​origine allemande ISO A4 (le célèbre « vingt-et-un vingt-neuf sept » des familles), utilisé dans le reste du monde. 
 + 
 +<note tip>Si la différence peut paraître minime au premier abord, cela peut poser des problèmes à l'​impression,​ car la majorité des imprimantes européennes ou africaines utilisent du papier A4. À l'​impression,​ le logiciel transposera vos éléments pour les faire rentrer sur une feuille A4, mais la taille du résultat sera alors différente de ce qui apparaît à l'​écran. Le meilleur moyen de se endre compte de ce défaut est de créer un document Writer vide, de régler le zoom à 110 % et de placer une feuille de votre imprimante sur votre écran. Si vous êtes en format A4, la feuille devrait suivre parfaitement les bords de votre document ; si ce dernier dépasse de la feuille, vous êtes en format « Lettre ». On peut alors bien voir la différence de taille entre ces deux formats.</​note>​ 
 + 
 +Pour régler ce problème, ouvrez la fenêtre **Outils → Options**, puis dans la liste **Paramètres linguistiques**,​ cliquez sur **Langue**. Changez la valeur **Paramètres locaux** de **Par défaut − Français (votre pays)** à **Français (votre pays)**. 
 + 
 +<note important>​Tous les documents que vous créerez après cette manipulation seront en format A4 ; cependant, ce que vous avez créés antérieurement sont toujours au format « Lettre ». Pensez à bien vérifier le format de vos anciens douments.</​note>​ 
 + 
 +<note tip>Au Canada, le format standard utilisé par les imprimantes est le format américain. Les paramètres locaux **Français (Canada)** sont à disposition des utilisateurs Québécois(([[https://​forum.openoffice.org/​fr/​forum/​ftopic4043.html]])). Le format de date sera également modifié, de même que les champs de monnaie s'​afficheront en dollars canadiens au lieu d'en euros.</​note>​ 
 +  
 +===== Pas de pilote SDBC dans Base ===== 
 +Pour régler ce problème, installer le paquet :  
 +  * [[:​tutoriel:​comment_installer_un_paquet|Installez le paquet]] **[[apt>​libreoffice-sdbc-hsqldb]]** ;
  
 ===== Voir aussi ===== ===== Voir aussi =====
 Discussion sur cette page [[http://​forum.ubuntu-fr.org/​viewtopic.php?​pid=9343381|sur le forum]]. Discussion sur cette page [[http://​forum.ubuntu-fr.org/​viewtopic.php?​pid=9343381|sur le forum]].
 +
 +
 ---- ----
 //​Contributeurs principaux : [[http://​forum.ubuntu-fr.org/​profile.php?​id=44251|GeekShadow]],​ [[:​utilisateurs:​Gemnoc]],​ [[:​utilisateurs:​McPeter]],​ [[http://​forum.ubuntu-fr.org/​profile.php?​id=484641|gguillaume017]],​ [[:​utilisateurs:​mohican]],​ [[:​utilisateurs:​lami|L'​ami René]], [[:​utilisateurs:​dolmen]],​ [[:​utilisateurs:​l_africain|L'​Africain]] .// //​Contributeurs principaux : [[http://​forum.ubuntu-fr.org/​profile.php?​id=44251|GeekShadow]],​ [[:​utilisateurs:​Gemnoc]],​ [[:​utilisateurs:​McPeter]],​ [[http://​forum.ubuntu-fr.org/​profile.php?​id=484641|gguillaume017]],​ [[:​utilisateurs:​mohican]],​ [[:​utilisateurs:​lami|L'​ami René]], [[:​utilisateurs:​dolmen]],​ [[:​utilisateurs:​l_africain|L'​Africain]] .//
  • libreoffice_problemes.txt
  • Dernière modification: Le 09/08/2020, 20:43
  • par eagle08