Contenu | Rechercher | Menus
Cette page est considée comme vétuste et ne contient plus d'informations utiles.
Cette page est en cours de rédaction.
Apportez votre aide…

Les informations sur cette page semblent obsolètes et nécessitent une mise à jour avec les dernières versions supportées d'Ubuntu. Il faut également refaire la mise en forme afin qu'elle respecte le modèle pour les ordinateurs portables.

Portable Medion Lifetec LT97500

Cette page reprend les ennuis rencontrés avec un portable Medion et une carte ATI x700xl ( différente de la x700) sous Edgy. J'espère qu'elle pourra aider à l'installation de ce matériel en particulier.

Beryl Atix700xl . : medion_ati_x700xl

installation des pilotes parfaite sauf la carte wifi intégrée et lecteur empreinte digitale. J'ai mis une carte wifi pcmcia, en attendant.

Note: en paramétrant dans le bios le Wifi sur "Last state", après le démarrage le wifi est actif, mais il n'est pas possible de le désactiver.

Compatibilité

Pré-requis

Pour la suite des opérations, des pré-requis sont nécessaires.

  • avoir installé ubuntu edgy
  • Disposer des droits d'administration ;
  • Disposer d'une connexion à Internet configurée et activée ;
  • Avoir activé l'accès aux dépôts APT universe et multiverse ;

Installation

L'utilisation de Synaptic fait l'objet d'une autre page.

Comment faire

Installation beryl avec ati x700xl (128mo) pilotes propriétaires sur un portable medion-lifetec LT97500

ubuntu edgy 512 mo - intel centrino 1.7g -écran 15,4" lcd - wifi( par pcmcia pas pu faire autrement) - bluetooth - lecteur carte sd -infrarouge

(tout ça fonctionne sauf le lecteur digital, mais ça ne me gènait pas)

  1. Pour la résolution : 1280x800, ça a été galère, en fait ça se fait facilement avec dpkg -reconfigure xserver-xorg

Attention meme si vous avez des messages d'erreur en faisant la commande

glxgears -printfps

du style :

Xlib:  extension "XFree86-DRI" missing on display ":1.0"

ce n'est pas grave, moi je bloquais sur ça, c'était idiot, au final j'ai toujours ce message mais beryl fonctionne très bien en utilisant une session xgl comme décrit ci-dessous.


d'abord il faut sauvegarder son xorg-conf par

sudo cp /etc/X11/xorg.conf /etc/X11/xorg.conf.kivabien

si on plante, on redémarre en console, et on fera :

sudo cp /etc/X11/xorg.conf.kivabien /etc/X11/xorg.conf

rajouter à son xorg.conf : sudo gedit /etc/X11/xorg.conf

Section "Extensions"
Option "Composite" "false"
EndSection 

télécharger envy le tuto est là : http://doc.ubuntu-fr.org/envy

le lancer et choisir

install ati driver manually ne pas choisir la dernière version, les pilotes de votre carte x700xl mobility n'y sont pas, prendre la version 8.28.8

Répondre aux questions (faciles) Redémarrer le pc

linux va faire des maj fglrx, laisser faire ça ne gène pas

ensuite créer une session xgl d'après ce tuto: (http://doc.ubuntu-fr.org/xgl_gnome)

dans un terminal taper :

sudo gedit /usr/bin/startxgl.sh

et y coller ces lignes :

#!/bin/sh
Xgl -fullscreen :1 -ac -accel glx:pbuffer -accel xv:pbuffer & sleep 4 
export DISPLAY=:1
exec dbus-launch --exit-with-session gnome-session

Si vous perdez les boutons Arrêter et Redémarrer dans le menu de gnome, rajoutez avant la dernière ligne :

cookie="$(xauth -i nextract - :0 | cut -d ' ' -f 9)"
xauth -i add :1 . "$cookie"

Chez moi le problème du clavier avec les touches # et @ absentes a été rencontré ,il a suffit d'aller dans le menu :

Système, préférences du clavier, agencement, choisir pc générique 105 touches intl, france: autre (quelques fois il faut utiliser "sans touches mortes", vérifier les accents circonflexes)

voilà, une fois cela fait, on peut redémarrer sous une session xgl : l'écran est gris avec des points :(

Lancez beryl et ça marche.

pour les paramètres beryl, un petit tuto super : http://bzarch.free.fr/dokuwiki/doku.php?id=howto:environnement:configurationdeberyl

Comme je suis sympa ;), je rajoute mon xorg.conf fonctionnel meme si ça devrait pas fonctionner (d'après les tutos que j'ai suivi) : ça fonctionne parfaitement.

# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the /etc/X11/xorg.conf manual page.
# (Type "man /etc/X11/xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg
#Option	    "RENDER" "Enable"
Section "ServerLayout"
Identifier     "Default Layout"
Screen      0  "aticonfig-Screen[0]" 0 0
InputDevice    "Generic Keyboard"
InputDevice    "Configured Mouse"
InputDevice    "stylus" "SendCoreEvents"
InputDevice    "cursor" "SendCoreEvents"
InputDevice    "eraser" "SendCoreEvents"
InputDevice    "Synaptics Touchpad"
EndSection
Section "Files"
  	# path to defoma fonts
FontPath     "/usr/share/X11/fonts/misc"
FontPath     "/usr/share/X11/fonts/cyrillic"
FontPath     "/usr/share/X11/fonts/100dpi/:unscaled"
FontPath     "/usr/share/X11/fonts/75dpi/:unscaled"
FontPath     "/usr/share/X11/fonts/Type1"
FontPath     "/usr/share/X11/fonts/100dpi"
FontPath     "/usr/share/X11/fonts/75dpi"
FontPath     "/usr/share/fonts/X11/misc"
FontPath     "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection
  
Section "Module"
Load  "bitmap"
Load  "ddc"
Load  "dri"
Load  "extmod"
Load  "freetype"
Load  "glx"
Load  "int10"
Load  "type1"
Load  "vbe"
EndSection
  
Section "InputDevice"
Identifier  "Generic Keyboard"
Driver      "kbd"
Option	    "CoreKeyboard"
Option	    "XkbRules" "xorg"
Option	    "XkbModel" "pc105"
Option	    "XkbLayout" "fr-latin9"
Option	    "XkbOptions" "lv3:ralt_switch"
EndSection    
Section "InputDevice"
Identifier  "Configured Mouse"
Driver      "mouse"
Option	    "CorePointer"
Option	    "Device" "/dev/input/mice"
Option	    "Protocol" "ExplorerPS/2"
Option	    "ZAxisMapping" "4 5"
Option	    "Emulate3Buttons" "true"
EndSection
  
Section "InputDevice"
Identifier  "Synaptics Touchpad"
Driver      "synaptics"
Option	    "SendCoreEvents" "true"
Option	    "Device" "/dev/psaux"
Option	    "Protocol" "auto-dev"
Option	    "HorizScrollDelta" "0"
EndSection
  
Section "InputDevice"
                                                    # /dev/input/event
                                                    # for USB
Identifier  "stylus"
Driver      "wacom"
Option	    "Device" "/dev/wacom"          # Change to 
Option	    "Type" "stylus"
Option	    "ForceDevice" "ISDV4"               # Tablet PC ONLY
EndSection
  
Section "InputDevice"

                                                    # /dev/input/event
                                                    # for USB
Identifier  "eraser"
Driver      "wacom"
Option	    "Device" "/dev/wacom"          # Change to 
Option	    "Type" "eraser"
Option	    "ForceDevice" "ISDV4"               # Tablet PC ONLY
EndSection
  
Section "InputDevice"
                                                    # /dev/input/event
                                                    # for USB
Identifier  "cursor"
Driver      "wacom"
Option	    "Device" "/dev/wacom"          # Change to 
Option	    "Type" "cursor"
Option	    "ForceDevice" "ISDV4"               # Tablet PC ONLY
EndSection
  
Section "Monitor"
Identifier   "Generic Monitor"
HorizSync    28.0 - 50.0
VertRefresh  43.0 - 75.0
Option	    "DPMS"
EndSection

Section "Monitor"
Identifier   "aticonfig-Monitor[0]"
Option	    "VendorName" "ATI Proprietary Driver"
Option	    "ModelName" "Generic Autodetecting Monitor"
Option	    "DPMS" "true"
EndSection

Section "Device"
Identifier  "ati mobility radeon X700 xl"
Driver      "ati"
Option	    "AddARGBGLXVisuals" "True"
BusID       "PCI:1:0:0"
EndSection

Section "Device"
Identifier  "aticonfig-Device[0]"
Driver      "fglrx"
Option	    "VideoOverlay" "on"
Option	    "OpenGLOverlay" "off"
EndSection

Section "Screen"
Identifier "Default Screen"
Device     "ati mobility radeon X700 xl"
Monitor    "Generic Monitor"
DefaultDepth     24
SubSection "Display"
	Depth     1
	Modes    "1280x800" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
	Depth     4
	Modes    "1280x800" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
	Depth     8
	Modes    "1280x800" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
	Depth     15
	Modes    "1280x800" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
	Depth     16
	Modes    "1280x800" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
	Depth     24
	Modes    "1280x800" "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Section "Screen"
Identifier "aticonfig-Screen[0]"
Device     "aticonfig-Device[0]"
Monitor    "aticonfig-Monitor[0]"
DefaultDepth     24
SubSection "Display"
	Viewport   0 0
	Depth     24
EndSubSection
EndSection

Section "DRI"
Mode         0666
EndSection

Section "Extensions"
Option	    "Composite" "Disable"
EndSection

j'ai bien essayé de décommenter des trucs pour voir si ça marchait sans, mais ça me plantait souvent alors je les laisse meme si je ne trouve pas normal les deux sections monitors ou les deux sections "screens"

Je précise que j'ai ramé plus de 3 semaines juste pour etre sure que l'humain est plus fort que la machine, alors, si ça peut aider ! et encore merci aux ubuntéros de #ubuntu-fr pour leur aide magistrale.

PS: accents circonflexes retrouvés

Références



Le contenu de ce wiki est sous licence : CC BY-SA v3.0