Contenu | Rechercher | Menus
Cette page est en cours de rédaction.
Apportez votre aide…

Ceci est une ancienne révision du document !


OpenCascade

OpenCascade est un environnement pour le développement d'applications de CAO multi-plateformes en trois dimensions, disponible gratuitement sur Internet. Cet environnement est destiné, à priori, à des professionnels.

Installation

Il n'y a pas de dépôt pour OpenCascade mais le site officiel de la société OpenCascade vous propose le téléchargement pour Linux. La procédure est un tantinet complexe et est exposée ci-dessous…

Installation de csh

Installez le shell C, installé par défauts dans les environnements BSD.

sudo apt-get install csh

apt://csh

Installation de l'environnement java adéquat

veillez à obtenir la réponse "java version "1.6.0"" à la commande

java -version

Si vous ne l'obtenez pas, installez éventuellement l'environnement java 1.6.0 adéquat ou utilisez la procédure suivante (6.10+)

sudo apt-get install sun-java6-jdk        #installation de l'environnement java
sudo update-alternatives --config java    #Choix de l'environnement java

Vous obtenez la volée de ligne suivante

Il y a 2 alternatives fournissant « java ».
  Sélection    Alternative
-----------------------------------------------
          1    /usr/bin/gij-wrapper-4.1
*+        2    /usr/lib/jvm/java-6-sun/jre/bin/java
Appuyez sur Entrée pour conserver la valeur par défaut[*] ou choisissez le numéro sélectionné :

Choisissez l'alternative 2, ou plutôt, celle qui contient java-6-sun.

Exécution du programme d'installation

Vous pouvez maintenant executer le programme d'installation, en tenant compte du répertoire où se trouve celui-ci, ici /CheminCompletVersOpenCascade/

sudo java -cp /CheminCompletVersOpenCascade/Linux/setup.jar run

Je pense que les instructions de l'installateur sont claires… Mais si ce n'était pas le cas, complétez ci-dessous.

Notez que Salome 3.2.6 intègre "OpenCascade 6.2" et que la nouvelle procédure détaillé d'installation, en date du 6 juin 2007, de Salome 3.2.6 est pleinement fonctionnel sous Kubuntu 7.04.

Voir aussi sur Ubuntu :

Ecrit par ymulleneers Contributeur(e)s : L'ami René



Le contenu de ce wiki est sous licence : CC BY-SA v3.0