Contenu | Rechercher | Menus

OpenOffice.org

Depuis la version 12.04 LTS openoffice.org installe sans en avertir l'utilisateur le logiciel libreoffice.

Si vous désirez installer Apache openoffice.org il faut vous rendre sur le site openoffice.org

Première installation de l'officielle Apache OpenOffice AOO 4.0.1 sur Ubuntu 12.04 et ses versions suivantes

À noter aussi le fork allégé, totalement libre, basé sur openoffice.org, OOoLight, créé par l'association à but non lucratif EducOOo

Dans les versions récentes d'Ubuntu, LibreOffice remplace avantageusement OpenOffice.org. Les informations de cette page sont en train d'être migrées vers d'autres pages ou supprimées.

Il faudrait vérifier l'intérêt des informations présentes sur cette page, migrer celle qui sont intéressantes puis supprimer cette page. FIXME

Utilisation

Compatibilité avec Microsoft Office

Si vous souhaitez travailler sur des documents provenant de (ou à destination de) la suite bureautique Microsoft Office, consultez le tutoriel Comment améliorer la compatibilité entre OpenOffice.org et MS Office.

Numéroter ses pages

Méthode simple et officielle

  • Allez dans Insertion → Pied de page → Tout ou Standard.
  • Cliquez sur le petit encadré Pied de page.
  • Allez dans Insertion → Champ → Numéro de page.
  • Vous pouvez placer ces numérotations ou vous le voudrez, elles se feront automatiquement sur chaque pages.

Numéroter à partir de la 2e page

Les solutions pour avoir une première page sans numérotation :

Solution manuelle :

  • Sur la première page :
    • Aller dans Format → Style et formatage → onglet Style de page → Première page
  • Sur la deuxième page :
    • Allez dans Insertion → Pied de page → Standard
    • Cliquez sur le petit encadré pied de page
    • Allez dans Insertion → Champ → Numéro de page
    • Double-cliquer sur le numéro de page que vous venez d'insérer, puis mettre -1 dans Correction.

Utiliser sa tablette graphique

Si vous disposez d'une tablette graphique, vous pouvez l'utiliser pour écrire dans un document, par exemple pour y apposer votre signature. Il suffit pour cela de cliquer sur l'icône « Afficher les fonctions de dessin » (ou de passer par le menu Affichage > Barres d'outils > Dessin), puis de sélectionner dans la barre qui apparaît l'outil « ligne à main levée ». Chaque trait que vous ferez avec le stylet sera une nouvelle image vectorielle.

Connecter OOo à des bases de données

Pour effectuer un publipostage ou mailing, le paquet apt://openoffice.org-base doit être installé, faute de quoi les boutons "définir" restent grisés quand on tente de se connecter à un fichier de base de donnée

Il existe également des extensions pour augmenter la connectivité d'OpenOffice.org.

Avec le pilote JDBC

Pré-requis : Avoir un environnement java installé.

  • Installer le paquet libmysql-java puis redémarrer la session.
  • Dans OOo, rendez-vous dans Nouveau>Base de données>Sélectionner "Se connecter à une base de données existante MySQL (et pas jdbc)
  • Cliquez sur suivant, puis Connexion utilisant JDBC (Java Database Connectivity).

Si la connexion à jdbc échoue, après une mise à jour d'OpenOffice.org par exemple, dans OOo, rendez vous sous Outils>Options, section Java, puis ajoutez l'archive du connecteur (/usr/share/java/mysql.jar) dans Class path.

Avec le pilote ODBC


openoffice.org.txt · Dernière modification: Le 15/10/2013, 11:17 par david96
Le contenu de ce wiki est sous licence : CC BY-SA v3.0