Contenu | Rechercher | Menus
Cette page n'a pas encore d'étiquettes.
Apportez votre aide…

Pré-requis

Installation

Pour installer ce logiciel, il suffit d'installer le paquet pcb.

Configuration

Pas de configuration particulière à apporter.

Utilisation

Dans ce tutorial, le dossier de travail sera ~/electronique. Créez le dossier depuis un terminal en tapant :

mkdir ~/electronique

Création du schéma

Lancez l'éditeur de schéma gEDA depuis le menu Applications → Science & Ingénierie → Editeur de schémas gEDA ou via la commande suivante :

/usr/bin/gschem

Permier schéma : l'alimentation

Tracé du schéma

Insérez les composants depuis le menu Ajouter → Component….

De cette façon, ajoutez :

  • connector2-1
  • io-1 (2 fois)

Tracez les liens ( menu Ajouter → Net…) pour obtenir le schéma suivant :

propriété des éléments

Double-cliquez sur le connecteur et renseigner le champs refdes → CONN1

Chaque refdes doit être unique dans l'ensemble des schémas du projet.

Ajoutez aussi une footprint → CONNECTOR 2 1

De la même manière renomez les IO :

  • premier IO : net → BRANCHE1:1
  • second IO : net → BRANCHE2:1

Le champs net d'un IO doit toujours se terminer par ":1".

Votre schéma ressemble à :

Sauvegardez votre fichier dans ~/electronique/alimentation.sch

Second schéma : la lumière

Créez un nouveau schéma en y insérant :

  • resistor-2
  • led-1
  • io-1 (2 fois)

Modifiez les refdes et spécifiez les footprint

Sauvegardez le fichier dans ~/electronique/lumiere.sch

Description du projet

Ouvrez l'éditeur de texte gedit via la commande suivante :

/usr/bin/gedit ~/electronique/mon_projet

Insérez le texte suivant :

schematics alimentation.sch lumiere.sch
output-name mon_circuit

Enregistrez et quittez l'éditeur de textes.

Génération du circuit

Deux fichiers vont êtres nécessaires : * la netlist (.net) qui décrit les lien fonctionnels du circuit * le circuit lui-même (.pcb) dans lequel nous allons gérer l'implantation des éléments Depuis un terminal, mettez-vous dans le dossier de travail :

cd ~/electronique

et lancez la commande :

gsch2pcb mon_projet

Trois fichiers sont créé :

  • mon_circuit.net
  • mon_circuit.pcb
  • mon_circuit.cmd

La console indique que 3 empreintes ont bien été créées :

implantation des éléments

Lancez PCB via la commande suivante :

/usr/bin/pcb mon_circuit.pcb

Dispersion des éléments

Vous devriez voir tous les composants massés en haut à gauche de votre écran. Commencez par les disperser depuis le menu Sélection → Disperser tous les éléments

Repositionnez les éléments à votre guise.

Renseignement des liens fonctionnels

Chargez le fichier de netlist depuis le menu Fichier → charger le fichier de netlist

Sélectionnez mon_circuit.net

Création du routing

Créez les liaisons depuis le menu Connects → optimiser les liaisons

Et enfin créez le routing final depuis le menu Connects → Auto-route all rats

Vous pouvez réinitialiser le routing depuis le menu Connects → Rip-up all auto-routed tracks

Vous pouvez changer le nombre de couches (en spécifiant 2 pour un circuit double face) depuis le menu Fichier → Préférences… → Couches

Vous pouvez changer la largeur des pistes et l'espacement minimum entre les couches en cliquant sur le bouton style de routage en bas à gauche de l'écran

Vous pouvez rechercher toutes les footprint disponible en pressant la touche « i »

Exportez votre typon depuis le menu Fichier → Export layout… → PS Spécifiez une échelle 1.05 dans le champs scale vous pourrez convertir votre PS en PDF via la commande ps2pdf

Désinstallation

Pour supprimer cette application, il suffit de supprimer son paquet. Selon la méthode choisie, la configuration globale de l'application est conservée ou supprimée. Les journaux du système, et les fichiers de préférence des utilisateurs dans leurs dossiers personnels sont toujours conservés.

Voir aussi



Le contenu de ce wiki est sous licence : CC BY-SA v3.0