Contenu | Rechercher | Menus
Selon les tags présents sur cette page, celle-ci est ancienne et ne contient plus d'informations sur une des versions supportées d'Ubuntu.
Apportez votre aide…

Canon - Scanner/imprimante multifonctions

Méthode 1 - via les drivers officiel Canon

Télécharger et installer les drivers via le site de Canon

  • Si cette méthode ne marche pas, utiliser la 2ème méthode
  • Avec cette méthode, les logiciels de scanner basés sur sane ne marcheraient pas. Il faut utiliser le logiciel Canon scangear via la commande scangearmp

Méthode 2 - via les dépôts officiel Canon

Cette méthode est inspirée de l'article sur les imprimantes Canon cet article sur Le libriste :

  1. Installation du dépôt Canon :
    sudo add-apt-repository ppa:michael-gruz/canon-trunk
  2. Rafraichissement des dépôts :
    sudo apt-get update
  3. Recherche manuel du driver du scanner :
    sudo apt-cache search scangearmp
  4. Installation du driver du scanner :
    sudo apt-get install nom_du_driver_retrouve_ci_dessus

Le scanner est maintenant installé, lancer la commande suivante pour lancer le logiciel de scanner :

scangearmp 

Avec cette méthode, les logiciels de scanner basés sur sane ne marcheraient pas.

Méthode 3 - drivers experimentaux

Cette méthode repose sur les pilotes créés par wittawat. Ce sont des pilotes expérimentaux, ils ne fonctionnent donc pas forcément très bien avec tous les modèles. Pour plus détails, allez sur son site.

Théoriquement, les modèles suivants sont supportés :

  • mp150
  • mp160
  • mp170
  • mp180
  • mp360
  • mp390
  • mp450
  • mp460
  • mp500
  • mp510
  • mp530
  • mp600
  • mp600R
  • mp610
  • mp700
  • mp730
  • mp750
  • mp760
  • mp780
  • mp800
  • mp800R
  • mp810
  • mp830
  • mx855

En pratique, le fonctionnement a été vérifié pour les modèles :

  • mp150
  • mp170
  • mp180
  • mp210
  • mp220 (besoin de rien pour la faire fonctionner, à part les pilotes inclus dans Ubuntu 8.10 pour la mp180, rien d'autre à installer :))
  • mp360
  • mp370
  • mp510
  • mp550 –> Fonctionne partiellement (Scanner Ok, cependant la qualité d'Impression reste moyenne pour les photos)
  • mp600
  • mp610
  • mp530
  • mp730
  • mp810

(n'hésitez pas à rajouter votre modèle à cette liste)

mp272 mp270 mp630 mp640 mp240 mp560 mp190

Ne fonctionne pas pour :

  • mp495

Installation

Tout d'abord il faut suivre la partie I du wiki sur les scanners USB.

Ensuite :

sudo apt-get install libtiff4 build-essential xsane

Allumer le scanner.

Installation des pilotes PIXMA (version de juillet 2007 : 0.13.1) :

wget http://home.arcor.de/wittawat/pixma/mp150-0.13.1.tar.bz2
sudo tar xjf mp150-0.13.1.tar.bz2 -C /usr/src
cd /usr/src/mp150-0.13.1/
sudo make
sudo ./scan -L

Vous devez voir votre scanner avec cette commande. Sinon, vérifiez que la liste que vous obtenez par la commande suivante :

sudo gedit /etc/udev/rules.d/45-libsane.rules

contient un paragraphe correspond à votre scanner (par ex pour le MP360) :

# Canon Smartbase MP360
SYSFS{idVendor}=="04a9", SYSFS{idProduct}=="263c", MODE="664", GROUP="scanner"

Attention, le fichier 45-libsane.rules ne contient pas de ligne pour le MP510, il faut donc rajouter la ligne suivante :
# Canon Smartbase MP510
SYSFS{idVendor}=="04a9", SYSFS{idProduct}=="1717", MODE="664", GROUP="scanner"

Constater que le mot pixma est dans la liste du fichier et qu'il reste une ligne vide à la fin du fichier :

sudo gedit /etc/sane.d/dll.conf

Aller sur xsane et constater que… son scanner n'est pas proposé C'est peut-être cette dernière manip' qui manquait à certains auparavant :

sudo cp libsane-pixma.so /usr/lib/sane/libsane-pixma.so.1.0.13
sudo mv /usr/lib/sane/libsane-pixma.so.1 /usr/lib/sane/libsane-pixma.so.2
sudo ln -s /usr/lib/sane/libsane-pixma.so.1.0.13 /usr/lib/sane/libsane-pixma.so.1

Avant de vous arracher les cheveux, essayez aussi

sudo /etc/init.d/udev restart

Et voilà c'est terminé, ça fonctionne bien avec xsane et kooka.

NB : pour ceux/celles qui sont sur KDE, remplacer gedit par kate. Pour ceux qui ont autre chose, remplacez gedit par nano.

Installation sur Hardy i386 (32bits) (Gnome) Pour la MP210 et MP220 pour système i386-32b

Original : http://ubuntuforums.org/showthread.php?t=943626 Original : http://mp610.blogspot.com/

Voir aussi


Rédigé par elturisto.

Ce wiki est inspiré de ce post, n'hésitez pas à y poster en cas de problème.


scanner_canon_multifonctions.txt · Dernière modification: Le 21/11/2013, 15:46 par maltouzes
Le contenu de ce wiki est sous licence : CC BY-SA v3.0