Contenu | Rechercher | Menus
Cette page n'a pas encore d'étiquettes.
Apportez votre aide…

Ceci est une ancienne révision du document !



Cette page est une réécriture allégée de la documentation de Thunderbird, et adaptée plus spécialement à Thunderbird 3 à partir de Ubuntu 10.04 LTS

Thunderbird 3

  • Mozilla Thunderbird est le courrielleur de la fondation Mozilla. Il vous permet de paramétrer un ou plusieurs comptes de courrier électronique, de flux RSS, Mail Unix (movemail) ou comptes de forums de discussion.
  • Avec Thunderbird, vous pourrez recevoir et envoyer des courriels.
  • Un carnet d'adresses permet de stocker les coordonnées de vos contacts. Vous pouvez aussi créer des listes de diffusion pour envoyer en masse des courriels à vos listes.
  • L'extension Lightning offre à Thunderbird la possibilité d'intégrer un calendrier, un agenda et des tâches à faire.
  • L'extension Personas Plus permet désormais d'appliquer des thèmes agréables à Thunderbird.

Installation

Depuis Lucid il suffit d'installer les paquets thunderbird et thunderbird-locale-fr pour l'avoir en français.

Pour les versions antérieures d'Ubuntu, il faut ajouter le dépôt PPA ppa:mozillateam/thunderbird-stable1) à vos sources de logiciels, rechargez la liste des paquets et installer les paquets ci-dessus.

Utilisation

Lancez l'application depuis le menu Applications → Internet → Messagerie Thunderbird ou via la commande suivante :

thunderbird

Configuration

La première fois que vous utilisez Thunderbird 3, il faut configurer votre boite mail. Théoriquement, Thunderbird vous le propose d'emblée et trouve assez rapidement et facilement les informations nécessaires, et il est utilisable dans les minutes qui suivent.

Pour une configuration plus poussée, voir : configurer_mail

Chiffrer son courrier

Vous trouverez votre bonheur sur la page consacrée à enigmail

Intégration à Ubuntu

Notify-OSD

Par défaut Thunderbird ne prend pas en compte le système de notifications d'Ubuntu.

  • Il faut télécharger cette extension : https://addons.mozilla.org/fr/thunderbird/addon/123887/
  • Une fois téléchargée, l'extension doit être installée par Thunderbird.
  • Allez dans le menu Outils > Modules Complémentaires, puis en bas à gauche de la fenêtre qui va s'ouvrir cliquez sur "Installer" et sélectionnez le fichier précédemment téléchargé.
  • C'est fait, l'extension se charge du reste toute seule.

N.B. Cette extension a besoin que le paquet libnotify-bin soit préalablement installé sur votre système.

Les extensions (Add-On)

Comment installer les extensions ?

Il existe deux manières d'installer, soit automatiquement, soir manuellement.

  • Avec l'outil intégré: Outils > Modules Complémentaires → Catalogue montre un grand nombre d'extensions. Il suffit de cliquer sur l'extension désirée, puis "Ajouter à thunderbird", enfin redémarrer Thunderbird
  • Manuellement: télécharger l'extension désirée (.xpi) sur le disque. Aller ensuite à Outils > Modules Complémentaires → Catalogue puis en bas à gauche de la fenêtre qui va s'ouvrir cliquez sur "Installer" et sélectionnez le fichier précédemment téléchargé.

Extensions principales

Lightning

La page sur thunderbird donne toutes les infos utiles à ce sujet. Lien direct vers le paragraphe sur lightning.

Clock Applet (pour Lightning)

Par défaut Thunderbird ne prend pas en compte l'affichage des rendez-vous du calendrier dans l'applet de l'horloge du tableau de bord. Pour que cela fonctionne, il faut recopier le contenu de l'agenda Lightning dans Evolution. Cela peut se faire automatiquement en installant l'extension suivante: Evolution Mirror

Cette extension a besoin du paquet python-evolution. Un fois ce paquet installé, il faut lancer une première fois evolution pour que le calendrier par défaut apparaisse. Ensuite tout événement créé ou modifié dans Lightning devrait apparaitre dans l'applet de l'horloge du tableau de bord. Il est peut être nécessaire de remettre l'extension dans son état initial (first run), pour cela, il faut modifier le booléen extensions.evolutionmirror.firstrun dans l'éditeur de configuration (Édition > Préférences > Avancé > Éditeur de configuration…) et relancer Thunderbird.

Ne fonctionne pas avec Thunderbird 3 sous 10.04 64 bits. La mise à jour datant de 2009, ces deux versions ne doivent pas être prises en charge.

Le test est pourtant concluant sous Ubuntu 10.10 64 bits et Thunderbird 3 chez moi…

Partager Thunderbird entre Ubuntu et Windows

Rappel : pour pouvoir partager un profil Thunderbird entre Windows et Linux, ce profil doit se trouver sur une partition formatée en FAT32 ou en NTFS montée au démarrage d'Ubuntu (voir ici ou ).

Il y a de nombreuses solutions pour partager Thunderbird entre Ubuntu et Windows. L'objectif ici est de présenter les deux solutions les plus simples qui conviendront au plus grand nombre d'entre nous.

Personnaliser son profil Thunderbird sous Windows

Sous Windows, le profil Thunderbird par défaut est stocké dans :

  • C:\Documents and Settings\<utilisateur>\Application Data\Thunderbird\Profiles\xxxxxxxx.default
  • C:\Documents and Settings\<utilisateur>\Local Settings\Application Data\Thunderbird\Profiles\xxxxxxxx.default

Avant d'entrer dans les détails, la première des choses à faire est de personnaliser votre profil sous Windows et ceci pour deux raisons :

  • Pour ne pas le laisser dans C: (il est toujours imprudent de laisser un profil sous une partition système)
  • Pour lui donner un nom un peu plus explicite que "xxxxxxxx.default"

Toujours effectuer une sauvegarde du dossier contenant le profil complet afin de pouvoir le restaurer en cas de fausse manipulation ! Un copier-coller de ce dossier fait très bien l'affaire (Sachez qu'il peut être toutefois très lourd !).

La gestion des profils, sur Ubuntu passe par la commande :

thunderbird -profilemanager

Sous Windows, la commande devient :

thunderbird.exe -profilemanager

ou

thunderbird -p
  • Créer un nouveau profil
  • Choisir un nouveau dossier sur une autre partition que C (ex : D:\Thunderbird\ProfilTB)
  • Ouvrir une fois ce nouveau profil sans rien y faire d'autre
  • Fermer Thunderbird
  • Copier le contenu intégral du profil initial en xxxxxxxx.default dans D:\Thunderbird\ProfilTB
  • Ré-ouvrir Thunderbird sous le nouveau profil et vérifier que tout est là (courriers, carnet d'adresses, extensions…)

Pour la suite des opérations, nous prendrons comme point de départ un profil Windows nommé : ProfilTB stocké dans D:\Thunderbird (D: étant une partition NTFS).

Partager le même profil entre les deux systèmes d'exploitation

Il s'agit de la solution la plus simple à mettre en œuvre mais il faut savoir que certaines extensions étant différentes d'un OS à l'autre, des problèmes de compatibilité de ces extensions risquent de survenir. Tout comme des réglages que vous souhaiteriez différents entre Ubuntu et Windows ne pourraient être dissociés (Polices, interface, personas, etc.)

Comment faire ?

Soit le profil Windows existant nommé : ProfilTB stocké dans D:\Thunderbird (D: étant une partition NTFS). Il va s'agir de créer un nouveau profil sous Ubuntu en lui indiquant simplement le chemin d'accès au profil Windows.

  • Pour cela, sous Ubuntu :
thunderbird -profilemanager
  • Cliquer sur « Créer un profil… ».
  • Entrer le nom de l'utilisateur du nouveau profil.
  • Cliquer sur « Choisir un dossier… » et sélectionner le dossier contenant votre profil Windows. Celui-ci doit se présenter sous la forme : /media/partitionD/Thunderbird/ProfilTB ou "partitionD" est le nom de votre partition Windows D: vue par Ubuntu.
  • Cliquer sur « Terminer ».
  • Cliquer sur votre nouveau profil et cocher la case « Ne pas me demander au démarrage ».
  • Lancer Thunderbird.

Vous devez à présent retrouver votre profil Windows avec tous vos comptes, courriers, carnets d'adresses, extensions (qui fonctionnent…ou pas), etc !

Créer deux profils différents avec des comptes de messagerie communs

Cette solution est un (tout petit) peu plus complexe mais permet de gérer indépendamment Thunderbird sous les deux OS tout en conservant l'avantage d'avoir tous ses courriers et ses contacts en commun.

Comment faire ?

Soit le profil Windows existant nommé : ProfilTB, stocké dans D:\Thunderbird (D: étant une partition NTFS). Il va s'agir de créer un nouveau profil indépendant sous Ubuntu.

  • Pour cela, sous Ubuntu :
thunderbird -profilemanager
  • Cliquer sur « Créer un profil… ».
  • Entrer le nom de l'utilisateur du nouveau profil.
  • Cliquer sur « Choisir un dossier… » et sélectionner un dossier vierge qui contiendra votre nouveau profil. Ce dossier peut tout aussi bien se trouver sur une partition Linux comme /home ou sur une partition NTFS ou FAT32, "à coté" du profil Windows.
  • Cliquer sur « Terminer ».
  • Cliquer sur votre nouveau profil et cocher la case « Ne pas me demander au démarrage ».
  • Lancer Thunderbird.

Vous devez à présent vous trouver sous un profil vierge.

  • Créer un compte de messagerie. Remplir les champs "Nom, prénom", "Adresse" et "mot de passe" et laisser Thunderbird détecter les paramètres (cela va très vite avec la détection automatique des paramètres de serveur de Thunderbird 3)
  • Cliquer ensuite sur « Création manuelle » et aller dans la partie « Paramètres serveur ».

Attention ! Dans cette partie « Paramètres serveur », décocher IMPÉRATIVEMENT les cases « Vérifier le courrier au lancement », « Vérifier les nouveaux messages… » et « Télécharger automatiquement les nouveaux messages », ceci afin d'éviter de télécharger vos courriers dans ce compte.

  • Dans la zone "Répertoire local", cliquer sur « Parcourir » et donner le chemin du dossier Windows qui contient les messages de ce compte. Celui-ci soit se présenter sous la forme /media/partitionD/Thunderbird/ProfilTB/ImapMail/imap.googlemail.com par exemple où le compte est un compte IMAP Gmail et partitionD est le nom de votre partition Windows D: vue par Ubuntu.

Attention de ne pas se tromper de dossier si vous avez plusieurs comptes pour ne pas générer de conflit (risque de pertes de données).

  • Effectuer vos autres réglages pour ce compte.
  • Relancer Thunderbird

Vous devez à présent retrouver tous vos messages et dossiers. Vous pouvez alors re-cocher les cases décochées précédemment dans les paramètres serveur afin de récupérer automatiquement vos futurs messages qui se feront alors dans le dossier commun.

  • Procéder de même pour tous vos autres comptes de messagerie qu'ils soient en POP ou en IMAP.
  • Installez vos extensions (version Linux)

Et mon carnet d'adresses alors ?

La technique donnée sur la documentation initiale fonctionne très bien : il s'agit de remplacer le fichier du carnet d'adresse (abook.mab) du profil Ubuntu par un lien symbolique du même nom qui mène au abook.mab du profil Windows. Pour cela :

  • Supprimer le fichier "abook.mab" dans le profil Ubuntu
  • Aller dans le profil Windows et créer un lien symbolique du fichier "abook.mab" (Clic-droit "créer un lien")
  • Couper ce lien et le coller dans le profil Ubuntu à la place du fichier précédemment effacé
  • Renommer ce lien en "abook.mab"
  • Relancer Thunderbird, les contacts sont là et toute modification se répercutera naturellement sous Windows.

Et pour mon agenda sous Lightning ?

Même technique que précédemment : remplacer le fichier "local.sqlite" situé dans le dossier "calendar-data" du profil Ubuntu par un lien symbolique du même fichier appartenant au profil Windows :

  • Supprimer le fichier "local.sqlite" dans le profil Ubuntu, dossier "calendar-data"
  • Aller dans le profil Windows et créer un lien symbolique du fichier "local.sqlite" (Clic-droit "créer un lien")
  • Couper ce lien et le coller dans le profil Ubuntu, dossier "calendar-data" à la place du fichier précédemment effacé
  • Renommer ce lien en "local.sqlite"
  • Relancer Thunderbird, les évènements et autres tâches sont là et toute modification se répercutera naturellement sous Windows.

Mettre thunderbird 3 en Français

Pour mettre Thunderbird 3 en Français :

- Option1:

  1. Rendez-vous dans le dossier suivant :
    http://releases.mozilla.org/pub/mozilla.org/thunderbird/releases/<version>/linux-i686/xpi/

    Note : changez <version> par le numéro de version de votre thunderbird, dans mon cas 3.0.10 … si vous ne connaissez pas le vôtre cliquez sur Help > About Thunderbird

  2. Cliquez droit sur le fichier de votre choix (par ex : fr.xpi) et "enregistrez la cible du lien sous …"
  3. Ensuite dans Thunderbird allez dans le menu "Tools" puis "Add-ons"
  4. Sélectionnez l'onglet "Plugins"
  5. Cliquez sur "Install" et allez chercher le fichier "fr.xpi" là où vous l'aviez enregistré.
  6. Cliquez de nouveau sur "Install" puis sur "Restart now" pour que les modifications prennent effet.

Source : cette page

- Option2:

  1. Relancer Thunderbird

Problèmes connus

Problème à l'ouverture des pièces jointes

Si l'association des types de fichiers aux applications désirées est erronée ou non définie et impossible à modifier. (Par exemple sous 10.04 Lucid les .pdf joints ne s'ouvrent pas alors qu'il devraient s'ouvrir avec /usr/bin/evince.)

Supprimer le fichier MimeType.rdf qui se trouve dans votre dossier de profil Thunderbird.

Pour celà :

ls ~/.thunderbird/

Cherchez un dossier avec un nom en .default (exemple on0ck6j7.default) Déplacez vous dans ce dossier par (remplacez MONPROFIL par son nom chez vous) :

cd ~/.thunderbird/MONPROFIL.default

Puis

rm MimeType.rdf

Vous pourrez ensuite choisir et modifier correctement le applications ouvrant les fichiers .pdf (ou autres…)


Liens (si vous n'êtes pas anglophone passez votre chemin)


Contributeur(e)s : gogy, …



Le contenu de ce wiki est sous licence : CC BY-SA v3.0