Différences

Ci-dessous, les différences entre deux révisions de la page.

Lien vers cette vue comparative

Les deux révisions précédentes Révision précédente
Prochaine révision
Révision précédente
x53sa [Le 18/11/2007, 19:50]
Chybeck
— (Version actuelle)
Ligne 1: Ligne 1:
-{{tag>​asus portable gutsy materiel}} 
-Rédigé par [[utilisateurs:​chybeck]] 
  
- 
- 
- 
- 
-====== Portable Asus X53SA / Asus laptop X53SA ====== 
- 
-===== En un coup d'œil ===== 
- 
-Le tableau suivant récapitule la prise en charge du matériel du portable par les différentes versions d'​Ubuntu. 
-Il utilise les notations suivantes : 
-  * {{icons:​important.png|Fonctionne après config}} : **Fonctionne après quelques manipulations** 
-  * {{icons:​icon-ubuntu.png|Fonctionne immédiatement}} : **Fonctionne immédiatement** 
-  * {{icons:​icon-support.png|Pas testé}} : **Pas d'​informations disponibles** 
-  * {{icons:​process-stop.png?​36|Ne fonctionne pas}} : **Ne fonctionne pas** 
- 
-^ Version ^ Installation ^ Carte graphique ^ Son ^ Wifi ^ Bluetooth ^ Webcam ^ Touchpad ^ Raccourcis multimédia ^ Autres : Bureau 3D ^ 
-| [[:​gutsy|"​Gutsy Gibbon"​ - 7.10]] | Live-CD | {{icons:​important.png|Fonctionne après config}} | {{icons:​important.png|Fonctionne après config}} | {{icons:​icon-ubuntu.png|Fonctionne immédiatement}} | {{icons:​icon-ubuntu.png|Fonctionne immédiatement}} | {{icons:​icon-ubuntu.png|Fonctionne immédiatement}} | {{icons:​icon-ubuntu.png|Fonctionne immédiatement}} | {{icons:​icon-support.png|Pas testé}} | {{icons:​process-stop.png?​36|Ne fonctionne pas}} | 
- 
-**Utilisateurs du Wiki possédant cet ordinateur, fonctionnel :** 
-  * **[[:​utilisateurs:​chybeck]]** : [[:​gutsy|Gutsy Gibbon]] 
- 
- 
- 
- 
- 
-===== Configuration Matérielle ===== 
- 
-==== Carte Graphique ATI Mobility HD 2600 ==== 
-<note tip> 
-A la FNAC ils ont appelé ce modèle ATI x2600 
-</​note>​ 
-<​note>​ 
-Les drivers 8.42.3 ne fonctionnent pas bien (pas d'​acceleration graphique, lag). D'​ailleurs voici ce qu'on peut trouver dans le release du driver :"​ Caution:​ The ATI Catalyst™ Linux software suite 8.42.3 does not support ATI Workstation products. AMD recommends using the AMD Proprietary Linux software driver version 8.40.4."​ .. C'est malheureux.. en esperant que ce ne soit pas le cas de la prochaine version. En attendant pas de compiz :( 
-</​note>​ 
- 
-Sauvegarder xorg.conf 
-  cp /​etc/​X11/​xorg.conf /​etc/​X11/​xorg.backup 
- 
-Telecharger les (bons) drivers 
-  cd ~/Bureau 
-  wget http://​www2.ati.com/​drivers/​linux/​ati-driver-installer-8.41.7-x86.x86_64.run 
- 
-ou sur http://​ati.amd.com/​support/​drivers/​linux/​linux-radeonhd.html 
- 
- 
-  * Supprimer les drivers graphiques éventuels, utilisez cette commande dans un [[:​terminal]]:​ 
- 
-  sudo apt-get remove fglrx* 
- 
-  * Mise à jour du système 
-<​code>​sudo apt-get update && sudo apt-get upgrade</​code>​ 
-  * Assurez-vous d'​avoir les [[:​dépôts#​universe et multiverse|dépôts universe et multiverse.]] 
-  * Installation des dépendances 
-<​code>​sudo apt-get update 
-sudo apt-get install module-assistant build-essential ​ 
-sudo apt-get install fakeroot dh-make debconf libstdc++5 gcc-3.3-base linux-headers-$(uname -r)</​code> ​ 
-   * Placez-vous dans le répertoire où se trouve le fichier que vous avez téléchargé. Si vous l'avez téléchargé sur votre bureau tapez  
-<​code>​cd ~/​Bureau</​code>​ 
-   * installation des librairies adéquates : 
-<​code>​chmod +x ati-driver-installer-8.4*.run 
-sudo ./​ati-driver-installer-8.4*.run</​code>​ 
-il suffit ensuite de cliquer plusieurs fois sur suivant pour faire l'​installation (cette étape n'est utile que pour installer des librairies qui ne s'​installent pas avec la méthode qui suit) 
-   * Création des paquets 
-<​code>​./​ati-driver-installer-8.4*.run --buildpkg Ubuntu/​gutsy</​code>​ 
-   * Installation des paquets 
-<​code>​sudo dpkg -i xorg-driver-fglrx_8.4*.deb 
-sudo dpkg -i fglrx-kernel-source_8.4*.deb 
-sudo dpkg -i fglrx-amdcccle_8.4*.deb 
-sudo dpkg -i xorg-driver-fglrx-dev_8.4*.deb 
-</​code> ​ 
-   ​*Compilation du module fglrx pour le kernel => **Cette étape doit être réalisée à chaque mise à jour du noyau** ​ 
- 
-Suppression du module précédemment compilé s'il existe (s'il n'​existe pas un message vous le dira) 
-<​code>​sudo rm /​usr/​src/​fglrx-kernel*.deb</​code> ​ 
-Compilation du module 
-<​code>​cd /usr/src 
-sudo module-assistant build,​install fglrx-kernel 
-sudo depmod -a</​code> ​ 
- 
-Voilà le pilote est installé ! 
-il faut maintenant configurer Xorg pour qu'il utilise le pilote ! 
- 
-Mais avant toute chose, un petit reboot s'​impose!FIXME -> Nécessaire?​ 
-<​code>​sudo reboot</​code> ​ 
- 
-Enfin une fois revenu, un petit 
-<​code>​sudo aticonfig --initial -f 
-sudo aticonfig --overlay-type=Xv</​code>​ 
- 
-Puis on finalise l'​installation par un 
-<​code>​sudo reboot</​code>​ 
- 
-Et la magie, demarrage en 1440x900 avec accélération graphique et tout le tralala !  ​ 
- 
- 
- 
- 
- 
-==== Installation du Son (Chipset Realtek 660VD Intel HDA) ==== 
- 
- 
-Référence du chipset : Intel Corporation 82801H (ICH8 Family) HD Audio Controller (rev 03) 
- 
- 
-== Installation des modules génériques == 
- 
-Il faut préalablement activer les [[:​depots#​backports|dépôts backports]]. 
-On installe alors le paquet **linux-backports-modules-generic**. 
-<​code>​sudo apt-get install linux-backports-modules-generic</​code>​ 
- 
-== Téléchargement des drivers == 
- 
-<​code>​ 
-wget ftp://​152.104.238.19/​pc/​audio/​realtek-linux-audiopack-4.07a.tar.bz2 
-ou 
-wget ftp://​202.65.194.212/​pc/​audio/​realtek-linux-audiopack-4.07a.tar.bz2 
-ou 
-wget ftp://​61.56.86.122/​pc/​audio/​realtek-linux-audiopack-4.07a.tar.bz2</​code>​ 
- 
-== Décompression des drivers == 
-<​code>​tar -xf realtek-linux-audiopack-4.07a.tar.bz2 </​code>​ 
- 
- 
-== Installation des drivers == 
-<​code>​cd realtek-linux-audiopack-4.07a 
-sudo ./​install</​code>​ 
- 
- 
-== Paramétrage du fichier "​alsa-base"​ == 
-<​code>​sudo gedit /​etc/​modprobe.d/​alsa-base</​code>​ 
- 
-==Ajoutez les lignes suivantes:​== 
-<​code>​options snd-hda-intel model=lenovo 
-alias snd-card-0 snd-hda-intel 
-alias sound-slot-0 snd-hda-intel 
-alias sound-slot-0 snd-card-0 
-alias sound-service-0-0 snd-mixer-oss 
-alias sound-service-0-1 snd-seq-oss 
-alias sound-service-0-3 snd-pcm-oss 
-alias sound-service-0-8 snd-seq-oss 
-alias sound-service-0-12 snd-pcm-oss</​code>​ 
- 
- 
-== Reconfiguration d'alsa == 
-<​code>​sudo dpkg-reconfigure alsa-base</​code>​ 
- 
-== Redémarrage du systeme == 
-<​code>​sudo reboot</​code>​ 
- 
-Et le son marche !  
- 
- 
-==== Paramétrage de la Webcam ==== 
- 
-Elle fonctionne par defaut (testée sur amsn) avec un problème cependant (non négligeable) : l'​image est inversée ! . On serait tenté d'​installer le driver syntek mais il ne reconnait pas la webcam. A ce jour, il semblerait que la seule solution pour avoir l'​image a l'​endroit est ... de démonter l'​ordinateur et tourner l'​objectif. 
- 
-==== Raccourcis multimédias ==== 
- 
-* Pour le son Fn + F10,F11,F12 c'est OK. (quoi que l'​affichage sur le desktop gnome ne marche pas lorsque le son est muté). 
- 
-* En revanche le raccourci pour désactiver le touchpad ne fonctionne pas, ce qui n'est pas pratique lorsque vous travaillez sur openoffice. 
-Si quelqu'​un peut créer un script de désactivation/​réactivation du touchpad, il serait le bienvenu ! 
- 
-* N'​utilisez pas le bouton matériel de désactivation bluetooth/​wifi,​ après réactivation il ne veux plus se connecter en wifi! 
-(La aussi une solution serait la bienvenue, /​etc/​init.d/​networking restart ne fonctionne pas). 
- 
-===== Tips divers ===== 
- 
-==== xorg.conf fonctionnel avec les drivers ATI 8.41.7 ==== 
-<​code>​A venir..</​code>​ 
  • x53sa.1195411842.txt.gz
  • Dernière modification: Le 18/04/2011, 14:42
  • (modification externe)