Selon les tags présents sur cette page, celle-ci n'a pas été vérifiée pour une des versions LTS supportées d'Ubuntu.
Apportez votre aide…

Ceci est une ancienne révision du document !


Rédigé par chybeck

Portable Asus X53SA / Asus laptop X53SA

Le tableau suivant récapitule la prise en charge du matériel du portable par les différentes versions d'Ubuntu. Il utilise les notations suivantes :

  • Fonctionne après config : Fonctionne après quelques manipulations
  • Fonctionne immédiatement : Fonctionne immédiatement
  • Pas testé : Pas d'informations disponibles
  • Ne fonctionne pas : Ne fonctionne pas
Version Installation Carte graphique Son Wifi Bluetooth Webcam Touchpad Raccourcis multimédia Autres : Bureau 3D
"Gutsy Gibbon" - 7.10 Live-CD Fonctionne après config Fonctionne après config Fonctionne immédiatement Fonctionne immédiatement Fonctionne immédiatement Fonctionne immédiatement Pas testé Ne fonctionne pas
"Hardy Heron" - 8.04 update-manager Fonctionne après config Fonctionne après config Fonctionne immédiatement Fonctionne immédiatement Fonctionne immédiatement Fonctionne immédiatement Pas testé Pas testé

Utilisateurs du Wiki possédant cet ordinateur, fonctionnel :

Carte Graphique ATI Mobility HD 2600

A la FNAC ils ont appelé ce modèle ATI x2600

Sauvegarder xorg.conf

cp /etc/X11/xorg.conf /etc/X11/xorg.backup
Avant de commencer, terminez l'installation de vos mises à jour, terminez l'installation des logiciels en cours d'installation (si par hasard vous étiez en train d'installer quelque chose), et fermez synaptic, ou le gestionnaire de mises à jour !!!

Explication: Les commandes qui suivent utilisent dpkg et apt-get, l'utilisation de synaptic (par exemple) en même temps, empêche donc certaines de ces commandes de s'exécuter …

  • Supprimer les pilotes graphiques éventuels, utilisez cette commande dans un terminal:
sudo apt-get remove fglrx*
sudo apt-get update && sudo apt-get upgrade
  • Installation des dépendances
sudo apt-get install module-assistant build-essential dkms
sudo apt-get install fakeroot dh-make debconf libstdc++5 gcc-3.3-base linux-headers-$(uname -r)
  • Téléchargez la dernière version du pilote sur le site d'Ati : http://ati.amd.com/support/driver.html.
  • Placez-vous dans le répertoire où se trouve le fichier que vous avez téléchargé.
  • Installation des librairies adéquates :
chmod +x ati-driver-installer-8-4-x86.x86_64.run 
sudo ./ati-driver-installer-8-4-x86.x86_64.run

Suivre les instructions du Setup ATI. Essayer l'installation des pilotes en mode automatique.

  • Création des paquets
sudo sh ./ati-driver-installer-8-*-x86.x86_64.run --buildpkg Ubuntu
  • Installation des paquets
sudo dpkg -i xorg-driver-fglrx_8.*-0ubuntu1_i386.deb
sudo dpkg -i xorg-driver-fglrx-dev_8.*-0ubuntu1_i386.deb
sudo dpkg -i fglrx-kernel-source_8.*-0ubuntu1_i386.deb
sudo dpkg -i fglrx-amdcccle_8.*-0ubuntu1_i386.deb

et pour les utilisateurs d'installation 64 bits :

sudo dpkg -i xorg-driver-fglrx_8.*-0ubuntu1_amd64.deb
sudo dpkg -i xorg-driver-fglrx-dev_8.*-0ubuntu1_amd64.deb
sudo dpkg -i fglrx-kernel-source_8.*-0ubuntu1_amd64.deb
sudo dpkg -i fglrx-amdcccle_8.*-0ubuntu1_amd64.deb

* Configuration de Xorg

sudo aticonfig --initial -f
sudo aticonfig --overlay-type=Xv

Puis on finalise l'installation par un

sudo reboot

Et la magie, demarrage en 1440x900 avec accélération graphique et tout le tralala !

Installation du Son (Chipset Realtek 660VD Intel HDA)

Référence du chipset : Intel Corporation 82801H (ICH8 Family) HD Audio Controller (rev 03)

Paramétrage du fichier "alsa-base"
sudo gedit /etc/modprobe.d/alsa-base
Ajoutez les lignes suivantes:
options snd-hda-intel model=lenovo

Redémarrez et le son marche ! :)

Paramétrage de la Webcam

Enfin ! Un patch pour le pilote uvc a été crée par arjos85 pour que l'image ne soit plus inversée ! voici les démarches a suivre pour faire marcher correctement la webcam 174f:5a35 http://ubuntuforums.org/showthread.php?t=838210

Si personne ne se dévoue je mettrait le how-to en francais ici.

Raccourcis multimédias

* Pour le son Fn + F10,F11,F12 c'est OK. (quoi que l'affichage sur le desktop gnome ne marche pas lorsque le son est muté).

* En revanche le raccourci pour désactiver le touchpad ne fonctionne pas, ce qui n'est pas pratique lorsque vous travaillez sur openoffice. Si quelqu'un peut créer un script de désactivation/réactivation du touchpad, il serait le bienvenu !

* N'utilisez pas le bouton matériel de désactivation bluetooth/wifi, après réactivation il ne veux plus se connecter en wifi! (La aussi une solution serait la bienvenue, /etc/init.d/networking restart ne fonctionne pas).

  • x53sa.1247764891.txt.gz
  • Dernière modification: Le 16/07/2009, 19:21
  • par YannUbuntu