Différences

Ci-dessous, les différences entre deux révisions de la page.

Lien vers cette vue comparative

Les deux révisions précédentes Révision précédente
enemy_territory [Le 11/06/2017, 19:40]
82.238.134.184 [Système 64 bits] ia32-libs n'existe plus
enemy_territory [Le 05/08/2017, 14:20] (Version actuelle)
L'Africain Petit nettoyage
Ligne 1: Ligne 1:
-{{tag>​jeu fps BROUILLON}}+{{tag>Xenial ​jeu fps BROUILLON}}
  
 ---- ----
Ligne 16: Ligne 16:
  
   * Vous devez avoir l'​[[:​accélération graphique]].   * Vous devez avoir l'​[[:​accélération graphique]].
-  * (Optionnel) Si vous voulez une installation avec interface graphique GTK, il vous faudra également  ​[[:​tutoriel:​comment_installer_un_paquet|installer le paquet]] **[[apt://​libgtk1.2|libgtk1.2]]**. **Ce paquet n'est plus disponible dans les dépôts officiels à partir d'​Ubuntu 9.10 Karmic Koala.** +  * Pour [[architecture matérielle|architecture matérielle 64 bits]] [[:tutoriel:comment_installer_un_paquet|installez les paquets]] **[[apt>​libc6:​i386,libdrm2:​i386,libexpat1:​i386,libgcc1:​i386,libgl1-mesa-glx:​i386,libglapi-mesa:​i386 libglu1-mesa:​i386,libstdc++6:​i386,libx11-6:​i386,libx11-xcb1:​i386,libxau6:​i386,libxcb1:​i386,libxcb-dri2-0:​i386,libxcb-dri3-0:​i386,libxcb-glx0:​i386,libxcb-present0:​i386,libxcb-sync1:​i386,libxdamage1:​i386,libxdmcp6:​i386,libxext6:​i386,libxfixes3:​i386,libxshmfence1:​i386,libxxf86vm1:​i386,libasound2:​i386,libasound2-plugins:​i386]]**, 
-<​note>​Vous pouvez trouver la [[http://​packages.ubuntu.com/​fr/​jaunty/​libgtk1.2|libgtk1.2]] ici, installez ​d'​abord ​les dépendances [[http://​packages.ubuntu.com/​fr/​jaunty/​libglib1.2ldbl|libglib1.2ldbl]] et [[http://​packages.ubuntu.com/​fr/​jaunty/​libgtk1.2-common|libgtk1.2-common]]. Vous aurez également besoin de la [[http://​packages.ubuntu.com/​jaunty/​amd64/​libstdc++5/​download|libstdc++5]].</​note> +  * Avoir activer le dépôt [[playdeb]].
- +
-==== Système 64 bits ==== +
-ET est un jeu 32 bits uniquement. Pour l'​installer et y jouer sur un système 64 bits il faut installer certains paquets 32 bits : +
-<​code>​ +
-sudo dpkg --add-architecture i386 +
-sudo apt-get update +
-sudo apt-get install ​libc6:i386 libdrm2:​i386 libexpat1:​i386 libgcc1:​i386 libgl1-mesa-glx:​i386 libglapi-mesa:​i386 libglu1-mesa:​i386 libstdc++6:​i386 libx11-6:​i386 libx11-xcb1:​i386 libxau6:​i386 libxcb1:​i386 libxcb-dri2-0:​i386 libxcb-dri3-0:​i386 libxcb-glx0:​i386 libxcb-present0:​i386 libxcb-sync1:​i386 libxdamage1:​i386 libxdmcp6:​i386 libxext6:​i386 libxfixes3:​i386 libxshmfence1:​i386 libxxf86vm1:​i386 libasound2:​i386 libasound2-plugins:​i386 +
-</​code>​+
  
 ===== Installation ===== ===== Installation =====
  
-Enemy Territory n'est pas disponible dans les dépôts officiels. Il peut être installé depuis le dépôt [[PlayDeb]] ​ou en téléchargeant le binaire du site officiel+Enemy Territory n'est pas disponible dans les dépôts officiels. Il peut être installé depuis le dépôt [[PlayDeb]]. 
- +[[:tutoriel:​comment_installer_un_paquet|installez les paquets]] **[[apt>enemy-territory,​enemy-territory-data|enemy-territory et enemy-territory-data]]**.
-==== Depuis le dépôt PlayDeb ==== +
-FIXME +
-<note important>​Les dépôts GetDeb et PlayDeb ne sont plus disponibles ! Vous pouvez tout de même télécharger les paquets *.deb 32 bits et 64 bits sur un miroir tel qu'[[http://​mirror.informatik.uni-mannheim.de/​pub/​mirrors/​getdeb/​ubuntu/​pool/​games/​e/​enemy-territory/​|ici]].</​note>​ +
-<note tip>Le dépôt PlayDeb contient déjà la dernière version disponible 2.60b, nul besoin de « patcher ».</​note>​ +
- +
-Ajoutez le dépôt ​[[PlayDeb]] à vos sources de logiciels, puis rendez-vous sur [[http://​www.playdeb.net/​software/​Enemy%20Territory|la page d'​Enemy Territory]],​ et cliquez sur le bouton « Install this now ». +
- +
-==== Depuis le binaire ==== +
- +
-Dans une console, tapez : +
- +
-<code>wget -c http://​www.jeuxlinux.fr/​ftp/​files/​Wolfenstein-Enemy-Territory-2.60.x86.run +
-sudo bash Wolfenstein-Enemy-Territory-2.60.x86.run</​code>​ +
- +
-Laissez-vous guider par l'​interface graphique… +
- +
-<note tip>Si vous ne voulez pas installer le jeu en super utilisateur (''​sudo''​)vous pouvez le faire en entrant dans la console : +
- +
-  bash et-linux-2.60.x86.run +
- +
-</​note>​ +
- +
-<​note>​Il vous faudra cependant entrer un dossier ou vous avez les droits d'​écriture lorsqu'​on vous demandera où installer le jeu.</​note>​ +
- +
-Pour patcher le jeu, téléchargez puis décompressez le fichier « 38672-ET-2.60b-linux.zip ». +
- +
-<​code>​wget -c http://​www.esreality.com/​files/​misc/​2006/​38672-ET-2.60b-linux.zip</​code>​ +
- +
- +
-Copiez les fichiers « etded.x86 » et « et.x86 » se trouvant dans « 38672-ET-2.60b-linux/​Enemy Territory 2.60b/​linux/​ » dans le répertoire « /​usr/​local/​games/​enemy-territory/ » : +
- +
-<​code>​sudo cp ~/38672-ET-2.60b-linux/​Enemy\ Territory\ 2.60b/​linux/​etded.x86 /​usr/​local/​games/​enemy-territory/​etded.x86</​code>​ +
- +
-<​code>​sudo cp ~/​38672-ET-2.60b-linux/​Enemy\ Territory\ 2.60b/​linux/​et.x86 /​usr/​local/​games/​enemy-territory/et.x86</​code>​+
  
-ou 
-<​code>​gksudo nautilus /​usr/​local/​games/​enemy-territory/</​code>​ 
-Et vous remplacez "à la main" les fichiers, comme par exemple [[http://​trafel.free.fr/​ubuntu/​wolfet/​et.xpm|Cette icône xpm à télécharger en 32X32 px 
- toute prête.]] 
  
 ===== Utilisation ===== ===== Utilisation =====
-==== Lancement ==== 
  
-Dans une console, ​tapez simplement ​: +Dans un [[:​terminal]] (toutes [[:​versions]] ou [[:​variantes]] d'​Ubuntu) ​tapez la [[:​commande_shell|commande]] suivante : <​code>​et</​code>​
- +
-<​code>​et</​code>​+
  
 <note important>​**Attention**,​ il est possible que le jeu ne fonctionne pas du premier coup. Il se pourrait que votre écran reste noir. Les solutions suivantes sont a tester : faire « Ctrl+Alt+<​= » (redémarrage du serveur X), Ctrl+Alt+F6,​ login et <​code>​killall et</​code>​ sinon, redémarrez votre PC.</​note>​ <note important>​**Attention**,​ il est possible que le jeu ne fonctionne pas du premier coup. Il se pourrait que votre écran reste noir. Les solutions suivantes sont a tester : faire « Ctrl+Alt+<​= » (redémarrage du serveur X), Ctrl+Alt+F6,​ login et <​code>​killall et</​code>​ sinon, redémarrez votre PC.</​note>​
Ligne 114: Ligne 65:
  
 Voici la ligne permettant de récupérer le script "​et-sdl-sound"​ : Voici la ligne permettant de récupérer le script "​et-sdl-sound"​ :
-<code bash> wget -q -O - http://methoid.com/​ressources/​et/​et-sdl-sound.gz | gzip -d > et-sdl-sound && chmod a+x et-sdl-sound </​code>​+<code bash>​wget -q -O - http://nullkey.kapsi.fi/et-sdl-sound/​et-sdl-sound.gz | gzip -d > et-sdl-sound && chmod a+x et-sdl-sound</​code>​
  
-Si vous suivez cette solution et que cela ne fonctionne toujours pas, vous pouvez éditer le fichier et-sdl-sound en remplaçant +Si vous suivez cette solution et que cela ne fonctionne toujours pas, vous pouvez ​[[:​tutoriel:​comment_modifier_un_fichier|éditer le fichier]] et-sdl-sound en remplaçant 
-<code bash>+<file>
 # SDL audio driver # SDL audio driver
 SDL_AUDIODRIVER="​alsa"​ SDL_AUDIODRIVER="​alsa"​
-</code>+</file>
  
 par par
-<code bash>+<file bash>
 # SDL audio driver # SDL audio driver
 SDL_AUDIODRIVER="​pulse"​ SDL_AUDIODRIVER="​pulse"​
-</code>+</file>
  
 Lancez ensuite le fichier à l'aide le la console. Lancez ensuite le fichier à l'aide le la console.
 +Plus d'​indications sur cette [[https://​ubuntuforums.org/​showthread.php?​t=2280340|page]] (en).
  
 == 2ème solution == == 2ème solution ==
Ligne 501: Ligne 452:
   * [[http://​www.et4life.fr/​|Communauté FR Enemy-Territory]]   * [[http://​www.et4life.fr/​|Communauté FR Enemy-Territory]]
   * [[http://​www.enemy-territory.fr/​|Enemy-Territory.fr (le nécessaire pour commencer à jouer)]]   * [[http://​www.enemy-territory.fr/​|Enemy-Territory.fr (le nécessaire pour commencer à jouer)]]
 +  * [[http://​www.playdeb.net/​software/​Enemy%20Territory|la page d'​Enemy Territory sur getdeb]]
  
 ---- ----
  
 //​Contributeurs : Slworld (première partie), [[utilisateurs:​Zoloom]] (deuxième partie sur TCE et note sur le son dans la première partie), Kanethornwyrd (astuce [[:​PulseAudio]]),​ [[utilisateurs:​casselinux]] (correction mineure).// //​Contributeurs : Slworld (première partie), [[utilisateurs:​Zoloom]] (deuxième partie sur TCE et note sur le son dans la première partie), Kanethornwyrd (astuce [[:​PulseAudio]]),​ [[utilisateurs:​casselinux]] (correction mineure).//
  • enemy_territory.txt
  • Dernière modification: Le 05/08/2017, 14:20
  • par L'Africain