Contenu | Rechercher | Menus

Différences

Ci-dessous, les différences entre deux révisions de la page.

Lien vers cette vue comparative

Les deux révisions précédentes Révision précédente
ltsenablementstack [Le 02/07/2017, 17:46]
88.189.253.25 [Passer à la dernière étape de version LTS]
ltsenablementstack [Le 09/10/2017, 10:46] (Version actuelle)
L'Africain Petit nettoyage
Ligne 1: Ligne 1:
-{{tag> ​Precise Trusty ​système kernel}}+{{tag>Xenial ​système kernel}}
 ---- ----
 ====== LTS Enablement Stack ====== ====== LTS Enablement Stack ======
Ligne 8: Ligne 8:
 Ainsi, quelques semaines après la sortie d'une [[:​versions|version]] stable d'​Ubuntu,​ son [[:​kernel|noyau]] sera dans la dernière version LTS disponible au téléchargement. Ceci permettant d'​installer une [[:​lts|distribution Ubuntu LTS]] en bénéficiant de la prise en charge de nouveaux matériels intégrée dans un [[:​kernel|noyau]] plus récent.\\ Ainsi, quelques semaines après la sortie d'une [[:​versions|version]] stable d'​Ubuntu,​ son [[:​kernel|noyau]] sera dans la dernière version LTS disponible au téléchargement. Ceci permettant d'​installer une [[:​lts|distribution Ubuntu LTS]] en bénéficiant de la prise en charge de nouveaux matériels intégrée dans un [[:​kernel|noyau]] plus récent.\\
  
-{{https://​wiki.ubuntu.com/​Kernel/​Support?​action=AttachFile&​do=get&​target=12.04.x+Ubuntu+Kernel+Support+Schedule.png?​640|precise kernel support schedule}}{{https://​wiki.ubuntu.com/​Kernel/​Support?​action=AttachFile&​do=get&​target=14.04.x+Ubuntu+Kernel+Support+Schedule.png?​640|trusty kernel support schedule}}+{{https://​wiki.ubuntu.com/​Kernel/​Support?​action=AttachFile&​do=get&​target=14.04.x+Ubuntu+Kernel+Support+Schedule.png?​640|trusty kernel support schedule}}
  
 Bien que les versions d'​[[:​lts|Ubuntu LTS]] soient soutenues pendant 5 années, ce dispositif s'​arrêtera après 2 années, c'est à dire une fois la prise en compte du noyau/​serveur-graphique de la nouvelle version d'​[[:​lts|Ubuntu LTS]] suivante. Bien que les versions d'​[[:​lts|Ubuntu LTS]] soient soutenues pendant 5 années, ce dispositif s'​arrêtera après 2 années, c'est à dire une fois la prise en compte du noyau/​serveur-graphique de la nouvelle version d'​[[:​lts|Ubuntu LTS]] suivante.
  
 ===== Installation ===== ===== Installation =====
-<​note>​Sur du matériel déjà reconnu le passage à une étape de version LTS (** HWE ** Hardware Enablement Stack) a peu d’intérêt (les [[:​dépôts]] restent les mêmes) et est même déconseillé pour des machines virtuelles. </​note>​+<​note>​Sur du matériel déjà reconnu le passage à une étape de version LTS (** HWE ** Hardware Enablement Stack) a peu d’intérêt (les [[:​dépôts]] restent les mêmes) et est même déconseillé pour des machines virtuelles.</​note>​
 Certaines applications utilisant des dépendances propres à la version du serveur graphique seront désinstallées. Une fois le passage à l'​étape de version LTS supérieure,​ il suffira de les ré-installer pour qu'​elles utilisent les dépendances en corrélation avec la nouvelle version du serveur graphique. ​ Certaines applications utilisant des dépendances propres à la version du serveur graphique seront désinstallées. Une fois le passage à l'​étape de version LTS supérieure,​ il suffira de les ré-installer pour qu'​elles utilisent les dépendances en corrélation avec la nouvelle version du serveur graphique. ​
  
Ligne 37: Ligne 37:
 </​note>​ </​note>​
  
-===Pour ​Xenial ​16.04===+===Pour ​Ubuntu ​16.04===
 Pour passer au HWE stack, Pour passer au HWE stack,
    * __DESKTOP__\\ [[:​tutoriel/​comment_installer_un_paquet|Installer les paquets]] depuis un [[:​terminal]] en saisissant la [[:​commande_shell|commande]] suivante :​ <​code>​sudo apt-get install --install-recommends linux-generic-hwe-16.04 xserver-xorg-hwe-16.04</​code> ​    * __DESKTOP__\\ [[:​tutoriel/​comment_installer_un_paquet|Installer les paquets]] depuis un [[:​terminal]] en saisissant la [[:​commande_shell|commande]] suivante :​ <​code>​sudo apt-get install --install-recommends linux-generic-hwe-16.04 xserver-xorg-hwe-16.04</​code> ​
    * __SERVER__ \\ Installer les paquets en saisissant la commande suivante :<​code>​sudo apt-get install --install-recommends linux-generic-hwe-16.04</​code>​    * __SERVER__ \\ Installer les paquets en saisissant la commande suivante :<​code>​sudo apt-get install --install-recommends linux-generic-hwe-16.04</​code>​
  
-===Pour ​Trusty ​14.04===+===Pour ​Ubuntu ​14.04===
   * Pour passer au HWE stack de Utopic (équipé du noyau 3.16.0-x)\\ [[:​tutoriel/​comment_installer_un_paquet|Installer les paquets]] depuis un [[:​terminal]] en saisissant la [[:​commande_shell|commande]] suivante :​ <​code>​ sudo apt-get install --install-recommends linux-generic-lts-utopic xserver-xorg-lts-utopic libgl1-mesa-glx-lts-utopic libegl1-mesa-drivers-lts-utopic </​code>​   * Pour passer au HWE stack de Utopic (équipé du noyau 3.16.0-x)\\ [[:​tutoriel/​comment_installer_un_paquet|Installer les paquets]] depuis un [[:​terminal]] en saisissant la [[:​commande_shell|commande]] suivante :​ <​code>​ sudo apt-get install --install-recommends linux-generic-lts-utopic xserver-xorg-lts-utopic libgl1-mesa-glx-lts-utopic libegl1-mesa-drivers-lts-utopic </​code>​
   * Pour passer au HWE stack de Vivid (équipé du noyau 3.19.0-x)   * Pour passer au HWE stack de Vivid (équipé du noyau 3.19.0-x)
Ligne 56: Ligne 56:
     * __MULTIARCH__ \\ [[:​tutoriel/​comment_installer_un_paquet|Installer les paquets]] depuis un [[:​terminal]] en saisissant la [[:​commande_shell|commande]] suivante :<​code>​sudo apt-get install --install-recommends linux-generic-lts-xenial xserver-xorg-core-lts-xenial xserver-xorg-lts-xenial xserver-xorg-video-all-lts-xenial xserver-xorg-input-all-lts-xenial libwayland-egl1-mesa-lts-xenial libgl1-mesa-glx-lts-xenial libgl1-mesa-glx-lts-xenial:​i386 libglapi-mesa-lts-xenial:​i386</​code>​([[https://​wiki.ubuntu.com/​Kernel/​LTSEnablementStack#​Multiarch_Desktop|(en) Source]])     * __MULTIARCH__ \\ [[:​tutoriel/​comment_installer_un_paquet|Installer les paquets]] depuis un [[:​terminal]] en saisissant la [[:​commande_shell|commande]] suivante :<​code>​sudo apt-get install --install-recommends linux-generic-lts-xenial xserver-xorg-core-lts-xenial xserver-xorg-lts-xenial xserver-xorg-video-all-lts-xenial xserver-xorg-input-all-lts-xenial libwayland-egl1-mesa-lts-xenial libgl1-mesa-glx-lts-xenial libgl1-mesa-glx-lts-xenial:​i386 libglapi-mesa-lts-xenial:​i386</​code>​([[https://​wiki.ubuntu.com/​Kernel/​LTSEnablementStack#​Multiarch_Desktop|(en) Source]])
     * __SERVER__ \\ Installer les paquets en saisissant la commande suivante :<​code>​sudo apt-get install --install-recommends linux-generic-lts-xenial</​code>​([[https://​wiki.ubuntu.com/​Kernel/​LTSEnablementStack#​Server-1|(en) Source]])     * __SERVER__ \\ Installer les paquets en saisissant la commande suivante :<​code>​sudo apt-get install --install-recommends linux-generic-lts-xenial</​code>​([[https://​wiki.ubuntu.com/​Kernel/​LTSEnablementStack#​Server-1|(en) Source]])
-=== Pour Precise 12.04=== +
-Pour passer à Precise 12.04.5, [[:​tutoriel/​comment_installer_un_paquet|installer le paquet]] **[[apt>​linux-generic-lts-trusty]]** et le paquet pour le serveur graphique [[wpfr>​xorg|Xorg]] **[[apt>​xserver-xorg-lts-trusty]]**\\ +
-([[https://​wiki.ubuntu.com/​Kernel/​LTSEnablementStack#​Precise|(en) Source]])+
  
 ==== Installer sans étape de version LTS==== ==== Installer sans étape de version LTS====
Ligne 66: Ligne 64:
   * utiliser une [[http://​old-releases.ubuntu.com/​releases/​14.04.1/​|ancienne iso de Trusty 14.04.1 LTS]].   * utiliser une [[http://​old-releases.ubuntu.com/​releases/​14.04.1/​|ancienne iso de Trusty 14.04.1 LTS]].
 Après avoir installé à partir d'une iso plus ancienne, vous pourrez mettre à jour votre système en 14.04.x mais en conservant un [[:​kernel|noyau]] 3.13.0.x . Après avoir installé à partir d'une iso plus ancienne, vous pourrez mettre à jour votre système en 14.04.x mais en conservant un [[:​kernel|noyau]] 3.13.0.x .
- 
-===Pour Precise 12.04=== 
-Si vous souhaitez [[:​installation|installer]] [[:​precise|Ubuntu 12.04 LTS]] sans étape de version LTS, avec un [[:​kernel|noyau]] 3.2.0-x, vous pouvez faire au choix: 
-  * une installation via le réseau(([[tutoriel:​installer_ubuntu_par_internet|netinstall]])) ((http://​cdimage.ubuntu.com/​netboot/​)) à l'aide d'une [[https://​help.ubuntu.com/​community/​Installation/​MinimalCD|mini-iso]];​ 
-  * utiliser une ancienne iso 12.04.1 LTS [[http://​old-releases.ubuntu.com/​releases/​12.04.1/​|ancienne iso Precise 12.04.1 LTS]]. 
-Après avoir installé à partir d'une iso plus ancienne, vous pourrez mettre à jour votre système en 12.04.x mais en conservant un [[:​kernel|noyau]] 3.2.0.x . 
  
 ===== Désinstallation ===== ===== Désinstallation =====


Le contenu de ce wiki est sous licence : CC BY-SA v3.0