Différences

Ci-dessous, les différences entre deux révisions de la page.

Lien vers cette vue comparative

Les deux révisions précédentes Révision précédente
Dernière révision Les deux révisions suivantes
openplm [Le 16/07/2012, 14:03]
92.139.173.77
openplm [Le 06/01/2016, 10:40]
80.254.150.51 Lucid est obsolete + ajout FIXME pre-requis
Ligne 1: Ligne 1:
-{{tag>Lucid Natty entreprise GED  }}+{{tag>Precise ​entreprise GED  }}
 ---- ----
  
Ligne 15: Ligne 15:
   * Disposer des [[:​sudo|droits d'​administration]].   * Disposer des [[:​sudo|droits d'​administration]].
   * Disposer d'une connexion à Internet configurée et activée.   * Disposer d'une connexion à Internet configurée et activée.
 +
 +FIXME les pré-requis ci-dessous étaient valides pour Ubuntu 10.10. Vérifier s'ils sont nécessaires pour les versions actuelles d'​Ubuntu.
   * Avoir [[:​tutoriel:​comment_installer_un_paquet|installé les paquets]] ** swig, build-essential,​ pkg-config, gettext, apache2 libapache2-mod-wsgi,​ python-setuptools python-dev python-imaging python-kjbuckets python-pypdf ipython, graphviz graphviz-dev,​ python-xapian rabbitmq-server,​ python-django python-docutils,​ postgresql python-psycopg2,​ python-pisa,​ poppler-utils,​ html2text, odt2txt, antiword, catdoc**.   * Avoir [[:​tutoriel:​comment_installer_un_paquet|installé les paquets]] ** swig, build-essential,​ pkg-config, gettext, apache2 libapache2-mod-wsgi,​ python-setuptools python-dev python-imaging python-kjbuckets python-pypdf ipython, graphviz graphviz-dev,​ python-xapian rabbitmq-server,​ python-django python-docutils,​ postgresql python-psycopg2,​ python-pisa,​ poppler-utils,​ html2text, odt2txt, antiword, catdoc**.
   * Avoir installé les oeufs Python :   * Avoir installé les oeufs Python :
Ligne 30: Ligne 32:
 ===== Installation ===== ===== Installation =====
  
-==== Ubuntu 10.10 ou plus récente ==== 
 Voir : Voir :
 [[http://​wiki.openplm.org/​docs/​admin/​ht_1_install_server.html | openPLM installation guide ]] [[http://​wiki.openplm.org/​docs/​admin/​ht_1_install_server.html | openPLM installation guide ]]
  
-==== Ubuntu 10.04 ==== 
-Suivre la même procédure que ci-dessus excepté pour le paquet Graphviz. 
-Nous devons en installer une version plus récente que celle proposée dans les dépôts. 
- 
-Deux solutions sont possibles : 
-=== Télécharger le paquet à partir d'un dépôt qui pointe sur une version plus récente d'​Ubuntu (ici nous proposons Maverick) === 
- 
-C'est faire ce qu'on appelle du  
-[[https://​help.ubuntu.com/​community/​PinningHowto|Pinning]] . 
- 
-1- [[:​tutoriel:​comment_modifier_sources_maj|Modifiez vos sources de mises à jour]] pour y ajouter le dépôt suivant : 
-<​file>​deb http://​fr.archive.ubuntu.com/​ubuntu maverick main restricted universe multiverse</​file>​ 
- 
-2- Il faut créer ou modifier les fichiers de configuration de apt 
- 
-[[:​tutoriel:​comment_modifier_un_fichier|Créer ou ouvrir le fichier]] **/​etc/​apt/​apt.conf** et ajouter : 
-<​code>​ 
-APT::​Default-Release "​lucid";​ 
-APT::​Cache-Limit 50331648; 
-</​code>​ 
- 
-[[:​tutoriel:​comment_modifier_un_fichier|Créer ou ouvrir le fichier]] **/​etc/​apt/​preferences** et ajouter : 
-<​code>​ 
-Package: * 
-Pin: release a=lucid 
-Pin-priority:​ 900 
- 
-Package: * 
-Pin: release a=maverick 
-Pin-priority:​ 700 
-</​code>​ 
- 
-3- [[:​tutoriel:​comment_installer_un_paquet|Installer le paquet]] graphviz en version 2.26.3-4 ou supérieure 
-<​code>​ 
-sudo apt-get update 
-sudo apt-get install graphviz=2.26.3-4 
-</​code>​ 
- 
-=== Télécharger le paquet graphviz et toutes les dépendances === 
-<​code>​wget http://​fr.archive.ubuntu.com/​ubuntu/​pool/​main/​g/​graphviz/​graphviz_2.26.3-5ubuntu4_i386.deb 
-</​code>​ 
-<​code>​dpkg -i graphviz_2.26.3-5ubuntu4_i386.deb</​code>​ 
-Analyser les messages d'​erreurs et télécharger+installer les paquets correspondants. 
- 
-Pour information,​ voici la liste de nos paquets téléchargés : graphviz_2.26.3-5ubuntu4_i386.deb,​ graphviz-dev_2.26.3-5ubuntu4_all.deb,​ libcdt4_2.26.3-5ubuntu4_i386.deb,​ libcgraph5_2.26.3-5ubuntu4_i386.deb,​ libgraph4_2.26.3-5ubuntu4_i386.deb,​ libgraphviz-dev_2.26.3-5ubuntu4_i386.deb,​ libgvc5_2.26.3-5ubuntu4_i386.deb,​ libgvpr1_2.26.3-5ubuntu4_i386.deb,​ libpathplan4_2.26.3-5ubuntu4_i386.deb,​ libxdot4_2.26.3-5ubuntu4_i386.deb,​ ocaml-base-nox_3.12.0-7ubuntu2_i386.deb 
  
 ===== Configuration ===== ===== Configuration =====
  • openplm.txt
  • Dernière modification: Le 23/10/2017, 09:54
  • par L'Africain