Différences

Ci-dessous, les différences entre deux révisions de la page.

Lien vers cette vue comparative

pcb_designer [Le 15/12/2011, 15:22] (Version actuelle)
Ligne 1: Ligne 1:
 +===== Pré-requis =====
 +
 +  * Disposer des [[:​sudo|droits d'​administration]].
 +  * Disposer d'une connexion à Internet configurée et activée.
 +  * Avoir [[:​tutoriel:​comment_installer_un_paquet|installé les paquets]] ​ **[[apt>​geda|geda]]** et **[[apt>​geda-utils|geda-utils]]**.
 +
 +===== Installation =====
 +
 +Pour installer ce logiciel, il suffit d'​[[:​tutoriel:​comment_installer_un_paquet|installer le paquet]] **[[apt>​pcb|pcb]]**.
 +
 +===== Configuration =====
 +
 +<note tip>Pas de configuration particulière à apporter.
 +</​note>​
 +
 +
 +
 +
 +===== Utilisation =====
 +Dans ce tutorial, le dossier de travail sera **~/​electronique**. Créez le dossier depuis un terminal en tapant :
 +<​code>​mkdir ~/​electronique</​code>​
 + 
 +==== Création du schéma ====
 +Lancez l'​éditeur de schéma gEDA depuis le menu //​Applications -> Science & Ingénierie -> Editeur de schémas gEDA// ou //via// la [[:​commande_shell|commande]] suivante :
 +<​code>/​usr/​bin/​gschem</​code>​
 +
 +=== Permier schéma : l'​alimentation ===
 +
 +== Tracé du schéma ==
 +Insérez les composants depuis le menu //Ajouter -> Component...//​.
 +
 +De cette façon, ajoutez :
 +
 +  * connector2-1
 +  * io-1  (2 fois)
 +
 +Tracez les liens ( menu //Ajouter -> Net...//) pour obtenir le schéma suivant :
 +
 +{{:​pcbdesigner_natty_01.png}}
 +
 +
 +
 +== propriété des éléments ==
 +Double-cliquez sur le connecteur et renseigner le champs **refdes** -> CONN1
 +<note importante>​ Chaque **refdes** doit être unique dans l'​ensemble des schémas du projet.</​note>​
 +Ajoutez aussi une **footprint** -> CONNECTOR 2 1
 +
 +De la même manière renomez les IO :
 +
 +  * premier IO : **net** -> BRANCHE1:1
 +  * second IO : **net** -> BRANCHE2:1
 +
 +<note importante>​Le champs **net** d'un IO doit toujours se terminer par ":​1"​.</​note>​
 +Votre schéma ressemble ​ à :
 +
 +{{:​pcbdesigner_natty_02.png}}
 +
 +Sauvegardez votre fichier dans **~/​electronique/​alimentation.sch**
 +
 +
 +=== Second schéma : la lumière ===
 +Créez un nouveau schéma en y insérant :
 +
 +  * resistor-2
 +  * led-1
 +  * io-1 (2 fois)
 +
 +Modifiez les **refdes** et spécifiez les **footprint**
 +{{:​pcbdesigner_natty_03.png}}
 +
 +Sauvegardez le fichier dans **~/​electronique/​lumiere.sch**
 +
 +
 +==== Description du projet ====
 +Ouvrez l'​éditeur de texte gedit  //via// la [[:​commande_shell|commande]] suivante :
 +<​code>/​usr/​bin/​gedit ~/​electronique/​mon_projet</​code>​
 +Insérez le texte suivant :
 +<​code>​schematics alimentation.sch lumiere.sch
 +output-name mon_circuit</​code>​
 +Enregistrez et quittez l'​éditeur de textes.
 +
 +==== Génération du circuit ====
 +Deux fichiers vont êtres nécessaires :
 +* la netlist (.net) qui décrit les lien fonctionnels du circuit
 +* le circuit lui-même (.pcb) dans lequel nous allons gérer l'​implantation des éléments
 +Depuis un terminal, mettez-vous dans le dossier de travail :
 +<​code>​cd ~/​electronique</​code>​
 +et lancez la commande :
 +<​code>​gsch2pcb mon_projet</​code>​
 +Trois fichiers sont créé :
 +  * mon_circuit.net
 +  * mon_circuit.pcb
 +  * mon_circuit.cmd ​
 +
 +La console indique que 3 empreintes ont bien été créées :
 +
 +{{:​pcbdesigner_natty_04.png}}
 +
 +==== implantation des éléments ====
 +Lancez PCB  //via// la [[:​commande_shell|commande]] suivante :
 +<​code>/​usr/​bin/​pcb mon_circuit.pcb</​code>​
 +
 +=== Dispersion des éléments ===
 +
 +Vous devriez voir tous les composants massés en haut à gauche de votre écran. Commencez par les disperser depuis le menu //​Sélection -> Disperser tous les éléments//​
 +
 +Repositionnez les éléments à votre guise.
 +
 +=== Renseignement des liens fonctionnels ===
 +Chargez le fichier de netlist depuis le menu //Fichier -> charger le fichier de netlist//
 +
 +Sélectionnez **mon_circuit.net**
 +
 +=== Création du routing ===
 +Créez les liaisons depuis le menu //Connects -> optimiser les liaisons//
 +
 +{{:​pcbdesigner_natty_05.png}}
 +
 +Et enfin créez le routing final depuis le menu //Connects -> Auto-route all rats//
 +
 +{{:​pcbdesigner_natty_06.png}}
 +
 +<​note>​Vous pouvez réinitialiser le routing depuis le menu //Connects -> Rip-up all auto-routed tracks//</​note>​
 +<​note>​Vous pouvez changer le nombre de couches (en spécifiant 2 pour un circuit double face) depuis le menu //Fichier -> Préférences... -> Couches // </​note>​
 +<​note>​Vous pouvez changer la largeur des pistes et l'​espacement minimum entre les couches en cliquant sur le bouton //style de routage// en bas à gauche de l'​écran</​note>​
 +<​note>​ Vous pouvez rechercher toutes les **footprint** disponible en pressant la touche « i » </​note>​
 +<note importante>​ Exportez votre typon depuis le menu //Fichier -> Export layout... -> PS // **Spécifiez une échelle 1.05 dans le champs scale**
 +vous pourrez convertir votre PS en PDF via la commande [[ps2pdf]]</​note>​
 +
 +===== Désinstallation =====
 + 
 +Pour supprimer cette application,​ il suffit de [[:​tutoriel:​comment_supprimer_un_paquet|supprimer son paquet]]. Selon la méthode choisie, la configuration globale de l'​application est conservée ou supprimée. Les journaux du système, et les fichiers de préférence des utilisateurs dans leurs dossiers personnels sont toujours conservés.
 + 
 +===== Voir aussi =====
 + 
 +  * **(en)** [[http://​pcb.gpleda.org]]
 +  * **(en)** [[http://​www.geda.seul.org/​wiki/​geda:​gsch2pcb_tutorial]]
 + 
 +----
 +//​Contributeurs principaux : [[utilisateurs:​landru_ker|Landru_ker]].//​
 + 
 +//Basé sur [[http://​www.geda.seul.org/​wiki/​geda:​gsch2pcb_tutorial|« Wiki du site officiel »]]
  
  • pcb_designer.txt
  • Dernière modification: Le 15/12/2011, 15:22
  • (modification externe)