Différences

Ci-dessous, les différences entre deux révisions de la page.

Lien vers cette vue comparative

Les deux révisions précédentes Révision précédente
supertux [Le 30/01/2017, 18:59]
bcag2 [Version 0.3.X (Version de développement)] ajout note dépôt landronimirc plus maintenu
supertux [Le 16/03/2017, 16:05] (Version actuelle)
bcag2 nettoyage paquet et liens morts… ajout lien github
Ligne 19: Ligne 19:
 Le jeu est aussi présent dans le dépôt de [[djl|DJL]]. Le jeu est aussi présent dans le dépôt de [[djl|DJL]].
  
-<​note>​Il y a 3 version du jeuLa première est indépendante des 2 autres. C'est la version du PPA (version de développement) qui offre un maximum de game-play.</​note>​+Sous [[xenial]], il faut [[:​tutoriel:​comment_installer_un_paquet|installer le paquet]] **[[apt://​supertux|supertux]]**
  
 ==== Version 0.1.3 (Milestone 1) pour ubuntu <= 16.04 ==== ==== Version 0.1.3 (Milestone 1) pour ubuntu <= 16.04 ====
Ligne 45: Ligne 45:
 <note important>​Si le jeu crash alors que vous utilisez un Add-Ons, ce n'est pas grave : relancez le jeu ( seul votre progression dans le niveau est perdu). C'est le cas lorsque il y a un bug dans le niveau qui n'a pas été détecté (ou corrigé). C'est pourquoi il vaut mieux remettre à jour souvent les Add-Ons.</​note>​ <note important>​Si le jeu crash alors que vous utilisez un Add-Ons, ce n'est pas grave : relancez le jeu ( seul votre progression dans le niveau est perdu). C'est le cas lorsque il y a un bug dans le niveau qui n'a pas été détecté (ou corrigé). C'est pourquoi il vaut mieux remettre à jour souvent les Add-Ons.</​note>​
  
-==== Version 0.3.X (Version de développement) ==== +==== Version ​développement ​0.4 (déc2015) ==== 
-La version la plus récente du jeu est disponible via le PPA daily de supertux ​+Les sources sont désormais sur github
-<note warning>​Le dépôt landronimirc ne semble plus maintenu ! L'url sur launchpad (note de bas de page (7) n'est plus bonne</​note>​ +[[https://github.com/SuperTux/supertux|version en développement sur github]]
-  * [[ppa|Ajoutez à vos sources de logiciels le PPA]] suivant : **ppa:​landronimirc/​supertux-git**((https://launchpad.net/~landronimirc/​+archive/supertux-git)) +
-  * [[:​tutoriel:​comment_modifier_sources_maj#​recharger_la_liste_des_paquets|Rechargez la liste des paquets]]+
-  * [[:​tutoriel:​comment_installer_un_paquet|Installez le paquet]] **[[apt://​supertux-git|supertux-git]]**. +
-ce qui donne en une seule ligne :\\ +
-<​code>​sudo add-apt-repository ppa:​landronimirc/​supertux-git && sudo apt-get update && sudo apt-get install -y supertux-git</​code>​ +
- +
-Cette version se substitue à la version 0.3.3 (Milestone 2) du paragraphe précédant : les 2 versions ne sont pas indépendantes. +
-<​note>​Cette version étant souvent mise à jour, la manipulation pour obtenir les Add-Ons du paragraphe précédant sont devenus inutiles (le jeu va lui même chercher les extentions disponibles via le menu "​Extentions"</​note>​ +
-Les Add-Ons sont accessibles via le menu //​Contributions//​. +
-<note tip>​Cette version étant la plus récente de toutes, c'est ici que le game-play est le meilleur (diverses corrections de bug)</​note>​ +
- +
-Lancez l'​application via le dash ou via le terminal (toutes versions d'​Ubuntu) avec la commande suivante : ''​supertux2''​ +
-L'​utilisation de cette version simplifie beaucoup l’installation et l'​utilisation de l'​éditeur de niveau.+
  
 ===== Éditeur de niveau : créer ses propres niveaux : ===== ===== Éditeur de niveau : créer ses propres niveaux : =====
Ligne 88: Ligne 75:
    * Le **commentaire** : inutile    * Le **commentaire** : inutile
    * L'​**image** : Prenez celle disponible dans ~((Votre dossier personnel))/​Editor_r5932_linux32/​supertux-editor.png    * L'​**image** : Prenez celle disponible dans ~((Votre dossier personnel))/​Editor_r5932_linux32/​supertux-editor.png
- 
-==== Installation de l'​éditeur de niveau pour la version de développement (0.3.X) (par paquet) ==== 
- 
-Pour installer l'​éditeur de niveau pour la version de développement (PPA), il suffit d'​installer le paquet **[[apt>​supertux-editor-git]]**. 
-Ce paquet est en conflit avec supertux2, donc il désinstallera ce dernier. De plus il est régulièrement mis à jour, et les dépendances (mono) sont satisfaites automatiquement lors de l'​installation. 
-La méthode du paragraphe précédent devient donc inutile et superflu. 
-Lancez l'​application via le dash (Ubuntu 11.04 et ultérieures) ou via le terminal (toutes versions d'​Ubuntu) avec la commande suivante : ''​supertux-editor''​ 
  
 ==== Conseils d' utilisation pour les versions par archive et par paquet ​ ==== ==== Conseils d' utilisation pour les versions par archive et par paquet ​ ====
  • supertux.txt
  • Dernière modification: Le 16/03/2017, 16:05
  • par bcag2