Contenu | Rechercher | Menus
Selon les tags présents sur cette page, celle-ci est ancienne et ne contient plus d'informations sur une des versions supportées d'Ubuntu.
Selon les tags présents sur cette page, les informations qu'elle contient n'ont pas été vérifiées depuis Ubuntu 10.04 LTS.
Cette page est en cours de rédaction.
Apportez votre aide…

Bazaar GUI

TODO (pour enlever le tag BROUILLON)

  • refaire les captures d'écran avec le thème par défaut

bzr-gtk est une interface graphique de Bazaar qui est aussi connu sous le nom de Bazaar GUI. Elle intègre l'éditeur Olive. Cette interface est désormais remplacée par Bazaar Explorer.

Installation

Le paquet bzr-gtk fait partie du dépôt Universe, qu'il faut donc activer. À la suite de cela, il suffit d'installez le paquet bzr-gtk.

Utilisation

Bien qu'il soit bien plus rapide et fiable d'utiliser la ligne de commande, il existe une interface pour gérer votre bazaar. :-D

Veillez cependant à être bien familiarisé avec l'usage de la commande bzr

bzr help commands # Liste des commandes
bzr help xxx      # Aide sur la commande xxx</code>

À partir de maverick, il n'y plus d'interface globale (Olive) comme il pouvait y avoir précédemment, d'où l'intérêt d'utiliser Bazaar Explorer. On peut toutefois utiliser les différents modules de bzr-gtk, comme l'explique la section Les modules de bzr-gtk.

Avant maverick, la commande à lancer est

olive-gtk

Présentation

L'interface bzr-gtk se présente comme suit :

  • Liste à puce
  • Une barre de menu regroupant les actions possibles en fonction du contexte.
  • Une barre d'outils des actions courantes.
  • 1 → L'emplacement dans votre arborescence, permet également de changer d'emplacement.
  • 2 → Le contenu du répertoire courant.
  • 3 → La fenêtre des marques-pages, correspondant à des emplacements définis dans votre arborescence.

La première action consistera à aller dans le menu Fichiers/File et d'ajouter un marque-page du répertoire courant (~/Projets)/Bookmark current directory

bzr-gtk au commencement

Création d'un projet

Sélectionner dans le menu Branch/Initialize, une boite de dialogue apparaît, entrez les informations comme ci-dessous.

Revient au même que :

mkdir MonProjet && cd MonProjet && bzr init

bzr-gtk initialisation du projet

Vous pouvez voir votre dossier MonProjet dans la partie de droite de bzr-gtk, Vous pouvez entrer dedans en double-cliquant sur l'icône du dossier. Afin de pouvoir accéder plus rapidement à votre projet, vous pouvez ajouter un marque-page comme expliqué plus haut.

Ajout et validation du projet

L'interface bzr-gtk, n'étant pas vraiment un gestionnaire de fichiers, nous allons créer 3 fichiers en ligne de commande.

cd ~/Projets/MonProjet && touch fichier1 fichier2 fichier3

Pour marquer les nouveaux fichiers à ajouter menu File/Add

bzr-gtk marquer les fichiers à ajouter

Pour valider l'ajout et/ou la modification de fichiers cliquez sur le Bouton Commit ou menu Branche/Commit.

bzr-gtk Valider l'ajout des trois fichiers

Consulter l'historique

Pour consulter l'historique de votre projet. Cliquez sur le bouton Log ou menu Statistics/Log

bzr-gtk Consulter l'historique de votre projet

Consulter les différences

Pour consulter les différences entre la version encours non "commitée" et la dernière de version du fichier. Cliquez sur le bouton Diff ou menu Statistics/Diff.

  • Le - devant la ligne indique que la ligne à été supprimée
  • Le + devant la ligne indique que la ligne a été ajoutée

Consulter les différences entre la version encours non "commitée" et la dernière de version

Créer un répertoire

Pour créer un sous dossier dans votre projet menu File/Make directory. Indiquer un nom de répertoire et cliquez sur Versioned directory. Ceci revient au même que :

mkdir SousDossier && bzr add SousDossier

Ajouter un répertoire et le valider

Renommer un fichier ou un répertoire

Sélectionner le fichier ou le dossier à renommer et menu File/Rename

Renommer un fichier

Supprimer un fichier

Sélectionner le ou les fichiers que vous souhaitez supprimer et menu File/Remove

Supprimer un fichier

Les bons réflexes

Si vous êtes seul à travailler sur votre projet, vous n'avez pas à vous soucier des mises à jours effectuées par d'autres personnes.

Cependant en équipe vous devez avant d'effectuer des modifications vérifier que des modifications n'ont pas été effectuées par d'autres. Première chose vous devez faire un pull du serveur launchpad vers votre répertoire projet. Cliquez sur le bouton Pull

 Mettre à jour sont projet sur sa machine

Néanmoins si vous aviez fait des modifications avant de faire le pull et que quelqu'un d'autre avait modifié les mêmes fichiers, dans de cas vous devrez faire un merge.

Récupérer un projet existant

Vous pouvez charger sur votre machine un projet existant et depuis n'importe quelle version (ou révision) Par exemple vous souhaitez apporter une correction à la version 30 alors que le projet en est à la 63, ce qui donnera la nouvelle version 30.1 Cliquez sur Jump-to et entrez le numéro de version désirée.

Récupérer un projet existant

Les modules de bzr-gtk

Pour obtenir les différents modules de l'interface de façon inviduelle, vous pouvez lancer depuis le répertoire de votre projet/branche la commande bzr suivi de

gannotate
gcheckout
gconflicts
ginit
gmissing
gpush
gselftest
gstatus
gbranch
gcommit
gdiff
gmerge
gpreferences
graph-ancestry
gsend
gtags

Liens



Le contenu de ce wiki est sous licence : CC BY-SA v3.0