Différences

Ci-dessous, les différences entre deux révisions de la page.

Lien vers cette vue comparative

Les deux révisions précédentes Révision précédente
Prochaine révision
Révision précédente
cacti [Le 05/09/2013, 11:59]
81.194.42.160 [Installation]
cacti [Le 05/04/2019, 13:33] (Version actuelle)
217.109.195.73 [Cacti : un serveur de supervision]
Ligne 1: Ligne 1:
-{{tag>Breezy Intrepid Hardy administration serveur sécurité système supervision}}+{{tag>Xenial ​administration serveur sécurité système supervision}}
  
 ---- ----
Ligne 8: Ligne 8:
  
  
-**Cacti** est un logiciel de supervision basé sur RRDtool permettant de surveiller l’activité de son architecture informatique à partir de graphiques quotidiens, hebdomadaires,​ mensuels et annuels. Voici un exemple de graphique : +**Cacti** est un logiciel de supervision basé sur RRDtool permettant de surveiller l’activité de son architecture informatique à partir de graphiques quotidiens, hebdomadaires,​ mensuels et annuels. Voici un exemple de graphique: ​
  
 {{ serveur:​graph.png }} {{ serveur:​graph.png }}
  
 ===== Pré-requis ===== ===== Pré-requis =====
- +  
-Pour pouvoir utiliser Cacti, il faut Apache, MySQL et PHP : [[:​tutoriel:​comment_installer_un_paquet|installez ​les paquets]] **apache2 ​mysql-server php5**+  * Disposer des [[sudo|droits d'​administration]]. 
- +  * Disposer d'une connexion à Internet configurée et activée. 
-Pour la question suivante laisser le paramètre par défaut.+  * Avoir [[:​tutoriel:​comment_installer_un_paquet|installé ​les paquets]] **[[apt>​snmpd,​snmp-mibs-downloader,​rrdtool,​php5-mysql,​php5-cgi,​php5-cli,​php5-snmp,​php-pearapache2,​mysql-server,php5]]**.
  
 ===== Installation ===== ===== Installation =====
-Cacti est indisponible +Il vous suffit, pour cela, d'​[[:​tutoriel:​comment_installer_un_paquet|installer ​les paquets]] ** [[apt>Cacti,cacti-spine]]**.
-==== Installation à partir des dépots ==== +
-<note important>​Avant de procéder à l'​installation de cacti par les dépots soyez sûr d'​avoir un serveur apache/​mysql fonctionnel</​note>​ +
-Il vous suffit, pour cela, d'​[[:​tutoriel:​comment_installer_un_paquet|installer ​le paquet]] ** [[apt://cacti|Cacti]] ** +
- +
-==== Installation à partir des sources ==== +
- +
- +
-[[:​tutoriel:​comment_installer_un_paquet|Installer les paquets]] **php5-mysql php5-cgi php5-cli php5-snmp php-pear snmp snmpd**. +
- +
-Activez les dépôts //​Universe//​ puis [[:​tutoriel:​comment_installer_un_paquet|installez le paquet]] **rrdtool**. +
- +
-Récupérer la [[http://​www.cacti.net/​download_cacti.php|dernière version de Cacti]] +
- +
-  sudo -s +
-  mv cacti-version.tar.gz /var/www +
-  cd /var/www +
-  tar xzf cacti-version.tar.gz +
-  mv cacti-version cacti +
-  rm cacti-version.tar.gz +
-  exit+
  
  
-Créer la base de données Cacti :+====Créer la base de données Cacti====
  
   cd /​var/​www/​cacti   cd /​var/​www/​cacti
Ligne 73: Ligne 53:
 */5 * * * * cactiuser php5 /​var/​www/​cacti/​poller.php > /dev/null 2>&1 */5 * * * * cactiuser php5 /​var/​www/​cacti/​poller.php > /dev/null 2>&1
 </​file>​ </​file>​
- 
-[[:​tutoriel:​comment_editer_un_fichier|Éditez le fichier]] **/​etc/​php5/​apache2/​php.ini** et décommenter la ligne suivante : 
- 
-  ;​extension=msql.so 
- 
-[[:​tutoriel:​comment_editer_un_fichier|Éditez le fichier]] **/​etc/​php5/​cli/​php.ini** et décommenter la ligne suivante : 
- 
-  ;​extension=msql.so 
- 
-[[:​tutoriel:​comment_editer_un_fichier|Éditez le fichier]] **/​etc/​php5/​cgi/​php.ini** et décommenter la ligne suivante : 
- 
-  ;​extension=msql.so 
  
 Redémarrer Apache : Redémarrer Apache :
  • cacti.1378375151.txt.gz
  • Dernière modification: Le 05/09/2013, 11:59
  • par 81.194.42.160