Contenu | Rechercher | Menus
Selon les tags présents sur cette page, celle-ci est ancienne et ne contient plus d'informations sur une des versions supportées d'Ubuntu.
Cette page est en cours de rédaction.
Apportez votre aide…

Eclipse et MySQL - SQL Explorer Plugin

Il peut s'avérer très pratique d'avoir un accès à une base de données via Eclipse. Nous allons voir ici comme installer le plugin SQL Explorer Plugin à Eclipse.

Prérequis

  • Disposer d'une connexion à Internet configurée et activée
  • Avoir installé un serveur LAMP, et disposer d'Eclipse
  • Avoir MySQL correctement configuré et fonctionnel
  • Connaître l'emplacement racine de l'application Eclipse

Installation

SQL Explorer Plugin

Téléchargez la dernière version ici.

Téléchargez le fichier SQL Explorer Plugin, pas les RCP.

Décompressez le fichier, vous obtenez deux dossiers : features et plugins. Vous trouverez deux dossiers identiques dans le dossier de l'application Eclipse, et comme vous l'avez certainement déjà deviné, il suffit de copier les nouveaux fichiers extraits dans ceux d'Eclipse.

MySQL Connector/J

Téléchargez la dernière version de MySQL Connector/J que vous trouverez ici sous la forme d'une archive tar.gz.

Décompressez le fichier que vous avez téléchargé. Dans les éléments décompressés, un seul fichier nous intéresse : mysql-connector-java-5.1.6-bin.jar.1)

Pour plus de commodités, nous allons copier ce fichier dans /usr/share/mysql :

sudo cp mysql-connector-java-5.1.6-bin.jar /usr/share/mysql

Configuration

La configuration se fait uniquement dans Eclipse, lancez donc celui-ci.

Allez dans le menu "Window → Preferences". Une nouvelle section "SQL Explorer" a fait son apparition. Déployez la et sélectionnez "JDBC DRIVERS".

Dans la partie de droite, double-cliquez sur "MySQL Driver".

Sélectionnez l'onglet "Extra Class Path", et cliquez sur "Add", et allez rechercher le fichier /usr/share/mysql/mysql-connector-java-5.1.6-bin.jar.

Une fois fait, cliquez sur "List Drivers", dans le menu déroulant "Driver Class Name", le premier de la liste "com.mysql.jdbc.Driver" est sélectionné par défaut, cela tombe bien car c'est celui qu'il nous faut.

Cliquez sur OK.

Eclipse et SQL Explorer sont maintenant prêts pour se connecter à des bases MySQL.

Connexion

Il est possible que la "vue" pour les connexions ne soit pas visible, pour cela allez dans le menu "Window → Show View → Other". Sélectionnez Connections et OK.

Ajoutez maintenant une nouvelle connexion à votre base MySQL.

Corrigez l'URL qui était :

jdbc:mysql://<hostname>[<:3306:>]/<dbname>

et devient (par exemple) :

jdbc:mysql://localhost:3306/mydb

Ensuite il ne vous reste plus qu'à utiliser les outils proposés par SQL Explorer.

Voir aussi

1) La version disponible en juin 2012 est la 5.1.20


Le contenu de ce wiki est sous licence : CC BY-SA v3.0