Contenu | Rechercher | Menus
Selon les tags présents sur cette page, celle-ci est ancienne et ne contient plus d'informations sur une des versions supportées d'Ubuntu.
Apportez votre aide…

Déclaration française d’impôts sur le revenu

Pré-requis

Avant de se lancer dans sa déclaration, on peut être amené à faire une demande ou une révocation de certificat. Pour ne pas aboutir à une fermeture brutale du navigateur, ajoutez : impots.gouv.fr à la liste des sites autorisés à ouvrir des "popup" (dans Firefox : Édition > Préférences ; Contenu ; Bloquer les fenêtres popup : Exceptions).

Afin que le plugin java soit bien reconnu par firefox, désinstaller le paquet icedtea6-plugin (ubuntu 10.04). Pour lister les plugin firefox : dans la barre d'adresse saisir "about:plugins" et valider 8-)

La déclaration 2009 sous Jaunty

Avec le plugin Java de Sun

La déclaration fonctionne sans problème avec le plugin Java de Sun. Pour celà, il peut être utile d'installer, s'ils ne sont pas présents sur votre système :

Afin de pouvoir installer Java de Sun sous Ubuntu 10.04 Lucid Lynx, il faut activer le dépôt partenaire : depot_commercial

Le problème version 9.04

Impossible de signer la déclaration à la fin lorsqu'on utilise un certificat : le paquet IcedTea Plugins empêche d'utiliser le paquet plugins fournit par sun, il suffit de le désinstaller avec synaptic.

Pour contourner ce problème, il faut faire sa déclaration sans certificat. https://inscriptionpart.impots.gouv.fr/tdir-03/TDL/DelestageLogin.html

Le problème version 8.04

Vous souhaitez faire votre déclaration d'impôts française par Internet et n'arrivez pas à la faire sur Ubuntu 8.04 LTS (soit en utilisant Firefox 3 Beta 5) ? C'est normal (enfin scandaleux, mais habituel) : il y a quelques commandes à exécuter afin avant de pouvoir exécuter la dernière signature.

Pour la déclaration d'impôts 2009, il est désormais possible de déclarer sans certificat, ça évite de tourner en rond pendant des heures à essayer de résoudre le problème de java bien installé mais non reconnu lors de l'accès à la déclaration, ou bien de comprendre pourquoi la procédure bloque à l'étape de signature (erreur n°100 ou autre rectangle gris qui cache la signature à sélectionner…).

La vérification

Tapez about:plugins dans la barre d'adresse de Firefox pour vérifier la version du plugin java employée et donc adapter la solution en fonction de cet élément (idem pour SeaMonkey).

La solution

Plug-in Java 1.6 installé

Si dans la page des plugins, vous lisez :

Java(TM) Plug-in 1.6.0_06-b02

Il vous suffit d'installer le paquet libnss3-dev et ses dépendances et de relancer Firefox.

Package "sun-java6-plugin" installé mais plug-in Java 1.6 non présent dans la page about:plugins

Si vous ne trouvez pas Java(TM) Plug-in, il se peut qu'il s'agisse du bug #205980 in sun-java6 (Ubuntu) décrit ici : https://bugs.launchpad.net/ubuntu/+source/sun-java6/+bug/205980

Auquel cas il vous faut créer manuellement le lien sur la librairie java :

sudo ln -s /usr/lib/jvm/java-6-sun/jre/plugin/i386/ns7/libjavaplugin_oji.so /usr/lib/xulrunner-addons/plugins/libjavaplugin.so

Si, après avoir entré la commande précédente vous obtenez le message suivant :

ln: création d'un lien symbolique `/usr/lib/xulrunner-addons/plugins/libjavaplugin.so': Le fichier existe

Entrez ceci (efface le lien existant) :

 sudo rm /usr/lib/xulrunner-addons/plugins/libjavaplugin.so

… et saisissez à nouveau la 1ere commande ci-dessus.

User agent

Pour que la solution décrite plus haut fonctionne, il se peut que vous ayez besoin de changer votre "user agent". Il s'agit d'une chaine de caractère que les navigateurs utilisent pour s'identifier (nom, version, système d'exploitation…). Pour la modifier simplement, installez l'extension de firefox User agent switcher, et choisissez de simuler la navigation avec Internet Explorer 7. Le site des impôts pensera alors que vous êtes un simple utilisateur de Windows et fonctionnera.

Autre solution (autres versions de Firefox ?)

On pourra préférer cette solution si Java 1.5 est installé (java5-plugin) et pas Java 1.6.

Tout d'abord supprimez les paquets sun-java6-plugin sun-java6-bin sun-java6-jre gcjwebplugin icedtea-java7-plugin.

Ensuite installez les paquets sun-java5-plugin sun-java5-bin sun-java5-jre libnss3-dev.

Utilisez la commande ci-dessous pour choisir la machine virtuelle Java à utiliser par défaut :

sudo update-alternatives --config java

Il ne vous reste plus qu'à relancer Firefox et le tour est joué. :-)

Si quand vous choisissez votre certificat l'applet Java vous demande votre mot de passe, il s'agit du « mot de passe principal » de Firefox (si vous en disposez d'un).

Si ça ne marche toujours pas !

Il ne faut pas désespérer ! Il existe beaucoup d'autres techniques (firefox2.0/java1.6, etc.) le post le plus complet en idée et en explication au sujet de cette maudite déclaration est ici : http://forum.ubuntu-fr.org/viewtopic.php?id=210760&p=1

Version 64 bits

La discussion et la résolution se trouve ici : http://forum.ubuntu-fr.org/viewtopic.php?id=119584


Contributeurs : BebelAdrien, Floriang, mavosaure, olivier.



Le contenu de ce wiki est sous licence : CC BY-SA v3.0