Contenu | Rechercher | Menus

Différences

Cette page vous donne les différences entre la révision choisie et la version actuelle de la page.

Lien vers cette vue

imprimante_canon_pixma_ip2600 [Le 17/03/2013, 11:05]
phoenamandre [Pour Ubuntu Maverick Meerkat (10.10) ou ultérieure]
— (Version actuelle)
Ligne 1: Ligne 1:
-{{tag>imprimante canon}} 
----- 
-====== Imprimante Canon Pixma IP2600 ====== 
  
-Les pilotes de cette imprimante ne sont pas libres. Il faut donc aller les télécharger sur le site du constructeur. 
- 
-===== Version Ubuntu Jaunty Jackalope (9.04) ou antérieure ===== 
- 
-Le driver est constitué de 2 paquets : 
- 
-  * le paquet ''cnijfilter-common'', commun à toutes les imprimantes Canon (à installer en premier) 
-  * le paquet ''cnijfilter-ip2600series'', spécifique à l'imprimante Pixma IP2600 (à installer en dernier) 
- 
-Aller sur [[http://support-asia.canon-asia.com/contents/ASIA/EN/0100118902.html|cette page]], cliquer sur le lien **Download** tout en bas de la page, et installer le paquet. 
- 
-Faire de même pour [[http://support-asia.canon-asia.com/contents/ASIA/EN/0100119102.html|cette page]]. 
- 
-Une fois les 2 paquets installés, il ne reste plus qu'à [[http://doc.ubuntu-fr.org/imprimante|configurer votre imprimante]]. 
- 
-Lors de la configuration, sélectionner le fichier PPD ''/usr/share/ppd/canonip2600.ppd''. 
- 
-===== Version Ubuntu Karmic Koala (9.10) ===== 
- 
-Les drivers fournis sur le site de Canon ne fonctionnent pas avec Ubuntu 9.10. 
- 
-Explication : le paquet ''libcupsys2'', dont dépend le driver, a été remplacé par ''cupsys2'' dans Ubuntu 9.10, et le driver n'a pas encore été mis à jour par Canon. 
- 
-==== Solution 1 : installer un faux paquet libcupsys2 ==== 
- 
-<note warning>Cette solution peut rendre votre système de gestion de paquets inutilisable. Si tel est le cas, désinstaller le faux paquet en question devrait résoudre le problème, cependant votre imprimante ne fonctionnera plus...</note> 
- 
-Télécharger et installer [[http://dl.dropbox.com/u/3336767/libcupsys2_1.3.7-6_all.deb|ce paquet]], puis installer les drivers comme décrit précédemment. 
- 
-==== Solution 2 (non testée) : compiler et installer le driver à partir des sources ==== 
- 
-Les sources du driver sont disponibles ici : http://support-asia.canon-asia.com/contents/ASIA/EN/0100119202.html 
- 
-===== Pour Ubuntu Maverick Meerkat (10.10) ou ultérieure ===== 
- 
- 
-<note warning>Cette solution ne semble plus disponible (impossible de télécharger les fichiers nécessaires)</note> 
- 
- 
-Le paquet "libcupsys2" a été remplaçé par "libcups2" or, les paquets .deb téléchargeables sur le site de Canon sont obsolètes et doivent être modifiés. 
- 
-Les paquets modifiés sont disponibles ici : 
- 
-  * [[http://louiz.org/jyraphe/file.php?h=R97183dbeb065dcb52e99e3ea8d2615b7|Paquet common]] 
-  * [[http://louiz.org/jyraphe/file.php?h=Rba2645a9693e5dd01f2caaf57a167156|Paquet ip2600-series]] 
- 
-<note important>Le paquet "common" doit être installé **avant** le paquet "ip2600-series". L'imprimante doit être branchée et allumée pendant l'installation.</note> 
- 
-Après l'installation de ces deux paquets, une série de commandes doit être entrée : 
- 
-<code>sudo chown -hR root /usr/lib/cups/filter</code> 
-<code>sudo chown -hR root /usr/lib/cups/backend</code> 
-<code>sudo chgrp -hR root /usr/lib/cups/filter</code> 
-<code>sudo chgrp -hR root /usr/lib/cups/backend</code> 
- 
-Un redémarrage du système peut être nécessaire. Il suffit ensuite d'ajouter l'imprimante dans Système > Administration > Impression. 
- 
-<note>Il faudrait vérifier que cette démarche fonctionne également sur les versions précédentes d'Ubuntu. Lien du post pris en référence : [[http://forum.ubuntu-fr.org/viewtopic.php?id=358597|ici]]</note> 

imprimante_canon_pixma_ip2600.1363514703.txt.gz · Dernière modification: Le 17/03/2013, 11:05 par phoenamandre
Le contenu de ce wiki est sous licence : CC BY-SA v3.0