Différences

Ci-dessous, les différences entre deux révisions de la page.

Lien vers cette vue comparative

Les deux révisions précédentes Révision précédente
libbluray [Le 02/09/2013, 12:14]
90.39.20.237 [libbluray : bibliothèque de prise en charge des disques Blu-Ray]
libbluray [Le 02/03/2017, 13:18] (Version actuelle)
L'Africain Maj de la page
Ligne 1: Ligne 1:
-{{tag>​multimédia blu-ray}}+{{tag>Xenial vidéo ​multimédia blu-ray}}
 ---- ----
  
Ligne 10: Ligne 10:
  
  
-<note tip>​**libbluray et les films du commerce** \\ La plupart des films sur disques Blu-Ray achetés dans vos commerces préférés sont protégés par **des systèmes** anti-copie (DRM). libbluray n'​inclut aucun moyen de contournement des DRM des disques Blu-Ray. Pour lire vos films du commerce, vous devrez installer également les bibliothèques de contournement [[libaacs]] et [[libbdplus]].+<note tip>​**libbluray et les films du commerce** \\ La plupart des films sur disques Blu-Ray achetés dans vos commerces préférés sont protégés par **des systèmes** anti-copie (DRM). libbluray n'​inclut aucun moyen de contournement des DRM des disques Blu-Ray. Pour lire vos films du commerce, vous devrez installer également les bibliothèques de contournement [[:libaacs]] et [[:libbdplus]].
 </​note>​ </​note>​
  
-===== Installation de libbluray ​=====+===== Pré-requis ​===== 
 +  
 +  * Disposer des [[:​sudo|droits d'​administration]]. 
 +  * Disposer d'une connexion à Internet configurée et activée.
  
-La bibliothèque "​libbluray"​ est disponible à partir des dépôts de [[natty]] (ubuntu 11.04) : [[:​tutoriel:​comment_installer_un_paquet|Installer le paquet]] **[[apt>​libbluray-bdj]]**.+===== Installation=====
  
-===== Installation Alternative ​ ​Compiler la version Git =====+La bibliothèque **libbluray** est disponible dans les dépôts, il suffit donc d'​[[:​tutoriel:​comment_installer_un_paquet|installer le paquet]] **[[apt>​libbluray-bdj]]**.
  
-Cette méthode est à utiliser seulement si vous n'​utiliser pas ubuntu 11.04 ou supérieur. ​+===== Utilisation=====
  
-[[:tutoriel:​comment_installer_un_paquet|Installer les dépendances]] **[[apt://git,autoconf,​libtool,​openssl,​openjdk-6-jdk,​ant,​doxygen,​latex-make|git autoconf libtool openssl openjdk-6-jdk ant gcj-4.6-jdk]]**.+Il ne s'agit que d'une bibliothèque,​ vous aurez besoin d'un lecteur vidéo ([[:VLC]][[:MPlayer]][[:xine]] etc...) avec le soutien de libbluray.
  
-<note important>​Pour Ubuntu 10.04 LTS, il semble que le paquet git soit obsolète : j'ai utilisé **[[apt://​git-core|git-core]]** à la place, qui a fonctionné.</​note>​ 
  
-  - Télécharger la version du git, en saisissant dans un [[terminal]] :<​code>​git clone git://​git.videolan.org/​libbluray.git</​code>​ 
-  - Se placer dans le dossier: <​code>​cd ~/​libbluray</​code>​ 
-  - Création des fichiers pour l'​installation <​code>​./​bootstrap</​code>​ 
-  - Configuration:​ <​code>​./​configure --prefix=/​usr --enable-bdjava</​code>​ 
-  - Création des fichiers à installer :<​code>​make</​code>​ 
-  - Installation des fichiers :<​code>​sudo make install</​code>​ 
  
-===== Utilisation de libbluray =====+==== Mplayer====
  
-Il ne s'agit que d'une bibliothèque,​ vous aurez besoin d'un lecteur vidéo ([[VLC]][[MPlayer]][[xine]] etc...) avec le soutien de libbluray.+Vous pouvez lire un bluray sans [[wpfr>​Gestion_des_droits_num%C3%A9riques|DRM]] (sinon installer en plus [[libaacs]] et [[libbdplus]]) avec la commande suivante : <​code>​mplayer '​bluray:////​media/​nom-du-disque-bluray'</​code>​
  
-==== VLC avec le soutien libbluray ==== +<note tip>Dans la commande pour lire un bluray, il faut 4 / contrairement à VLC.</​note>​
- +
-Seulement après avoir installé [[libbluray]] (et [[libaacs]] si besoin) vous devrez compiler la dernière version de développement de VLC. +
-Pour cela il suffit de suivre l'​étape ci-dessus en l'​adaptant,​ voici l'​adresse du git de vlc : +
-   git clone git://​git.videolan.org/​vlc.git +
- +
-Cette commande vous permettra de télécharger les dépendances nécessaire à la compilation de vlc : +
-   sudo apt-get build-dep vlc +
- +
-Vous pouvez lire un bluray sans [[https://​secure.wikimedia.org/​wikipedia/​fr/​wiki/​Gestion_des_droits_num%C3%A9riques|DRM]] (sinon installer en plus [[libaacs]] et [[libbdplus]]) avec la commande suivante : +
-   vlc '​bluray:///​media/​nom-du-disque-bluray'​ +
- +
-<note tip>Dans la commande pour lire un bluray, il faut 3 / contrairement à Mplayer</​note>​ +
- +
-==== Mplayer avec le soutien libbluray ==== +
- +
-Compiler la dernière version de mplayer : [[http://​www.mplayerhq.hu/​MPlayer/​releases/​mplayer-checkout-snapshot.tar.bz2|Subversion snapshot]]. +
- +
-Vous pouvez lire un bluray sans [[https://​secure.wikimedia.org/​wikipedia/​fr/​wiki/​Gestion_des_droits_num%C3%A9riques|DRM]] (sinon installer en plus [[libaacs]] et [[libbdplus]]) avec la commande suivante : +
-   ​mplayer '​bluray:////​media/​nom-du-disque-bluray'​ +
- +
-<note tip>Dans la commande pour lire un bluray, il faut 4 / contrairement à VLC</​note>​+
  
 ===== Voir aussi ===== ===== Voir aussi =====
  • libbluray.txt
  • Dernière modification: Le 02/03/2017, 13:18
  • par L'Africain