Contenu | Rechercher | Menus

forme


Faire fonctionner 6play sous Ubuntu

Si vous tentez de faire fonctionner 6play sous GNU/Linux, vous risquez d'être déçus : après la publicité, pas de vidéo. Flashplayer est bien sûr nécessaire, mais ce n'est pas suffisant…

slider-6play-1200x490.jpg

Explications

Pourquoi la vidéo ne se lance pas? Tout simplement car 6play utilise un contenu "protégé" avec des DRM (Digital Rights Management). De plus, il faut au minimum la version 14 de Flashplayer. Cependant, la version Linux de Flashplayer reste cantonnée à la 11.2.
On pourrait croire qu'utiliser un navigateur internet utilisant des versions supérieures de Flashplayer comme Chromium avec Pepperflash ou son dérivé Google Chrome soit la solution au problème, malheureusement, dans leur version GNULinux, ces navigateurs ne gèrent pas les DRM dans Flash. Par conséquent, ni le direct ou le replay ne sont donc accessibles sous ces navigateurs.
La solution consiste alors à utiliser la version Flashplayer de Windows® gérant les DRM.

(MAJ du 01/12/15): Toutefois, 6Play est en train de se passer de :Flashplayer et utilise la technologie HTML5 pour son interface et les publicités, mais pas encore pour les vidéos. Les responsables du service espèrent passer au tout HTML début 2016, « quand les DRM HTML5 donneront satisfaction aux ayants-droit ».

Pour profiter du service, vous devez avoir recours à une des méthodes expliquées ci-après.

Pré-requis

Solution avec Pipelight et Firefox

En utilisant la version Flashplayer de Windows®, Pipelight permet aux navigateurs Firefox et Midori de s'affranchir de l'arrêt du développement de Flashplayer pour GNU/Linux et ce, avec la gestion des DRM.

Pipelight n'est pas disponible depuis les dépôts officiels mais depuis un PPA. Installer un paquet hors des dépôts officiels peut présenter un risque d'instabilité pour votre système.

Installation

Voici les commandes à taper dans un terminal :

  1. Ajouter à vos sources de logiciels le PPA suivant : ppa:pipelight/stable1),
    sudo add-apt-repository ppa:pipelight/stable
  2. Recharger la liste des paquets,
    sudo apt-get update
  3. Installer le paquet Pipelight-multi.
    sudo apt-get install --install-recommends pipelight-multi

    Vous serez amené à valider les licences (EULA). (Pour déplacer le curseur dans ce type d'interface graphique, utiliser la touche <tab>).

  4. Mettre à jour la base de données des plugins:
    sudo pipelight-plugin --update
  5. :!: Avant de continuer plus loin, vous devez fermer Firefox :!:.
    Sans cela, il se peut que votre navigateur plante ou se ferme de façon brusque ou même que l'installation ne fonctionne pas correctement.
  6. Pour que Firefox prenne en compte les plugins de Pipelight:
    sudo pipelight-plugin --create-mozilla-plugins
  7. Supprimer les anciennes versions de Flashplayer:
    sudo apt-get remove flashplugin-installer adobe-flashplugin --purge
  8. Activer le plugin Flash:
    sudo pipelight-plugin --enable flash

    (Confirmer en saisissant y. Ne rien saisir entraînera l'abandon).

  9. Supprimer la liste des plugins de Firefox (Il mettra à jour le fichier tout seul)
    mv ~/.mozilla/firefox/*.default/pluginreg.dat ~/.mozilla/firefox/old_pluginreg.dat

     Source

Et pour vérifier la version de Flash utilisée, une fois Firefox redémarré, saisir dans la barre d'adresse de Firefox : about:addons. Dans la rubrique "plugins", vérifier que le plugin Shockwave Flash soit actif et de version supérieure à 11.2.

Utilisation

Redémarrer Firefox. (La première fois, une petite fenêtre "wine-flash-installer" apparaîtra. Patientez, elle se fermera toute seule).

Solution avec Wine et la version Windows® de Firefox

Bien qu'elle puisse vous dépanner si les autres solutions ont échoué, cette solution n'est pas recommandée car elle utilise la version Windows® et non GNU/Linux de Firefox.

Installation

  1. Télécharger la dernière version de Firefox pour Windows®, depuis le site Mozilla, et exécuter l'installateur avec wine.
  2. Télécharger la dernière version de Adobe Flash player pour Firefox, depuis le site d'Adobe, et exécuter l'installateur avec wine.

Utilisation

Utiliser avec wine la version Windows® de Firefox que vous venez d'installer pour aller sur 6play.fr

Problèmes connus

Mise à jour d'Ubuntu

Il est possible qu'après une mise à jour d'Ubuntu, la version Pipelight de Flashplayer ne fonctionne plus. Redémarrer votre système puis si le problème persiste, faire une nouvelle mise à jour du plugin:

  1. Fermer Firefox puis dans un terminal, saisir les commandes suivantes:
  2. Remettre à jour la base de données des plugins:
    sudo pipelight-plugin --update
  3. Activer le plugin Flash:
    sudo pipelight-plugin --enable flash

    (Confirmer en saisissant y. Ne rien saisir entraînera l'abandon);

  4. Redémarrer Firefox.

Flashplayer ne fonctionne toujours pas avec M6play

Si les plugins n'apparaissent pas dans la liste des plugins. On peut aussi vérifier le dossier:

''@desktop:/usr/lib/mozilla/plugins$ ls -alrt "

"total 8"

"drwxr-xr-x 3 root root 4096 mai 19 10:49 .."

"lrwxrwxrwx 1 root root 49 mai 22 19:09 libpipelight-silverlight5.1.so → /usr/lib/pipelight/libpipelight-silverlight5.1.so"

"lrwxrwxrwx 1 root root 40 mai 23 10:43 libpipelight-flash.so → /usr/lib/pipelight/libpipelight-flash.so"

"drwxr-xr-x 2 root root 4096 mai 23 11:16 ."

Vous pouvez désormais profiter des programmes sur 6play

Voir aussi


Contributeurs:



Le contenu de ce wiki est sous licence : CC BY-SA v3.0