Contenu | Rechercher | Menus

nVidia nForce mpc55

Cet article concerne les problèmes de connexion liés à l'utilisation des cartes réseau nVidia nForce mpc55: au démarrage d'ubuntu, la connexion internet semble ne pas fonctionner, alors que le modem ou la box est pourtant sous tension et parait être fonctionelle.
La méthode présentée pour régler le problème a été testée uniquement sur cette carte.

Si la technique a fonctionné pour vous avec des problèmes de connexion similaires et sur d'autre cartes, merci de l'indiquer et/ou de la signaler à la liste de discussion de cette documentation.

  • ne marche pas chez moi avec une carte mere asus m2n32 même pour le wifi integré

Pré-requis

  • Disposer d'une connexion modem ou d'une box relié via un port RJ45 Ethernet

Solution immédiate

Depuis un terminal saisissez les commandes suivantes:

sudo rmmod forcedeth
sudo modprobe forcedeth msi=0 msix=0
sudo /etc/init.d/networking restart

Cependant, vous devrez rentrer ces commandes à chaque redémarrage de votre ordinateur à moins de mettre en place la solution pérenne.

Solution pérenne

Ouvrez avec les droits d'administration le fichier /etc/init.d/rc.local et y insérer entre la ligne . /lib/lsb/init-functions et do_start() { :

rmmod forcedeth
modprobe forcedeth msi=0 msix=0
etc/init.d/networking restart

FIXME pas moyen d'ajouter dans /etc/modules uniquement forcedet msi=0 msix=0 ?

Ceci étant fait, la connection fonctionnera maintenant à chaque redémarrage de l'ordinateur.


Contributeurs: FIXME


nvidia_nforce_mcp55.txt · Dernière modification: Le 10/12/2012, 19:38 par 69.196.177.24
Le contenu de ce wiki est sous licence : CC BY-SA v3.0