Contenu | Rechercher | Menus

PyQt

PyQt est un ensemble de liens Python pour Qt qui fonctionne sur toutes les plates-formes supportées par Qt, y compris Windows, MacOS / X et Linux. Il y a deux jeux de fixations : PyQt4 supporte Qt version 4, et PyQt5 prend en charge Qt version 5. Notez que ces deux versions de Qt ne sont pas compatibles. Les liaisons sont mises en œuvre comme un ensemble de modules Python et contiennent plus de 300 classes et plus de 6000 fonctions et méthodes.

Site officiel

Vous trouverez sur le site de Riverbank, toutes les infos nécessaires à son utilisation, en particulier, le guide de référence et la dernière version (actuellement la 4.8.4).

PyQt est indispensable pour pouvoir utiliser qtiplot avec le support des scripts python.

Installation

cd /tmp/
wget http://www.riverbankcomputing.co.uk/static/Downloads/PyQt4/PyQt-x11-gpl-4.9.1.tar.gz
tar xvzf PyQt-x11-gpl-4.9.1.tar.gz
cd PyQt-x11-gpl-4.9.1
python configure.py; make; sudo make install

Installation facile

Vous pouvez aussi installer PyQT via un paquet. Pour cette installation il suffit d'exécuter cette commande :

sudo apt-get -y install python-qt4

Une fois l'installation terminée, vous pouvez tester cette ligne dans une console :

echo "import PyQt4" |python

S'il ne renvoie rien, votre installation est fonctionnelle.


Contributeurs : Volfoni54, hannibal.76.



Le contenu de ce wiki est sous licence : CC BY-SA v3.0