Contenu | Rechercher | Menus

Différences

Ci-dessous, les différences entre deux révisions de la page.

Lien vers cette vue comparative

Both sides previous revision Révision précédente
Prochaine révision
Révision précédente
tutoriel:comment_installer_un_paquet [Le 22/08/2013, 16:07]
212.23.175.180 [Via votre navigateur Web]
tutoriel:comment_installer_un_paquet [Le 30/03/2015, 10:42] (Version actuelle)
L'Africain [Installer un paquet avec des dépendances] lien vers lo
Ligne 1: Ligne 1:
-{{tag>​Lucid Precise Quantal ​Raring ​installation_logiciel tutoriel dépôts apt}}+{{tag>​Lucid Precise Quantal ​Saucy Trusty ​installation_logiciel tutoriel dépôts apt}}
  
 ---- ----
Ligne 6: Ligne 6:
  
 Sous Ubuntu, les logiciels se composent d'un ou plusieurs **[[wpfr>​Paquet_(logiciel)|paquets]]**. Ce didacticiel résume les différentes manières d'​installer un paquet sous Ubuntu, Kubuntu et Xubuntu. Pour Edubuntu, suivez les mêmes procédures qu'​Ubuntu. Sous Ubuntu, les logiciels se composent d'un ou plusieurs **[[wpfr>​Paquet_(logiciel)|paquets]]**. Ce didacticiel résume les différentes manières d'​installer un paquet sous Ubuntu, Kubuntu et Xubuntu. Pour Edubuntu, suivez les mêmes procédures qu'​Ubuntu.
-===== Pré-requis ===== +  ​* L'​installation d'un paquet (applicationsbibliothèques, etc.) est une tâche d'​administration ​qui s'​effectue avec les [[:​sudo|droits d'​administration]]. Votre **mot de passe** vous sera demandé. Si vous utilisez le compte utilisateur créé lors de l'​installation d'​Ubuntu,​ il n'y a pas de problème. Sinon l'​utilisateur concerné ​sera obligatoirement administreur du système. ​Consultez ​la page concernant [[:​users-admin|la gestion des utilisateurs]]. 
- +  * **Type de paquet à préférer**,​ dans l'​ordre,​ selon leur disponibilité (de la plus sûre à la plus incertaine) : 
-  ​* L'​installation d'un paquet (logicielbibliothèque, etc.) est une tâche d'​administration. Il faut donc les [[:​sudo|droits d'​administration]] ​pour l'​exécuter et votre **mot de passe** vous sera demandé. Si vous utilisez le compte utilisateur créé lors de l'​installation d'​Ubuntu,​ il n'y a pas de problème((sinon il faudra que l'​utilisateur concerné ​ait le droit d'​administrer le système. ​Consulter ​la page concernant [[:​users-admin|la gestion des utilisateurs]].))+    - paquet dans un [[:depots|dépôt]] Ubuntu officiel ; 
-  * **Type de paquet à préférer**,​ dans l'​ordre,​ selon disponibilité (de la plus sûre à la plus incertaine) : +    - paquet dans un [[:depots|dépôt ​PPA]];
-    - paquet dans un dépôt Ubuntu officiel ; +
-    - paquet dans un dépôt ​externe « connu » ou réputé (Medibuntu, etc.) ;+
     - paquet Ubuntu isolé ;     - paquet Ubuntu isolé ;
     - paquet Debian isolé (peut poser des problèmes techniques) ;     - paquet Debian isolé (peut poser des problèmes techniques) ;
-    - paquet dans un dépôt tiers (peut poser des problèmes de confiance)+    - paquet dans un dépôt tiers (peut poser des problèmes de confiance)
- +
-===== Installer un paquet présent dans les dépôts (recommandé) ===== +
- +
-Si le paquet que vous voulez installer est présent dans votre liste de dépôts, son installation sera très simple. Remarque: pour toutes les méthodes expliquées ici, vous pouvez installer plusieurs paquets à la fois. +
-<note tip>Si Ubuntu ne trouve pas votre paquet, c'est que vous avez peut-être oublié d'​activer préalablement le dépôt adéquat (sources de logiciels) du paquet. Si vous connaissez le nom du dépôt sur lequel se trouve votre paquet, activez ce dépôt en suivant [[:​tutoriel:​comment_modifier_sources_maj|ce mini-tutoriel dédié]] puis revenez ici.</​note>​ +
- +
-==== Via votre navigateur Web ==== +
- +
-{{ :​applications:​apturl_lucid2.png?​250|apt-url}} +
- +
-Vous trouverez sur certaines pages Web((notamment dans la [[:​accueil|Documentation ubuntu-fr]] sur laquelle vous vous trouvez actuellement)) des « liens apt » dans des phrases comme celle ci-dessous : +
- +
-> [[:​tutoriel:​comment_installer_un_paquet|Installez le paquet]] **[[apt>​ri-li]]** <-- **__il s'agit d'un exemple, n'​installez pas ce paquet !!__**  +
- +
-En cliquant sur le nom du paquet (« ri-li » dans l'​exemple ci-dessus), une fenêtre s'​ouvrira et vous proposera de l'​installer : +
-  * si vous utilisez [[:​maverick|Ubuntu 11.04]] ou suivante, ce sera //via// la [[:​software-center|logithèque Ubuntu]] par défaut ;​ +
-  * si vous utilisez [[:​lucid|Ubuntu 10.04]], il s'​agira de l'​application [[:apturl]] (voir capture ci-contre). +
- +
-Pour changer le gestionnaire utilisé lors d'un clic sur un lien apt, consulter la section de page :  [[:​gestionnaire_de_paquets#​choisir_quel_gestionnaire_de_paquet_se_lance_avec_les_liens_apt |choisir quel gestionnaire de paquet se lance avec les liens apt]].+
  
-On peut aussi Installer ​ce paquet " ri-li " en mode ligne de commande depuis ​un [[:​terminal]] :+===== Installer un paquet présent dans les dépôts officiels =====
  
-<​code>​sudo apt-get install ri-li </​code>​ +==== Depuis votre navigateur Web ==== 
-==== Via la « Logithèque Ubuntu » ====+Vous trouverez sur internet des liens du style **[[apt>​nom_du_paquet]]** avec lequel installer le paquet en question.\\ 
 +Sur cette documentation,​ vous trouverez une icône sur lequel vous pourrez cliquer pour installer divers logiciels ou paquets, se présentant sous cette forme :​{{:​apt.png?​30}}. 
 +En cliquant sur le nom du paquet une fenêtre s'​ouvrira et vous proposera de l'​installer depuis la [[:​software-center|Logithèque Ubuntu]] par défaut.\\ 
 +<​note>​Une alternative légère à la Logithèque est l'​application [[:​apturl]]. \\ 
 + ​{{:​applications:​apturl_lucid2.png?​250|apt-url}} \\ 
 +Pour changer le gestionnaire utilisé lors d'un clic sur un lien apt, consulter la section de page :  [[:​gestionnaire_de_paquets#​choisir_quel_gestionnaire_de_paquet_se_lance_avec_les_liens_apt |choisir quel gestionnaire de paquet se lance avec les liens apt]].</​note>​
  
 {{ :​software-center_logo.png?​80&​nolink|Logo de la logithèque}} {{ :​software-center_logo.png?​80&​nolink|Logo de la logithèque}}
 +==== Depuis la Logithèque Ubuntu ====
  
-  ​Ouvrir ​« Logithèque Ubuntu » (application //[[:​software-center]]//) en cliquant sur son icône ​(par défaut à gauche ​de l'​écran), ​ou depuis le Dash (Ubuntu 11.04 et ultérieures),​ ou depuis le menu //​Applications ​→ Logithèque Ubuntu// ​(Ubuntu 10.04+  ​Ouvrir ​la [[:​software-center|Logithèque Ubuntu]] en cliquant sur son icône ​dans la [[:​unity_launcher|barre ​de lancement]] ​ou depuis le [[:​unity#​tableau_de_bord_dash|tableau de bord]] d'​[[:​Unity]] ​(Pour les menus classiques :  ​//​Applications ​-> Logithèque Ubuntu//.)  
-  ​* Entrez ​le //nom du paquet à rechercher//​ dans le champ de recherche. +  ​- Entrer ​le //nom du paquet à rechercher//​ dans le champ de recherche. 
-  ​Puis cliquez sur la flèche correspondante. +  ​Puis cliquez sur la flèche correspondante. 
-  ​* Cliquez ​sur « Installer » pour installer le paquet. +  ​- Cliquer ​sur « Installer » pour installer le paquet. 
-  ​Vous pouvez ajouter d'​autres paquets pendant que le premier paquet s'​installe ; une file d'​attente sera créée.+  ​Vous pouvez ajouter d'​autres paquets pendant que le premier paquet s'​installe ; une file d'​attente sera créée.
  
-→ [[:software-center|Plus d'informations sur la Logithèque Ubuntu]]+====Depuis le tableau de bord d'​Unity==== 
 +Sur les dernières ​[[:versions]] d'​Ubuntu,​ il est possible d'​installer une application directement depuis le [[:​unity#​tableau_de_bord_dash|tableau de bord]] d'​[[:​Unity]]. (Exemple pour [[:Vlc]]) 
 +  ​Sélectionnez la [[:​unity-lens|loupe]] « Application » {{:​tutoriel:​installer_un_paquet:​installer_un_paquet_13.10_21.png?​60|}};​ 
 +  - Tapez « Vlc » dans la zone de saisie. L'​application apparaîtra dans la zone « Plus de suggestions » ; {{ :​tutoriel:​installer_un_paquet:​installer_un_paquet_13.10_22.png?​600 |}} 
 +  - Cliquer sur l’application choisie (Dans notre exemple : Vlc).{{ :​tutoriel:​installer_un_paquet:​installer_un_paquet_13.10_23.png?​600 |}} 
 +  -Suivez les instructions. L’icône de l'​application en cours d'installation apparaîtra dans la [[:​unity_launcher|barre de lancement d'​Unity]] avec une barre de progression.\\ 
 +{{:​tutoriel:​installer_un_paquet:​installer_un_paquet_13.10_24.png?​60|}}
  
 <note important>​ <note important>​
-Attention, cette interface ​ne contient ​pas tous les paquets disponibles dans Ubuntu. +La [[:​software-center|Logithèque]] ainsi que le [[:​unity#​tableau_de_bord_dash|tableau de bord]] d'​Unity ​ne contiennent ​pas tous les paquets disponibles dans Ubuntu.\\
 Si vous deviez installer une « application système », préférez la méthode « [[#Via une interface graphique complète (gestionnaire de paquets)|Gestionnaire de paquets]] » ci-dessous. Si vous deviez installer une « application système », préférez la méthode « [[#Via une interface graphique complète (gestionnaire de paquets)|Gestionnaire de paquets]] » ci-dessous.
 </​note>​ </​note>​
-==== Via une interface graphique complète (gestionnaire de paquets) ====+==== Depuis ​une interface graphique complète (gestionnaire de paquets) ==== 
 +Pour plus d'​informations,​ voir la [[:​gestionnaire_de_paquets|page sur les gestionnaires de paquets]].
  
-→ [[:​gestionnaire_de_paquets|Plus d'​informations sur les gestionnaires de paquets]] +=== Synaptic === 
- +[[:​Synaptic]] est une interface graphique "​complète"​ pour [[:​APT]]. ​ Elle permet l'​installation ​de paquets ​depuis des [[:​depots|dépôts APT]], de même que leur désinstallation.\\ 
-=== Pour Ubuntu, Xubuntu et Edubuntu : avec Synaptic === +[[:​Synaptic]] n'est pas installé ​par défaut ​dans Ubuntu. ​Pour plus d'​informations et son installation,​ voir la [[:​synaptic|page dédiée pour Synaptic]]. 
- +<​note>​Les utilisateurs de [[:Kubuntu]] utilisent par défaut [[:Adept]] sous KDE3 et [[:Muon]] sous KDE4, mais [[:​Synaptic]] peut tout à fait être utilisée sous [[:​Kubuntu]]. (Ainsi que les autres ​[[:variantes]] !)</​note>​
-[[:​Synaptic]] est le gestionnaire ​de paquets par défaut ​d'Ubuntu ​10.04. Il peut être installé sur toutes les autres versions. +
- +
-→ [[:​synaptic|Plus d'​informations sur Synaptic]] +
- +
-=== Pour Kubuntu ​=== +
- +
-FIXME [[:Apper]] ?+
  
 ==== En ligne de commande ==== ==== En ligne de commande ====
- 
 Ouvrir un terminal : Ouvrir un terminal :
- 
 ^ Ubuntu ​    ​|depuis le [[:​unity#​tableau_de_bord_dash|tableau de bord]] d'​Unity (ou Ctrl−Alt−T).| ^ Ubuntu ​    ​|depuis le [[:​unity#​tableau_de_bord_dash|tableau de bord]] d'​Unity (ou Ctrl−Alt−T).|
 ^ Edubuntu ​   | //​Applications → Accessoires → Terminal// ou Alt−F2 et tapez **gnome-terminal** | ^ Edubuntu ​   | //​Applications → Accessoires → Terminal// ou Alt−F2 et tapez **gnome-terminal** |
Ligne 79: Ligne 61:
 ^ toutes les variantes ​ | depuis une console (Ctrl−Alt−F1…F6 ; Ctrl−Alt−F7 pour revenir à votre session graphique) | ^ toutes les variantes ​ | depuis une console (Ctrl−Alt−F1…F6 ; Ctrl−Alt−F7 pour revenir à votre session graphique) |
  
-<​note>​Depuis ​[[http://​packages.ubuntu.com/​search?​suite=default&​section=all&​arch=any&​searchon=names&​keywords=apt|apt-get 0.7]] (et donc sur toutes les versions actuellement supportées d'​Ubuntu),​ **apt-get** et **aptitude**, (et par conséquent aussi les interfaces graphiques qui les utilisent, par ex **Synaptic** et la **Logithèque Ubuntu**), partagent les mêmes informations. L'​utilisation alternée de l'un ou l'​autre ne présente donc pas de risque. [[http://​raphaelhertzog.com/​2011/​06/​20/​apt-get-aptitude-%E2%80%A6-pick-the-right-debian-package-manager-for-you|Source]]</​note>​+<​note>​**[[:apt|Apt-get]]** et **[[:​Aptitude]]**, (et par conséquent aussi les interfaces graphiques qui les utilisent, par ex **Synaptic** et la **Logithèque Ubuntu**), partagent les mêmes informations. L'​utilisation alternée de l'un ou l'​autre ne présente donc pas de risque. [[http://​raphaelhertzog.com/​2011/​06/​20/​apt-get-aptitude-%E2%80%A6-pick-the-right-debian-package-manager-for-you|Source]] ​**(en)**</​note>​
  
 Dans les commandes ci-dessous, remplacez « mon_paquet » par le nom de votre paquet. Si vous voulez installer plusieurs paquets en même temps, remplacez « mon_paquet » par la liste des paquets à installer, séparés par une espace. Dans les commandes ci-dessous, remplacez « mon_paquet » par le nom de votre paquet. Si vous voulez installer plusieurs paquets en même temps, remplacez « mon_paquet » par la liste des paquets à installer, séparés par une espace.
Ligne 85: Ligne 67:
 === Avec apt-get === === Avec apt-get ===
  
-  ​sudo apt-get install mon_paquet +<​code>​sudo apt-get install mon_paquet</​code>​ 
- +Plus d'​informations sur APT, apt-get et leurs outils ​voir la [[:apt|page dédiée à Apt]].
-→ [[:apt|Plus d'​informations sur APT, apt-get et leurs outils]]+
  
 === Avec Aptitude === === Avec Aptitude ===
 +<​code>​sudo aptitude install mon_paquet</​code>​
 +Pour plus d'​informations,​ voir la [[:​aptitude|page dédiée à Aptitude]].
  
-  sudo aptitude install mon_paquet+====Installer un paquet depuis un PPA===== 
 +Pour plus d'​informations,​ voir la [[:PPA|page dédiée aux dépôts PPA]].
  
- 
-→ [[:​aptitude|Plus d'​informations sur Aptitude]] 
 ===== Installer un paquet hors dépôts (non recommandé) ===== ===== Installer un paquet hors dépôts (non recommandé) =====
- 
 <note important>​Cette méthode ne permet pas les mises à jour automatiques.</​note>​ <note important>​Cette méthode ne permet pas les mises à jour automatiques.</​note>​
  
Ligne 102: Ligne 83:
   * si vous n'avez pas accès à internet ;   * si vous n'avez pas accès à internet ;
   * ou si le paquet n'est pas disponible dans les dépôts Ubuntu. Ce qui arrive dans deux cas : soit le logiciel n'est pas référencé par Ubuntu, soit une nouvelle version d'un logiciel référencé existe, mais n'est pas disponible dans les dépôts Ubuntu de votre version.   * ou si le paquet n'est pas disponible dans les dépôts Ubuntu. Ce qui arrive dans deux cas : soit le logiciel n'est pas référencé par Ubuntu, soit une nouvelle version d'un logiciel référencé existe, mais n'est pas disponible dans les dépôts Ubuntu de votre version.
 +<note important>​Ces paquets ne bénéficient ni de la validation officielle Ubuntu, ni du support des développeurs des équipes officielles Ubuntu. Ils peuvent rendre le système instable. Vous les installez à vos risques et périls.</​note>​
  
-<​note ​important>+<​note>​
 Rappel : même si des paquets ne se trouvent pas dans les [[:​dépôts]] Ubuntu, il est possible de rajouter des dépôts officiels de projets ([[:Wine]], [[:​Cairo-Dock]],​ etc.), ou des dépôts officieux, dans votre [[:​gestionnaire de paquets]] ([[:​Synaptic]],​ [[:​Apper]]). Cela ne réduit pas les risques d'​instabilité évoqués ci-dessous, mais évite d'​avoir à installer à la main ces paquets, et permet une mise la jour automatique des logiciels (si celle-ci est gérée par le dépôt supplémentaire paramétré). Le présent chapitre traite de l'​installation de paquets lorsque l'​installation de ces dépôts supplémentaires n'a pas été possible ou n'a pas été souhaitée. Pour en savoir plus, voir la page [[:​dépôts]]. Rappel : même si des paquets ne se trouvent pas dans les [[:​dépôts]] Ubuntu, il est possible de rajouter des dépôts officiels de projets ([[:Wine]], [[:​Cairo-Dock]],​ etc.), ou des dépôts officieux, dans votre [[:​gestionnaire de paquets]] ([[:​Synaptic]],​ [[:​Apper]]). Cela ne réduit pas les risques d'​instabilité évoqués ci-dessous, mais évite d'​avoir à installer à la main ces paquets, et permet une mise la jour automatique des logiciels (si celle-ci est gérée par le dépôt supplémentaire paramétré). Le présent chapitre traite de l'​installation de paquets lorsque l'​installation de ces dépôts supplémentaires n'a pas été possible ou n'a pas été souhaitée. Pour en savoir plus, voir la page [[:​dépôts]].
 </​note>​ </​note>​
Ligne 110: Ligne 92:
   * les sites officiels des logiciels qui vous intéressent ;   * les sites officiels des logiciels qui vous intéressent ;
   * des sites tiers non officiels ([[http://​www.getdeb.net/​]],​ [[http://​www.UbuntuUpdates.org]],​ etc.).   * des sites tiers non officiels ([[http://​www.getdeb.net/​]],​ [[http://​www.UbuntuUpdates.org]],​ etc.).
- 
-Ces paquets **ne sont pas certifiés par Canonical**,​ et dans certains cas (rares) peuvent rendre le système instable. Vous les installez à vos risques et périls. 
  
 Il existe deux démarches possibles : installer un paquet isolé sans dépendance,​ ou installer un groupe de paquets ayant des relations de dépendance entre eux. Il existe deux démarches possibles : installer un paquet isolé sans dépendance,​ ou installer un groupe de paquets ayant des relations de dépendance entre eux.
Ligne 146: Ligne 126:
 === Installation graphique === === Installation graphique ===
  
-Vous pouvez installer tous les paquets un par un avec [[:gdebi]], simplement en cliquant dessus (méthode graphique), mais cela peut poser deux problèmes : le nombre de .deb peut-être très grand ([[:OpenOffice.org]], par exemple), et surtout, l'​ordre d'​installation doit être strictement respecté, donc doit être connu. À défaut, [[:gdebi]] refuse l'​installation. Il faut en effet d'​abord installer les paquets listés en dépendances avant de pouvoir installer le paquet principal. C'​est-à-dire que si vous voulez installer le paquet XYZ et que ce paquet dépend du paquet ABC, il faudra installer ABC avant de pouvoir installer XYZ. Si ABC est disponible dans les dépôts Ubuntu, Gdebi essayera de l'​installer automatiquement,​ mais nous sommes ici dans l'​hypothèse d'une installation hors dépôts, donc il ne trouvera pas. Problème courant avec les jeux : il faut installer un paquet « exemple-data.deb » avant « exemple.deb ».+Vous pouvez installer tous les paquets un par un avec [[:gdebi]], simplement en cliquant dessus (méthode graphique), mais cela peut poser deux problèmes : le nombre de .deb peut-être très grand ([[:LibreOffice]], par exemple), et surtout, l'​ordre d'​installation doit être strictement respecté, donc doit être connu. À défaut, [[:gdebi]] refuse l'​installation. Il faut en effet d'​abord installer les paquets listés en dépendances avant de pouvoir installer le paquet principal. C'​est-à-dire que si vous voulez installer le paquet XYZ et que ce paquet dépend du paquet ABC, il faudra installer ABC avant de pouvoir installer XYZ. Si ABC est disponible dans les dépôts Ubuntu, Gdebi essayera de l'​installer automatiquement,​ mais nous sommes ici dans l'​hypothèse d'une installation hors dépôts, donc il ne trouvera pas. Problème courant avec les jeux : il faut installer un paquet « exemple-data.deb » avant « exemple.deb ».
  
 En bref, l'​installation graphique de paquets multiples hors dépôts est compliquée et difficile à mettre en œuvre. D'où le recours à l'​[[#​Installation manuelle (en ligne de commande)|installation manuelle]]. En bref, l'​installation graphique de paquets multiples hors dépôts est compliquée et difficile à mettre en œuvre. D'où le recours à l'​[[#​Installation manuelle (en ligne de commande)|installation manuelle]].
Ligne 170: Ligne 150:
  
 ===== Voir aussi ===== ===== Voir aussi =====
-  * [[:​apt-key|Signature des dépots]]+  * [[:​apt-key|Signature des dépôts]]
   * [[:​terminal|Plus d'​informations sur comment ouvrir un terminal]]   * [[:​terminal|Plus d'​informations sur comment ouvrir un terminal]]
   * [[:​dpkg|Plus d'​informations sur dpkg]]   * [[:​dpkg|Plus d'​informations sur dpkg]]
Ligne 178: Ligne 158:
 ---- ----
  
-//​Contributeurs principaux : [[:​utilisateurs:​Ner0lph]],​ [[:​utilisateurs:​_Enchained]],​ [[:​utilisateurs:​Grummfy]],​ [[utilisateurs:​Fabien26]],​ [[utilisateurs:​YannUbuntu]].//​+//​Contributeurs principaux : [[:​utilisateurs:​Ner0lph]],​ [[:​utilisateurs:​_Enchained]],​ [[:​utilisateurs:​Grummfy]],​ [[utilisateurs:​Fabien26]],​ [[utilisateurs:​YannUbuntu]], Contributeurs : [[:​utilisateurs:​cafecho]].//


Le contenu de ce wiki est sous licence : CC BY-SA v3.0