Selon les tags présents sur cette page, les informations qu'elle contient n'ont pas été vérifiées pour les dernières versions LTS depuis Ubuntu 14.04 LTS.
Apportez votre aide…

Ceci est une ancienne révision du document !



Lenovo Flex 2-14

Le tableau suivant récapitule la prise en charge du matériel de portable par les différentes versions d'Ubuntu. Il utilise les notations suivantes :

  • OK 32 bits Fonctionne immédiatement en 32 bits.
  • OK 64 bits Fonctionne immédiatement en 64 bits.
  • 32 et 64 bits Fonctionne immédiatement en 32 et 64 bits.
  • Fonctionne après config Fonctionne après quelques manipulations
  • Ne fonctionne pas Ne fonctionne pas
  • |Pas testé Pas d'informations disponibles
  • Information obsolète Information de support trop ancienne, si possible mettez là à jour.
Version Installation Carte graphique Son Casque audio Wifi Bluetooth Webcam Touchpad Raccourcis multimédia Autres
14.04.3 Fonctionne après config OK 64 bits OK 64 bits OK 64 bits Fonctionne après config Ne fonctionne pas OK 64 bits OK 64 bits OK 64 bits
13.10 - - - - - - - - -
12.10 - - - - - - - - -
12.04 - - - - - - - - -

Utilisateurs du Wiki possédant cet ordinateur, fonctionnel :

Cet ordinateur portable n'est a priori pas tatoué.

Avant toutes choses, il faut pouvoir démarrer sur une clé USB d'Ubuntu (pas de lecteur CD/DVD dans ce modèle). Pour ça, il faut accéder à l'UEFI.

Accéder à l'UEFI/BIOS

C'est la touche F2 sur ce modèle qui permet d'accéder à l'UEFI.

Oui, mais… j'ai mis longtemps à comprendre qu'il fallait faire Fn-F2 au lieu d'appuyer simplement sur la touche F2.

La touche Fn est de couleur orange en bas à gauche de l'écran, à droite du bouton Ctrl.

Une solution alternative consiste à passer par l'option correspondante dans Windows : https://support.lenovo.com/fr/fr/documents/ht081446

Erreur au démarrage : "Image failed to verify : Access denied"

Symptômes

Après l'installation, Ubuntu 14.04.3 ne démarre pas, et met ce message d'erreur. Une solution est de désactiver le "Secure Boot" :

Désactivation du Secure Boot

Il suffit d'aller dans l'UEFI (voir ci-dessus comment faire), dans le menu Security, et à la ligne "Secure Boot", faire Entrée, et choisir "Disabled". Puis faire F10 pour enregistrer les paramètres et redémarrer.

Coupure intempestive du Wifi

Symptômes

Le Wifi se "coupe" au bout de quelques minutes, dans le sens où il n'y a plus aucun trafic réseau dessus (alors que l'icône indique qu'on est encore connecté).

Dans les logs du kernel, il y a parfois un crash et une stacktrace.

Paramétrage du driver Wifi

Le chipset Wifi (RTL8723BE) semble avoir ce type de problèmes avec son driver sous Linux, et ce n'est pas encore résolu complètement : https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1461174

Par contre, il y a pas mal de contournements proposés : essentiellement ajouter des options au driver dans /etc/modprobe.d/rtl8723be.conf, et installer une version plus récente du driver wifi : http://askubuntu.com/questions/590414/wifi-problems-with-rtl8723be-in-ubuntu-14-04

Dans mon cas, sur cet appareil, il m'a semblé que les options de driver suffisent à avoir une connexion satisfaisante, en mettant ce contenu dans /etc/modprobe.d/rtl8723be.conf :

options rtl8723be fwlps=0 ips=0

Apparemment il y a un nouveau driver qui fonctionne mieux, et qui sera a priori intégré dans les prochains kernels donc on peut espérer que la situation s'améliore quand on pourra installer un kernel backporté de la version 15.10 (wily) par exemple.

Redémarrage quand on éteint le portable

Symptômes

On demande à Ubuntu de s'éteindre : il s'éteint… mais redémarre parfois quelques secondes plus tard.

???

J'ai essayé pas mal de choses : supprimer le laptop-mode-tools, utiliser un kernel 4.0.9, upgrader le BIOS, quelques paramètres passés au kernel.

Pour l'instant, rien n'y fait…

A tester : https://rpubs.com/dasaptaerwin/15272 rmmod ehci_hcd dans un /etc/rc.local.shutdown

Bluetooth qui ne fonctionne pas

Symptômes

Le bluetooth est bien détecté, semble fonctionnel, mais ne voit/n'est visible d'aucun appareil.

Désactivation du bluetooth

N'ayant pas vraiment besoin du bluetooth, je n'ai pas beaucoup cherché. J'ai simplement essayé un kernel plus récent (un 4.0.9) et ça n'a pas résolu le problème.

Ayant peur que cela consomme de l'énergie pour rien, j'ai préféré le désactiver complètement.

Pour cela, j'ai modifié /etc/rc.local (cf http://askubuntu.com/questions/67758/how-can-i-deactivate-bluetooth-on-system-startup), en y rajoutant la ligne suivante avant le exit 0 :

rfkill block bluetooth

Temps de démarrage

Juste après l'installation, j'ai remarqué un temps de démarrage particulièrement long (entre 30s et une minute, je n'ai pas chronométré), et j'entendais le disque dur gratter pendant ce démarrage.

Au bout d'un certain temps, ce problème a disparu tout seul, et le démarrage se fait en 18s. Je suppose que c'est le disque SSHD qui a transféré des blocs disque sur sa partie SSD. A moins que ce soit simplement ureadahead.

Autonomie

L'autonomie est autour de 2h sans optimisation.

L'estimation passe à 3h environ avec :

  • soit le paquet TLP (en prenant les packages tlp tlp-rdw tp-smapi-dkms et acpi-call-tools)
  • soit le paquet laptop-mode-tools

J'ai préféré installer laptop-mode-tools mais sans avoir fait de réel comparatif…

Sur cette machine (qui n'est pas neuve), l'autonomie de 3h correspond à ce qu'on obtient sur Windows également.

  • lenovo_flex_2_14.1442264497.txt.gz
  • Dernière modification: Le 14/09/2015, 23:01
  • par mossroy