Différences

Ci-dessous, les différences entre deux révisions de la page.

Lien vers cette vue comparative

Les deux révisions précédentes Révision précédente
lightspark [Le 23/01/2015, 17:22]
maltouzes
lightspark [Le 21/03/2016, 16:14] (Version actuelle)
L'Africain Maj de la page
Ligne 1: Ligne 1:
-{{tag>​navigateur internet flash plugin_navigateur ​BROUILLON}}+{{tag>Trusty ​navigateur internet flash plugin_navigateur}}
 ---- ----
  
  
 <note warning>​Ce lecteur est expérimental,​ ce qui veut dire que, dans l'​ensemble,​ il ne fonctionne pas correctement.</​note>​ <note warning>​Ce lecteur est expérimental,​ ce qui veut dire que, dans l'​ensemble,​ il ne fonctionne pas correctement.</​note>​
 +
 ====== Lightspark :​ un lecteur libre d'​animations Flash ====== ====== Lightspark :​ un lecteur libre d'​animations Flash ======
 {{ http://​allievi.sssup.it/​techblog/​wp-content/​uploads/​2010/​05/​g170.png?​180|Logo de Lightspark}} {{ http://​allievi.sssup.it/​techblog/​wp-content/​uploads/​2010/​05/​g170.png?​180|Logo de Lightspark}}
Ligne 12: Ligne 13:
  
 == Compatibilité avec les versions de Flash et recommandation == == Compatibilité avec les versions de Flash et recommandation ==
-Lightspark peut être considéré comme complémentaire à [[gnash|GNU Gnash]] : alors que ce dernier se concentre sur la prise en charge du format Flash 8 et antérieur (ActionScript 1.0 et 2.0, avec un environnement AVM1), Lightspark s'​intéresse à la prise en charge du format Flash 9 et ultérieur (ActionScript 3.0, avec un environnement AVM2).+Lightspark peut être considéré comme complémentaire à [[:gnash|GNU Gnash]] : alors que ce dernier se concentre sur la prise en charge du format Flash 8 et antérieur (ActionScript 1.0 et 2.0, avec un environnement AVM1), Lightspark s'​intéresse à la prise en charge du format Flash 9 et ultérieur (ActionScript 3.0, avec un environnement AVM2).
  
-Comme ces deux logiciels gèrent des versions différentes du format Flash, Lightspark inclut un //​fallback//​ vers GNU Gnash lorsqu'​il rencontre une animation nécessitant un environnement AVM1. Si vous décidez d'​installer Lightspark, il est recommandé d'​installer en plus [[gnash|GNU Gnash]], afin de profiter d'un maximum d'​animations Flash.+Comme ces deux logiciels gèrent des versions différentes du format Flash, Lightspark inclut un //​fallback//​ vers GNU Gnash lorsqu'​il rencontre une animation nécessitant un environnement AVM1. Si vous décidez d'​installer Lightspark, il est recommandé d'​installer en plus [[:gnash|GNU Gnash]], afin de profiter d'un maximum d'​animations Flash.
  
-<​note>​La version de lightspark à partir de 0.7.1 ([[https://​launchpad.net/​~sparkers/​+archive/​ppa|présente dans le dépôt PPA de “Sparkers” team]]) commence à bien fonctionner !</​note>​ 
  
 ===== Pré-requis ===== ===== Pré-requis =====
Ligne 25: Ligne 25:
 ===== Installation ===== ===== Installation =====
  
-==== A partir ​d'Ubuntu Oneric (11.10) ====+Sous [[:​Trusty|Ubuntu 14.04]] et supérieures,​ pour installer ce logiciel, il suffit ​d'[[:​tutoriel:​comment_installer_un_paquet|installer le paquet]] **[[apt>​lightspark]]**.
  
-Pour installer ce logiciel, il suffit d'[[:tutoriel:​comment_installer_un_paquet|installer le paquet]] **[[apt>​lightspark]]**. +Sous [[:Precise|Ubuntu ​12.04]] utilisez ​le PPA Daily de Sparker:
- +
-==== Depuis le PPA de Sparker (depuis ​Ubuntu ​10.10: Maverick) ==== +
- +
-  * [[:​PPA|Ajoutez le PPA]] **ppa:​sparkers/​ppa**((https://​launchpad.net/​~sparkers/​+archive/​ppa)) dans vos sources de logiciels. +
-  * [[:​tutoriel:​comment_modifier_sources_maj#​recharger_la_liste_des_paquets|Rechargez la liste des paquets]]. +
-  * [[:​tutoriel:​comment_installer_un_paquet#​paquet_present_dans_les_depots|Installez le paquet]] **[[apt://​lightspark|lightspark]]**. +
- +
-==== Depuis ​le PPA Daily de Sparker ​(expérimental) ==== +
- +
-il peut être installé depuis un dépôt PPA (à partir de Ubuntu 11.04Natty).+
  
   * [[:​PPA|Ajoutez le PPA]] **ppa:​sparkers/​daily**((https://​launchpad.net/​~sparkers/​+archive/​daily)) dans vos sources de logiciels.   * [[:​PPA|Ajoutez le PPA]] **ppa:​sparkers/​daily**((https://​launchpad.net/​~sparkers/​+archive/​daily)) dans vos sources de logiciels.
   * [[:​tutoriel:​comment_modifier_sources_maj#​recharger_la_liste_des_paquets|Rechargez la liste des paquets]].   * [[:​tutoriel:​comment_modifier_sources_maj#​recharger_la_liste_des_paquets|Rechargez la liste des paquets]].
-  * [[:​tutoriel:​comment_installer_un_paquet#​paquet_present_dans_les_depots|Installez le paquet]] **[[apt://​lightspark|lightspark]]**.+  * [[:​tutoriel:​comment_installer_un_paquet#​paquet_present_dans_les_depots|Installez le paquet]] **[[apt>lightspark]]**.
  
-==== Depuis l'​archive ==== +==== Installation du greffon pour navigateurs ​Internet ====
- +
-FIXME +
- +
-==== Depuis le dépot GIT  (Ubuntu Lucid et ultérieur)==== +
-Recupérer les sources: +
-  git clone git://​github.com/​lightspark/​lightspark.git lightspark +
-Installer les dépendances +
-FIXME +
-  sudo apt-get install cmake nasm llvm-dev libsdl1.2-dev libgl1-mesa-dev libxext-dev libcurl4-gnutls-dev libxml2-dev zlib1g-dev libnspr4-dev libavcodec-dev libpcre3-dev libftgl-dev libglew1.5-dev xulrunner-dev libgtkglext1-dev libffi-dev +
-  sudo apt-get install libxml++2.6-dev +
-<note important>​Il faut la librairie libxml++ >=  2.33.1 confère [[https://​answers.launchpad.net/​lightspark/​+question/​142740|Ubuntu Lucid PPA ?]] mais celle des dépôts main de Lucid et Maverick est la 2.30.0-1, dommage :-( !</​note>​ +
-Compiler et installer +
-<code bash> +
-cd lightspark +
-mkdir build +
-cd build +
-cmake -DCMAKE_BUILD_TYPE=Release -DCOMPILE_PLUGIN=1 -DCMAKE_INSTALL_PREFIX=/​usr .. +
-make && sudo make install +
-</​code>​ +
-===== Installation du greffon pour navigateur ​Internet ​=====+
 Procédez de la même façon que pour le lecteur, mais installez cette fois ci le paquet **[[apt>​browser-plugin-lightspark]]** Procédez de la même façon que pour le lecteur, mais installez cette fois ci le paquet **[[apt>​browser-plugin-lightspark]]**
-puis supprimer ​le paquet **browser-plugin-gnash** ​en tapant la commande suivante dans un terminal de commandes : +puis [[:​tutoriel:​comment_supprimer_un_paquet|supprimez ​le paquet]] **browser-plugin-gnash**.
-  sudo apt-get install browser-plugin-lightspark +
-  sudo apt-get purge browser-plugin-gnash+
  
-===== Configuration ​=====+===== Utilisation=====
  
-FIXME+====... en tant que logiciel individuel==== 
 +Pour lire une vidéo flash avec lightspark ouvrez un [[:​terminal]] et lancer la commande : <​code>​lightspark [paramètres] http://​chemin/​vers/​la/​vidéo.sfw</​code>​
  
-===== Utilisation=====+====... en tant que greffon pour un navigateur web==== 
 +Une fois le paquet d'​extension pour les [[:​navigateur|navigateurs web]] installé, fermez toutes les instances de votre navigateur web. À l'​ouverture suivante, Lightspark est automatiquement intégré à votre navigateur. Vous pouvez immédiatement lire du contenu Flash en vous rendant dans votre site préféré. ​
  
-FIXME 
  
 ===== Désinstallation ===== ===== Désinstallation =====
  • lightspark.txt
  • Dernière modification: Le 21/03/2016, 16:14
  • par L'Africain