Différences

Ci-dessous, les différences entre deux révisions de la page.

Lien vers cette vue comparative

Les deux révisions précédentes Révision précédente
Prochaine révision
Révision précédente
smillaenlarger [Le 01/08/2011, 12:21]
zococo [Pré-requis]
smillaenlarger [Le 25/09/2017, 17:18] (Version actuelle)
L'Africain ppa
Ligne 1: Ligne 1:
-{{tag>Lucid Maverick ​graphisme photo}}+{{tag>Xenial ​graphisme photo}}
 ---- ----
  
Ligne 14: Ligne 14:
 {{:​smillaenlarger_maverick_00_.png?​500|}} {{:​smillaenlarger_maverick_00_.png?​500|}}
  
-===== Pré-requis ===== 
  
-  * Disposer des [[:sudo|droits d'​administration]] ; +===== Installation ===== 
-  * Disposer d'une connexion à Internet configurée et activée ; +Il vous faut ajouter un [[:ppa]]  
-  * Avoir [[:tutoriel:​comment_installer_un_paquet|installé ​le paquet]] **[[apt://​libqt4-dev|libqt4-dev]]** et ses dépendances ​(à vérifier ?) FIXME. +  * [[:PPA|Ajouter ​le PPA]] **ppa:dhor/myway**((https://launchpad.net/~dhor/+archive/ubuntu/​myway)) dans vos sources ​de logiciels;  
-  L'​installation de libqt4 n'est possible qu'à partir de la version 10.04 LTS d'​Ubuntu. En effet la version 0.9.0 nécessite des dépendances qui ne sont disponibles qu'à partir de la version 10.04 d'​Ubuntu. Vous pouvez cependant compiler la version 0.8.9 sur certaines versions antérieures à Ubuntu 10.04. J'ai fait un tuto à l'​adresse [[http://www.wubijacq.com/repixel/]]. L'​installation nécessite ​de nombreuses manipulations qui peuvent paraître difficiles pour un débutant, cependant elle fonctionne.  +  * [[:tutoriel:​comment_modifier_sources_maj#​recharger_la_liste_des_paquets|recharger la liste des paquets]] 
- +  * [[:​tutoriel:​comment_installer_un_paquet|installer ​le paquet]] **[[apt>​smillaenlarger]]**. 
-==== Installation ==== +
- +
-SmillaEnlarger n'est pas disponible dans les dépôts. Il est possible :  +
-  * soit d'​installer le paquet deb non officiel (v 0.9.) +
-  * soit de télécharger les sources à partir du site du projet puis de les compiler. +
- +
-=== Installation à partir du paquet deb === +
- +
-Il suffit de télécharger le paquet en cliquant ​[[http://​kent.dl.sourceforge.net/​project/​linuxfreedomfor/​SmillaEnlarger/​smillaenlarger_0.9.0_all.deb|ici]] (V. 0.9.0) puis de l'[[:​tutoriel:​comment_installer_un_paquet|installer]]+
- +
- +
-=== Installation à partir des sources === +
- +
-Commencer par télécharger les sources ​[[http://​sourceforge.net/​projects/​imageenlarger/​files/​|ici]] (attention à ne pas se tromper de version, éviter la version w!) ; +
-  ​Décompresser (dézipper) les sources ; +
-  * Se rendre (en console) dans le répertoire des sources : +
- +
-   cd /chemin du dossier des sources/​SmillaElarger_x_x_x_source/​SmillaEnlargerSrc +
- +
-Compiler (deux étapes) : +
- +
-   make ImageEnlarger.pro +
-   ​make +
- +
-C'est terminé.+
  
   ​   ​
 ===== Utilisation===== ===== Utilisation=====
- +Lancez l'​application ​comme indiqué ​[[:​tutoriel:​comment_lancer_application|ici]] ou via le [[:​terminal]] (toutes [[:​versions]] ou [[:​variantes]] d'​Ubuntuavec la [[:​commande_shell|commande]] suivante :​ <​code>​smillaenlarger<​/code>
-==== Lancement ==== +
-=== Version du paquet === +
- +
-L'​application ​se lance depuis le depuis le menu //​Applications -> Graphismes -> SmillaEnlarger//​. +
- +
-=== Version des sources === +
- +
-Pour lancer le logiciel il faudra saisir : +
- +
-   ​./​smilla-enlarger +
- +
-Il est possible de créer un [[raccourci-lanceur|lanceur (raccourci pour démarrer un logiciel, ouvrir un fichier, etc)]] sur le bureau ​ou dans les menus en saisissant cette commande (parfois avec le chemin completdans le champ //Commande// du lanceur.+
  
 L'​utilisation de SmillaEnlarger est assez intuitive. ​ L'​utilisation de SmillaEnlarger est assez intuitive. ​
  • smillaenlarger.1312194091.txt.gz
  • Dernière modification: Le 15/12/2011, 15:20
  • (modification externe)