Différences

Ci-dessous, les différences entre deux révisions de la page.

Lien vers cette vue comparative

Les deux révisions précédentes Révision précédente
Prochaine révision
Révision précédente
tutoriel:utiliser_carte_identite_electronique_belge [Le 06/05/2022, 17:55]
applejuice [Chrome / Chromium]
tutoriel:utiliser_carte_identite_electronique_belge [Le 19/07/2022, 12:09] (Version actuelle)
applejuice [Navigateurs Brave et Opera]
Ligne 14: Ligne 14:
   * Disposer d'un lecteur de cartes compatibles [[wpfr>​PC/​SC|PC/​SC]]   * Disposer d'un lecteur de cartes compatibles [[wpfr>​PC/​SC|PC/​SC]]
   * Avoir [[:​tutoriel:​comment_installer_un_paquet|installé les paquets]] **[[apt>​pcscd,​libccid,​libacsccid1|pcscd libccid libacsccid1]]**.   * Avoir [[:​tutoriel:​comment_installer_un_paquet|installé les paquets]] **[[apt>​pcscd,​libccid,​libacsccid1|pcscd libccid libacsccid1]]**.
-<​note>​La bibliothèque **libacsccid1** remplace les anciennes bibliothèques **libacr38u** et **libacr38ucontrol0** qui ne sont plus disponibles dans les dépôts à partir de [[:​bionic|Bionic 18.04 LTS]]. Cette nouvelle bibliothèque supporte une multitude de lecteurs de carte utilisant des puces du fabricant ACS(([[https://​www.acs.com.hk/​|Advanced Card System Ltd.]])). 
-\\ 
-La gestion de cette transition ne s'est pas faite correctement. 
-\\ 
-D'une part, la communauté aurait dû plus participer pour signaler que le retrait de ces bibliothèques allait engendrer un impact sur l'​utilisation de certains logiciels. Il aurait fallu demander qu'un paquet de transition redirigeant **libacr38u** et **libacr38ucontrol0** vers **libacsccid1** soit crée pour le temps de la transition. 
-  * **[[https://​bugs.launchpad.net/​ubuntu/​+source/​belpic/​+bug/​1781819|Un bug]]** a été introduit sur Launchpad. Si vous êtes affecté par ce problème, vous pouvez le signaler en allant cliquer sur "This bug affects you" (+1) pour que celui-ci ait une chance d'​être corrigé. 
- 
-D'​autre part, le service fédéral en charge du développement du paquet **eid-mw** aurait dû enlever dans les recommandations du paquet pour la version [[:​bionic|Bionic 18.04 LTS]] le paquet **libacr38u** (qui n'​existe plus) et y mettre à la place le paquet **libacsccid1**. 
-  * Vous pouvez également signaler que vous êtes affecté par ce problème en contactant le bureau d'​assistance du Registre National (Belpic) via leur [[https://​eid.belgium.be/​fr/​contact|formulaire en ligne]]. 
-</​note>​ 
- 
  
 =====Installation===== =====Installation=====
Ligne 32: Ligne 21:
   * Puis [[:​tutoriel:​comment_modifier_sources_maj#​recharger_la_liste_des_paquets|rechargez la liste des paquets]].   * Puis [[:​tutoriel:​comment_modifier_sources_maj#​recharger_la_liste_des_paquets|rechargez la liste des paquets]].
   * Il ne vous reste plus qu'à [[:​tutoriel:​comment_installer_un_paquet|installer le paquet]], **[[apt>​eid-mw]]**,​ puis **[[apt>​eid-viewer]]**   * Il ne vous reste plus qu'à [[:​tutoriel:​comment_installer_un_paquet|installer le paquet]], **[[apt>​eid-mw]]**,​ puis **[[apt>​eid-viewer]]**
 +
 +==== Test ====
 +Avand d'​aller plus loin, tester que le lecteur et votre carte (insérée) fonctionnent bien, en lancant l'EID viewer :
 +
 +<​code>​eid-viewer</​code>​
 +
 +Les informations de votre carte doivent s'​afficher dans une nouvelle fenêtre: votre nom, votre photo,...
 +
 +==== Echec du test ====
 +Si le viewer ne fonctionne pas, il se peut que votre démon pcscd ne soit pas lancé. ​
 +Il faut alors passer les deux commandes suivantes:
 +<​code>​
 +sudo systemctl enable pcscd
 +sudo systemctl start pcscd</​code>​
 +
 +puis relancer l'EID viewer:
 +<​code>​eid-viewer</​code>​
  
 ===== Intégration dans les navigateurs web ===== ===== Intégration dans les navigateurs web =====
-Pour s'​authentifier,​ les navigateurs doivent ​pouvoir ​accéder aux certificats de votre carte d'​identité électronique. D'où la nécessité de la procédure qui suit.+Pour s'​authentifier,​ les [[:​navigateur|navigateurs ​web]] doivent accéder aux certificats de votre carte d'​identité électronique. D'où la nécessité de la procédure qui suit
 +<note warning>​De manière générale, un navigateur web installé via [[:​snap|Snap]] ou [[:​flatpak|Flatpak]] ([[:​firefox|Firefox]] et [[:​chromium-browser|Chromium]] par défaut sur [[:​jammy|Ubuntu 22.04]]) ne pourra accéder aux certificats de votre carte d'​identité (Voir la page FAQ du [[https://​eid.belgium.be/​fr/​faq/​pourquoi-lutilisation-de-leid-est-elle-impossible-avec-des-logiciels-de-snap-etou-flatpak#​7636|site officiel de eID]]). Pour une utilisation d'Eid avec un [[:​navigateur|navigateurs web]], il est indispensable d'​installer ce dernier via un [[:​ppa|ppa]]. 
 + 
 +Voici la marche à suivre pour installer [[:​firefox#​installer_firefox_en_.deb_classique_au_lieu_de_snap|Firefox]] ou [[:​chromium-browser#​Installation|Chromium]] depuis leurs [[:​ppa|ppa]] officiels</​note>​.
 ====Firefox==== ​ ====Firefox==== ​
-<​note>​ 
-À partir [[:​jammy|Ubuntu 22.04 LTS ("The Jammy Jellyfish"​)]] le navigateur [[:​Firefox]],​ même s'il est installable à l'aide de [[:​Synaptic]] ou de la [[:​Logithèque]],​ est installé au format [[:Snap]]. Il semble que ce format ne permette pas à Firefox d'​accéder aux bibliothèques opensc-pkcs11.so permettant de se connecter aux cartes à puce à des fins d'​authentification (et à tout autre programme extérieur). Voir la page FAQ du [[https://​eid.belgium.be/​fr/​faq/​pourquoi-lutilisation-de-leid-est-elle-impossible-avec-des-logiciels-de-snap-etou-flatpak#​7636|site officiel de eID]]. 
- 
-En attendant la résolution de ce problème (en cours), pour une utilisation de la carte eID avec Firefox dans [[:​jammy|Ubuntu 22.04 LTS]], il est nécessaire de désinstaller le paquet snap de Firefox et d'​installer Firefox via un paquet [[:​deb|.deb]] et passer par un dépôt [[:​ppa|PPA]]. Choisissez la [[https://​www.mozilla.org/​fr/​firefox/​linux/​|version officielle du téléchargement de Firefox]] ou la version [[https://​doc.ubuntu-fr.org/​firefox#​version_esr_extended_support_release|firefox-esr (Extended Support Release)]]. ​ 
-</​note>​ 
 L'​installation du paquet intègre l'​extension pour Mozilla. Si le module n’apparaît tout de même pas dans le gestionnaire de modules de Firefox faites ce qui suit : L'​installation du paquet intègre l'​extension pour Mozilla. Si le module n’apparaît tout de même pas dans le gestionnaire de modules de Firefox faites ce qui suit :
   * Téléchargez et installez l'​extension **eID Belgique** [[https://​addons.mozilla.org/​fr/​firefox/​addon/​belgium-eid/​|ici]] ou via votre gestionnaire de modules : ​   * Téléchargez et installez l'​extension **eID Belgique** [[https://​addons.mozilla.org/​fr/​firefox/​addon/​belgium-eid/​|ici]] ou via votre gestionnaire de modules : ​
Ligne 48: Ligne 52:
   * Redémarrer Firefox ... :-D    * Redémarrer Firefox ... :-D 
  
-<note important>​Le lecteur de carte doit être branché AVANT de lancer firefox !!!</​note>​+<note important>​Le lecteur de carte et la carte insérée ​doit être branché AVANT de lancer firefox !!!</​note>​
  
 ==== Chrome / Chromium ==== ==== Chrome / Chromium ====
-<​note>​ 
-Depuis [[:​eoan|Eoan 19.10]] le navigateur [[:​Chromium-Browser|Chromium]],​ même s'il est installable à l'aide de [[:​Synaptic]] ou de la [[:​Logithèque]],​ est installé avec le format [[:Snap]]. Depuis l'​utilisation de ce format d'​installation,​ Chromium ne peut plus accéder à la bibliothèque opensc-pkcs11.so permettant de se connecter aux cartes à puce à des fins d'​authentification (Firefox y arrive grâce à l'​extension Eid). Info pour Chromium : [[https://​bugs.launchpad.net/​ubuntu/​+source/​chromium-browser/​+bug/​1843392|snap : smart card reader no longer works]]. 
- 
-Par contre, le tutoriel ci-dessous permet à l'Eid de fonctionner avec [[:Google Chrome]] installable via le [[:paquet]] Ubuntu/​debian proposé sur la page officielle de [[http://​www.google.fr/​chrome|téléchargement de Google Chrome]]. 
- 
-Il existe des [[:ppa]] permettant de forcer l'​installation de Chromium (en anglais) par [[:apt]]. Cependant, même si l'​authentification de l'Eid fonctionne avec ces versions, leur lancement génère beaucoup d'​erreurs (testé sur [[:​focal|20.04 LTS]]). C'est à déconseiller,​ donc. 
-</​note>​ 
- 
 <​note>​ <​note>​
 Ajoutez le support NSS en [[:​tutoriel:​comment_installer_un_paquet|installant le paquet]], **[[apt>​libnss3-tools]]**,​ puis configurez [[:​google_chrome|chrome]] ou [[:​chromium]] avec la commande ''​modutil''​. ​ Il faudra fermer Chrome pour que cette configuration puisse être réalisée.</​note>​ Ajoutez le support NSS en [[:​tutoriel:​comment_installer_un_paquet|installant le paquet]], **[[apt>​libnss3-tools]]**,​ puis configurez [[:​google_chrome|chrome]] ou [[:​chromium]] avec la commande ''​modutil''​. ​ Il faudra fermer Chrome pour que cette configuration puisse être réalisée.</​note>​
Ligne 91: Ligne 87:
 ----------------------------------------------------------- -----------------------------------------------------------
 </​code>​ </​code>​
 +====Navigateurs Brave et Opera====
 +<​note>​Ne pas installer ces [[:​navigateur|navigateurs]] à l'aide d'un [[:​snap|snap]],​ mais bien de celle de leur [[:​depots|dépôts]] officiels, ou du [[:​deb|Paquet Debian]] de ces navigateurs.</​note>​
 +Les navigateurs [[:​brave|Brave]] et [[:​opera|Opera]] sont basés sur le navigateur [[:​Chromium|Chromium]]. Une fois l'​installation du logiciel eID effectuée (voir plus haut), ces navigateurs reconnaissent nativement l'​utilisation d'une carte d'​identité électronique belge (aucune extension nécessaire).
 +
 ===== Utilisation ===== ===== Utilisation =====
    
  • tutoriel/utiliser_carte_identite_electronique_belge.1651852558.txt.gz
  • Dernière modification: Le 06/05/2022, 17:55
  • par applejuice