Contenu | Rechercher | Menus

Subversive

Subversive est un greffon permettant d'utiliser Subversion (SVN) avec Eclipse.

Il existe aussi subclipse

Principales fonctionnalités

  • Parcourir un dépôt
  • Ajouter un projet dans un dépôt et récupérer un projet depuis un dépôt
  • Synchroniser un projet afin de visualiser les changements
  • Faire les opérations courantes : commit, update, merge, revert, etc.
  • Gérer les conflits

Installation (dans Eclipse 3.5 - Galileo)

Pré-requis

Ajout des greffons dans Eclipse

Eclipse a besoin de deux greffons pour pouvoir utiliser la technologie SVN :

  • Un greffon de base pour disposer de Subversive (Subversive SVN Team Provider)
  • Un connecteur SVN (SVNKit), réalisé par la communauté Polarion

Ajout du greffon Subversive SVN Team Provider

  1. Aller dans le Menu AideInstall New Software .
  2. Sélectionner alors la ligne qui contient cette URL dans Work with :
  3. Puis dérouler Subversion SVN Team Provider Plugin (Incubation)
  4. Et cocher Subversive SVN Team Provider (Incubation) et Subversive SVN Team Provider Localization (Optional) (Incubation)
  5. Enfin cliquer sur Suivant pour installer ce greffon.

Ajout du greffon SVNKit

  1. Aller dans le Menu AideInstall New Software .
  2. Sélectionner alors la ligne qui contient cette URL dans Work with :
  3. Puis dérouler Subversion SVN Connectors
  4. Et cocher SVNKit 1.3.2 Implementation (Optional)
  5. Enfin cliquer sur Suivant pour installer ce greffon.

Enfin redémarrez Eclipse lorsque c'est terminé.

Pour vérifier que tout s'est bien passé, allez dans Window → Preferences → Team → SVN → onglet SVN Connector

Si aucun connecteur n'est disponible, c'est que l'installation n'a pas fourni les résultats escomptés.

Créer un projet depuis un dépôt SVN

Ici nous créerons un projet C++ depuis un dépôt vide, la procédure est cependant similaire avec d'autres langages ou pour récupérer un projet déjà existant.

Menu FichierNouveauAutre … (File → New → Other…)

Dans la fenêtre qui s'affiche, sélectionnez SVNProject from SVN

Laissez-vous guider pour l'étape suivante : saisissez l'URL de votre dépôt SVN, votre login et mot de passe, puis cliquez sur Suivant.

Dans la fenêtre suivante, on vous demande de choisir une version du dépôt, à vous de choisir en fonction de vos besoins. Cliquez sur Terminer.

Eclipse vous demande alors dans quel projet il doit poser les fichiers du dépôt. Vous pouvez aussi demander la création d'un nouveau projet en choisissant l'option Check out as a project configured using the New Project Wizard. Cliquez sur Finish.

Cette fois, demandez un projet C++ (ou Java, Python, Ruby, etc. selon cas) et laissez-vous guider par la procédure standard de création de projet. Eclipse va automatiquement récupérer les fichiers sur le dépôt et les insérer dans le nouveau projet…

Codez… compilez !

Désinstallation

Pour supprimer ces greffons, il suffit de retourner dans le gestionnaire de mises à jour d'Eclipse.

Menu Help → Software Updates… → onglet Installed Software. Sélectionnez les deux greffons et cliquez sur Uninstall.

Voir aussi

Vous pouvez consulter les sites suivants pour obtenir un complément d'information…


Contributeurs : Guigouz, quent57


eclipse_subversive.txt · Dernière modification: Le 21/05/2010, 21:54 par quent57
Le contenu de ce wiki est sous licence : CC BY-SA v3.0