Contenu | Rechercher | Menus
Selon les tags présents sur cette page, les informations qu'elle contient n'ont pas été vérifiées depuis Ubuntu 12.10.
Apportez votre aide…

Logo d'Eclipse

IDE : Eclipse

Eclipse est un IDE (environnement de développement intégré) écrit en Java, extensible par des greffons, multi-langages et multi-plates-formes, qui s'intègre particulièrement bien à GNOME.

Il est d'abord conçu pour le langage Java mais ses nombreux greffons en font un environnement de développement pour de nombreux autres langages de programmation (C/C++, Python, PHP, Ruby, …).

Toutes les fonctions qu'on peut attendre de ce genre de logiciel sont présentes ou existent sous forme de greffons (coloration syntaxique, complétion, debugger, gestion de projets, intégration aux gestionnaires de versions, …).

Pré-requis

  • Activer les dépôts Universe ;
  • Avoir une machine virtuelle Java fonctionnelle (des différences de performances peuvent apparaître suivant la machine virtuelle java choisie) ;
  • Avoir les compilateurs et/ou interpréteurs (C/C++, python, php, ruby ou ruby on rails,…) des langages choisis pour développer, installés et fonctionnels, et les outils complémentaires (subversion, cvs, bzr, Apache, MySQL, …) que vous voudrez utiliser.

Installation

Installation par les dépôts officiels

Installez le paquet eclipse. Si besoin, la machine Java OpenJDK sera automatiquement installée. Pour avoir directement les greffons pour le C/C++, installez plutôt le paquet eclipse-cdt.

Version Ubuntu Version Eclipse
Ubuntu 12.10 Eclipse 3.8.0 (Indigo)
Ubuntu 12.04 LTS Eclipse 3.7.2 (Indigo)
Ubuntu 11.10 Eclipse 3.7.0 (Indigo)
Ubuntu 10.04 LTS Eclipse 3.5.2 (Galileo)

Eclipse en français

Pour utiliser Eclipse en français, vous devez installer un pack de langue babel en ajoutant un serveur de mise à jour.

  1. Ouvrez Eclipse ;
  2. Allez dans le menu Help → Install New Software… ;
  3. Cliquetez sur le bouton Add… ;
  4. Donnez un nom au serveur (par exemple Traduxion ;-)) et copiez-collez l'adresse correspondant à votre version avant de valider le formulaire.

Eclipse 3.6 n'est plus supporté. Il est impératif de faire la mise à jour pour profiter du pack de langue français…

Si les adresses de serveur ne fonctionnent plus, il faudra peut-être remplacer le numéro de version (R0.11.0) par celui de la dernière version indiquée sur la page du projet Babel.

Eclipse devrait vous afficher pending… puis au bout d'un moment, le menu d'installation des packs de langues apparaîtra. La traduction d'Eclipse est disponible sous l'intitulé « Babel Language Packs for eclipse » où vous pourrez choisir la langue appropriée. Après la fin de l'installation, la langue sera prise en charge automatiquement au redémarrage du logiciel.

Attention : les packs de langues ne fonctionnent correctement que pour Eclipse Classic. Dans la version Eclipse IDE for Java Developers avec la version Helios, le pack de langue entraîne la paralysie du logiciel et bloque énormément de fonctionnalités, comme l'exportation ou l'importation d'un projet.

Dernière version disponible

Cette solution vous permet d'utiliser la dernière version d'Eclipse (Juno).

Eclipse étant développé en Java, il ne nécessite qu'une machine virtuelle Java pour fonctionner.

  • Téléchargez la version qui vous convient sur le site officiel, en effet des packs tout prêts suivant le langage de programmation que vous voudrez utiliser sont disponibles, ainsi que différentes versions suivant votre plate-forme (x86, x86_64, PPC, …), cherchez bien. Si vous ne voulez pas développer en Java, nous vous conseillons de partir sur la distribution Eclipse Classic à laquelle vous ajouterez les greffons dont vous aurez besoin. Lisez les paragraphes sous Principales Configurations pour vous faire une idée.
  • Créez un dossier où vous voulez, pourquoi pas le dossier .eclipse3.x placé dans votre dossier personnel histoire qu'il "disparaisse" (/!\ attention, évitez de nommer le dossier .eclipse car il est utilisé par la version disponible dans les dépôts si vous comptez également utiliser cette dernière.)
  • Décompressez l'archive précédemment téléchargée dans ce dossier (une remarque, les archives contiennent le dossier "eclipse" qui au final ne sert à rien si on choisit un autre nom pour le dossier où nous plaçons les fichiers)
  • Créez un lanceur dans votre menu Application afin de lancer le fichier eclipse

créer le fichier eclipse.desktop ou en ligne de commande

gksudo gedit /usr/share/applications/eclipse.desktop 

et copiez-y le texte suivant dans le fichier eclipse.desktop (en supposant que votre répertoire eclipse se trouve sous /opt)

[Desktop Entry]
Name=Eclipse 
Type=Application
Exec=/opt/eclipse/eclipse
Terminal=false
Icon=/opt/eclipse/icon.xpm
Comment=Integrated Development Environment
NoDisplay=false
Categories=Development;IDE
Name[en]=eclipse.desktop

Et voilà, c'est fait. Vous pouvez même avoir plusieurs versions ou configurations différentes sur votre machine sans aucun problème tant que vous séparez les espaces de travail.

Pour avoir le français (pour toutes les versions), téléchargez les packs de langue ici et décompressez-les de la même façon dans votre dossier d'installation.

Pour avoir le français (pour les versions 3.3.x), lisez cet article.

Résolutions des problèmes

Lancement d'Eclipse

Description
Rien ne se passe…

Solution
Suivez: http://doc.ubuntu-fr.org/java#je_souhaite_executer_un_programme_java

Erreur au lancement

Problème avec le Workspace

Description
Si, au lancement d'Eclipse, vous avez une erreur et en vérifiant votre rapport d'erreur à cet emplacement workspace/.metadata/.log vous voyez une phrase comme : "Failed to map segment to shared object: Operation not permitted".

Solution
Il faut vérifier que le système de fichiers où se trouve votre répertoire personnel (typiquement /home) est monté avec l'autorisation d'exécution pour les programmes. Pour cela tapez :

mount | grep home

Si /home est monté avec l'option noexec, il faut modifier le fichier /etc/fstab et retirer cette option de la ligne /home du fichier.

Problème de chargement d'une librairie SWT

Description
Si, au lancement d'Eclipse, il y a une erreur et, en vérifiant le fichier de log, il est possible de lire quelque chose ressemblant à ceci :

java.lang.UnsatisfiedLinkError: Could not load SWT library. Reasons: 
        no swt-gtk-3740 in java.library.path
        no swt-gtk in java.library.path
        Can't load library: /home/<nom_utilisateur>/.swt/lib/linux/x86[_64]/libswt-gtk-3740.so
        Can't load library: /home/<nom_utilisateur>/.swt/lib/linux/x86[_64]/libswt-gtk.so

Solution
Il faut ajouter un lien symbolique vers les librairies SWT contenues dans /usr/lib/jni/ vers le dossier :

  • /.swt/lib/linux/x86/ pour un système 32 bits ;
  • /.swt/lib/linux/x86_64/ pour un système 64 bits.

Ce qui vous donne :

  • Pour un système 64 bits.
ln -s /usr/lib/jni/libswt-* .swt/lib/linux/x86_64/
  • Pour un système 32 bits.
ln -s /usr/lib/jni/libswt-* .swt/lib/linux/x86/

Could not initialize…

Description
Si au lancement d'Eclipse, vous obtenez l'erreur suivante: "Could not initialize the application's security component. The most likely cause is problems with files in your application's profile directory. Please check that this directory has no read/write restrictions and your hard disk is not full or close to full. It is recommended that you exit the application and fix the problem. If you continue to use this session, you might see incorrect application behaviour when accessing security features."

Solution
Il suffit de créer un dossier vide nommé eclipse dans le répertoire .mozilla de votre répertoire utilisateur. Pour cela, tapez :

mkdir ~/.mozilla/eclipse

Bugs d'affichages

Description
Dans la dernière version d'Eclipse (3.5), un bug gênant peut apparaître. Lorsque vous ouvrez une boîte de dialogue, les boutons (Next, Finish, etc.) ne semblent pas répondre.

Solution
C'est un bug dû à un mauvais paramètre GDK. Vous pouvez démarrer Eclipse grâce au script suivant :

#!/bin/sh
export ECLIPSE_HOME="/chemin/vers/votre/dossier/dinstallation"
export GDK_NATIVE_WINDOWS=1
$ECLIPSE_HOME/eclipse $*

Problème de mémoire

Description
Un problème de mémoire (java.lang.OutOfMemoryError: GC overhead limit exceeded) peut apparaître, par exemple lors d'installation de plugins (Help→"Install New Software"). La version 64 bits utilisée par le SDK d'Eclipse nécessite plus de mémoire que la version 32 bits.

Solution
Vérifier que vous avez une taille de mémoire suffisante définie dans le fichier eclipse.ini de votre répertoire d'installation (source : site JFire):

-Xms512m
-Xmx1024m
-XX:PermSize=64m
-XX:MaxPermSize=128m

Transitions très lentes

Description
Une latente très marquée est constatée lorsqu'on agrandit par exemple l'éditeur de code. Durant ces lenteurs, le taux d'utilisation du processeur marque un pic. Ce défaut se produit avec d'anciennes cartes vidéo ATI utilisant le pilote libre Radeon.

Rapport de bug: https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-ati/+bug/363238

Solution
Modifier les paramètres du serveur X et plus particulièrement l'accélération 2D. Se reporter à la page de documentation radeon.

Défilement impossible

Description
Avec Ubuntu 11.10 Oneriic, les nouvelles barres de défilement ne fonctionnent pas dans Eclipse.

Solution
Pour pouvoir utiliser les overlays scrollbars dans Eclipse, modifiez le fichier /usr/bin/eclipse : Commentez la ligne

export GDK_NATIVE_WINDOWS=true

en ajoutant un # au début de cette ligne.

Sinon, vous pouvez lancer Eclipse en ligne de commande en désactivant les overlays scrollbars :

LIBOVERLAY_SCROLLBAR=0 eclipse

Pour modifier le raccourci d'Eclipse dans le menu, modifiez le fichier /usr/share/applications/eclipse.desktop :

gksu gedit /usr/share/applications/eclipse.desktop

La ligne

Exec=eclipse

devient :

Exec=bash -c "LIBOVERLAY_SCROLLBAR=0 eclipse"

FIXME Est-ce nécessaire pour les utilisateurs de GNOME, KDE, Xfce ou LXDE ? Nécessaire sous Gnome Shell

Les menus ne se déplient pas

Description
Avec Ubuntu 13.04 et 13.10 et Ubuntu Kepler (installation manuelle de la dernière version d'Eclipse), les menus "File, Edit, Navigate, Search… etc" sont présents mais lorsque l'on clique dessus, ils ne se déplient pas.
Voir bug déclaré : https://bugs.launchpad.net/ubuntu/+source/unity/+bug/1221848

Solution
En attendant la correction du bug, pour pouvoir avoir des menus fonctionnels, un contournement consiste à modifier le lanceur de l'application comme suit :
Ouvrir le fichier lanceur :

gksudo gedit /usr/share/applications/eclipse.desktop

Changez la ligne :

Exec=/opt/eclipse/eclipse

Par :

Exec=env UBUNTU_MENUPROXY= /opt/eclipse/eclipse

Eclipse se ferme sans raison apparente

Description
Que ce soit avec la version disponible dans les dépôts ou avec celle téléchargée sur eclipse.org, il arrive qu'Eclipse se ferme sans raison apparente. Le bug est facilement reproductible : Si vous auto-complétez votre code (CTRL + ESPACE) et qu'Eclipse se ferme, vous êtes victime de ce bug. Si le problème ne se produit plus quand vous lancez Eclipse à l'aide de la commande suivante :

eclipse -vmargs -Dorg.eclipse.swt.browser.DefaultType=mozilla

Vous pouvez modifier le fichier eclipse.ini et rajouter :

-Dorg.eclipse.swt.browser.DefaultType=mozilla

en dessous de

-vmargs

Source : https://bugs.eclipse.org/bugs/show_bug.cgi?id=410739#c3

Les greffons supplémentaires

Que vous ayez choisi l'installation par les dépôts, ou l'installation manuelle, vous voudrez sûrement ajouter des fonctionnalités complémentaires à votre Eclipse.

Pour faire cela tout se passe dans le menu Aide > Mise à jour de logiciels > Rechercher et installer… (en anglais Help > Software updates > Find and install…). Là vous pouvez soit mettre à jour les composants déjà installés, soit rechercher de nouveaux composants, ce que nous voulons faire. À partir de là vous avez plusieurs sites de recherche proposés, et vous pouvez aussi en rajouter de nouveaux.

Attention : le système de mises à jour d'Eclipse ne fonctionne pas correctement derrière un proxy d'entreprise à cause de problèmes de formatage de l'authentification. Ceci est notamment vrai avec Java 1.5 et une authentification de réseau Windows.

Développer pour Android

Principales Configurations

Vous pouvez configurer Eclipse ainsi que toutes ses extensions au même endroit en allant dans le menu Fenêtre > Préférences… (window > Préférences… en anglais) qui se présente avec à gauche les différents éléments configurables (Général, Java, Ant, …) sous forme d'une arborescence, et à droite les différentes options de configuration suivant l'élément sélectionné. Tous les greffons que vous installerez rajouteront leur page de configuration à cet endroit pour que vous puissiez y accéder facilement.

Eclipse pour Java

(installation par les dépôts déjà décrite plus haut)

Pas besoin de rajouter de greffons pour faire du Java avec Eclipse, il suffit de choisir la bonne distribution sur le site officiel et de l'installer comme décrit plus haut.

Il y a 3 distributions officielles principales pour développer en Java:

  • Eclipse IDE for Java Developers contenant tout ce qu'il faut pour le développement Java.
  • Eclipse IDE for Java EE Developers destinée au développement avec le SDK Java Edition Entreprise pour le serveur d'application du même nom.
  • Eclipse for RCP/Plug-in Developers destinée au développement d'Eclipse et des greffons, mais de ce fait aussi très complète, avec les sources d'Eclipse.

Voir les sources de Java en faisant ctrl + clique gauche

Installez le paquet sun-java6-source

Eclipse pour C/C++

[note : ce paragraphe n'est pas compréhensible/utilisable pour un utilisateur non avancé dans la maîtrise d'Ubuntu] (installation par les dépôts déjà décrite plus haut)

Si vous souhaitez utiliser Eclipse uniquement pour développer en C/C++, et que vous installez Eclipse manuellement, nous vous recommandons de prendre directement la version Eclipse IDE for C/C++ developpers qui ne contient que l'essentiel sans surcharge, et qui contient surtout le greffon décrit ci-dessous.

Si vous souhaitez intégrer la prise en charge du langage C/C++ dans votre installation Eclipse, il vous faut le greffon CDT: C/C++ Development Tooling.

Installation

  • Sélectionner le site de mise à jour Callisto Discovery Site (Eclipse 3.2), Europa Discovery Site (Eclipse 3.3),Ganymede Discovery Site (Eclipse 3.4) ou Galileo Discovery Site (Eclipse 3.5) et lancer la recherche en appuyant sur terminé.
  • Rechercher C and C++ Development, sélectionner Eclipse C and C++ Development Tools, et lancer l'installation.
  • Relancer Eclipse et c'est fini :)

Il ne reste plus qu'à vérifier dans les préférences d'Eclipse que le greffon est configuré selon vos besoins, surtout la partie sur Make.

Liens spécifiques

Eclipse pour Perl

Il existe un plugin d'Eclipse pour Perl, disponible sur http://www.epic-ide.org/. Pour l'installer, ajouter l'url http://e-p-i-c.sf.net/updates (ou http://e-p-i-c.sf.net/updates/testing pour la version en développement) à la liste sites de mise à jour (Help > Install New Software…), et choisissez le plugin à installer.

Liens spécifiques * Site Officiel (en) * Instructions pour l'installation (en)

Eclipse pour Python

(installation par les dépôts déjà décrite plus haut)

Installation manuelle du greffon PyDev

  • Ajouter un Nouveau Site Distant… (New Remote Site… en anglais) de recherche de mise à jour que vous pouvez appeler PyDev : http://pydev.org/updates
  • Sélectionner ce nouveau site et lancer la recherche en appuyant sur terminé.
  • Sélectionner PyDev for Eclipse et lancer l'installation.
  • Relancer Eclipse et c'est fini :)

Il ne reste plus qu'à vérifier dans les préférences d'Eclipse que le greffon PyDev est configuré selon vos besoins. Vérifier surtout que les chemins vers les interpréteurs (/usr/bin/python et /usr/share/java/jython.jar si vous voulez utiliser jython) sont correctement définis.

Il faut aussi penser à ajouter la perspective PyDev pour un accès plus rapide à celle-ci.

Vous pourrez aussi installer les greffons additionnels pour mylin (extension pour travail collaboratif) si vous en avez besoin.

Liens spécifiques

Eclipse pour PHP

Deux greffons concurrents sont disponibles pour intégrer le PHP dans Eclipse phpeclipse et PDT: PHP Development Tools. Une fois votre solution LAMP installée, vous n'avez plus qu'à choisir le greffon qui vous convient (installer les deux créerait un conflit).

1. PHPEclipse

La dernière version de ce greffon est officiellement compatible avec Eclipse 3.1 mais fonctionne aussi avec Eclipse 3.2. Par contre pour l'utiliser avec les dernières versions Eclipse 3.3 et supérieur il vous faudra utiliser une version NightyBuild de développement et donc sujette à de nombreux bugs.

De plus il vous faudra impérativement Java 1.5 ou supérieur et l'utilisation de la version libre de java est à proscrire.

Installation

ou http://phpeclipse.sourceforge.net/update/stable/1.2.x (version stable 1.2.x) ou http://phpeclipse.sourceforge.net/update/nightly (version instable)

  • Sélectionner ce nouveau site et lancer la recherche en appuyant sur terminé.
  • Sélectionner PHP Eclipse et lancer l'installation.
  • Relancer Eclipse et c'est fini :)

PHPEclipse intègre une simplification de l'utilisation d'un environnement XAMPP (non disponible dans les dépôts) grâce à un menu et des boutons dédiés. Même sans XAMPP, il reste très pratique pour contrôler les serveurs Apache et MySQL.

Pour que tout fonctionne correctement, un tour dans les préférences pour configurer les différentes applications externes. Sur Ubuntu vous aurez besoin des droits utilisateurs afin de lancer des commandes sur apache ou mysql, ce qui explique les données ci-dessous ;) (configuration LAMP normale).

  • PHP command : /usr/bin/php
  • PHP Parser command: /usr/bin/php -l -f {0}
  • Start Apache: /etc/init.d/apache2 start
  • Stop Apache: /etc/init.d/apache2 stop
  • Restart Apache: /etc/init.d/apache2 restart
  • Apache: /usr/bin/gksudo
  • Path to httpd.conf: /etc/apache2/httpd.conf
  • Path to etc/hosts: /etc/hosts
  • Start MySQL: /etc/init.d/mysql start
  • MySQL: /usr/bin/gksudo

Sans Oublier le dossier racine de votre serveur web, ainsi que l'emplacement de vos librairie comme PEAR ou Symfony, si vous en utilisez.

Liens spécifiques

2. PDT: PHP Development Tools

Tutoriel video http://www.youtube.com/watch?v=sAwOXvtu8k0

Installation Si malgré le tutoriel vidéo vous ne trouvez pas PDT, ajouter http://download.eclipse.org/releases/indigo comme source dans help→install new software→bouton ADD. Attention, indigo est une version récente en juillet 2011, si vous avez une autre version, remplacer indigo dans l'URL par votre version de Eclipse (elle s'affiche quand on démarre Eclipse)

A détailler (versions concernées, etc)</note>

Il ne reste plus qu'à vérifier dans les préférences d'Eclipse que le greffon PHP est configuré selon vos besoins. Vérifier surtout que l'exécutable /usr/bin/php est correctement défini.

Liens spécifiques

En cas de problème

Si aucun fichier PHP ne peut être ouvert dans Eclipse il est probable que la configuration Java ne soit pas exacte. Utilisez la commande suivante : sudo update-alternatives –config java puis choisissez /usr/lib/jvm/java-6-sun/jre/bin/java

Eclipse pour Ruby/RubyOnRails

Selon que vous vouliez développer en Ruby seul, ou avec l'aide du framework Rails très prisé pour ses qualités dans le développement web, vous avez le choix entre deux configurations différentes, à vous de choisir celle qui vous convient le mieux (n'installer pas les deux, cela ne sert à rien et peut entraîner des conflits).

1. Ruby

L'intégration du langage Ruby se fait avec le greffon RDT: Ruby Development Tools qui permet de ne pas surcharger votre IDE.

Installation

  • Ajouter un Nouveau Site Distant… (New Remote Site… en anglais) de recherche de mise à jours que vous pouvez appeler RDT : http://update.aptana.com/update/rdt/3.2/site.xml
  • Sélectionner ce nouveau site et lancer la recherche en appuyant sur terminé.
  • Sélectionner Ruby Development Tools et lancer l'installation.
  • Relancer Eclipse et c'est fini :)

Aller ensuite dans les préférences pour configurer selon vos besoin et vérifier le chemin vers l'interpréteur Ruby (/usr/bin/ruby).

2. Ruby on Rails

Pour travailler avec Ruby On Rails Le greffon RadRails vous est proposé par Aptana (ainsi que le greffon RDT ci-dessus) et lui est particulièrement lié. Nous allons voir ici comment l'installer sans toute l'artillerie du greffon Aptana. Toutefois, la méthode la plus simple reste l'installation d'Aptana qui est décrite plus bas et qui intègre un mécanisme d'installation de ce greffon simplifiée.

FIXME les 2 liens ci-dessous sont morts, si quelqu'un pouvait mettre à jour

Installation

  • Ajouter un Nouveau Site Distant… (New Remote Site… en anglais) de recherche de mise à jours que vous pouvez appeler RadRails : http://update.aptana.com/install/rails/3.2/
  • Ajouter un Nouveau Site Distant… (New Remote Site… en anglais) de recherche de mise à jours que vous pouvez appeler Aptana : http://update.aptana.com/install/studio/3.2/
  • Sélectionner le site de mise à jour Callisto Discovery Site (Eclipse 3.2), Europa Discovery Site (Eclipse 3.3) ou Ganymede Discovery Site (Eclipse 3.4), ainsi que les deux sites distants que nous venons de définir et lancer la recherche en appuyant sur terminé.
  • Sous Aptana dans les Features sélectionner Aptana HTML Editor
  • Sous le Discovery Site dans les Other tools sélectionner Eclipse Monkey
  • Sous RadRails sélectionner Aptana RadRails et lancer l'installation.
  • Relancer Eclipse et c'est fini :)

Cette installation peut paraître compliquée, de plus il vous faudra aller dans les préférences comme d'habitude pour configurer selon vos besoins, et indiquer les chemins vers l'interpréteur ruby (/usr/bin/ruby) facultatif car jruby (interpréteur ruby écrit en java) est aussi installé et le framework rails.

FIXME si quelqu'un pouvait préciser le minimum pour l'installation Rails

Liens spécifiques

Eclipse pour le Web

Pour travailler plus facilement avec des fichiers html, css, js, xml, … que l'on rencontre généralement dans le développement d'applications web, Eclipse met à notre disposition des greffons regroupés sous WTP: Web Tools Platform. Certains de ces greffons sont d'ailleurs intégrés dans certaines distributions d'Eclipse ou sont requis par d'autres greffons.

Installation

  • Sélectionner le site de mise à jour Callisto Discovery Site (Eclipse 3.2), Europa Discovery Site (Eclipse 3.3) ou Ganymede Discovery Site (Eclipse 3.4) et lancer la recherche en appuyant sur terminé.
  • Rechercher Web et JEE Development et sélectionner Eclipse XML Editors and Tools (uniquement Eclipse 3.3) si vous ne voulez que travailler sur des fichiers XML, Web Standard Tools (WST) pour tous les fichiers courants (html, css, js, xml, …) ou J2EE Standard Tools (JST) si vous comptez utiliser la plate-forme web J2EE, et lancer l'installation.
  • Relancer Eclipse et c'est fini :)

Il ne reste plus qu'à vérifier dans les préférences d'Eclipse que les greffons sont configurés selon vos besoins.

Ces greffons ne facilitent pas encore l'intégration d'AJAX dans vos projets, mais cette fonctionnalité devrait être intégrée dans les prochaines versions, en attendant, le greffon ci-dessous fera votre bonheur.

Web 2.0 avec AJAX

Pour ceux qui veulent aller plus loin et faire de belles pages utilisant de l'AJAX grâce aux librairies existantes actuellement (Dojo, Scriptaculous, …), le greffon JSEclipse vous simplifiera la vie. Et pour aller encore plus loin, le greffon Aptana décrit plus bas est encore mieux adapté.

Installation

  • Ajouter un Nouveau Site Distant… (New Remote Site… en anglais) de recherche de mise à jour que vous pouvez appeler JSEclipse : http://download.macromedia.com/pub/labs/jseclipse/autoinstall/
  • Sélectionner ce nouveau site et lancer la recherche en appuyant sur terminé.
  • Sélectionner JSEclipse et lancer l'installation.
  • Relancer Eclipse et c'est fini :)

Ce greffon très simple, avec peu d'éléments à configurer, permet grâce à un menu dédié de vous interfacer avec les toolkits AJAX courant.

Liens spécifiques

Eclipse pour Latex

Le plug-in Texlipse permet d'éditer un fichier Latex dans Eclipse : http://texlipse.sourceforge.net/

Pour l'installer, ajouter http://texlipse.sourceforge.net/ au gestionnaire de mise à jour d'Eclipse.

Eclipse et Aptana

Aptana peut créer des conflits avec certains greffons, notamment ceux couvrant des domaines qu'il couvre également (Web, PHP, Ruby…)

Aptana est avant tout un IDE basé sur Eclipse 3.2, néanmoins une version sous forme de greffon existe afin de vous permettre d'intégrer tous les greffons développés par Aptana dans votre configuration Eclipse actuelle.

Aptana est orienté vers le développement internet, il dispose de ce qu'il faut pour écrire vos applications web, avec l'intégration de la plupart des bibliothèques AJAX. Il offre de plus la possibilité d'ajouter très facilement le support de PHP et de Ruby On Rails ainsi que de Subversion dans votre IDE, et dispose en plus de quelques greffons qui pourront vous faire plaisir.

Installation du greffon

Allez ensuite dans les préférences pour finir de configurer selon vos besoins. Profitez-en pour afficher aussi "Aptana start page" qui se trouve dans le menu aide, vous aurez ainsi accès à une présentation claire des greffons complémentaires disponibles chez Aptana.

Liens spécifiques

Aptana Studio étant un IDE complet, si vous ne voulez que faire du développement web, vous pouvez l'installer de façon autonome sans passer par l'installation préalable d'Eclipse : Page sur Aptana Studio

Eclipse pour Flex (Flash)

"Adobe® Flex™ est un environnement RIA basé sur Adobe Flash® qui vous permettra de créer de manière productive de remarquables applications évolutives exploitables par tous sur la quasi-totalité des plates-formes. Il comprend un puissant outil de développement basé sur Eclipse™, une bibliothèque étendue de composants graphiques et des services de données hautes performances adaptés aux exigences applicatives les plus pointues."

L'installation devant se faire extèrieurement à Eclipse et mettant en place tout le SDK, ainsi qu'une version de Flash spécial débugage, veuillez vous référer à cette page : Installation de Flex Builder

Eclipse et FTP

Pour pouvoir modifier directement vos fichiers se situant sur un FTP (un peu comme l'éditeur Quanta+ de KDE), vous pouvez installer DSDP (http://wiki.eclipse.org/DSDP/TM).

Pour cela, il vous faut ajouter le site distant suivant :

Puis le sélectionner, ainsi que Europa Discovery Site pour satisfaire les dépendances.

Après l'avoir installé, il vous faut vous rendre dans Windows>Show View>Other, puis Remote Systems > Remote Systems. Dans le nouvel onglet qui apparaît, cliquez droit puis faites New Connection pour ajouter un FTP.

Note : La version 3 de DSDP ne fonctionne qu'avec Eclipse 3.3.x.

Eclipse et Visual Editor

Visual Editor est un plugin Eclipse qui vous permet de dessiner graphiquement votre interface graphique en générant à la volée le code correspondant

FIXME installation sur la version d'Eclipse des dépots

Si vous utilisez la version Eclipse 3.4 Ganymède, voici la procédure d'installation :

  • Ouvrez le menu Help, puis Software Updates…
  • Cliquez sur Add Site…
  • Ajoutez l'adresse http://update.soyatec.org/Ganymede/ve/1.4/ dans la zone de texte, puis cliquez sur OK pour mettre à jour la liste des logiciels
  • Cherchez dans la liste Visual Editor, cochez la case, et cliquez sur Install…

Ensuite vous n'avez plus qu'à créer une nouvelle Visual Class pour ouvrir utiliser le Visual Editor.

Si vous utilisez la version Eclipse 3.5 Galileo, voici la procédure d'installation : idem que précedemment avec l'adresse: http://download.eclipse.org/tools/ve/updates/1.4/

ou pour Helios: http://download.eclipse.org/tools/ve/updates/1.5.0/

+ d'infos @ http://wiki.eclipse.org/VE/Update

Eclipse en équipe

Eclipse et CVS

Eclipse intègre la gestion CVS pour gérer vos différentes versions et travailler en collaboration avec d'autres utilisateurs.

Vous n'avez donc rien de plus à installer pour utiliser CVS, la configuration générale se fait dans les préférences dans la rubrique Equipe (Team en anglais), et la configuration par projet se fait en cliquant avec le bouton droit sur le nom du projet et vous verrez également le menu Equipe pour pouvoir configurer votre accès à un serveur CVS.

Liens Spécifiques

Eclipse et Subversion

Subversive et Subclipse sont tous deux des greffons pour Eclipse permettant de se connecter à un dépôt SVN.

1. Subversive

Voir le tutoriel spécifique : Subversive

2. Subclipse

Voir le tutoriel spécifique : Subclipse

Eclipse et Bazaar

FIXME à faire, Ubuntu étant sur bazaar autant en parler aussi ici, surtout qu'il existe un plugin récent pour ça

Eclipse et Git

Le plug-in Egit existe pour permettre de travailler avec Git : http://www.eclipse.org/egit/ .

Il suffit de le chercher dans le dépôt de votre version d'Eclipse, par exemple : http://download.eclipse.org/releases/helios , rubrique Collaboration.

Vous pouvez aussi ajouter ce dépôt : http://download.eclipse.org/egit/updates .

Pour cloner un projet existant, aller dans Fichier → Importer

Eclipse et MDA

L'architecture dirigée par les modèles ou MDA (pour l'Anglais Model Driven Architecture) est une démarche de conception de logiciel, proposée et soutenue par l'OMG. Un exemple typique est la génération automatique de code source à partir d'une modélisation UML.

Introduction :

Des solutions libres :

  • Acceleo (site) est un générateur de code qui permet de transformer des modèles vers du code (approche MDA ).

Acceleo est simple à utiliser, dispose de générateurs prêts à l'emploi (JEE, .Net, Php…) et d'éditeurs de templates de génération sous Eclipse.

  • EMF (Eclipse Modeling Framework) (site), l'environnement de la plate-forme Eclipse dédié au MDA,
  • GMT Project (site)
  • ATL (Atlas Transformation Language), disponible sous forme de plugg-in pour Eclipse, qui permet de réaliser des transformations quelconques sur des données au format XMI,
  • Poséidon (site), qui existe également sous forme de plugin Eclipse (en version payante), mais qui est utilisé ici dans sa version Communauté, en libre accès.
  • JMI, Java Metadata Interface, permet d'accéder à une base de données de métamodèle et de les manipuler

Désinstallation

Version des dépôts

Si vous avez utilisé les dépôts Ubuntu, pour supprimer cette application, il suffit de supprimer les paquets installés. La configuration de l'application sera conservée ou supprimée selon la méthode de désinstallation que vous choisirez.

Vérifier également que le dossier .eclipse de votre dossier personnel ait bien été supprimé pour qu'aucune trace de votre configuration d'Eclipse ne perdure.

Version installée manuellement

Si vous avez installé manuellement Eclipse, supprimez tout simplement le dossier dans lequel vous l'avez installé, sans oublier le lanceur du menu Application si vous en avez créé un.

Désinstaller un Greffon

Pour faire cela tout ce passe dans le menu Aide > Mise à jour de logiciels > Gérer la configuration… (en anglais Help > Software updates > Manage configuration).

Là vous verrez une arborescence des divers éléments et greffons installés, qu'il vous faut Désactiver (disable) avant de les Désinstaller (uninstall) (pensez à afficher les éléments désactivés gràce au boutons prévu à cet effet).

Attention, la désinstallation de certains éléments peut entraîner des problèmes de dépendances qui risquent de rendre inopérationnel votre IDE.

Utilisation/Liens

Eclipse étant un IDE complet et multi-langages, décrire comment le configurer ou l'utiliser mériterait une multitude de pages, voire même plusieurs livres, et ce n'est pas le but de ce wiki.

Astuces

Soyez prévoyants
Une fois votre installation manuelle réalisée, vos greffons installés, et votre configuration personnalisée, pensez à compresser votre dossier d'installation pour le sauvegarder dans un coin, comme ceci vous n'aurez pas à refaire tout ce travail de réinstallation si il vous arrive un pépin. Une simple décompression de votre distribution personnelle suffira.

Afficher les numéros de ligne
Deux solutions:

  • Dans les préférences d'Eclipse (rappel: Window –> Preferences…) aller sur General –> Editors –> Text Editors et cochez Show line numbers, puis validez.
  • Dans l'éditeur, effectuez un clic avec le bouton droit de la souris sur la barre vertical grise/orangée à gauche de la zone d'édition et cochez Show Line Numbers dans ce menu contextuel.

Plugins & Co

Eclipse & PHP XDebug
Configuration et utilisation de PHP-XDebug avec Eclipse (PDT)

eclipse_mysql_sql_explorer
Explorer vos base MySQL depuis Eclipse

Liens

Nous vous recommandons de visiter des sites plus appropriés à vos besoins (fonctionnement d'Eclipse, recherche de greffons, distributions personnalisées, …). Vous pouvez commencer par ceux que nous vous proposons ci-dessous.

N'hésitez pas à rajouter vos liens.


Contributeurs : Basé sur le blogue de Keyes, avec les contributions de P-Hell, de Ronan et d'ajouts mineurs de la part de martin.sam. Refonte complète par YoBoY. Contribution de quent57


eclipse.txt · Dernière modification: Le 02/01/2014, 15:34 par 195.78.50.2
Le contenu de ce wiki est sous licence : CC BY-SA v3.0