Contenu | Rechercher | Menus
Selon les tags présents sur cette page, celle-ci est ancienne et ne contient plus d'informations sur une des versions supportées d'Ubuntu.
Apportez votre aide…

Frostwire : client pour Gnutella

Frostwire

FrostWire est un client d'échange de fichiers pair-à-pair (P2P). Il permet de rechercher, de télécharger et de mettre à disposition en téléchargement libre de nombreux fichiers de divers types à travers le réseau d'échange Gnutella. Il faut savoir qu'il prend également en charge le protocole torrent.

FrostWire est exactement comme LimeWire, mais son utilité réside dans le fait que contrairement à ce dernier, FrostWire ne va jamais filtrer les fichiers sur le réseau. FrostWire n'est pas plus rapide que LimeWire ni ne donne plus de résultats. Le but est d'éviter les éventuelles restrictions de LimeWire tout en respectant les principes qui font que LimeWire est un bon programme Gnutella.

Installation

Tout comme LimeWire, le programme FrostWire requiert l'environnement d'exécution Java pour pouvoir fonctionner. Référez-vous à la page sur Java pour de plus amples informations à son propos.

Téléchargez FrostWire au format .deb pour (K)Ubuntu directement sur le site officiel de FrostWire :

Utilisation

FIXME

Problèmes connus

  • Note (Si vous n'arrivez pas à démarrer FrostWire 4.9.10) : Le fichier /usr/lib/frostwire/runFrost.sh est enregistré dans un format DOS et vous ne pourrez lancer FireWire avant de l’avoir enregistré au format Unix avec les actions suivantes :
sudo nano /usr/lib/frostwire/runFrost.sh

Faites Ctrl + O pour l’enregistrer (vous remarquez que [Format DOS] précède le nom du fichier), changez le format en faisant Alt + D ([Format DOS] disparaît) et appuyez sur Entrée pour enregistrer le fichier. Vous pouvez à présent démarrer FrostWire.

  • Si vous n'arrivez pas à lancer Frostwire, en utilisant le JRE 1.5 de Sun et un gestionnaire de fenêtres composite (tel que Beryl/Compiz avec Aiglx ou XGL), Tapez ce qui suit dans votre terminal, puis relancez Frostwire :
 export AWT_TOOLKIT=MToolkit
 export HOSTNAME=localhost

Il s'agirait d'un bug dans le JRE qui ne sait pas trop quoi faire avec Beryl/Compiz !

  • Si, lors du premier lancement au moment du choix du surnom, aucun champ n'apparait, il vous faut relancer FrostWire en anglais cette fois. Le bug n'a alors pas lieu et il vous suffira de remettre en français après (View > Change Language > Français).

Solution 2

Note si la première solution et si vous avez Beryl ou Compiz activé, vous allez avoir un écran gris. Pour résoudre ce problème créer un fichier par ex lunch_frostwire. Puis mettez dans le fichier :

 #!/bin/bash
 export AWT_TOOLKIT=MToolkit
 export HOSTNAME=localhost
 /usr/bin/frostwire
  • Vous devrez peut-être remplacer la dernière ligne par "/opt/FrostWire/runFrost.sh" sans les ""
  • Sauvegardez le, faite un clic droit dessus propriétés, permissions, et cochez la case Autoriser l'exécution du fichier comme un programme
  • Cliquez sur le fichier et le programme se lancera sans problème. Si vous souhaitez vous n'avez plus qu'a faire un lien du menu de lancement vers ce lanceur.

Bug version 4.18 et Java 1.6

Si en lançant Frostwire 4.18 dans un terminal, vous rencontrez un souci de version de JAVA, ce bug est dû à un morceau de Java OpenJDK qui porte le même nom dans Java de Sun

Il s'agit de :

 /usr/lib/jvm/java-6-openjdk/jre/lib/i386/headless/libmawt.so

qui entre en conflit avec

 /usr/lib/jvm/java-6-openjdk/jre/lib/i386/headless/libmawt.so
 /usr/lib/jvm/java-6-sun-1.6.0.13/jre/lib/i386/headless/libmawt.so
 /usr/lib/jvm/java-6-sun-1.6.0.13/jre/lib/i386/motif21/libmawt.so
 /usr/lib/jvm/java-6-sun-1.6.0.13/jre/lib/i386/xawt/libmawt.so

en lançant

 sudo rm /usr/lib/jvm/java-6-openjdk/jre/lib/i386/headless/libmawt.so

cela effacera le fichier en doublon de Java openJDK.

Attention, rm est une commande d'effacement qui en étant administrateur peut faire des dégâts. Veuillez donc vous documenter sur cette commande avant de l'effectuer.

PROBLÈME APRÈS INSTALLATION

Frostwire ne se lance pas mais une petite fenêtre d'erreur s'affiche.

Problème rencontré avec java6 et Frostwire-4.18.3.i586.

Dans un terminal, faire :

 sudo aptitude install sun-java6-jdk sun-java6-jre

Puis réinstallez le paquet Frostwire-4.18.3.i586.deb.

Voir aussi


frostwire.txt · Dernière modification: Le 02/02/2014, 14:15 par Bixo358
Le contenu de ce wiki est sous licence : CC BY-SA v3.0