Contenu | Rechercher | Menus
Cette page n'a pas encore d'étiquettes.
Apportez votre aide…

Gens/GS : un émulateur Megadrive performant pour Ubuntu

Gens/GS est une version modifiée de l'émulateur Gens (émulateur), un classique reconnu pour sa qualité d'émulation. Retouché par GerbilSoft, il comporte dans cette version moins de bugs que l'original, de meilleurs performances grâce à de nombreuses optimisations, et une interface plus simple d'usage en particulier pour la configuration.

Installation

Commencez par récupérer le fichier d'installation .deb pour Ubuntu : http://info.sonicretro.org/Gens/GS#Download

Double-cliquez sur le fichier, Ubuntu vous proposera alors de l'installer automatiquement en échange de votre mot de passe administrateur. Une fois la procédure terminée, vos disposerez d'un lanceur dans le menu Application → Jeux. (Pour davantage de détails sur l'installation d'un logiciel, consultez cette page).

Installation sur Ubuntu 64 bits

edit 06/2014: La procédure ci-dessous ne semble plus nécessaire depuis Ubuntu 13.04. Il faut utiliser à la place le paquet multiarch-support au lieu de ia32-libs…

sudo apt-get install multiarch-support

Installez le paquet ia32-libs

Récupérez le paquet d'installation .deb pour Ubuntu : http://info.sonicretro.org/Gens/GS#Download

Tapez dans un terminal : sudo apt-get install multiarch-supportsudo dpkg –force-architecture -i Gens_*_i386.deb </code>

Attention : sur Ubuntu 12.04 64 bits, il est possible que vous ayez une notification de package "cassé" après l'installation telle que décrite ci-dessus. Si vous lancez la mise à niveau partielle de la distribution faisable à partir de cette notification, vous allez être obligé de désinstaller Gens/GS. Le problème est dû à une dépendance non satisfaite : xdg-utils. En réalité, xdg-utils peut déjà être installé en version multiarch sur votre système, mais non reconnue. Pour éviter la détection de cette dépendance, vous pouvez vous inspirer du didacticiel sur cette page : http://www.sudo-juice.com/ignore-broken-packages-ubuntu-aptitude/ Attention, la ligne de commande pour éditer le fichier status est mal indiquée : tapez dans le terminal

sudo xdg-open /var/lib/dpkg/status 

et non

gksudo gedit /var/lib/dkpg/status 

Rechargez ensuite la liste des paquets dans Synaptic et voilà ! :-)

Vous pouvez aussi télécharger les paquets gens-gs-data et gens-gs et les installer dans ce même ordre.

Utilisation

Lancez Gens/GS en passant par votre menu principal Applications : il est disponible dans la catégorie Jeux.

Pour jouer à un jeu Megadrive, vous devez tout d'abord vous procurer une image ROM de celui-ci. Utilisez le menu Fichier → Ouvrir et sélectionnez votre jeu pour le démarrer.

Configuration

Remarques

Patchs de traduction IPS

Pour certaines ROMs il existe des patchs de traduction, ayant l'extension .ips. Gens est capable de les appliquer, il vous suffit de placer le patch dans ~/.gens, en s'assurant que le nom de fichier corresponde à celui du .bin de la ROM.

Voir aussi:

32 bits exclusivement ?

Info peut-être obsolète..

Gens/GS comporte une grande partie de code machine spécifique aux processeurs x86 32bits. Vous ne pourrez pas faire fonctionner ce programme, dans son état actuel, sur d'autres architectures (Playstation 3, Mac PowerPC ). Cependant, GerbilSoft travaille actuellement sur ce soucis et est en train de reprendre petit à petit le code du logiciel, pour le libérer de cette contrainte.

Envie d'aider ? Voyez ici !

Liens

* Site officiel (Téléchargements, liste des modifications) http://info.sonicretro.org/Gens/GS



Le contenu de ce wiki est sous licence : CC BY-SA v3.0