Cette page est en cours de rédaction.

Apportez votre aide…


Jupyter

Jupyter permet notamment d'utiliser/générer des carnets (notebook) en langage python, mais aussi R et bien d’autres (Jupyter vient de JUlia PYThon R), avec des textes en markdown ce qui est très utilisé pour des formations mais aussi pour expérimenter/documenter des essais.

Installation

Vous pouvez l'installer directement :

pip install jupyter

ou mieux dans un environnement virtuel Comme indiqué dans la doc ci-dessus, une fois votre environnement virtuel activé, lancer :

(.venv) mon-nom2user@mon-nom2pc:~/mon/chemin/$ pip install jupyter

Dans tous les cas :

pip install ipykernel
python -m ipykernel install --user
pip install notebook

Utilisation

Lancer les carnets (notebook) avec la commande :

jupyter notebook

Une page doit s’ouvrir dans votre navigateur web, pointer à l'adresse locale http://localhost:8889/tree/ et afficher l’arborescence du répertoire courant.
Vous pouvez créer un notebook en cliquant File → New → Notebook
Une cellule de code s'affiche, vous pouvez y taper :

print("Bonjour")

puis valider avec les touches Shift + Entrée ce qui va exécuter le code

Reportez-vous à des tutoriels ou cours sur Jupyter notebook pour aller plus loin.

Ajout de module

Cela peut être fait directement dans un notebook, il suffit dans une cellule de code, de faire, par exemple pour ajouter le module permettant de gérer des fichiers CSV :

pip install csv

Pour versionner un notebook

Avant de versionner un notebook, il est préférable de le “nettoyer” des résultats des opérations qui sont susceptibles de varier d'une exécution à une autre.
Pour cela, ouvrir le menu Édition puis Effacer les sorties de toutes les cellules (en anglais : Edit → Clear Outputs of All Cells)
Puis sauvegarder et versionner le notebook.

Exporter vers un script Python

L'interface Jupyter permet d'exporter le carnet vers un script python :
avant cela, il est judicieux d'effacer les cases de résultats,
puis cliquer sur le menu Fichier puis Enregistrer et exporter le notebook comme puis Script exécutable (File puis Save and Export Notebook As puis Executable Script en anglais).
Les cases de résultats subsistent, vides, mises en commentaire, ainsi que des lignes vides. On peut les supprimer avec la commande suivante sed :

sed -e 'N;s/^# In.*\n//g;P;D' -e '/^$/N;/^\n$/D' -i mon-fichier.py

Il est aussi courant d'avoir des noms de variables ou objets pour que le notebook affiche leur contenu. On peut alors les modifier pour les mettre dans un print ou un logging.info :

sed -e 's/^\([a-zA-Z]\+\)\n/print("\1 : ", \1)/'
# version avec logging, mais qui nécessite d'ajouter aussi l'import du module logging :
sed -e 's/^\([a-zA-Z]\+\)\n/logging.info(f"\1 : {\1}")/'

Voir aussi