Différences

Ci-dessous, les différences entre deux révisions de la page.

Lien vers cette vue comparative

Les deux révisions précédentes Révision précédente
Prochaine révision
Révision précédente
libreoffice [Le 20/08/2013, 13:54]
corrigo [Via le PPA]
libreoffice [Le 19/05/2018, 09:46] (Version actuelle)
77.145.213.194 [Avec les PPA]
Ligne 1: Ligne 1:
-{{tag>Precise Quantal ​logiciels bureautique }}+{{tag>Xenial ​logiciels bureautique }}
  
 ---- ----
  
-{{ libreoffice.png| Logo de LibreOffice}} +{{ http://​upload.wikimedia.org/​wikipedia/​commons/​thumb/​a/​aa/​Logo-libreoffice.svg/​219px-Logo-libreoffice.svg.png?50| Logo de LibreOffice}}
 ====== LibreOffice ====== ====== LibreOffice ======
  
-{{ capture1_libreoffice.png?​350|Capture ​d'écran de LibreOffice}}+**LibreOffice**(([[wpfr>​LibreOffice]])) est une suite bureautique libre, gratuite, multiplateforme et complète (traitement de texte, tableur, logiciel de présentation,​ etc.), ce qui fait d'elle une excellente alternative aux suites bureautiques propriétaires telles que Microsoft Office, Microsoft Office Online, Google Docs, ...
  
 +{{ http://​i.imgur.com/​SA9To3W.png?​450 |Interface de gestion documentaire de LibreOffice 5}}
  
-**[[wpfr>​LibreOffice]]** ​est une suite bureautique libregratuite et complète (traitement de textetableurlogiciel de présentationetc).+C'est une suite logicielle très modulaire : des extensionsdes modèlesdes imagesdes thèmesdes polices sont librement mis à disposition par la communauté.
  
-LibreOffice est libre, gratuite et multiplateforme,​ ce qui fait d'elle une excellente alternative aux suites bureautiques telles ​que MS Office, Google Docs.+Sur la plupart des [[:​variantes]] d'​Ubuntu,​ **LibreOffice** est installé en tant que suite [[:​bureautique]] par défaut.
  
-Elle est aussi très modulaire : des extensionsdes modèles, des images, des polices ​vous sont librement mis à disposition par la communauté.+<note important>​ 
 +  * Bien vérifier la version de LibreOffice qui s'est installéesurtout si vous souhaitez la version stable ! Ouvrez LibreOffice puis //Aide ->  À propos de LibreOffice//​ pour voir votre version installée. 
 +  * Regarder sur [[https://​fr.libreoffice.org/​download/​libreoffice-stable/​|le site de LibreOffice]] le numéro de la dernière version stable. 
 +</​note>​
  
-LibreOffice est un [[wpfr>​fork_(développement logiciel)|embranchement (ou fork)]] de la suite libre de bureautique OpenOffice.org,​ développé par //The Document Foundation//,​ une fondation regroupant la communauté de développeurs d'​OpenOffice.org ainsi que différents partenaires comme la FSF, OASIS, Google, Novell, Red Hat, Canonical, OSI.+=== Licences ===
  
-<note tip> +D'un point de vue légal, **LibreOffice** est distribué sous les licences libres ​[[wpfr>​Mozilla_Public_License|MoPL V2]][[http://​www.apache.org/​licenses/​LICENSE-2.0|Licence Apache 2.0]] pour le code basé sur Apache-OpenOffice ​et diverses autres licences ​[[wpfr>​Open_Source_Initiative|open source]].
-  * LibreOffice est une suite bureautique complète. Si vous cherchez simplement à pouvoir lire et modifier des documents ​de type texte formaté (.doc.odt) ou tableur (.xls), le couple ​**[[:Abiword]][[:Gnumeric]]** peut être une alternative intéressante car plus légère si vous êtes dans un environnement GTK (c'​est ​le cas d'​Ubuntu ​et de Xubuntu) ou [[calligra|Calligra Words + Calligra Cells]] si vous utilisez un environnement en Qt (par exemple Kubuntu). +
-  * LibreOffice prend notamment en charge les formats Open XML de Microsoft Office (.docx, .xlsx, .pptx), mais LibreOffice peut avoir des difficultés à les lire. Il est préférable de lire/​modifier ces types de fichiers avec les logiciels de Microsoft ou de les enregistrer dans les anciens formats de Office (antérieurs à 2007 : .doc, .xls, .ppt) qui sont mieux pris en charge par LibreOffice. Il en est de même si vous souhaitez lire un fichier ODT avec Word par exemple. +
-</​note>​+
  
-===== Pré-requis =====+**LibreOffice** est un [[wpfr>​fork_(développement logiciel)|embranchement (ou fork)]] de la suite libre de bureautique [[:​OpenOffice.org]],​ développée par //The Document Foundation//,​ une fondation regroupant la communauté de développeurs d'​OpenOffice.org ainsi que différents partenaires comme la FSF, OASIS, Google, Novell, Red Hat, [[Canonical]],​ OSI, ...
  
-  * Disposer des [[:​sudo|droits d'​administration]]. 
-  * Disposer d'une connexion à Internet configurée et activée. 
  
-===== Installation =====+=== Sur la conversion de fichiers et les alternatives libres à la suite Libre Office ​===
  
-==== Via les dépôts officiels ====+  * //​LibreOffice//​ est une suite bureautique complète. \\ Si vous cherchez simplement à pouvoir lire et modifier des documents de type texte formaté (.doc, .odt) et des feuilles de tableur (.xls, .ods), le couple **[[:​Abiword]] + [[:​Gnumeric]]** peut être une alternative intéressante car plus légère si vous êtes dans un environnement GTK+ (c'est le cas d'​Ubuntu et de [[:​Xubuntu]]) ou [[:​calligra|Calligra Words + Calligra Cells]] si vous utilisez un environnement en Qt (par exemple [[:​Kubuntu]]). 
 +  * //​LibreOffice//​ prend notamment en charge ​les formats Open XML de **Microsoft Office** (.docx, .xlsx, .pptx), mais peut avoir des difficultés à les lire. \\ Il est préférable de lire/​modifier ces types de fichiers avec les logiciels de Microsoft ou de les enregistrer dans les anciens formats de Office (antérieurs à 2007 : .doc, .xls, .ppt) qui sont mieux pris en charge par //​LibreOffice//​. \\ Il en est de même si vous souhaitez lire un fichier ''​.odt''​ avec Word par exemple. 
 +  * Il est par contre toujours possible d'​utiliser le successeur d'​[[:​OpenOffice]],​ en installant //Apache OpenOffice//,​ même si cette solution ne présente aucun intérêt notable ; au contraire, LibreOffice supporte davantage de configurations des formats propriétaires Microsoft, comme l'​intégration et la lecture possible des formules de MS Word & Excel, ou la reconnaissance et la lecture des documents MS Office enregistrés avec protection mot de passe.
  
-**Cette méthode concerne [[natty|Ubuntu 11.04]] et les versions antérieures** 
  
-LibreOffice est installé par défaut sous Ubuntu depuis [[:​oneiric|Ubuntu 11.10]].  +===== Installation =====
-<note tip>​Ubuntu 11.10 Live (et les versions suivantes) englobe une installation minimale de LibreOffice,​ toutes les librairies nécessaires à une utilisation complète doivent être installées après coup en installant le paquet **[[apt>​libreoffice]]**</​note>​+
  
-Pour installer ​LibreOffice ​dans [[:natty|Ubuntu 11.04]] (après y avoir activé le [[:​depots#​universe_et_multiverse|dépôt Universe]]), ou pour réinstaller LibreOffice ​dans les versions suivantes, [[:​tutoriel:​comment_installer_un_paquet|installez les paquets]] :  +==== Méthode recommandée ==== 
-  * Meta-paquet installant **tout** LibreOffice : **[[apt>​libreoffice]]**,​ vous pouvez également vous limiter à  ;+ 
 +LibreOffice ​est installé par défaut sous la plupart des [[:variantes]] d'​Ubuntu. Pour installer LibreOffice quand il n'est pas installé, ou pour réinstaller LibreOffice,​ [[:​tutoriel:​comment_installer_un_paquet|installez les paquets]] ​suivants ​
 +  * Meta-paquet installant **tout** LibreOffice :  
 +    * **[[apt>​libreoffice]]**, ​\\ ou bien selon votre [[:​variante]]:​ 
 +    * Si vous utilisez [[:GNOME]], [[:MATE]] ou [[Xfce]] : **[[apt>​libreoffice-gtk]]** ;  
 +    * Si vous utilisez [[:KDE]] : **[[apt>​libreoffice-kde]]**.  
 +  * Vous pouvez également vous limiter à;
     * **[[apt>​libreoffice-base|LibreOffice Base]]** : création de bases de données     * **[[apt>​libreoffice-base|LibreOffice Base]]** : création de bases de données
     * **[[apt>​libreoffice-calc|LibreOffice Calc]]** : tableur     * **[[apt>​libreoffice-calc|LibreOffice Calc]]** : tableur
Ligne 45: Ligne 49:
     * **[[apt>​libreoffice-math|LibreOffice Math]]** : création de formules mathématiques     * **[[apt>​libreoffice-math|LibreOffice Math]]** : création de formules mathématiques
     * **[[apt>​libreoffice-writer|LibreOffice Writer]]** : traitement de texte     * **[[apt>​libreoffice-writer|LibreOffice Writer]]** : traitement de texte
-  * Francisation de LibreOffice : **[[apt>​libreoffice-l10n-fr,​libreoffice-help-fr,​hyphen-fr|libreoffice-l10n-fr libreoffice-help-fr hyphen-fr]]** ;  
-  * Habillage graphique en fonction des environnements :  
-    * Si vous utilisez [[bureau_gnome|Gnome]] ou [[Xfce]] : **[[apt>​libreoffice-gtk]]** ;  
-    * Si vous utilisez [[bureau_kde|KDE]] : **[[apt>​libreoffice-kde]]**. 
  
-Pour que LibreOffice ​soit compatible avec le [[globalmenu|globalmenu]] d'Unityil suffit d'​installer ​le paquet **[[apt>​lo-menubar]]** ([[:​depots#​universe_et_multiverse|dépôt Universe]]). Il semble que pour la 12.04ce paquet apporte plus de problèmes que de solutions (cf [[https://​bugs.launchpad.net/​ubuntu/​+source/​libreoffice/​+bug/​754562 ​bogue 754562]]). Ce paquet n'est plus nécessaire à partir d'​Ubuntu 12.10 (Quantal Quetzal).+<note tip>​Recherchez simplement "LibreOffice" dans la [[:​gnome-software|logithèque]] et installez ce qui vous convient.</​note>​ 
 + 
 +Les paquets des langues de votre système seront aussi installées. Si ce n'était pas le caspour le français, ​[[:​tutoriel:​comment_installer_un_paquet|installez les paquets]]  **[[apt>​libreoffice-l10n-fr,​libreoffice-help-fr,​hyphen-fr|libreoffice-l10n-fr libreoffice-help-fr hyphen-fr]]**
  
 === Les extensions incluses dans LibreOffice === === Les extensions incluses dans LibreOffice ===
Ligne 63: Ligne 65:
   * Fournisseur de script pour Python **[[apt>​python]]**   * Fournisseur de script pour Python **[[apt>​python]]**
  
 +<​note>​Il peut arriver que le paquet libreoffice-nlpsolver installé après coup ne soit pas actif. Dans ce cas il semble nécessaire de désinstaller puis de réinstaller libreoffice avec la [[:​commande_shell|commande]] suivante dans un [[:​terminal]]:​ <​code>​sudo apt-get purge libreoffice* && sudo apt-get install libreoffice libreoffice-nlpsolver libreoffice-help-fr libreoffice-l10n-fr</​code>​
 +</​note>​
 +
 +=== Autres exemples d'​extensions installables ===
 +
 +   * **[[apt>​libreoffice-dmaths]]** (pour l'​insertion de formules - ATTENTION FAIT planter libreoffice 5.2 ET SUIVANTS) ​
 +   * **[[apt>​libreoffice-ogltrans]]** (transitions supplémentaires pour diaporama) ​
 +   * **[[apt>​libreoffice-templates]]** (modèles de documents supplémentaires)
 +   * **[[apt>​openclipart-libreoffice]]** (modèles clipart supplémentaires)
  
 === Les styles d'​icônes incluses dans LibreOffice === === Les styles d'​icônes incluses dans LibreOffice ===
Ligne 74: Ligne 85:
   * Hicontrast symbol style **[[apt>​libreoffice-style-hicontrast]]**   * Hicontrast symbol style **[[apt>​libreoffice-style-hicontrast]]**
   * Galaxy (Default) symbol style **[[apt>​libreoffice-style-galaxy]]**   * Galaxy (Default) symbol style **[[apt>​libreoffice-style-galaxy]]**
 +  * Sifr symbol style **[[apt>​libreoffice-style-sifr]]**
 +  * Breeze style**[[apt>​libreoffice-style-breeze]]**
 +  * Elementary style**[[apt>​libreoffice-style-elementary]]**
 +  * Office 2013 style **[[http://​charliecnr.deviantart.com/​art/​Office-2013-theme-for-LibreOffice-512127527|sur DeviantArt]]**. À renommer en //​images_office2013.zip//​ et copier dans /​usr/​lib/​libreoffice/​share/​config/​ et /​usr/​share/​libreoffice/​share/​config/​.
 +  * Kalahari **[[http://​marianogaudix.deviantart.com/​art/​LibreOffice-5-2-0-Kalahari-381401284|sur DeviantArt]]** À copier dans /​usr/​lib/​libreoffice/​share/​config/​ et /​usr/​share/​libreoffice/​share/​config/​.
  
 +==== Au format appimage ====
  
-=== Autres exemples d'​extensions installables ===+**Article dédié** au fonctionnement de cette méthode : [[:​appimage]].
  
-   * **[[apt>libreoffice-dmaths]]** (pour l'​insertion de formules)  +Les fichiers se trouveront sur [[http://libreoffice.soluzioniopen.com/​|ce site]].
-   * **[[apt>​libreoffice-ogltrans]]** (transitions supplémentaires pour diaporama)  +
-   * **[[apt>​libreoffice-templates]]** (modèles de documents supplémentaires) +
-   * **[[apt>​libreoffice-scope-asklibreoffice]]** (lentille d'aide dans le tableau de bord)  +
-   * **[[apt>​openclipart2-libreoffice]]** (modèles clipart supplémentaires)+
  
-==== Via le PPA ==== +==== Avec Flatpak (Ubuntu ≥ 16.04) ​====
-Cette méthode permet :​ +
-  * d'​obtenir une version récente et stable de LibreOffice sur Ubuntu 12.04 et suivantes. +
-<​note>​Une version de LibreOffice est considérée comme stable (donc recommandée pour une utilisation dans un contexte professionnel) à partir de sa 2ème ou 3ème révision (par exemple 4.0.2 ou 4.0.3).+
  
-Une approche conservatrice demanderait d'​attendre la 4ème révision((https://​wiki.documentfoundation.org/​File:​LibOReleaseLifecycle.png))</​note>​ +**Articles dédiés** ​: [[:flatpak]][[:tutoriel/​installer_application_flatpak|tutoriel pour l'​utiliser]].
-^ Version Ubuntu ^ Version installée ^  Version du PPA 4.0 ^ Version du PPA de test ^ +
-| Ubuntu ​[[:raring|13.04]] | 4.0.2 |  4.0.4~rc2 | 4.1.0 | +
-| Ubuntu ​[[:quantal|12.10]] | 3.6.2 |  4.0.4~rc2 | sans objet | +
-| Ubuntu [[:​precise|12.04 LTS]] | 3.5.7 |  4.0.4~rc2 | 4.1.0 |+
  
-//(informations à jour le 19/08/2013)// +Depuis [[https://www.libreoffice.org/download/flatpak/|cette page de leur site]], suivez les instructions qui vous concernent pour installer ​//​LibreOffice//​ selon le [[:​tutoriel/​installer_application_flatpak#​niveaux_de_privileges|niveau de privilèges]] qui vous convient. 
-<note tip>​Les ​pré-versions ​RC2 sont en général identiques à la version finale. Contrairement aux builds officielles,​ les PPA ne les renomment alors pas comme telles.</​note>​+ 
 +==== Avec Snap (Ubuntu ≥ 16.04) ==== 
 + 
 +**Article dédié** : [[:​snap]]. 
 + 
 +Ouvrez un [[:​terminal]] et entrez la commande suivante [[:sudo|en tant qu'​administrateur]] : 
 +<​code>​snap install libreoffice</​code>​ 
 +BTS :-P 
 +==== Avec les PPA ==== 
 + 
 +<note tip>Ce [[:​ppa|dépôt PPA]] __**maintenu par un employé de Canonical et aussi développeur en amont de LibreOffice.**__ permet d'​obtenir une version stable relativement récente par rapport à celle des dépôts officiels. 
 + 
 +Une version de LibreOffice est considérée comme stable (donc recommandée pour une utilisation dans un contexte professionnel) à partir de sa 4<​sup>​e</​sup> ​ révision , soit la 5.4.4 
 +Une version admissible, généralement désignée par le terme anglais Release Candidate (souvent abrégé en RC) 
 + 
 +Les versions ​X.X.X~rc2 ​sont en général identiques à la version finale. Contrairement aux builds officielles,​ les PPA ne les renomment alors pas comme telles.</​note>​ 
 + 
 +^ Version d'​Ubuntu ^ Version installée ^Version du PPA 5.4^Version du PPA 6.0 ^Version du PPA générique ^ Version du PPA pré-versions ^ 
 +| Ubuntu [[:​bionic|18.04 LTS]] | 6.0.3 | Non disponible| 6.0.4~rc2|6.0.4~rc2 | 6.0.4~rc2 ​ | 
 +| Ubuntu [[:​artful|17.10]] | 5.4.6 | 5.4.6~rc2| 6.0.4~rc2|6.0.4~rc2 | 6.0.4~rc2 ​ | 
 +| Ubuntu [[:​xenial|16.04 LTS]] | 5.1.6 | 5.4.6~rc2 | 6.0.4~rc2 |6.0.4~rc2 | 6.0.4~rc2| 
 +| Ubuntu [[:​trusty|14.04 LTS]] | 4.2.8 | 5.4.6~rc2 | 6.0.4~rc2 ​ |6.0.4~rc2 | 6.0.4~rc2 | 
 +//​(informations à jour le 19/​05/​2018)//​ 
 + 
 +=== Versions stables === 
 + 
 +Ces PPA contiennent la dernière version de la branche (ou de toutes les branches pour le PPA générique),​ ou éventuellement la release candidate prévue pour être la version finale (RC2). Les paquets présents dans le dépôt PPA générique sont accessibles [[https://​launchpad.net/​~libreoffice/​+archive/​ppa|ici]],​ vous y trouverez également un lien vers les dépôts de chacune des branches (actuellement : 5.4 et 6.0).  
 + 
 +<note important>​ Avant d’aller plus loin, veuillez noter que les paquets sur le PPA n'ont subi que des tests minimaux. Cette mise à jour est réservée aux utilisateurs sachant utiliser [[:​ppa#​en_desinstallant_les_paquets_de_ce_ppa|ppa-purge]] pour annuler les modifications si quelque chose venait à ne plus fonctionner comme il le faut. Cependant, cela est plus sûr que d'​utiliser directement les fichiers ''​.deb''​ fournis par //The Document Foundation//​.</​note>​
  
   - [[:​PPA|Ajoutez dans vos sources de logiciels le PPA]]   - [[:​PPA|Ajoutez dans vos sources de logiciels le PPA]]
-      + 
-    ​* ​ pour la version ​4.0 disponible pour [[:​Précise]][[:​Quantal]] et [[:​Raring]],​ considérée comme stable ​par the Document Foundation  :\\ **ppa:​libreoffice/​libreoffice-4-0**((https://​launchpad.net/​~libreoffice/​+archive/​libreoffice-4-0)) +  ​* __**Pour ​la version ​5.4**__ Version "​Stable"​utilisable ​par tous, y compris dans un cadre professionnel ​: **ppa:​libreoffice/​libreoffice-5-4** ((https://​launchpad.net/​~libreoffice/​+archive/​libreoffice-5-4)) 
-    pour la toute dernière version de test :\\ **ppa:​libreoffice/​ppa**((https://​launchpad.net/​~libreoffice/​+archive/​ppa))+  * __**Pour la version 6.0**__ Version "​Évolution"​ destinée aux utilisateurs avancés souhaitant tester les nouveautés de LibreOffice : **ppa:​libreoffice/​libreoffice-6-0** ((https://​launchpad.net/​~libreoffice/​+archive/​libreoffice-6-0)) 
 +  * **__**Pour la dernière version ​du PPA générique** :​__**(permet ​de rester à jour sans avoir à changer de branche) **ppa:​libreoffice/​ppa**((https://​launchpad.net/​~libreoffice/​+archive/​ppa)) 
   - [[:​tutoriel:​comment_modifier_sources_maj#​recharger_la_liste_des_paquets|rechargez la liste des paquets]] ;​   - [[:​tutoriel:​comment_modifier_sources_maj#​recharger_la_liste_des_paquets|rechargez la liste des paquets]] ;​
   - [[:​tutoriel:​comment_installer_un_paquet|installez le paquet]] **[[apt>​libreoffice|libreoffice]]** ;​   - [[:​tutoriel:​comment_installer_un_paquet|installez le paquet]] **[[apt>​libreoffice|libreoffice]]** ;​
   - Pour chaque langue installée sur votre système et/ou pour laquelle vous désirez l'​aide,​ [[:​tutoriel:​comment_installer_un_paquet|installez le paquet]] d'​internationalisation **libreoffice-l10n-XX**,​ par exemple pour **fr** : **[[apt>​libreoffice-l10n-fr]]**;​   - Pour chaque langue installée sur votre système et/ou pour laquelle vous désirez l'​aide,​ [[:​tutoriel:​comment_installer_un_paquet|installez le paquet]] d'​internationalisation **libreoffice-l10n-XX**,​ par exemple pour **fr** : **[[apt>​libreoffice-l10n-fr]]**;​
-==== Via les DEB du site LibreOffice ==== 
  
-Cette méthode est plus complexe, et n'​apporte que peu d'​avantages. 
  
-=== Installation de la suite bureautique ​===+=== Pré-versions (alpha, béta, RC1) === 
 +<note important>​Conçu seulement pour les testeurs...</​note>​
  
-Il est possible d'​installer LibreOffice à partir des paquets ''​deb''​ proposés sur le [[http://​www.libreoffice.org/​download/​|site du projet]], paquets qui sont disponibles pour les architectures 32 et 64 bits. 
  
-Le site vous propose automatiquement les paquets à télécharger en fonction ​de la configuration de l'​ordinateur avec lequel vous consultez ​le site (système d'​exploitation,​ architecture,​ langue ; par exemple "linux x86 (deb)" et "fr-Français"​). Vérifiez que cette configuration correspond bien à l'​ordinateur sur lequel vous allez faire l'​installation.+  - [[:​PPA|Ajoutez dans vos sources ​de logiciels ​le PPA]] **ppa:​libreoffice/​libreoffice-prereleases**((https://​launchpad.net/​~libreoffice/​+archive/​libreoffice-prereleases)
 +  - [[:​tutoriel:​comment_modifier_sources_maj#​recharger_la_liste_des_paquets|rechargez la liste des paquets]] ;​ 
 +  - [[:​tutoriel:​comment_installer_un_paquet|installez le paquet]] **[[apt>​libreoffice|libreoffice]]**. 
  
-Si vous ne savez pas si vous êtes en 32 ou 64 bits, reportez-vous à la documentation [[architecture_materielle|l'​architecture matérielle]] 
  
-Décompressez l'​archive puis rendez-vous dans le répertoire d'​installation,​ dans un [[terminal]] :+===== Configuration =====
  
-  cd ~/​VOTRE_RÉPERTOIRE_DE_TÉLÉCHARGEMENT/​LE_RÉPERTOIRE_DE_DÉCOMPRESSION/​DEBS+==== Accélérer LibreOffice ==== 
 +→ [[optimisation#​accelerer_libreoffice]]
  
- ​[[:​tutoriel:​comment_installer_un_paquet|Installez]] ​l'ensemble ​des archives ​.deb qui y sont présentes :+==== Installer des extensions dans LibreOffice ==== 
 + * Téléchargez ​l'extension (**Enregistrer sous**). 
 +  * Allez dans //Outils → Gestionnaire ​des extensions//​ puis cliquez sur le bouton « Ajouter » 
 +  * Sélectionnez l'​extension,​ puis cliquez sur le bouton « Ouvrir ».
  
-  sudo dpkg -i *.deb+Pour les extensions se trouvant dans les dépôts, il suffit d'​[[tutoriel:​comment_installer_un_paquet#​installer_un_paquet_present_dans_les_depots_recommande|installer les paquets]] en question.
  
-Pour bénéficier des menus sous Gnome (et KDE, Fluxbox), entrez dans le dossier desktop-integration et [[:​tutoriel:​comment_installer_un_paquet|installez l'archive .deb]] :+=== Rotation d'images ===
  
-  cd desktop-integration +L'​extension [[https://​extensions.libreoffice.org/​extensions/​writerrotationtool|Writer Rotation Tool]] permet de tourner facilement les images dans Writer.
-  sudo dpkg -i *.deb+
  
-LibreOffice ​sera ajouté dans le menu //​Applications → Bureautique// ​et s’intégrera dans votre bureau.+=== Extensions pour l'​éducation === 
 +Reportez-vous la page « [[extension_lo_education|extensions ​LibreOffice ​pour l'​éducation ​et la recherche]] ».
  
 +=== Installer des correcteurs===
 +Pour indiquer à LibreOffice dans quelle langue est le document courant, sélectionner la langue via **Outils / Langues / Pour le texte…** (sélectionner Français). Noter qu'il est possible de changer la langue d'un groupe de mots seulement (phrase, paragraphe…). Pour lancer une passe de correction orthographique manuelle, sélectionner le menu Outils → Orthographe et grammaire (accès direct par F7).
  
-=== Installation ​de l'​interface ​en français ​===+Les fonctionnalités ​de correction **orthographique** et **grammaticale** ​en français ​sont disponibles sous la forme d'​extension à installer manuellement. Le plus simple est de corriger l'​orthographe et/ou la grammaire à l'aide de  [[http://​www.dicollecte.org/​grammalecte/​telecharger.php|Grammalecte]].
  
-Il vous suffit d'​utiliser le paquet ''​LibO_xxxxxxxxxxxx_langpack-deb_fr.tar.gz''​ téléchargé à l'​étape précédente.+=== Se passer du logiciel propriétaire Antidote™ ===
  
-Ensuite ​[[archivage|extrayez l'​archive]], placez-vous dans le dossier et installez ​l'ensemble des fichiers ​.deb+Le correcteur orthographique alternatif ​[[http://​extensions.libreoffice.org/​extension-center/​languagetool|LanguageTool]] est également disponible comme extension pour LibreOffice. Pour l'​utiliser en même temps que Grammalectil vous faudra la dernière version. \\ 
 +Dans le cas de l'installation d'une version récente de [[http://​extensions.libreoffice.org/​extension-center/​languagetool|LanguageTool]],​ il est nécessaire d'​installer **[[apt>​libreoffice-java-common]]**,​ **[[apt>​openjdk-8-jre]]** et de le choisir dans **Outils → Options → Avancé → Paramètres,​ choisir Oracle Corporation**.
  
-  cd LibO_xxxxxxxxxxxx_langpack-deb_fr/​DEBS +**Cette astuce permet d'​avoir accès — par un clic droit contextuel sur les mots soulignés en bleu — au correcteur typographique et linguistique contextuel de Language Tool**. \\ 
-  sudo dpkg -i *.deb+Exemple, pour : **12h30**, Language Tool vous donne le format typographique correct suivant : **12{espace insécable}h{espace insécable}30**. \\ 
 + ☛ Ce qui donne **12¬h¬30**,​ les tirets insécables symbolisant ici les espaces insécables grisés qui ne sont pas disponibles dans les balises Wiki ou les caractères spéciaux — **Ω*— de cette documentation.
  
-Au prochain lancement, LibreOffice sera en français.+  * **Cette option du menu contextuel corrige la faute d'un clic de souris !** 
 +  * ** Le couple Grammalecte - Language Tool se comporte alors exactement de la même manière que le logiciel propriétaire et payant [[antidote_rx|Antidote™]]**
  
-=== Installation de l'aide en français ===+Il se peut que LibreOffice plante à l'installation de Grammalecte dans ce cas vérifiez que vous disposez du paquet **[[apt>​python3-uno]]**.
  
-Il vous suffit d'utiliser le paquet ''​LibO_xxxxxxxxxxxx_helppack-deb_fr.tar.gz''​ téléchargé précédemment.+==== Le cas particulier de l'extension Menu Linguistique et du pack linguistique FieldWorks ====
  
-Ensuite extrayez l'archiveplacez-vous dans le dossier et installez l'​ensemble des fichiers .deb+Si vous souhaitez installer une extension de Linguistique (extension de Matrice de Traduction - base de données) à la manière [[antidote_hd|d'Antidote]] ou d'​autres logiciels de traduction payantsil vous suffit ​ de vous rendre sur la page dédiée : \\ 
 +[[lingtools_fieldworks|Pack linguistique de Sil Software © : Libre Office devient linguiste]]
  
-  cd LibO_xxxxxxxxxxxx_helppack-deb_fr/​DEBS +==== Le cas particulier de l'​extension Basic IDE Tools : Environnement de développement intégré OOBasic ​====
-  sudo dpkg -i *.deb +
-===== Configuration =====+
  
-==== Accélérer LibreOffice ==== +À l'​image de l'​environnement de développement Visual Basic™, il existe une interface équivalente sous Libre Office.
-→ [[optimisation#​accelerer_libreoffice]]+
  
-==== Extensions ==== +Pour utiliser ​l'environnement de développement intégré OOBasic il suffit d'​ouvrir Libre Office et de [[https://​extensions.openoffice.org/fr/project/​basic-ide-tools?​SetFreedomCookie|télécharger l’extension Basic IDE Tools]] ​sur le site de Apache Open Office. 
- * Téléchargez ​l'extension (**Enregistrer sous**). +<note help> 
-  * Allez dans //Outils → Gestionnaires des extensions// ​puis cliquez ​sur le bouton « Ajouter » +FIXME L'​utilisation de l'interface de développement dans LibreOffice reste cependant un mystère obscure voire absconsmême dans les documentations en anglais…</​note>​
-  * Sélectionnez ​l'extensionpuis cliquez sur le bouton « Ouvrir ».+
  
-Pour les extensions se trouvant dans les dépôts, il suffit d'​[[tutoriel:​comment_installer_un_paquet#​installer_un_paquet_present_dans_les_depots_recommande|installer les paquets]] en question. 
  
-=== Installer des correcteurs ​===+=== Éditeur d'​équation sous LaTeX ===
  
-Les fonctionnalités de correction **orthographique** et **grammaticale** en français sont disponibles sous la forme d'extension à installer manuellement. Le plus simple est de récupérer le [[http://​extensions.libreoffice.org/​extension-center/​dictionnaires-francais|dictionnaire français]] pour l'​orthographe et [[http://extensions.libreoffice.org/extension-center/​grammalecte|Grammalecte]] pour la grammaire.+Éditeur ​d'équations mathématiques en LaTeX : 
 +[[https://​extensions.libreoffice.org/​extensions/​texmaths-1|TexMaths]]
  
-Pour indiquer à LibreOffice dans quelle langue est le document courant, sélectionner la langue via **Outils / Langues / Pour le texte…** (sélectionner Français). Noter qu'il est possible de changer la langue ​d'un groupe de mot seulement (phrase, paragraphe…). Pour lancer une passe de correction orthographique manuelle, sélectionner le menu Outils / Orthographe et grammaire ​(accès direct par F7).+==== Vignettes ​d'aperçu ​(thumbnails)====
  
-<note important>​Note : le correcteur orthographique alternatif ​[[http://​extensions.libreoffice.org/​extension-center/​languagetool|LanguageTool]] également disponible comme extension pour LibreOffice,​ n'est pas compatible avec Grammalecte,​ n'​utilisez donc pas ces deux extensions ensemble</​note>​ +Les méthodes ci-dessous vont permettront d'​afficher dans votre navigateur de fichiers les miniatures des fichiers ​[[wpfr>​OpenDocument]].
-==== Vignettes d'​aperçu dans Nautilus ====+
  
-Il est possible de faire afficher des vignettes d'​aperçu dans le navigateur de fichier ​[[:​nautilus|Nautilus]]. La façon ​de procéder ​est indiquée ​sur la documentation de [[:​nautilus|Nautilus]].+^ Méthode ^ [[:​Nautilus]] ^[[:​Thunar]] ^[[:​Dolphin]] ^[[:Nemo]] ^ [[:​Caja]] ​ ^[[:​PCManFM]] ^ 
 +| Paquet ooo-thumbnailer | Fonctionne | Fonctionne→[[thunar#​vignettes_d_apercu_des_fichiers_libreoffice|voir ici]] | Incompatible→[[dolphin#​apercu_fichiers_openoffice_ou_libreoffice|voir ici]]  |Fonctionne ​ |Fonctionne ​ |Non testé ​ | 
 +| Script Nicolas Bernaerts | Fonctionne | Incompatible ​ | Incompatible ​ | Fonctionne ​ | Fonctionne ​ |Fonctionne ​ | 
 +| PPA Atareao | Fonctionne ​  | Incompatible ​ | Non testé ​ |Fonctionne ​  | Non testé ​ |Non testé ​ |  
 +\\ 
 + 
 +**NB** : les dernières versions modifiées — de ooo-thumbnailer et MSOffice-thumbnailer — par Nicolas Bernaerts suite à un échange de mails avec [[:​utilisateurs:​eagle08]] fonctionnent avec tous les gestionnaires de fichiers — à l'​exception de Dolphin 4.xx qui ne prend en compte aucun des fichiers cités — testés au 14 mars 2018 sous Xenial V.3. \\  
 + 
 +<note tip>__La version présentée plus bas au paragraphe Méthode 1 a été modifiée et testée par [[:​utilisateurs:​eagle08]] ; elle permet d'​introduire des variables__ ; dès lors, vous pouvez ajouter autant de variables MimeType que vous le souhaitez en ajoutant une ligne de déclaration,​ par exemple : 
 +<​file>​ 
 +OOOtext=application/​vnd.oasis.opendocument.text;​ 
 +GenericTextFormat=text/​x-gettext-translation;​text/​plain;​ 
 +IDETextFormat=text/​x-c;​application/​x-compactpro;​application/​x-csh;​text/​x-script.csh;​application/​x-pointplus;​text/​css;​text/​x-fortran;​text/​vnd.fmi.flexstor;​text/​x-h;​ 
 +… 
 +MimeType=$graphics&&​$presentation&&​$spreadsheet&&​$OOOtext;&&​$GenericTextFile&&​$IDETextFormat 
 +</​file>​ 
 +</​note>​ 
 + 
 +La [[https://​www.sitepoint.com/​mime-types-complete-list/​|liste complète des "​variables"​ MimeTypes]]— **(en)** The Complete List of MIME Types ; site : Site Point ; Auteur : Ophélie Lechat ; date : 15 août 2015. 
 + 
 +=== Méthode 1 : grâce à ooo-thumbnailer === 
 + 
 +[[:​tutoriel:​comment_installer_un_paquet|Installez le paquet]][[apt>​ooo-thumbnailer]] 
 + 
 +**NB**: Vérifier au préalable que le paquet **libgsf-bin** soit bien installé. 
 + 
 + 
 +**__Cependant, ​ il arrive qu'un bogue empêche son bon fonctionnement,​ voici comment le régler :__ 
 +** 
 +  *  Avec [[:sudo|les droits d'​administrateur]],​ créer le fichier **///​usr/​share/​thumbnailers/​ooo.thumbnailer//​** et copiez-y le contenu suivant : <file bash /​usr/​share/​thumbnailers/​ooo.thumbnailer>​usr/​share/​thumbnailers/​ooo.thumbnailer>​ 
 +#​!/​bin/​bash 
 + 
 +usr/​share/​thumbnailers/​ooo.thumbnailer>​ 
 + 
 +# déclaration des variables mime type de documents 
 + 
 +graphics=application/​vnd.oasis.opendocument.graphics;​ 
 +presentation=application/​vnd.oasis.opendocument.presentation;​ 
 +spreadsheet=application/​vnd.oasis.opendocument.spreadsheet;​ 
 +text=application/​vnd.oasis.opendocument.text;​ 
 + 
 +[Thumbnailer Entry] 
 + 
 +TryExec=ooo-thumbnailer 
 +Exec=/​usr/​bin/​ooo-thumbnailer %i %o %s 
 +MimeType=$graphics&&​$presentation&&​$spreadsheet&&​$text 
 +</​file>​ 
 + 
 +   * Sauvegarder le fichier et redémarrer Nautilus :​ <code bash>rm -r $HOME/​.cache/​thumbnails 
 +nautilus -q 
 +</​code>​ 
 + 
 +===Méthode 2 : grâce à un script de Nicolas Bernaerts === 
 + 
 +Il est possible de faire afficher des vignettes d'​aperçu dans le navigateur de fichiers pour les fichiers libreoffice classiques (.dot, ...) ou flat XML (.fodt, ...), grâce à un script de Nicolas Bernaerts présenté en détails sur la page : [[http://​bernaerts.dyndns.org/​linux/​76-gnome/​285-gnome-shell-generate-libreoffice-thumbnail-nautilus|Nautilus ​- Thumbnailer for LibreOffice documents]] 
 + 
 +Là où //​ooo-thumbnailer//​ se contente ​de produire des versions miniatures des documents en guise d'​icônes (comme pour les images ou les fichiers PDF), le script ajoute des captures d'​écran avec des petites logos distinctifs en surimpression des miniatures de manière à reconnaître facilement le type de fichier (ce qui pourra être un avantage ou inconvénient selon les goûts). 
 + 
 +Installation depuis un terminal : 
 +<code bash> 
 +wget https://​raw.githubusercontent.com/​NicolasBernaerts/​ubuntu-scripts/​master/​thumbnailer/​libreoffice/​lo-thumbnailer-install.sh 
 +. ./​lo-thumbnailer-install.sh 
 +</​code>​ 
 + 
 +Vous devriez obtenir le résultat suivant : 
 + 
 +{{https://​lh3.googleusercontent.com/​-96AhQ6f1xSg/​Vc8MLLq5aoI/​AAAAAAAAtvo/​t2tKXKxraEI/​s718/​lothumbnails.png?​500}} 
 + 
 +Pour obtenir des vignettes des documents Ms Office, un thumbnailer ​est disponible ​sur la page //([[http://​bernaerts.dyndns.org/​linux/​76-gnome/​325-gnome-shell-generate-msoffice-thumbnail-nautilus|Nautilus ​- Thumbnailer for Ms Office documents]])// 
 + 
 +Installation depuis un terminal : 
 +<code bash> 
 +wget https://raw.githubusercontent.com/​NicolasBernaerts/​ubuntu-scripts/​master/​thumbnailer/​msoffice/​msoffice-thumbnailer-install.sh 
 +. ./​msoffice-thumbnailer-install.sh 
 +</​code>​ 
 + 
 +===Méthode 3 : via un PPA de l'​équipe Atareao=== 
 +L’équipe [[http://​www.atareao.es/​ubuntu/​elegantes-miniaturas-de-tus-documentos-de-libreoffice-en-ubuntu/​|atareao]] a développé des extensions qui permettent d’afficher les miniatures pour ces formats de fichiers dans Nautilus (dont les vignettes pour LibreOffice) 
 + 
 +Pour l'​installer :   
 + 
 +  * [[:​PPA|Ajoutez le PPA]] **ppa:​atareao/​thumbnailers**((https://​launchpad.net/​~atareao/​+archive/​ubuntu/​thumbnailers)) dans vos sources de logiciels 
 +  * [[:​tutoriel:​comment_modifier_sources_maj#​recharger_la_liste_des_paquets|Rechargez la liste des paquets]] 
 +  * [[:​tutoriel:​comment_installer_un_paquet|Installez le paquet]]**[[apt>​lothumbnailer|lothumbnailer]]**. 
 + 
 +Pour appliquer les modifications,​ enlever les caches miniatures et redémarrer [[:​Nautilus]] en exécutant les commandes ci-dessous :​ 
 +<code bash> 
 +rm ~/​.cache/​thumbnails/​fail/​gnome-thumbnail-factory/​* 
 +rm ~/​.cache/​thumbnails/​large/​* 
 +rm ~/​.cache/​thumbnails/​normal/​* 
 +killall nautilus 
 +</​code>​
  
 ==== Créer un document depuis le navigateur de fichiers ==== ==== Créer un document depuis le navigateur de fichiers ====
 +
 Le nouveau document est créé à partir d'un modèle déjà enregistré dans le dossier ~/Modèles. Le nouveau document est créé à partir d'un modèle déjà enregistré dans le dossier ~/Modèles.
  
-Plus de détails dans la documentation de [[nautilus#​ajout_de_nouveaux_modeles_pour_la_commande_contextuelle_creer_un_document|Nautilus]].+Plus de détails dans **[[:​tutoriel/​nouveau_document_nautilus|ce tutoriel]]**.
  
 ==== Changer le(s) modèle(s) par défaut ==== ==== Changer le(s) modèle(s) par défaut ====
 +
 1. Créer un document [classeur, présentation,​ dessin] conforme à ce qu’on souhaite avoir par défaut. En particulier définir la police du ou des styles qui s’appellent « Par défaut ». 1. Créer un document [classeur, présentation,​ dessin] conforme à ce qu’on souhaite avoir par défaut. En particulier définir la police du ou des styles qui s’appellent « Par défaut ».
 +
 +(LibreOffice 5)
 +
 +2. menu **Fichier > Modèles > Enregistrer comme modèle** : choisir la catégorie de modèle « Mes Modèles » avec le nom qu'on souhaite.
 +et cocher la case "​Définir comme modèle par défaut"​.
 +
 +(LibreOffice 4)
  
 2. menu **Fichier > Enregistrer comme modèle** : l'​enregistrer dans le dossier « Mes Modèles » avec le nom qu'on souhaite. 2. menu **Fichier > Enregistrer comme modèle** : l'​enregistrer dans le dossier « Mes Modèles » avec le nom qu'on souhaite.
  
 3. Procéder comme suit pour définir ce nouveau modèle comme étant le modèle par défaut : 3. Procéder comme suit pour définir ce nouveau modèle comme étant le modèle par défaut :
-=== dans LibreOffice 3 === 
-3.1. menu **Fichier > Modèles > Gérer** : ceci ouvre le gestionnaire de modèles.\\ 
-ensuite... FIXME 
-=== dans LibreOffice 4 === 
-3.1. menu **Fichier > Nouveau > Modèle** : ceci ouvre le gestionnaire de modèles.\\ 
-3.2. Choisir l'​onglet correspondant (Documents, Classeurs, Présentations,​ Dessins).\\ 
-3.2. Si l'​aperçu du nouveau modèle n'est pas visible dans le dossier « Mes Modèles », appuyer le bouton "Menu Action"​ et choisir "​Actualiser"​.\\ 
-3.3. Double cliquer sur le dossier « Mes Modèles », ceci ouvre la liste des modèles présents.\\ 
-3.4. Sélectionner le modèle voulu (simple clic) : ceci fait apparaître un nouvelle liste de boutons.\\ 
-3.5. Appuyer sur le bouton "​Définir par défaut"​.\\ 
  
-4. Fermer ​le gestionnaire de modèles.+menu **Fichier > Nouveau > Modèle > Classeurs** 
 +si le nouveau modèle créé n'​apparaît pas dans le dossier (rectangle aux coins arrondis) "​Mes ​modèles" il faut appuyer sur le bouton "​Importer"​ et le sélectionner depuis son emplacement 
 +Ensuite il faut double cliquer sur le dossier "Mes modèles"​ pour ouvrir la liste des modèles 
 +• On sélectionne le modèle qu’on a créé, on clique sur « Définir par défaut »
  
 +A noter : il y a un bug (mauvaise intégration avec le thème ?) qui fait que le nom du dossier ou du document n'est pas toujours visible. Il faut cliquer sous le rectangle, à l'​emplacement du titre pour le voir.
  
 ==== Ajouter des raccourcis d'​accès ==== ==== Ajouter des raccourcis d'​accès ====
  
-<note important>​Ces consignes s'​appliquent pour Unity (testé dans Ubuntu 11.10 et Ubuntu 12.04). Elles ne fonctionnent pas sur Gnome Shell. ​(à moins que l'​extension Quicklist soit activée ?) +<note important>​Ces consignes s'​appliquent pour Unity et GNOME Shell. 
-chaque ​nouvelle version de LibreOffice ​ ou mise à jour, l'​opération est à recommencer.</​note>​ + 
-{{:​libreoffice:​quicklist_libreoffice.png?​200}}+À chaque mise à jour de LibreOffice, l'​opération est à recommencer.</​note>​ 
 +{{ :​libreoffice:​quicklist_libreoffice.png?​200}}
 Pour pouvoir ajouter des Quicklist à LibreOffice sur le lanceur, il faut préalablement placer l'​application LibreOffice sur le lanceur. Pour pouvoir ajouter des Quicklist à LibreOffice sur le lanceur, il faut préalablement placer l'​application LibreOffice sur le lanceur.
  
-Il faut ensuite ​taper la commande suivante dans un terminal ​ +Il faut ensuite ​[[:tutoriel:​comment_modifier_un_fichier|modifiez le fichier]] **/​usr/​share/​applications/​libreoffice-startcenter.desktop** avec [[:sudo|les droits d'​administration]] et y copier le contenu ​suivant __à la fin__ du fichier ouvert :​ 
- +<​file ​/​usr/​share/​applications/​libreoffice-startcenter.desktop>
-  sudo gedit /​usr/​share/​applications/​libreoffice-startcenter.desktop +
- +
-Puis, copier le script ​suivant __à la fin__ du fichier ouvert : +
- +
-<​file>​+
 X-Ayatana-Desktop-Shortcuts=Writer;​Calc;​Impress;​Base;​Draw;​Math X-Ayatana-Desktop-Shortcuts=Writer;​Calc;​Impress;​Base;​Draw;​Math
  
Ligne 250: Ligne 380:
  
 Après avoir copié ce texte, enregistrez le fichier et redémarrez votre session. Un clic droit sur l'​icône de LibreOffice du lanceur affiche maintenant les accès rapides. Après avoir copié ce texte, enregistrez le fichier et redémarrez votre session. Un clic droit sur l'​icône de LibreOffice du lanceur affiche maintenant les accès rapides.
 +
 ==== Installer des polices ==== ==== Installer des polices ====
  
-Pour disposer des nouvelles polices **qui ne serviront que pour LibreOffice**,​ il suffit de les mettre dans un répertoire nommé **./fonts** situé dans ce dossier utilisateur. ​Plus d'​information sur la page expliquant [[:​installer_de_nouvelles_polices_de_caractere#​installation_pour_un_seul_utilisateur|comment installer de nouvelles polices de caractère]].+Plus d'​information sur la page expliquant [[:​installer_de_nouvelles_polices_de_caractere#​installation_pour_un_seul_utilisateur|comment installer de nouvelles polices de caractère]].
  
 ==== Modifier le nom des polices ==== ==== Modifier le nom des polices ====
Ligne 279: Ligne 410:
   * [[https://​wiki.documentfoundation.org/​Macros/​fr|le wiki de la Document Foundation]]   * [[https://​wiki.documentfoundation.org/​Macros/​fr|le wiki de la Document Foundation]]
   * [[https://​www.openoffice.org/​fr/​Documentation/​Macros/​indexmac.html|le dépôt de macros d'​OpenOffice.org]]   * [[https://​www.openoffice.org/​fr/​Documentation/​Macros/​indexmac.html|le dépôt de macros d'​OpenOffice.org]]
 +
 +Trouver de l'​information d'aide à la programmation :
 +  * [[http://​openoffice3.web.fc2.com/​|OSS( Open Source Software )]]
 +  * [[http://​conference.libreoffice.org/​assets/​Conference/​Aarhus/​Slides/​MatthewFrancisPyUNO.pdf|Les changements pour python3]].
  
 ==== Répertoire par défaut ==== ==== Répertoire par défaut ====
  
-Sous [[:​oneiric|Ubuntu 11.10]], le répertoire par défaut ​où sont stockées les données utilisateurs de LibreOffice ​est : **~/​.libreoffice/​3/​user/​**.+L'​emplacement du répertoire ​de configuration ​par défaut est : **~/.config/libreoffice/​3/​user/​** ​ou **~/.config/​libreoffice/​4/​user/​**
  
-Sous [[:​precise|Ubuntu 12.04 LTS]], l'​emplacement de ce répertoire par défaut ​est changé en : **~/​.config/​libreoffice/​3/user/**+L'​emplacement ​des scripts python3 ​de l'​utilisateur ​est : **~/​.config/​libreoffice/​4/user/​Scripts/​python/​** 
 + 
 +L'​emplacement des scripts python3 pour tous les utilisateurs est : **/​usr/​lib/​libreoffice/​share/​Scripts/​python/**
  
 ===== Utilisation ===== ===== Utilisation =====
 +Lancez l'​application souhaitée comme indiqué [[:​tutoriel:​comment_lancer_application|ici]]. La suite bureautique LibreOffice étant composée de différents modules, adaptez vos recherches en fonction du nom du module voulu.
  
-La suite bureautique LibreOffice est composée de différents modules accessibles depuis ​le menu //​Applications → Bureautique// ​+Vous pouvez également utiliser les commandes suivantes dans le [[:​terminal]] (toutes [[:​versions]] ou [[:​variantes]]) 
-  * **LibreOffice** : le lanceur ​de LibreOffice +   ​* **LibreOffice ​Base** : traitement ​de texte 
-  * **LibreOffice Base** : création de bases de données+  * <​code>​ lobase Démarre avec une base de données ​vide. </​code>​
   * **LibreOffice Calc** : tableur   * **LibreOffice Calc** : tableur
-  * **LibreOffice Draw** ​(aussi disponible sous //​Applications → Graphisme//​) : application de dessin+  ​* <​code>​localc Démarre avec un document Calc vide.</​code>​ 
 +  ​* **LibreOffice Draw** application de dessin 
 +  * <​code>​lodraw Démarre avec un document Draw vide.</​code>​
   * **LibreOffice Impress** : logiciel de présentation   * **LibreOffice Impress** : logiciel de présentation
 +  * <​code>​loimpress ​ Démarre avec un document Impress vide.</​code>​
   * **LibreOffice Math** : création de formules mathématiques   * **LibreOffice Math** : création de formules mathématiques
 +  * <​code>​lomath Démarre avec un document Math vide.</​code>​
   * **LibreOffice Writer** : traitement de texte   * **LibreOffice Writer** : traitement de texte
 +  * <​code>​ lowriter Démarre avec un document Writer vide. </​code>​
  
-===== Problèmes rencontrés =====+Les fichiers de configurations sont dans le dossier **~/​.config/​libreoffice**
  
 +=====Trucs et Astuces =====
 +Rendez-vous sur la [[:​libreoffice_trucs_et_astuces|page consacrée à ce sujet]].
 +
 +===== Problèmes rencontrés =====
 → [[libreoffice_problemes|Résoudre les problèmes rencontrés avec LibreOffice]]. → [[libreoffice_problemes|Résoudre les problèmes rencontrés avec LibreOffice]].
  
Ligne 304: Ligne 451:
  
 Pour supprimer cette application,​ il suffit de [[:​tutoriel:​comment_supprimer_un_paquet|supprimer ses paquets]]. Selon la méthode choisie, la configuration globale de l'​application est conservée ou supprimée. Les journaux du système, et les fichiers de préférence des utilisateurs dans leur dossier personnel sont toujours conservés. Pour supprimer cette application,​ il suffit de [[:​tutoriel:​comment_supprimer_un_paquet|supprimer ses paquets]]. Selon la méthode choisie, la configuration globale de l'​application est conservée ou supprimée. Les journaux du système, et les fichiers de préférence des utilisateurs dans leur dossier personnel sont toujours conservés.
 +
 +<​code>​sudo apt-get remove --purge libreoffice*</​code>​
 +
 +===== Collabora Office™ : Libre Office Cloud =====
 +
 +==== Présentation de Collabora Office™ ====
 +
 +À l'​instar d'​Office Online 365™ de Microsoft<​sup>​®</​sup>,​ Libre Office possède également sa version dématérialisée collaborative ; il s'agit de Libre Office Cloud rebaptisée Collabora Office™. \\
 +<note important>​__**Plusieurs points sont à souligner**__ :
 +  * __La suite Collabora Office__™,​ bien que résultant d'une collaboration entre The Document Foundation et Collabora Productivity<​sup>​®</​sup>,​ __est un logiciel payant basé sur du code propriétaire__.
 +  * L'​installation de la suite Collabora Office™ — __en version 5.1.10.21.21__ — **nécessite de désinstaller totalement toute version présente sur votre ordinateur** !
 +  * __**Les mises à jour dépendent de Collabora Productivity<​sup>​®</​sup>​ !**__
 +</​note>​
 +
 +==== Téléchargement des paquets pré-compilés ====
 +
 +Les paquets (*.deb) peuvent être téléchargés sous forme d'​archive à l'​adresse suivante : \\
 +**(en)** [[https://​www.collaboraoffice.com/​|Site de Collabora Productivity]]<​sup>​®</​sup>​.
 +  * Choisissez la section « Collabora Online » ;
 +  * Cliquer sur < Try The Online Demo > ;
 +  * Remplissez le formulaire ;
 +  * Cliquer sur < Get Access to the Free Online Demo >
 +  * Décompresser [[formats_archives|l'​archive]] dans votre répertoire préféré.
 +
 +[[installation_paquet|Les paquets à installer]] se trouvent dans ''​~/​Collabora_Office_5.1-21_Linux_x86-64_deb/​DEBS''​. ils contiennent les différents paquets de la suite Libre Office ainsi que des paquets de localisation (langues).
 +
 +<note help>Le répertoire ''​~/​Collabora_Office_5.1-21_Linux_x86-64_deb/​readmes''​ ne contient qu'un fichier texte pointant sur l'aide en ligne </​note>​
 +
 +===== Suites logicielles de productivité alternatives libres et commerciales =====
 +
 +  * Pour les principales alternatives libres, voir le paragraphe « [[#​Remarques sur la conversion de fichiers et les alternatives libres à la suite Libre Office]] » ;
 +  * [[https://​www.wps.com/​|WPS office]]™ {{https://​www.wps.com/​assets/​mediahub/​WPS-Office-Mobile.png?​18}} : suite bureautique clonant l'​interface de Microsoft Office ; Les archives pré-compilées (paquets *.deb) sont téléchargeables à l'​adresse : [[http://​wps-community.org/​downloads|Espace communautaire de WPS]].
 +  * [[http://​www.onlyoffice.com/​fr/​apps.aspx|OnlyOffice]]™ {{https://​dl2.macupdate.com/​images/​icons256/​56981.png?​18}} : suite bureautique open-source (version dématérialisée collaborative disponible). Les versions Cloud et Entreprise sont payantes. ;
 +  * [[http://​www.freeoffice.com/​fr/​|FreeOffice 2016]]™ {{http://​www.freeoffice.com/​images/​logo/​softmaker_freeoffice_icon.png?​21}} : version 100% gratuite((FreeOffice se gargarise de convertir les documents Office 365 sans perte ; \\ la conversion d'un simple texte LibreOffice comporte des ratés : erreurs de formatage, texte absent, interface minimaliste… Les dictionnaires sont disponibles,​ mais les instructions d'​installation obscures.)) ​
 +    * Les dictionnaires,​ thésaurus sont disponibles dans la version SoftMaker Office Standard 2016™ {{http://​img.findmysoft.com/​ico/​133283.png?​15}} ​
 +    * Le traducteur Berlitz™ multilingue est disponible dans la version SoftMaker Office Professionnel 2016™ {{http://​img.findmysoft.com/​ico/​133283.png?​15}}. \\ Les versions SoftMaker Office™ {{http://​img.findmysoft.com/​ico/​133283.png?​15}} sont payantes.
  
 ===== Voir aussi ===== ===== Voir aussi =====
  
-  * **(en)** [[http://​www.libreoffice.org/​|Site officiel du logiciel]] ​; +  * **(en)** [[http://​www.libreoffice.org/​|Site officiel du logiciel]] 
-  * **(fr)** [[http://​fr.libreoffice.org/​telecharger/​|Téléchargement de LibreOffice]] : la page officielle francophone,​ récapitulant les avertissements et les paquets disponibles ​; +  * **(fr)** [[http://​fr.libreoffice.org/​download/​|Téléchargement de LibreOffice]] : La page officielle francophone,​ récapitulant les avertissements et les paquets disponibles. 
-  * **(fr, en)** [[http://​wiki.documentfoundation.org/​Main_Page/​fr|Le wiki de la Document Foundation]] ​; +  * **(fr, en)** [[http://​wiki.documentfoundation.org/​Main_Page/​fr|Le wiki de la Document Foundation]] 
-  * **(fr)** [[https://​wiki.documentfoundation.org/​FR/​La_documentation_de_l%27utilisateur|La documentation utilisateur]] ​; +  * **(fr)** [[https://​wiki.documentfoundation.org/​FR/​La_documentation_de_l%27utilisateur|La documentation utilisateur]] ​sur le Wiki de The Document Foundation. 
-  * **(fr,en)** [[http://​extensions.libreoffice.org/​|Les extensions ​libre office]] ;+  * **(fr,en)** [[http://​extensions.libreoffice.org/​|Les extensions ​LibreOffice]]
   * **(fr)** [[http://​user.services.openoffice.org/​fr/​forum/​viewtopic.php?​p=180597|Ubuntu & LibreOffice:​ Réglages & Conseils après Installation]],​ sur le forum d'​Apache OpenOffice.   * **(fr)** [[http://​user.services.openoffice.org/​fr/​forum/​viewtopic.php?​p=180597|Ubuntu & LibreOffice:​ Réglages & Conseils après Installation]],​ sur le forum d'​Apache OpenOffice.
 +  *  **(fr)** [[http://​fr.flossmanuals.net/​initiation-a-draw/​|Floss Manuals : Initiation à Draw]] : Pour bien débuter avec Draw.
 +  * **(fr)** [[http://​www.overnightprints.fr/​open-office|Fichiers de démarrage pour OpenOffice : Fichiers modèles pour la création de votre propre design]] : Vous trouvez des modèles pour les formats de document différents ici.
 +  * **(en)** [[http://​designingwithlibreoffice.com/​|Designing with LibreOffice]] : L'​utilisation des styles et la mise en page de document. Traduction en français en cours (août 2016).
 +
 +
 +==== Notes de versions majeures ====
 +
 +|  nouveau visuel de LibreOffice 6  |
 +{{  https://​www.broussegoutte.com/​images/​blog/​logo-libreoffice-600.png?​500 ​ |Nouveau visuel de LibreOffice ​ }}
 +
 +  * **(fr)** [[https://​wiki.documentfoundation.org/​ReleaseNotes/​6.0/​fr|Notes de version LibreOffice 6.0]]
 +  * **(en)** [[https://​www.youtube.com/​watch?​v=8JrqLf1lvV0|Top 5 Upcoming Features and Changes in LibreOffice 6]] —{ Les 5 meilleurs fonctionnalités et changements attendus dans LibreOffice 6.0 } ; source : Youtube ; auteur : Chris' Tutorials ; date : 17 décembre 2017.
 +  * **(fr)** [[https://​www.nextinpact.com/​news/​104387-chiffrement-et-signature-gpg-dans-libreoffice-6-0-comment-ca-marche.htm|Chiffrement et signature GPG dans LibreOffice 6.0 : comment ça marche ?]] source : Next Impact ; auteur : David Legrand ; date : 20 février 2018.
  
  
 ---- ----
-//​Contributeurs principaux : [[http://​forum.ubuntu-fr.org/​profile.php?​id=44251|GeekShadow]], [[:​utilisateurs:​Gemnoc]], [[:​utilisateurs:​McPeter]], [[http://​forum.ubuntu-fr.org/​profile.php?​id=484641|gguillaume017]],​ [[:​utilisateurs:​lami|L'ami René]].// +Date de dernière révision : 14 mars 2018 ; \\ 
-[[:utilisateur:​Sonkei]]+//​Contributeurs principaux : [[:utilisateurs:​corrigo|corrigo]], [[:​utilisateurs:​geekshadow|GeekShadow]], [[:​utilisateurs:​gguillaume017|gguillaume017]],​ [[:​utilisateurs:​wullfk|Wullfk]], Julientux, ​... \\  
 +Autres contributeurs : [[utilisateurs:eagle08|eagle08]]// : note de compatibilité des correcteurs orthographiques,​ notes de versions, Collabora Office, vignettes d'​aperçu des documents. 
  • libreoffice.1376999644.txt.gz
  • Dernière modification: Le 20/08/2013, 13:54
  • (modification externe)