Contenu | Rechercher | Menus

Différences

Cette page vous donne les différences entre la révision choisie et la version actuelle de la page.

Lien vers cette vue

libreoffice [Le 20/08/2013, 13:54]
corrigo [Via le PPA]
libreoffice [Le 13/04/2014, 20:58] (Version actuelle)
L'Africain [Extensions] ajout du paramètres pour language tools récent
Ligne 1: Ligne 1:
-{{tag>Precise Quantal logiciels bureautique }}+{{tag>Precise raring saucy logiciels bureautique }}
  
 ---- ----
Ligne 62: Ligne 62:
   * Solveur de programmation non linéaire **[[apt>libreoffice-nlpsolver]]**   * Solveur de programmation non linéaire **[[apt>libreoffice-nlpsolver]]**
   * Fournisseur de script pour Python **[[apt>python]]**   * Fournisseur de script pour Python **[[apt>python]]**
 +
 +<note>Il peut arriver que le paquet libreoffice-nlpsolver installé après coup ne soit pas actif. Dans ce cas il semble nécessaire de désinstaller puis de réinstaller libreoffice avec la commande suivante dans un terminal
 +</note>
 +
 +  sudo apt-get purge libreoffice* && sudo apt-get install libreoffice libreoffice-nlpsolver libreoffice-help-fr libreoffice-l10n-fr
 +
 +
 +
 +
  
  
Ligne 82: Ligne 91:
    * **[[apt>libreoffice-templates]]** (modèles de documents supplémentaires)    * **[[apt>libreoffice-templates]]** (modèles de documents supplémentaires)
    * **[[apt>libreoffice-scope-asklibreoffice]]** (lentille d'aide dans le tableau de bord)     * **[[apt>libreoffice-scope-asklibreoffice]]** (lentille d'aide dans le tableau de bord) 
-   * **[[apt>openclipart2-libreoffice]]** (modèles clipart supplémentaires)+   * **[[apt>openclipart-libreoffice]]** (modèles clipart supplémentaires)
  
-==== Via le PPA ==== +==== Via les PPA ==== 
-Cette méthode permet : +<note tip>Une version de LibreOffice est considérée comme stable (donc recommandée pour une utilisation dans un contexte professionnel) à partir de sa 2ème ou 3ème révision (par exemple 4.0.2 ou 4.0.3). Une approche conservatrice demanderait d'attendre la 4ème révision((https://wiki.documentfoundation.org/File:LibOReleaseLifecycle.png))
-  * d'obtenir une version récente et stable de LibreOffice sur Ubuntu 12.04 et suivantes. +
-<note>Une version de LibreOffice est considérée comme stable (donc recommandée pour une utilisation dans un contexte professionnel) à partir de sa 2ème ou 3ème révision (par exemple 4.0.2 ou 4.0.3).+
  
-Une approche conservatrice demanderait d'attendre la 4ème révision((https://wiki.documentfoundation.org/File:LibOReleaseLifecycle.png))</note> +Les pré-versions RC2 sont en général identiques à la version finaleContrairement aux builds officielles, les PPA ne les renomment alors pas comme telles.</note> 
-^ Version Ubuntu ^ Version installée ^  Version du PPA 4.^ Version du PPA de test +^ Version d'Ubuntu ^ Version installée ^   Version du PPA 4.1 ^   Version du PPA 4.2 ^ Version du PPA générique ^ Version du PPA prerelease 
-| Ubuntu [[:raring|13.04]] | 4.0.2 |  4.0.4~rc2 | 4.1.| +| Ubuntu [[:saucy|13.10]] | 4.1.3.2 | 4.1.5~rc3 | 4.2.2~rc1 4.2.2~rc1 | 4.2.3~rc1 
-| Ubuntu [[:quantal|12.10]] | 3.6.2 |  4.0.4~rc2 | sans objet +| Ubuntu [[:precise|12.04 LTS]] | 3.5.7 | 4.1.5~rc3 | 4.2.2~rc1 | 4.2.2~rc1 4.2.3~rc1 | 
-| Ubuntu [[:precise|12.04 LTS]] | 3.5.7 |  4.0.4~rc2 | 4.1.|+//(informations à jour le 07/04/2014)//
  
-//(informations à jour le 19/08/2013)// +=== Versions stables === 
-<note tip>Les pré-versions RC2 sont en général identiques à la version finale. Contrairement aux builds officielles, les PPA ne les renomment alors pas comme telles.</note>+Ces PPA contiennent la dernière version stable de la branche (ou de toutes les branches pour le PPA générique), ou éventuellement la release candidate prévue pour être la version finale (RC2)Les paquets présents dans le dépôt PPA générique sont accessible [[https://launchpad.net/~libreoffice/+archive/ppa|ici]], vous y trouverez également un lien vers les dépôts de chacune des branches (actuellement : 4.1). 
  
 +<note important> La plupart des paquets __**dans le PPA générique**__ n'ont subit que des test réduits. En fait c'est l'endroit permettant à une audience plus large de tester les paquets avant qu'ils ne soient intégrés dans la distro. En général, ce PPA n'est __pas__ destiné à l'utilisateur lambda (dans le cas contraire ces paquets seraient dans les dépots principaux). </note>
 +
 +== Méthode graphique ==
   - [[:PPA|Ajoutez dans vos sources de logiciels le PPA]]   - [[:PPA|Ajoutez dans vos sources de logiciels le PPA]]
-      + 
-    *  pour la version 4.disponible pour [[:Précise]], [[:Quantal]] et [[:Raring]], considérée comme stable par the Document Foundation  :\\ **ppa:libreoffice/libreoffice-4-0**((https://launchpad.net/~libreoffice/+archive/libreoffice-4-0)) +  
-    pour la toute dernière version de test :\\ **ppa:libreoffice/ppa**((https://launchpad.net/~libreoffice/+archive/ppa))+  * __**pour la version 4.1**__ disponible pour [[:Précise]] et [[:Saucy]]. __Version stablerecommandée à tous les utilisateurs à partir de la 4.1.3__ : **ppa:libreoffice/libreoffice-4-1**((https://launchpad.net/~libreoffice/+archive/libreoffice-4-1)) 
 +  * __**Pour la version 4.2**__ disponible pour [[:Précise]] et [[:Saucy]]. Cette version est encore trop jeune. Elle est destinée aux utilisateurs expérimentésles autres attendront les premières mises à jour correctives à partir sa 2ème ou 3ème révision : **ppa:libreoffice/libreoffice-4-2** ((https://launchpad.net/~libreoffice/+archive/libreoffice-4-2)) 
 +  **__pour la dernière version du PPA générique :__** **ppa:libreoffice/ppa**((https://launchpad.net/~libreoffice/+archive/ppa)) 
   - [[:tutoriel:comment_modifier_sources_maj#recharger_la_liste_des_paquets|rechargez la liste des paquets]] ;   - [[:tutoriel:comment_modifier_sources_maj#recharger_la_liste_des_paquets|rechargez la liste des paquets]] ;
   - [[:tutoriel:comment_installer_un_paquet|installez le paquet]] **[[apt>libreoffice|libreoffice]]** ;   - [[:tutoriel:comment_installer_un_paquet|installez le paquet]] **[[apt>libreoffice|libreoffice]]** ;
   - Pour chaque langue installée sur votre système et/ou pour laquelle vous désirez l'aide, [[:tutoriel:comment_installer_un_paquet|installez le paquet]] d'internationalisation **libreoffice-l10n-XX**, par exemple pour **fr** : **[[apt>libreoffice-l10n-fr]]**;   - Pour chaque langue installée sur votre système et/ou pour laquelle vous désirez l'aide, [[:tutoriel:comment_installer_un_paquet|installez le paquet]] d'internationalisation **libreoffice-l10n-XX**, par exemple pour **fr** : **[[apt>libreoffice-l10n-fr]]**;
 +
 +== Méthode en ligne de commande ==
 +Ouvrez un [[:terminal]] et entrez les commandes suivantes pour la branche 4.1:
 +<code>sudo add-apt-repository ppa:libreoffice/libreoffice-4-1</code>
 +
 +Pour la branche 4.2 :
 +<code>sudo add-apt-repository ppa:libreoffice/libreoffice-4-2</code>
 +
 +Puis dans les 2 cas : 
 +<code>sudo apt-get update
 +sudo apt-get install libreoffice </code>
 +ou pour le PPA générique (non recommandé pour une utilisation quotidienne): <code>sudo add-apt-repository ppa:libreoffice/ppa
 +sudo apt-get update
 +sudo apt-get install libreoffice </code>
 +
 +
 +=== Versions instables (alpha, béta, RC1) ===
 +<note important>Pour les cascadeurs uniquement...</note>
 +
 +== Méthode graphique ==
 +  - [[:PPA|Ajoutez dans vos sources de logiciels le PPA]] **ppa:libreoffice/libreoffice-prereleases**((https://launchpad.net/~libreoffice/+archive/libreoffice-prereleases))
 +  - [[:tutoriel:comment_modifier_sources_maj#recharger_la_liste_des_paquets|rechargez la liste des paquets]] ;
 +  - [[:tutoriel:comment_installer_un_paquet|installez le paquet]] **[[apt>libreoffice|libreoffice]]**. 
 +
 +== Méthode en ligne de commande ==
 +Ouvrez un [[:terminal]] et entrez les commandes suivantes:<code>sudo add-apt-repository ppa:libreoffice/libreoffice-prereleases
 +sudo apt-get update
 +sudo apt-get install libreoffice</code>
 ==== Via les DEB du site LibreOffice ==== ==== Via les DEB du site LibreOffice ====
  
Ligne 167: Ligne 208:
  
 Les fonctionnalités de correction **orthographique** et **grammaticale** en français sont disponibles sous la forme d'extension à installer manuellement. Le plus simple est de récupérer le [[http://extensions.libreoffice.org/extension-center/dictionnaires-francais|dictionnaire français]] pour l'orthographe et [[http://extensions.libreoffice.org/extension-center/grammalecte|Grammalecte]] pour la grammaire. Les fonctionnalités de correction **orthographique** et **grammaticale** en français sont disponibles sous la forme d'extension à installer manuellement. Le plus simple est de récupérer le [[http://extensions.libreoffice.org/extension-center/dictionnaires-francais|dictionnaire français]] pour l'orthographe et [[http://extensions.libreoffice.org/extension-center/grammalecte|Grammalecte]] pour la grammaire.
 +Pour Grammalecte, vérifiez que vous disposez du paquet python-uno.
 +Il se peut que LibreOffice plante à l'installation de Grammalecte, dans ce cas faites export dans un terminal avant de lancer libreoffice afin que celui-ci ait accès à uno.py :
 +
 +  export PYTHONPATH=/usr/lib/libreoffice/program:/usr/share/pyshared
 +  libreoffice &
 +
  
 Pour indiquer à LibreOffice dans quelle langue est le document courant, sélectionner la langue via **Outils / Langues / Pour le texte…** (sélectionner Français). Noter qu'il est possible de changer la langue d'un groupe de mot seulement (phrase, paragraphe…). Pour lancer une passe de correction orthographique manuelle, sélectionner le menu Outils / Orthographe et grammaire (accès direct par F7). Pour indiquer à LibreOffice dans quelle langue est le document courant, sélectionner la langue via **Outils / Langues / Pour le texte…** (sélectionner Français). Noter qu'il est possible de changer la langue d'un groupe de mot seulement (phrase, paragraphe…). Pour lancer une passe de correction orthographique manuelle, sélectionner le menu Outils / Orthographe et grammaire (accès direct par F7).
  
 <note important>Note : le correcteur orthographique alternatif [[http://extensions.libreoffice.org/extension-center/languagetool|LanguageTool]] également disponible comme extension pour LibreOffice, n'est pas compatible avec Grammalecte, n'utilisez donc pas ces deux extensions ensemble. </note> <note important>Note : le correcteur orthographique alternatif [[http://extensions.libreoffice.org/extension-center/languagetool|LanguageTool]] également disponible comme extension pour LibreOffice, n'est pas compatible avec Grammalecte, n'utilisez donc pas ces deux extensions ensemble. </note>
 +
 +<note important> Dans le cas de l'installation d'une version récente de [[http://extensions.libreoffice.org/extension-center/languagetool|LanguageTool]] il est nécessaire d'installer **[[apt>openjdk-7-jre]]** et de le choisir dans Outils > Options > Avancé > Paramètres, choisir Oracle Corporation.</note>
 ==== Vignettes d'aperçu dans Nautilus ==== ==== Vignettes d'aperçu dans Nautilus ====
  
Ligne 252: Ligne 301:
 ==== Installer des polices ==== ==== Installer des polices ====
  
-Pour disposer des nouvelles polices **qui ne serviront que pour LibreOffice**, il suffit de les mettre dans un répertoire nommé **./fonts** situé dans ce dossier utilisateur. Plus d'information sur la page expliquant [[:installer_de_nouvelles_polices_de_caractere#installation_pour_un_seul_utilisateur|comment installer de nouvelles polices de caractère]].+Plus d'information sur la page expliquant [[:installer_de_nouvelles_polices_de_caractere#installation_pour_un_seul_utilisateur|comment installer de nouvelles polices de caractère]].
  
 ==== Modifier le nom des polices ==== ==== Modifier le nom des polices ====
Ligne 284: Ligne 333:
 Sous [[:oneiric|Ubuntu 11.10]], le répertoire par défaut où sont stockées les données utilisateurs de LibreOffice est : **~/.libreoffice/3/user/**. Sous [[:oneiric|Ubuntu 11.10]], le répertoire par défaut où sont stockées les données utilisateurs de LibreOffice est : **~/.libreoffice/3/user/**.
  
-Sous [[:precise|Ubuntu 12.04 LTS]], l'emplacement de ce répertoire par défaut est changé en : **~/.config/libreoffice/3/user/**+À partir d'[[:precise|Ubuntu 12.04 LTS]], l'emplacement de ce répertoire par défaut est changé en : **~/.config/libreoffice/3/user/** ou **~/.config/libreoffice/4/user/**
  
 ===== Utilisation ===== ===== Utilisation =====
Ligne 296: Ligne 345:
   * **LibreOffice Math** : création de formules mathématiques   * **LibreOffice Math** : création de formules mathématiques
   * **LibreOffice Writer** : traitement de texte   * **LibreOffice Writer** : traitement de texte
 +
 +Les fichiers de configurations sont dans le dossier **~/.config/libreoffice**
  
 ===== Problèmes rencontrés ===== ===== Problèmes rencontrés =====
Ligne 313: Ligne 364:
   * **(fr,en)** [[http://extensions.libreoffice.org/|Les extensions libre office]] ;   * **(fr,en)** [[http://extensions.libreoffice.org/|Les extensions libre office]] ;
   * **(fr)** [[http://user.services.openoffice.org/fr/forum/viewtopic.php?p=180597|Ubuntu & LibreOffice: Réglages & Conseils après Installation]], sur le forum d'Apache OpenOffice.   * **(fr)** [[http://user.services.openoffice.org/fr/forum/viewtopic.php?p=180597|Ubuntu & LibreOffice: Réglages & Conseils après Installation]], sur le forum d'Apache OpenOffice.
 +  *  **(fr)** [[http://fr.flossmanuals.net/initiation-a-draw/|Manuel draw flossmanuals]], pour bien débuter avec Draw.
  
  

libreoffice.1376999644.txt.gz · Dernière modification: Le 20/08/2013, 13:54 (modification externe)
Le contenu de ce wiki est sous licence : CC BY-SA v3.0