Contenu | Rechercher | Menus

 Logo de LibreOffice

LibreOffice

LibreOffice est une suite bureautique libre, gratuite et complète (traitement de texte, tableur, logiciel de présentation, etc).

LibreOffice est libre, gratuite et multiplateforme, ce qui fait d'elle une excellente alternative aux suites bureautiques telles que MS Office, Google Docs.

Elle est aussi très modulaire : des extensions, des modèles, des images, des polices vous sont librement mis à disposition par la communauté.

LibreOffice est un embranchement (ou fork) de la suite libre de bureautique OpenOffice.org, développé par The Document Foundation, une fondation regroupant la communauté de développeurs d'OpenOffice.org ainsi que différents partenaires comme la FSF, OASIS, Google, Novell, Red Hat, Canonical, OSI.

  • LibreOffice est une suite bureautique complète. Si vous cherchez simplement à pouvoir lire et modifier des documents de type texte formaté (.doc, .odt) ou tableur (.xls), le couple AbiwordGnumeric peut être une alternative intéressante car plus légère si vous êtes dans un environnement GTK (c'est le cas d'Ubuntu et de Xubuntu) ou Calligra Words + Calligra Cells si vous utilisez un environnement en Qt (par exemple Kubuntu).
  • LibreOffice prend notamment en charge les formats Open XML de Microsoft Office (.docx, .xlsx, .pptx), mais LibreOffice peut avoir des difficultés à les lire. Il est préférable de lire/modifier ces types de fichiers avec les logiciels de Microsoft ou de les enregistrer dans les anciens formats de Office (antérieurs à 2007 : .doc, .xls, .ppt) qui sont mieux pris en charge par LibreOffice. Il en est de même si vous souhaitez lire un fichier ODT avec Word par exemple.

Pré-requis

Installation

Via les dépôts officiels

Cette méthode concerne Ubuntu 12.04 et les versions ultérieures

LibreOffice est installé par défaut sous Ubuntu Ubuntu 12.04.

Pour installer LibreOffice dans Ubuntu 12.04 (après y avoir activé le dépôt Universe), ou pour réinstaller LibreOffice dans les versions suivantes, installez les paquets :

Pour que LibreOffice soit compatible avec le globalmenu d'Unity, il suffit d'installer le paquet lo-menubar (dépôt Universe). Il semble que pour la 12.04, ce paquet apporte plus de problèmes que de solutions (cf bogue 754562). Ce paquet n'est plus nécessaire à partir d'Ubuntu 12.10 (Quantal Quetzal).

Les extensions incluses dans LibreOffice

La version provenant du site Libreoffice donne une liste de 6 extensions que l'on peut ou non installer (cochés par défaut), mais elles ne sont pas disponibles sur son site. Pour les retrouver dans la logithèque vous tapez libreoffice extension ; sinon voici le nom de chacune et le nom de son paquet :

Il peut arriver que le paquet libreoffice-nlpsolver installé après coup ne soit pas actif. Dans ce cas il semble nécessaire de désinstaller puis de réinstaller libreoffice avec la commande suivante dans un terminal

sudo apt-get purge libreoffice* && sudo apt-get install libreoffice libreoffice-nlpsolver libreoffice-help-fr libreoffice-l10n-fr

Les styles d'icônes incluses dans LibreOffice

Pour des questions de place, seul un ensemble restreint de jeux d'icônes est inclus dans la version fournie par Canonical par rapport à la version fournie par The Document Fondation. Elles peuvent être retrouvées en tapant les mots libreoffice-style dans la logithèque, sinon voici la liste complète :

Autres exemples d'extensions installables

Via les PPA

Un avantage d’utiliser le PPA vient des mises à jour automatiques rendant plus faciles la mise à niveau vers des versions plus récentes de LibreOffice.

Une version de LibreOffice est considérée comme stable (donc recommandée pour une utilisation dans un contexte professionnel) à partir de sa 2ème ou 3ème révision (par exemple 4.0.2 ou 4.0.3). Une approche conservatrice demanderait d'attendre la 4ème révision1)

Les pré-versions RC2 sont en général identiques à la version finale. Contrairement aux builds officielles, les PPA ne les renomment alors pas comme telles.

Version d'Ubuntu Version installée Version du PPA 4.2 Version du PPA 4.3 Version du PPA générique Version du PPA prerelease
Ubuntu 14.04 LTS 4.2.3 4.2.6~rc2 4.3.1~rc2 4.3.1~rc2 4.3.0
Ubuntu 12.04 LTS 3.5.4 4.2.6~rc2 4.3.1~rc2 4.3.1~rc2 4.3.0

(informations à jour le 05/08/2014)

Versions stables

Ces PPA contiennent la dernière version de la branche (ou de toutes les branches pour le PPA générique), ou éventuellement la release candidate prévue pour être la version finale (RC2). Les paquets présents dans le dépôt PPA générique sont accessible ici, vous y trouverez également un lien vers les dépôts de chacune des branches (actuellement : 4.2 et 4.3).

 Avant de d'allez plus loin, veuillez noter que les paquets sur le PPA générique n'ont subit que des tests minimums. Cette mise à jour est réservée aux utilisateurs sachant utiliser ppa-purge pour annuler les modifications si quelque chose venait à ne plus fonctionner comme il le faut. Cependant, cela est plus sûr que d'utiliser directement les .deb fournit par The Document Foundation.

Méthode graphique
  • Pour la version 4.2 Version stable, recommandée à tous par la Document Fondation : ppa:libreoffice/libreoffice-4-2 2)
  • Pour la version 4.3 Version recommandée aux utilisateurs souhaitant profiter des dernières innovations de LibreOffice : ppa:libreoffice/libreoffice-4-3 3)
  • pour la dernière version du PPA générique :(permet de rester perpétuellement à jour sans changer de branche dans le temps): ppa:libreoffice/ppa4)
  1. Pour chaque langue installée sur votre système et/ou pour laquelle vous désirez l'aide, installez le paquet d'internationalisation libreoffice-l10n-XX, par exemple pour fr : libreoffice-l10n-fr;
Méthode en ligne de commande

Ouvrez un terminal et entrez les commandes suivantes pour la branche 4.2:

sudo add-apt-repository ppa:libreoffice/libreoffice-4-2

Pour la branche 4.3 :

sudo add-apt-repository ppa:libreoffice/libreoffice-4-3

Puis dans les 2 cas :

sudo apt-get update
sudo apt-get install libreoffice 

ou pour le PPA générique (permet de rester perpétuellement à jour sans changer de branche dans le temps):

sudo add-apt-repository ppa:libreoffice/ppa
sudo apt-get update
sudo apt-get install libreoffice 

Versions instables (alpha, béta, RC1)

Pour les cascadeurs uniquement…

Méthode graphique
Méthode en ligne de commande

Ouvrez un terminal et entrez les commandes suivantes:

sudo add-apt-repository ppa:libreoffice/libreoffice-prereleases
sudo apt-get update
sudo apt-get install libreoffice

Via les DEB du site LibreOffice

Cette méthode est plus complexe, et n'apporte que peu d'avantages.

Installation de la suite bureautique

Il est possible d'installer LibreOffice à partir des paquets deb proposés sur le site du projet, paquets qui sont disponibles pour les architectures 32 et 64 bits.

Le site vous propose automatiquement les paquets à télécharger en fonction de la configuration de l'ordinateur avec lequel vous consultez le site (système d'exploitation, architecture, langue ; par exemple "linux x86 (deb)" et "fr-Français"). Vérifiez que cette configuration correspond bien à l'ordinateur sur lequel vous allez faire l'installation.

Si vous ne savez pas si vous êtes en 32 ou 64 bits, reportez-vous à la documentation l'architecture matérielle

Décompressez l'archive puis rendez-vous dans le répertoire d'installation, dans un terminal :

cd ~/VOTRE_RÉPERTOIRE_DE_TÉLÉCHARGEMENT/LE_RÉPERTOIRE_DE_DÉCOMPRESSION/DEBS

Installez l'ensemble des archives .deb qui y sont présentes :

sudo dpkg -i *.deb

Pour bénéficier des menus sous Gnome (et KDE, Fluxbox), entrez dans le dossier desktop-integration et installez l'archive .deb :

cd desktop-integration
sudo dpkg -i *.deb

LibreOffice sera ajouté dans le menu Applications → Bureautique et s’intégrera dans votre bureau.

Installation de l'interface en français

[Attention: La méthode décrite ci-dessous ne fonctionne pas pour xubuntu 14.04 (problème avec libobasis). Il faut installer le paquet libreoffice-l10n-fr et l'interface est en français au redémarrage de libreoffice!]

Il vous suffit d'utiliser le paquet LibO_xxxxxxxxxxxx_langpack-deb_fr.tar.gz téléchargé à l'étape précédente.

Ensuite extrayez l'archive, placez-vous dans le dossier et installez l'ensemble des fichiers .deb

cd LibO_xxxxxxxxxxxx_langpack-deb_fr/DEBS
sudo dpkg -i *.deb

Au prochain lancement, LibreOffice sera en français.

Installation de l'aide en français

Il vous suffit d'utiliser le paquet LibO_xxxxxxxxxxxx_helppack-deb_fr.tar.gz téléchargé précédemment.

Ensuite extrayez l'archive, placez-vous dans le dossier et installez l'ensemble des fichiers .deb

cd LibO_xxxxxxxxxxxx_helppack-deb_fr/DEBS
sudo dpkg -i *.deb

Configuration

Accélérer LibreOffice

Extensions

* Téléchargez l'extension (Enregistrer sous).

  • Allez dans Outils → Gestionnaires des extensions puis cliquez sur le bouton « Ajouter »
  • Sélectionnez l'extension, puis cliquez sur le bouton « Ouvrir ».

Pour les extensions se trouvant dans les dépôts, il suffit d'installer les paquets en question.

Installer des correcteurs

Les fonctionnalités de correction orthographique et grammaticale en français sont disponibles sous la forme d'extension à installer manuellement. Le plus simple est de récupérer le dictionnaire français pour l'orthographe et Grammalecte pour la grammaire. Pour Grammalecte, vérifiez que vous disposez du paquet python-uno. Il se peut que LibreOffice plante à l'installation de Grammalecte, dans ce cas faites export dans un terminal avant de lancer libreoffice afin que celui-ci ait accès à uno.py :

export PYTHONPATH=/usr/lib/libreoffice/program:/usr/share/pyshared
libreoffice &

Pour indiquer à LibreOffice dans quelle langue est le document courant, sélectionner la langue via Outils / Langues / Pour le texte… (sélectionner Français). Noter qu'il est possible de changer la langue d'un groupe de mot seulement (phrase, paragraphe…). Pour lancer une passe de correction orthographique manuelle, sélectionner le menu Outils / Orthographe et grammaire (accès direct par F7).

Note : le correcteur orthographique alternatif LanguageTool également disponible comme extension pour LibreOffice, n'est pas compatible avec Grammalecte, n'utilisez donc pas ces deux extensions ensemble.

Dans le cas de l'installation d'une version récente de LanguageTool il est nécessaire d'installer libreoffice-java-common, openjdk-7-jre et de le choisir dans Outils > Options > Avancé > Paramètres, choisir Oracle Corporation.

Vignettes d'aperçu dans Nautilus

Il est possible de faire afficher des vignettes d'aperçu dans le navigateur de fichier Nautilus. La façon de procéder est indiquée sur la documentation de Nautilus.

Créer un document depuis le navigateur de fichiers

Le nouveau document est créé à partir d'un modèle déjà enregistré dans le dossier ~/Modèles.

Plus de détails dans la documentation de Nautilus.

Changer le(s) modèle(s) par défaut

1. Créer un document [classeur, présentation, dessin] conforme à ce qu’on souhaite avoir par défaut. En particulier définir la police du ou des styles qui s’appellent « Par défaut ».

2. menu Fichier > Enregistrer comme modèle : l'enregistrer dans le dossier « Mes Modèles » avec le nom qu'on souhaite.

3. Procéder comme suit pour définir ce nouveau modèle comme étant le modèle par défaut :

dans LibreOffice 3

3.1. menu Fichier > Modèles > Gérer : ceci ouvre le gestionnaire de modèles.
ensuite… FIXME

dans LibreOffice 4

3.1. menu Fichier > Nouveau > Modèle : ceci ouvre le gestionnaire de modèles.
3.2. Choisir l'onglet correspondant (Documents, Classeurs, Présentations, Dessins).
3.2. Si l'aperçu du nouveau modèle n'est pas visible dans le dossier « Mes Modèles », appuyer le bouton "Menu Action" et choisir "Actualiser".
3.3. Double cliquer sur le dossier « Mes Modèles », ceci ouvre la liste des modèles présents.
3.4. Sélectionner le modèle voulu (simple clic) : ceci fait apparaître un nouvelle liste de boutons.
3.5. Appuyer sur le bouton "Définir par défaut".

4. Fermer le gestionnaire de modèles.

Ajouter des raccourcis d'accès

Ces consignes s'appliquent pour Unity (testé dans Ubuntu 11.10 et Ubuntu 12.04). Elles ne fonctionnent pas sur Gnome Shell. (à moins que l'extension Quicklist soit activée ?) A chaque nouvelle version de LibreOffice ou mise à jour, l'opération est à recommencer.

Pour pouvoir ajouter des Quicklist à LibreOffice sur le lanceur, il faut préalablement placer l'application LibreOffice sur le lanceur.

Il faut ensuite taper la commande suivante dans un terminal :

sudo gedit /usr/share/applications/libreoffice-startcenter.desktop

Puis, copier le script suivant à la fin du fichier ouvert :

X-Ayatana-Desktop-Shortcuts=Writer;Calc;Impress;Base;Draw;Math

[Writer Shortcut Group]
Name=Nouveau document texte
Exec=libreoffice -writer %U
TargetEnvironment=Unity

[Math Shortcut Group]
Name=Formule mathématique
Exec=libreoffice -math %U
TargetEnvironment=Unity

[Impress Shortcut Group]
Name=Nouvelle présentation
Exec=libreoffice -impress %U
TargetEnvironment=Unity

[Draw Shortcut Group]
Name=Nouveau dessin
Exec=libreoffice -draw %U
TargetEnvironment=Unity

[Calc Shortcut Group]
Name=Nouvelle feuille de calcul
Exec=libreoffice -calc %U
TargetEnvironment=Unity

[Base Shortcut Group]
Name=Nouvelle base de données
Exec=libreoffice -base %U
TargetEnvironment=Unity

Il est bien sûr possible de supprimer certaines parties de ce script pour les raccourcis que vous n'utiliserez pas.

Après avoir copié ce texte, enregistrez le fichier et redémarrez votre session. Un clic droit sur l'icône de LibreOffice du lanceur affiche maintenant les accès rapides.

Installer des polices

Plus d'information sur la page expliquant comment installer de nouvelles polices de caractère.

Modifier le nom des polices

Quand LibreOffice découvre de nouvelles polices :

  • soit dans le dossier polices du système (/usr/share/fonts/),
  • soit dans le dossier polices de l'utilisateur (~/.fonts),
  • soit dans le dossier "/usr/lib/libreoffice/share/fonts/" des configurations système de LibreOffice,
  • soit dans le dossier "fonts" du répertoire des configurations de LibreOffice de l'utilisateur,

il les ajoute à son cache des polices, nommé "pspfontcache", qui se trouve dans le dossier "psprint" situé dans ce même répertoire des configurations de LibreOffice de l'utilisateur.

En cas de problème ou d'erreur, enlevez les polices erronées du dossier où elles se trouvent, redémarrer LibreOffice, puis les y remettre. Autrement supprimez le fichier "pspfontcache".

Dans ce fichier, il indique le nom du dossier exploré, à chaque changement de dossier ou de sous-dossier :

FontCacheDirectory:1335506239:/usr/share/fonts/truetype/msttcorefonts

Il liste ensuite les fichiers de polices qu'il y trouve, en prenant 4 lignes pour chacun, et séparant deux fichiers de polices par une ligne vide. Par exemple, pour le fichier "/usr/share/fonts/truetype/msttcorefonts/Comic_Sans_MS.ttf", après l'indication du répertoire exploré, il indique :

File:Comic_Sans_MS.ttf
2;1
Comic Sans MS
-1;ComicSansMS;0;5;5;2;65535;1102;291;393;0;1278;1393;1278;1393;0;0;0;0;Regular

La troisième de ces lignes indique le nom que LibreOffice indiquera pour la police dans le menu déroulant : il est donc possible de le modifier avec soin, par exemple pour donner le même nom à toutes les variantes de taille d'une même police…

Macros

Vous pouvez récupérer des macros sur les sites suivants :

Répertoire par défaut

Sous Ubuntu 11.10, le répertoire par défaut où sont stockées les données utilisateurs de LibreOffice est : ~/.libreoffice/3/user/.

À partir d'Ubuntu 12.04 LTS, l'emplacement de ce répertoire par défaut est changé en : ~/.config/libreoffice/3/user/ ou ~/.config/libreoffice/4/user/

Utilisation

La suite bureautique LibreOffice est composée de différents modules accessibles depuis le menu Applications → Bureautique :

  • LibreOffice : le lanceur de LibreOffice
  • LibreOffice Base : création de bases de données
  • LibreOffice Calc : tableur
  • LibreOffice Draw (aussi disponible sous Applications → Graphisme) : application de dessin
  • LibreOffice Impress : logiciel de présentation
  • LibreOffice Math : création de formules mathématiques
  • LibreOffice Writer : traitement de texte

Les fichiers de configurations sont dans le dossier ~/.config/libreoffice

Problèmes rencontrés

Désinstallation

Pour supprimer cette application, il suffit de supprimer ses paquets. Selon la méthode choisie, la configuration globale de l'application est conservée ou supprimée. Les journaux du système, et les fichiers de préférence des utilisateurs dans leur dossier personnel sont toujours conservés.

Voir aussi


Contributeurs principaux : GeekShadow, Gemnoc, McPeter, gguillaume017, L'ami René. Sonkei



Le contenu de ce wiki est sous licence : CC BY-SA v3.0