Contenu | Rechercher | Menus

Résoudre les problèmes rencontrés avec LibreOffice

 Logo de LibreOffice

Cette page propose des solutions aux problèmes rencontrés lors de l'utilisation de LibreOffice.

Problèmes de sécurité

Consulter la liste sur la page officielle, et faire les mises à jour de versions recommandées.

Cette page permet aussi le signalement d'un problème de sécurité.

Généralité

Certains problèmes sont dus à des corruptions de fichiers de configurations, renommez ~/.config/libreoffice en ~/.config/libreoffice_old Au prochain démarrage de LibreOffice, le programme recréera les fichiers de configurations contenus dans ~/.config/libreoffice. Cela est souvent plus efficace que de désinstaller/réinstaller le logiciel.

De plus Ubuntu fournit un LibreOffice allégée: le module Base est absent, certaines extensions (Presenter Console, PDF import, Report Builder, …) n'y sont pas présentes par défaut à la différence du fichier fournit par The Document Foundation (la version 4.0 en intégrera certaines par défaut1) ). Vous trouverez dans le chapitre de cette page une liste plus détaillée.

Enfin, il souvent possible d'ajouter un ppa pour obtenir une version plus récente de LibreOffice, Lors de la sortie d'Ubuntu, la version de LibreOffice est souvent jeune (version x.y.2) et la communauté francophone conseille une utilisation à partir de la x.y.3 voir la x.y.42)3) Le ppa se trouve sur la page https://launchpad.net/~libreoffice/+archive/libreoffice-x-yx et y représente les valeur de la version de LibreOffice (par exemple pour la 3.6.2 installé dans la 12.10, x=3 et y=6). Suivez ce chapitre, pour installer le ppa.

Problèmes hérités de OpenOffice.org

Certains problèmes déjà répertoriés avec OpenOffice.org subsistent. C'est le cas notamment de :

Virgule et pavé numérique

Problème rencontré avec: LibreOffice 3.4.4 sous Ubuntu 11.10, LibreOffice 3.5.2 sous Ubuntu 12.04)

Dans le tableur Calc, la touche de séparateur décimal du pavé numérique donne un point au lieu d'une virgule (voir sur Launchpad).

Trois méthodes sont proposées ci-dessous. Les deux premières (au choix) permettent de rétablir la virgule. La 3e permet de faire en sorte que le point soit interprété comme séparateur décimal.

1ère méthode : par le menu « Système » (recommandé)

Unity (Ubuntu 12.04)
  • Aller dans Paramètres Système → Agencement du clavier (bouton en haut à droite, premier choix)
  • Cliquer sur le bouton « Option… »
  • Développer disposition du pavé numérique
  • Sélectionnez l'option « Obsolète »
Unity (Ubuntu 11.10)
  • Aller dans Paramètres Système →Matériel → Clavier (bouton en haut à droite, dernier choix après "éteindre")
  • Onglet « Agencement
  • Cliquer sur le bouton « Option… »
  • Développer Comportement de la touche suppression du clavier numérique
  • Sélectionnez l'option « Touche obsolète avec point ». (permet d'avoir une virgule avec openoffice, et un point ailleurs. Avec « Touche obsolète avec virgule » la virgule est partout)
MATE
  • Allez dans le menu Système → Préférence → Clavier, onglet « Agencements ».
  • Sélectionner l'agencement « France Autre » dans la liste.
  • Cliquer sur le bouton « Options de l'agencement… ».
  • Développez Comportement de la touche de suppression du clavier numérique.
  • Sélectionnez l'option « Touche obsolète avec point ». (permet d'avoir une virgule avec openoffice, et un point ailleurs. Avec « Touche obsolète avec virgule » la virgule est partout)

2e méthode : par Xmodmap

Utilisez un fichier « .Xmodmap » pour corriger la définition du clavier. Vous pouvez :

  • Créer le fichier :

Créez un fichier .Xmodmap dans votre home/nom_dutilisateur/ Insérez y le contenu suivant :

#!/bin/bash
val=`xmodmap -pke | grep "keycode 91 = KP_Delete KP_Decimal"`
echo $val
if [ -n "$val" ]
then
xmodmap -e 'keycode 91 = KP_Delete comma'
else
xmodmap -e 'keycode 91 = KP_Delete KP_Decimal'
fi 

Rendez ce fichier exécutable (avec Nautilus, clic droit → propriétés → Permissions → Exécuter comme un programme) Lancez le script dans une console:

cd ../..
home/nom_dutilisateur/.Xmodmap

Si tout s'est bien passé, automatisez le script au démarrage : Système → Préférence → Session, Ajouter :

  • Nom : Virgule OOo
  • Commande : home/nom_dutilisateur/.Xmodmap

Source

3e méthode

À la différence des méthodes précédentes, cette méthode ne remplace pas le point par une virgule, elle utilise le point comme séparateur décimal.

Elle a été proposée sur le forum. Elle est à utiliser si la touche décimale (le point) du pavé numérique est mal interprétée, c'est-à-dire considérée comme un point et non comme un séparateur décimal (virgule en France). Dans OOo, faire Options → Paramètres linguistiques → Langues :

  • Interface utilisateur : par défaut
  • Environnement linguistique : Anglais (Royaume-Uni)

Ensuite, cochez Touche séparateur de décimales identique à environnement linguistique.

Les dates seront également modifiées en conséquence pour s'adapter à l'affichage anglais du Royaume-Uni tel que défini dans l'environnement linguistique.

Il semble que l'environnement linguistique Français (Suisse) fasse la même chose, et peut être offre-t-il une meilleure compatibilité quant aux formats de dates (à vérifier cependant). Ce que je confirme. On peut en outre dans le tableur sélectionner les formats de date, monétaires ou numérique pour qu'ils s'affichent à la française en choisissant dans l'option de cellule la langue française(FR).

Un autre avantage de cette méthode est de pouvoir garder un agencement de clavier France-autre qui permet, entre autre, un accès simple aux caractères œ et Œ

Autocorrection : suffixe des nombres ordinaux non pris en compte

Problème rencontré avec: LibreOffice 3.5.3 sous Ubuntu 12.04

Une option d'autocorrection est présente pour transformer en exposant les suffixes des nombres ordinaux.

Exemples : 1er, 2nd, 2èmé, 3ème… Ier, IIe, IIIe… XXIe…

Elle n'a jamais fonctionné (confirmé pour LibreOffice 3.5.3). Voir bug sur launchpad et la discussion sur le forum

Serait résolu à partir de LibreOffice 3.6.2 sous Ubuntu 12.10 Quantal : A CONFIRMER FIXME

Non résolu pour LibreOffice 4.0.1 (version du ppa) sous Ubuntu 12.04.

Le démarrage rapide de LibreOffice empêche de fermer la session

Problème rencontré avec: LibreOffice 3.4.4 sous Ubuntu 11.10 — CORRIGÉ à partir de 3.5.0 sous Ubuntu 12.04 : cf. launchpad)

Cela empêche, par voie de conséquence, d'éteindre ou de redémarrer l'ordinateur. .

Solution qui règle le problème une fois pour toute* :

(postée sur Launchpad le 02/10/2010 par panticz.de)

sudo sed -i '5s|true|false|g' /usr/lib/openoffice/basis3.*/share/registry/data/org/openoffice/Office/Recovery.xcu

a pour effet de mettre à false la propriété :

<node oor:name="SessionShutdown"><prop oor:name="DocumentStoreUIEnabled" oor:type="xs:boolean"><value>false</value></prop></node>

  • Les effets secondaires sont inconnus à ce jour (lié à la restauration des fichiers en cas de plantage :?:)
  • La manipulation est à réitérer en cas de mise à jour de OpenOffice.org modifiant le fichier Recovery.xcu

En dehors de cette solution, vous pouvez toujours :

Soit désactiver le démarrage rapide : Traitement de texte OpenOffice.org → Outils → Options → OpenOffice.org → Mémoire Vive → Décocher "Activer le démarrage rapide de la zone de notification".

L'utilitaire preload - présent dans la logithèque - est suggéré sur launchpad. Il permet de charger plus vite les applications utilisées couramment. Son site : http://sourceforge.net/projects/preload/)

Soit, si on souhaite conserver le démarrage rapide, penser à faire un clic droit sur l'icône de notification, puis "Quitter le démarrage rapide" avant de fermer la session ou d'éteindre l'ordinateur.

Bricolage pour faire cela automatiquement :

  1. Menu Applications –> Accessoires –> Éditeur de texte Gedit
  2. Écrire ce script :
    #!/bin/bash
    pkill soffice
    /usr/lib/indicator-session/gtk-logout-helper --shutdown
  3. Enregistrer sous "extinction.sh", fermer Gedit
  4. Dans l'explorateur, retrouver ce fichier, clic droit, propriétés, permissions, cocher "Autoriser ce fichier à s'éxécuter comme un programme"
  5. Faire glisser le fichier extinction.sh vers un tableau de bord
  6. Vous avez un nouveau bouton d'extinction qui fonctionne malgré le démarrage rapide d'OpenOffice.
  7. Il vous faudra aussi un bouton pour le redémarrage FIXME et un pour la fermeture de session FIXME

Erreur de lecture d'un fichier enregistré avec mot de passe

La gestion du chiffrement des fichiers (enregistrement avec mot de passe) a changé depuis LibreOffice 3.5.

LibreOffice 3.5 peut ouvrir les fichiers enregistrés avec mot de passe dans une version antérieure.

Par contre, les fichiers enregistrés avec mot de passe par une version 3.5 ne peuvent être ouverts qu'avec une version 3.4.5 ou supérieure.

Si vous avez LibreOffice 3.4.4 ou antérieure, cela ne fonctionnera pas, il faut installer une version supérieure.

Erreur de lecture/écriture d'un fichier enregistré avec mot de passe (profil avec chemin absolu dans Firefox)

Concerne LibreOffice versions inférieures à 3.5.4. Le problème est annoncé corrigé lors du passage à la version 3.5.4 sous Ubuntu - À vérifier FIXME

Problème décrit sur le forum : http://forum.ubuntu-fr.org/viewtopic.php?pid=9331071#p9331071.

Suivi du bug (en) : https://bugs.freedesktop.org/show_bug.cgi?id=45171.

Pour corriger le problème pour les versions antérieures à 3.5.4. voici comment procéder :

Méthode 1 (sous Gnome)

Créer un lien symbolique dans ~/.mozilla/firefox qui pointe vers le répertoire du profil distant. (Par exemple dans Nautilus il suffit de cliquer-milieu glisser le répertoire puis choisir "lier ici".)

Exemple : toto : lien pointant vers /media/partition-de-données-partagées/toto/.mozilla/firefox/toto

Puis modifier profiles.ini pour pointer (en relatif) vers ce lien :

[Profile0]
Name=toto
IsRelative=1
Path=toto

Méthode 2 (sous KDE)

Avec le gestionnaire de fichiers Dolphin ou Konqueror, déplacez-vous dans le répertoire du profile de Firefox, par défaut c'est le répertoire :

~/.mozilla/firefox

Si vous ne voyez pas vos répertoires cachés, alors copier « ~/.mozilla/firefox » et coller dans la barre d'adresse de votre gestionnaire de fichiers et appuyez sur la touche « Entrée » pour vous déplacer dans ce répertoire.

Vous devriez voir dans ce répertoire et le fichier « profiles.ini ».

Ouvrez ce fichier pour l'éditer, pas seulement pour l'afficher. Pour ma part, j'ai configuré l'ouverture des fichiers textes pour l'ouverture hors de Konqueror et avec le texteur KWrite.

Si vous avez des problèmes pour éditer le fichier, copier la commande suivante dans un terminal ou une konsole pour l'ouvrir avec le texteur Kate la commande est :

kate ~/.mozilla/firefox/profiles.ini

Dans la section « [Profile0] », adaptez comme ce qui suit :

IsRelative=1
Path=rene

Évidemment vous remplacer le « Path=rene » par « Path=votre_nom_de_compte_de_firefox » et qui sera aussi le nom du lien symbolique que nous allons maintenant créer.

Toujours avec le gestionnaire de fichiers Dolphin ou Konqueror, faites un clic du bouton droit de la souris sur un espace libre pour afficher les options du menu contextuel.

Dans le menu contextuel, placer le pointeur de la souris sur le sous-menu « Créer un nouveau… » et dans le sous-menu qui apparaît, aller cliquer sur l'option « Lien de base vers un fichier ou un dossier… ».

Dans la boîte de dialogue « Créer un lien symbolique » qui apparaît, entrez dans le champ « Nom de fichier : », le nom entré précédemment pour le « Path=… ». Dans mon cas c'est « rene » et pour vous c'est « votre_nom_de_compte_de_firefox ». C'est le nom que portera le fichier de lien symbolique dans votre répertoire « ~/.mozilla/firefox/ ».

Toujours dans la boîte de dialogue « Créer un lien symbolique », dans le champ « Saisissez l'emplacement du fichier ou du dossier : », coller le chemin de votre répertoire de compte de Firefox qui devrait ressembler à « ~/.mozilla/firefox/rene » ou cliquer sur l'icône au bout du champ pour sélectionner votre répertoire avec le gestionnaire de fichiers.

Chez moi, c'est un peu plus compliqué, car je partage mes données et configurations entre Linux Kubuntu et Windows, j'ai donc un répertoire de partage sur une partition NTFS et mon répertoire de profile de Firefox est « ~/sda6/Logiciel/FireFox ».

Il ne reste plus qu'à créer le lien symbolique par un clic sur le bouton « OK ».

Dès maintenant, vous pouvez de nouveau ouvrir et enregistrer vos fichiers LibreOffice avec mot de passe.

Autres erreurs de lecture

Lors de l'ouverture de classeur (fichier ods et odt), si vous rencontrez le message d'erreur suivant : Erreur de lecture une erreur inconnue s'est produite cela peut être dû à un fichier corrompu ou dans la résolution du problème proposé par une mise à jour depuis OpenOffice ou une installation incomplète. Il existe trois solutions différentes selon l'origine du problème. Veuillez appliquer une résolution du problème et vérifier son fonctionnement en ouvrant de nouveau le fichier incriminé. Si votre problème n'est pas résolu, veuillez appliquer la résolution suivante.

Paquet de transition

Il existe un paquet permet de faire la transition depuis OpenOffice.Org à LibreOffice. Installez le paquet openoffice.org.

Si le problème n'est pas corrigé, veuillez appliquer la résolution suivante.

Nettoyez votre profil utilisateur

  1. Fermez LibO et le « Démarrage rapide » si vous l'avez installé (c'est le cas avec Gnome de la version 3.4.3 Ubuntu) ;
  2. Affichez les fichiers caché de votre répertoire personnel ;
    • Si vous utilisez LibO 3.3.x ou 3.4.x renommez le répertoire .libreoffice en .oldlibreoffice (ou supprimez-le) ;
    • Si vous utilisez LibO 3.5.x renommez le répertoire .config/libreoffice en .config/oldlibreoffice (ou supprimez le).

Si le problème n'est pas corrigé, veuillez appliquer la résolution suivante.

Réinstallez LibreOffice

Supprimez le logiciel et toutes ses dépendances du paquet libreoffice pour les réinstaller. Consultez les rubriques désinstallation et installation de cette page pour obtenir plus d'informations.

Il y a de très fortes chances que votre problème soit entièrement résolu. Si ce n'est pas le cas, consultez la communauté francophone de LibreOffice

Blocage sur le 'splash screen'

Version 3.3 depuis les paquets fournis sur le site.

Lors de la tentative de lecture d'un fichier sur NFS, le splash screen de LibreOffice se lance et tout freeze. Il faut tuer le processus 'soffice.bin' (comme pour OOo).

Il suffit d'ouvrir le fichier /opt/libreoffice/program/soffice et de commenter la ligne suivante :

# export SAL_ENABLE_FILE_LOCKING

Source : http://fr.libreoffice.org/home/lisezmoi/ section Verrouillage de fichier

Plantage sous Ubuntu 11.04

Lors de l'édition d'un document Libreoffice 3.3.3 (Writer ou Impress), Ubuntu 11.04 plante (freeze total) au bout d'un certain temps, en particulier suite à une opération de copier/coller. Ce problème est résolu si l'option "Utiliser le lissage" est désactivée (menu Outils » Options » Affichage » Rendu des images).

Source : https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-intel/+bug/816075

Attention aussi à ce bug: https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/817326 (risque de perte de données). Corrigé dans Ubuntu 12.04.

Publipostage impossible

LibreOffice dans la version pré-installée avec Ubuntu ne semble pas contenir les outils nécessaires au publipostage. Pour pouvoir profiter pleinement des ressources de publipostage il faut installer le paquet : libreoffice-base

Présentation - Impress : son dans les fichiers PPS

Si vous recevez des diaporamas par e-mail (souvent des fichiers .pps créés avec Microsoft Powerpoint) vous n'entendrez pas de son si vous avez une installation standard d'Ubuntu.

En effet, certains paquets supplémentaires sont nécessaires pour cette fonctionnalité mais ne sont pas installés par défaut car certains composants sont non libres (ou moins libres) :

Tableur - Calc : nom des fonctions en anglais sous Ubuntu 11.10

Les noms des fonctions sont en anglais ; il ne reconnaît pas =SOMME(B1:C4), mais =SUM(B1:C4) lui convient parfaitement. Ce bogue n'est présent que sur les paquets fournis par Ubuntu. La version provenant du site officiel est exempte de ce bogue.

Remarque : j'ai dû désinstaller complètement LibreOffice avant de réinstaller la version du site officiel pour que ce problème disparaisse, je ne sais pas si c'est un hasard, mais au cas où, essayez toujours. On peut sauvegarder (avant la désinstallation complète évidemment) son ancien profil, en copiant le répertoire ~/.libreoffice (ancienne version) et le recopier après réinstallation mais à cet endroit : ~/.config/libreoffice

Le problème peut être corrigé après une mise à jour vers la dernière version via l'ajout du ppa. (Version 3.5.1.2 de LibreOffice à la date du 22/03/2012.)

Si vous avez des classeurs dans lesquels vous avez utilisé des fonctions avec les noms anglais, ils seront automatiquement francisés. :-)

Un bogue est signalé à ce sujet et vous pouvez y souscrire.

Source : https://bugs.launchpad.net/ubuntu/+source/libreoffice/+bug/873702

Fonction "Envoyer par email" ne fonctionne pas

(fonction accessible par le menu Fichier > Envoyer ou par un bouton de la barre d'outil principale.)

L'erreur dit que Libreoffice ne trouve pas le client mail, c'est visiblement dû à un mauvais paramétrage du client mail par défaut.
Ou bien un nouveau courriel s'ouvre bien mais la pièce jointe ne s'y trouve pas (LibreOffice 4.0.1. sous Ubuntu 12.04).

Résolution : aller dans le menu Outils > Options > Internet > E-mail.
Saisissez thunderbird ou utilisez le bouton qui permet de naviguer pour trouver un autre exécutable (par exemple dans /usr/bin puis sélection de "thunderbird"). Validez par OK.

Tableur - Calc : URL brisée si saisie ultérieure

(LibreOffice Calc 3.4.4. sous Ubuntu 11.10 ; LibreOffice Calc 4.0.1 sous Ubuntu 12.04 )

Dans une cellule ou une URL a été saisie (et transformée en hyperlien), si on rajoute ensuite du texte dans la cellule, l'URL se trouve brisée et parfois* une partie du texte s'insère au milieu de l'URL.

Dans l'exemple ci-contre le texte ajouté après l'URL est <espace>HORREUR<espace>123456. Les chiffres se sont insérés au milieu de l'URL.

* Pour reproduire le bug, essayer d'insérer derrière l'URL le texte <point><espace>Horreur
(apparemment le fait de taper une majuscule serait déterminant)

(LibreOffice Calc 3.5.3. sous Ubuntu 11.10 et LibreOffice Calc 3.6.0 sous Ubuntu 12.04)

L'URL n'est plus brisée mais elle perd sa qualité d'hyperlien.

On en discute sur le forum : topic dédié

Contournement : effectuer la saisie directement dans la cellule (mode saisie activé par un double-clic dans la cellule)

Affichage détérioré par le numéro de ligne flottant sous Ubuntu 11.10 gnome classique

(LibreOffice Calc 3.4.4. et 3.5.3 sous Ubuntu 11.10 et gnome 3 classique - pas de problème avec gnome-shell et unity, pas de problème sous Ubuntu 12.04 avec LibreOffice 3.5.2)

 Lorsqu'on fait défiler verticalement avec la molette de la souris, le numéro de ligne courant s'affiche en surimpression, mais il laisse une trace car l'affichage n'est pas correctement rétabli derrière son passage.

Pas de problème si on utilise exclusivement l'ascenseur.

Les numéros de ligne sont supprimés si on désactive l'affichage des infobulles. (Menu Options > LibreOffice > Général)

On en discute sur le forum : topic dédié



Les commentaires ne sont pas visibles dans un tableur xls

Les tableurs dans le formats xls (aussi nommés excel) ne sont pas visibles. La couleur du commentaire est blanche sur un fond jaune. Il faut corriger la couleur de la police du commentaire.

[Upstream] VIEWING: Comments are not readable (shown in white over yellow)

Crash à cause de java

ayant eu l'erreur ci-dessous :

[Java framework] Error in function createSettingsDocument (elements.cxx).
javaldx failed! 
Warning: failed to read path from javaldx
terminate called after throwing an instance of 'com::sun::star::uno::RuntimeException'

je me suis aperçu que les droits dans le dossier .config/libreoffice/ n'étaient plus ceux de l'utilisateur, j'ai donc tapé dans un terminal la ligne suivante (remplacer user par votre nom d'utilisateur).

sudo chown user:user -R .config/libreoffice/

Fichier->assistants n'ouvre aucune fenêtre

Il suffit d'installer le paquet libreoffice-java-common

Voir aussi

Discussion sur cette page sur le forum.


Contributeurs principaux : GeekShadow, Gemnoc, McPeter, gguillaume017, mohican, L'ami René, dolmen .


libreoffice_problemes.txt · Dernière modification: Le 06/10/2013, 15:15 par 78.211.13.87
Le contenu de ce wiki est sous licence : CC BY-SA v3.0