Contenu | Rechercher | Menus
Cette page est en cours de rédaction.
Apportez votre aide…

Objective Caml

Ocaml est le successeur de Caml Light. C'est un langage multi-paradigmes, qui peut être interprété et compilé.

Pour le CamlLight, voir ici :)

Installation

Pour installer OCaml et ses dépendances, il suffit d'installer le paquet ocaml

sudo apt-get install ocaml

Le métapaquet ocaml-core installe OCaml, ses dépendances et de nombreux outils dont ocaml-tools

Utilisation

Interpréteur

Pour lancer l'interpréteur, on entre la commande suivante dans un terminal :

ocaml

Pour plus de flexibilité, on peut lancer l'interpréteur avec la commande suivante :

ledit ocaml

Pour quitter l'interpréteur, il faut entrer (avec le #) :

#quit ;;

Compiler

Pour compiler, on utilise ocamlc :

ocamlc -o programme code_source.ml

Pour exécuter le programme, il suffit ensuite de l'exécuter :

./programme

Editeurs de texte

Vim

Le paquet ocaml-tools fournit omlet qui améliore l'indentation de code OCaml dans Vim.

Geany

Pour que Geany sache qu'il s'agit de code OCaml, il suffit de sélectionner dans les menus : Document → Définir le type de fichier → Langages de programmation → Fichier source (O)Caml ou bien d'enregistrer le fichier au format *.ml.

Emacs

FIXME1)

ocaml-mode

Le paquet ocaml-mode vise à améliorer la prise en charge d'OCaml dans Emacs

tuareg-mode

Le paquet tuareg-mode a pour objectif d'obtenir de meilleurs résultats que ocaml-mode

gEdit

Propose la coloration syntaxique. Il est facile d'écrire des scripts "external tool" pour améliorer le développement en OCaml. toto

Liens

—-

Contributeurs principaux : Kshegzyaj

1) utilisateur d'emacs requis pour tester ces paquets


Le contenu de ce wiki est sous licence : CC BY-SA v3.0