Contenu | Rechercher | Menus
Selon les tags présents sur cette page, celle-ci est ancienne et ne contient plus d'informations sur une des versions supportées d'Ubuntu.
Apportez votre aide…

Salome

Logo de Salomo 3.2.6

Salome est une solution multiplateforme et opensource (LGPL) permettant de réaliser des modèles de pièces en trois dimensions et des simulations (ou calculs) numériques.

Capable de réaliser des extrusions, révolutions, opérations booléennes… il vous permettra de réaliser bon nombre de pièce 3D. Il possède un sketcher basique.

Salome n'est pas un logiciel de CAO avec l'objectif d'avoir une représentation géométrique de bureau d'études (les plans avant fabrication). C'est en réalité un logiciel pour préparer des modèles géométriques pour la simulation numérique (il y en a de toutes sortes : calcul de la tenue mécanique, de la thermique, des écoulements fluides). D'ailleurs Salome ne fait que préparer le modèle discret (éléments finis). La simulation est à effectuer avec d'autres logiciels (Code_Aster, OpenFOAM, … pour parler des solutions gratuites).

Il est capable d'importer ainsi que d'exporter en :

  • IGES 5.3
  • STEP AP203/214 schemas
  • BREP (Open CASCADE internal format)

Installation

Via l'archive universelle Linux

  1. Créez-vous un compte sur cette page et connectez-vous
  2. Téléchargez l'archive ("Universal binaries for Linux") correspondant à votre architecture (32 ou 64 bits) sur la page "Download" du site Salome
  3. Décompresser l'archive (clic-droit → Extraire ici)
  4. Ouvrez le dossier décompressé, et exécutez le script runSalome

Installation sous Kubuntu 7.10

Procédure obsolète ? Requiert quelques modifications pour Lucid, voir cette discussion

Une version de Salome est en préparation pour son intégration dans les dépôts standards de Kubuntu/Ubuntu. Mais si vous n'avez pas la patience d'attendre, voici une procédure d'installation sous Kubuntu 7.10 utilisant la version SALOME 3.2.6 compressé des sources pour Debian Sarge (535 Mo), ci-haut mentionné. Cette procédure fut testée sur un PIII 933 avec 512 Mo de RAM et une carte vidéo nVidia GeForce II MX-400 de 64 Mo, le 25 novenbre 2007.

Après le téléchargement de l'archive des sources dans votre dossier d'usager "/home/votre_nom_de_login" (cela est très important pour la suite de l'installation), vous décompressez le fichier en utilisant Konqueror, ce qui créera le dossier "/home/votre_nom_de_login/InstallWizard_3.2.6_DebianSarge".

La compilation des sources est simplifiée par le script d'installation qui suit et se déroule en mode graphique.

Script de compilation des sources et installation

Dans une console, déplacez-vous dans le dossier des archives :

cd InstallWizard_3.2.6_DebianSarge

Créez le fichier de script avec l'éditeur de texte Kate, dans le dossier des archives décompressées sous le nom Salome-Installation.sh. Dans une console :

kate Salome-Installation.sh

Copier le texte qui suit dans le fichier Salome-Installation.sh

#!/bin/bash
echo
echo "0) Installation de salome_3.2.6"
    echo
    echo "1- Le script crée le repertoire « salome_appli_3.2.6 » dans le home de l'utilisateur"
        export INSTALL_ROOT=${HOME}/salome_appli_3.2.6
        mkdir $INSTALL_ROOT
        echo
    echo "2- Installation des paquets prérequis pour Salome 3.2.6"
        sudo apt-get install tcl8.4 tcl8.4-dev tk8.4 tk8.4-dev qt3-dev-tools sip4 python-sip4-dev libboost-dev swig g++ libg2c0
        echo
    echo "3- Extraction de l'archive tar.gz de Salome_3.2.6"
        tar xvzf InstallWizard_3.2.6_DebianSarge.tar.gz
        echo
    echo "4- Lancement de l'instalateur de Salome_3.2.6 en mode graphique"
        ./runInstall -g -f config.xml
        echo
    echo "5- Changement les permission du fichier "$INSTALL_ROOT"/env_products.sh"
        sudo chmod -R +x $INSTALL_ROOT
        echo
    echo "6- Instalation du lanceur "$INSTALL_ROOT"/run_salome"
        echo "#!/bin/bash" > $INSTALL_ROOT/run_salome
        echo "echo Lancement de salome" >> $INSTALL_ROOT/run_salome
        echo "source "$INSTALL_ROOT"/env_products.sh " >> $INSTALL_ROOT/run_salome
        echo  $INSTALL_ROOT"/KERNEL_3.2.6/bin/salome/runSalome.py" >> $INSTALL_ROOT/run_salome
        echo
    echo "7- Changement les permission du fichier " $INSTALL_ROOT"/run_salome"
        sudo chmod +x $INSTALL_ROOT/run_salome
        echo
    echo "8- Instalation terminée !!!"

Enregistrez le fichier et quittez l'éditeur de texte.

Toujours dans une console, lancez le script avec la commande :

sh ./Salome-Installation.sh

Lors que demandé, entrez votre mot de passe.

Il est possible que sudo soit nécessaire pour lancer l'installation correctement (sinon des messages liés à des fichiers inaccessibles peut apparaître)

Compilation et installation des modules de Salome

L'installateur de "Salome" est lancé :

Cliquez sur le bouton « Next> ».

Il est important pour la bonne suite de l'installation que vous vous assuriez que le champ « Installation directory : » soit réglé sur :

/home/votre_nom_de_login/salome_appli_3.2.6

N'oubliez pas de remplacer « votre_nom_de_login » par le nom que vous utilisé pour démarrer votre session Linux, pas votre mot de passe.

Ne cochez pas la boîte « Install all products from sources »

Ça pourrait être long.

Si vous avez des erreurs concernant les droits du dossier /tmp, notamment avec jaunty, faites

 sudo rm /bin/sh
 sudo ln -s /bin/bash /bin/sh

Cliquez sur le bouton « Next> ».

Si vous avec le message qui suit, cliquez sur le bouton « Yes ».

Vous pouvez réviser ce que l'installateur va faire et cliquez sur le bouton « Next> » pour poursuivre.

Dans cette fenêtre, les étapes de l'installation apparaîtront au fur et à mesure de leur exécution. Cliquez sur le bouton « Start » pour lancer la compilation des modules et leur installation.

Sur mon ordinateur cela a pris 9 minutes.

À la fin de la compilation et de l'installation des modules, cliquez sur le bouton « Next> ».

Suivez les instructions pour quitter l'installateur, ne lancez pas Salome maintenant, terminons l'installation avant. Pour cela, cliquez sur le bouton « Finish ».

Premier lancement de Salome

Toujours dans la console, changer de dossier courant avec la commande :

cd ../salome_appli_3.2.6

Pour lancer Salome, nous utilisons le script « run_salome » crée par l'installateur, avec la commande :

./run_salome

Si des erreurs liées à des fichiers inexistants apparaissent, il faut modifier ce fichier pour qu'il soit cohérent avec l'installation

Ajouter Salome au menu KDE de Kubuntu 7.10

La procédure qui suit vous indique les étapes pour ajouter un item et son icône dans le sous-menu Graphisme du menu KDE.

  1. Avec le bouton droit de la souris, clique sur le menu principal KDE.
  2. Dans le menu contextuel qui apparaît, cliquez sur l'option Éditeur de menu.
  3. Dans la section de gauche, cliquez sur le signe plus « + », qui précède le texte du sous-menu Graphisme.
  4. Pour placer le nouvel item dans l'ordre alphabétique, identifier l'item qui devra précéder celui de Salome.
  5. Avec le bouton droit de la souris, cliquez sur cet item.
  6. Dans le menu contextuel qui apparaît, cliquez sur l'option Nouvel élément….
  7. Dans la boîte de saisie, entrez le texte Salome 3.2.6 CAO/DAO 3D.
  8. Cliquez sur le bouton OK, pour créer l'item au menu.
  9. Concentrons-nous maintenant sur la section droite du gestionnaire de menu de KDE.
  10. Dans le champ Description :, n'entrez rien.
  11. Dans le champ Commentaire :, entrez le texte Logiciel de Conception et de Dessin 3D Assisté par Ordinateur.
  12. Dans le champ Commande :, entrez le texte sh '/home/votre_nom_de_login/salome_appli_3.2.6/./run_salome'. N'oubliez pas de changer votre_nom_de_login par votre nom d'utilisateur !
  13. Au bout du champ Nom : (à droite), cliquez sur l'icône représentant une feuille de papier.
  14. Dans le gestionnaire de fichier d'icône qui apparaît, cliquez sur le bouton radio qui précède le texte Autres icônes :.
  15. À l'extrême droite du texte Autres icônes :, cliquez sur le bouton Parcourir…
  16. Dans le gestionnaire de fichier qui apparaît, déplacez-vous dans le dossier salome_appli_3.2.6/GUI_3.2.6/doc/salome/gui/GUI/kernel.
  17. Dans ce dossier, double cliquez sur le fichier application.png.
  18. L'icône de Salome est ajoutée.
  19. Pour enregistrer le nouvel item du menu, appuyez simultanément sur les touches Ctrl+S.
  20. Pour fermer le gestionnaire de menu de KDE, appuyez simultanément sur les touches Ctrl+Q.

Pour démarrer Salome, il ne vous reste plus qu'a clique sur son item dans le menu principal KDE → Graphisme → Salome 3.2.6 DAO 3D.

Bon dessin 3D et bonne conception à tous !

Configuration

Si télécharger avec Mozilla Firefox, dans un terminal su mot de passe root :"………."← mot de passe a taper comme pour sudo cd /home/"nom d'utilisateur"/Téléchargements/ ./configure Salome……..*.run sh /home/"nom d'utilisateur"/Téléchargements/Salome………..*.run

Utilisation

Exemples de dessins

  1. Exemple de fichier de dessins réalisés avec Salome : http://www.salome-platform.org/user-section/tui-examples
  2. Téléchargez le script de génération du dessin AngleBracket.py du site Web de Salome à l'adresse suivante :
  3. Lancez Salome et créez un nouveau projet : menu File → New.
  4. Prenez la bonne habitude d'enregistrer et de nommer dès le début vos travaux. Enregistrez votre projet sous le nom : AngleBracket.hdf
  5. Ouvrez le fichier AngleBracket.py décompressé : menu File → Load script.
  6. Attendez que l'analyse du fichier soit faite, une arborescence est ajoutée dans la colonne de gauche.
  7. Avec le bouton droit de la souris, cliquez sur Geometry.
  8. Dans le menu contextuel, sélectionnez l'option Activate Geometry Module
  9. Toujours avec le bouton droit de la souris, recliquez sur Géometry.
  10. Dans le menu contextuel, sélectionnez l'option Display.
  11. Pour agrandir la vue de la pièce, cliquez sur l'icône de la loupe et sélectionnez Fit All.
  12. Dans le menu View → Display mode → Shading, pour habiller la pièce,
  13. Enregistrez le projet menu File → Save.

Pour le reste, amusez-vous bien, c'est là ou j'en suis rendu !

Désinstallation

Si vous avez installé Salome via l'archive universelle linux, la désinstallation de Salome se fait par suppression pure et simple du répertoire d'installation. Un fichier de configuration dans le répertoire $HOME est également présent (.SalomeApprc.[version]). Si vous souhaitez complètement supprimer Salome, vous pouvez le supprimer.

Voir aussi


Contributeurs : Pirrote (L'auteur), L'ami René (co-auteur), fanatux, ymulleneers, sbrunner.


salome.txt · Dernière modification: Le 06/12/2013, 23:54 par 88.166.188.154
Le contenu de ce wiki est sous licence : CC BY-SA v3.0