Différences

Ci-dessous, les différences entre deux révisions de la page.

Lien vers cette vue comparative

Les deux révisions précédentes Révision précédente
summoning_wars [Le 24/01/2015, 01:31]
YannUbuntu retrait version
summoning_wars [Le 24/01/2015, 02:18] (Version actuelle)
YannUbuntu [Installation] impossible de compiler.
Ligne 26: Ligne 26:
 === Dépendances de compilation === === Dépendances de compilation ===
  
-Téléchargez la dernière ​source ​Linux du jeu Summoning Wars - depuis ​la [[http://www.sumwars.org/​index.php?p=2|page de téléchargement]],​ puis extrayez-la avec le [[:​file-roller|gestionnaire d'​archives]] dans le répertoire de votre choix.+Téléchargez la source ​0.5.6 du jeu Summoning Wars - depuis ​sa [[http://​sumwars.org/​wiki/0.5.6_Release|page de téléchargement]],​ puis extrayez-la avec le [[:​file-roller|gestionnaire d'​archives]] dans le répertoire de votre choix
 +Remarque: la version 0.5.8 requiert libcegui 0.8 , qui [[http://​packages.ubuntu.com/​search?​suite=default&​section=all&​arch=any&​searchon=names&​keywords=libcegui|n'​existe pas encore dans les dépots d'​Ubuntu à ce jour]].
  
 Vous aurez besoin d'​installer toutes les dépendances et les bibliothèques nécessaires à la [[:​tutoriel/​compilation|compilation.]] Vous aurez besoin d'​installer toutes les dépendances et les bibliothèques nécessaires à la [[:​tutoriel/​compilation|compilation.]]
  
-Pour cela vous devez [[:​tutoriel:​comment_installer_un_paquet|installer le paquet]] **[[apt://​build-essential|build-essential]]** et installer les bibliothèques suivantes : **[[apt://​libogre-1.9-dev,​libois-dev,​libcegui-mk2-dev,​libopenal1,​libopenal-dev,​libalut-dev,​liblua5.1-0-dev,​libogg-dev,​libvorbis-dev,​libfreeimage-dev,​libphysfs-dev,​libxrandr-dev,​libenet-dev|libogre-1.9-dev libois-dev libcegui-mk2-dev libopenal1 libopenal-dev libalut-dev liblua5.1-0-dev libogg-dev libvorbis-dev libfreeimage-dev libphysfs-dev libxrandr-dev libenet-dev]]**+Pour cela vous devez [[:​tutoriel:​comment_installer_un_paquet|installer le paquet]] **[[apt://​build-essential|build-essential]]** et installer les bibliothèques suivantes : **[[apt://​libogre-1.8-dev,​libois-dev,​libcegui-mk2-dev,​libopenal1,​libopenal-dev,​libalut-dev,​liblua5.1-0-dev,​libogg-dev,​libvorbis-dev,​libfreeimage-dev,​libphysfs-dev,​libxrandr-dev,​libpoco-dev,​libenet-dev|libogre-1.8-dev libois-dev libcegui-mk2-dev libopenal1 libopenal-dev libalut-dev liblua5.1-0-dev libogg-dev libvorbis-dev libfreeimage-dev libphysfs-dev libxrandr-dev libpoco-dev libenet-dev]]**
  
 +<note warning>​Erreur de compilation "ld returned 1 exit status"​ sur 14.04. Les [[http://​sumwars.org/​wiki/​Build_instructions|instructions du site]] sont obsolètes. Le forum du jeu est fermé, donc impossible de demander de l'​aide.</​note>​
  
 === La compilation === === La compilation ===
  • summoning_wars.txt
  • Dernière modification: Le 24/01/2015, 02:18
  • par YannUbuntu