Contenu | Rechercher | Menus

Ceci est une ancienne révision du document !



Effectuer la migration de Ubuntu Warty 4.10 vers Ubuntu Hoary 5.04

Cette page a pour but de vous aider à mettre à jour votre Ubuntu Warty en Hoary. Pour cela, vous pouvez le faire de deux manières différentes : soit via une interface graphique (via Synaptic), soit en mode console (via le terminal).

En mode console

Modification des dépots

Vous devez modifier la liste des dépots afin de remplacer Warty par Hoary. Le plus simple est d'utiliser une console (terminal) root pour toutes les opérations suivantes:

sudo nano -w /etc/apt/sources.list

ou

sudo gedit /etc/apt/sources.list

Recherchez les lignes correspondantes aux dépots d'Ubuntu (exemple):

deb http://archive.ubuntu.com/ubuntu warty main restricted multiverse universe
deb-src http://archive.ubuntu.com/ubuntu Warty main restricted multiverse universe

deb http://archive.ubuntu.com/ubuntu warty-updates main restricted
deb-src http://archive.ubuntu.com/ubuntu warty-updates main restricted

deb http://security.ubuntu.com/ubuntu warty-security main restricted universe
deb-src http://security.ubuntu.com/ubuntu warty-security main restricted universe

Et remplacez warty par hoary:

deb http://archive.ubuntu.com/ubuntu hoary main restricted multiverse universe
deb-src http://archive.ubuntu.com/ubuntu hoary main restricted multiverse universe

deb http://archive.ubuntu.com/ubuntu hoary-updates main restricted
deb-src http://archive.ubuntu.com/ubuntu hoary-updates main restricted

deb http://security.ubuntu.com/ubuntu hoary-security main restricted universe
deb-src http://security.ubuntu.com/ubuntu hoary-security main restricted universe

Enfin, enregistrez les modifications et sortez de nano.

Mettre à jour

Lancez les commandes suivantes pour mettre à jour la liste des paquets disponibles et faire une mise à jour de la distribution:

apt-get update
apt-get dist-upgrade

Le système vous demandera confirmation pour la mise à jour. Puis une fois lancée, vous pouvez aller prendre un café car la mise à jour d'une distribution entière prend un peu de temps :-).

Vérification et finition

  • Une fois terminée, vérifiez que le nouveau serveur X d'Ubuntu Xorg est bien présent :
dpkg -l | grep xorg

Vous devriez avoir comme retour:

xorg-common 6.8.2-10
xserver-xorg 6.8.2-10
  • Si xorg ne s'est pas installé (chose rare mais bon nul n'est parfait :-P ) installez le:
apt-get install xserver-xorg   (acceptez les dépendances)
  • Si le nouveau système ne s'est pas francisé correctement lors de la mise à jour:
apt-get install language-pack-fr
apt-get install language-pack-fr-base
apt-get install language-support-fr
  • Et pour terminer:
apt-get install ubuntu-base ubuntu-desktop

Après tout ça, redémarrez votre machine pour activer les changements.

Via Synaptic

Avant la mise à jour

  • Ouvrir le Gestionnaire de paquets Synaptic.
  • Ajouter un CD-ROM à la liste des dépôts via le menu : Edition ⇒ Ajouter un cédérom…
  • Insérer le CD-ROM d'installation de Hoary et cliquez sur OK.
  • Changer vos dépôts pour qu'ils affichent Hoary via le menu : Catégories ⇒ Dépôts.

De :

URI: http://archive.ubuntu.com/ubuntu/
Distribution: warty
Sections: main restricted                                   

En :

http://archive.ubuntu.com/ubuntu/
Distribution: hoary
Sections:  main restricted                                 

Remarque : Si vous avez d'autres dépôts liés à Warty; modifiez les en conséquences (comme universe ou multiverse). Vous pouvez supprimer le dépôt Crimsun (il est destiné uniquement à Warty) .

  • Rechargez votre liste de sources via le bouton Recharger.
  • Cliquez le bouton Tout m-à-j suivi du bouton Appliquer.

Après la mise à jour

  • Si vous n'exécutez pas NFS (Network File System) comme client ou serveur, supprimez le paquet portmap (en suppression complète).
  • Il est recommandé de réinstaller les méta-paquets ubuntu-base et ubuntu-desktop, afin de vous assurer de disposer de l'ensemble des paquets installés par défaut. Ne pas le faire pourrait casser le système. Pour ce faire, sélectionnez les paquets ubuntu-base et ubuntu-desktop dans le gestionnaire Synaptic (Sélectionner pour réinstallation)
  • Installez les paquets language-pack-fr, language-pack-fr-base et language-support-fr.
  • Redémarrez la machine.

Après le redémarrage

  • A l'écran de connexion, vous pouvez choisir la langue avec le bouton "Language" et choisir le Français UTF-8.
  • Ubuntu 5.04 supporte la suspension d'activité vers le disque et configure votre système pendant l'installation pour suspendre vers la partition swap. Si vous faites une mise à jour, vous devez régler manuellement la configuration de la suspension d'activité vers le disque. Pour ce faire, vous devez éditez le fichier /etc/mkinitrd/mkinitrd.conf (en utilisant la commande sudo). Remplacez la ligne #RESUME= par RESUME=/dev/SWAP en remplaçant SWAP par la partition swap. Pour trouver votre partition swap, utilisez la commande sudo fdisk -l qui affiche la table de partition de votre(vos) disque(s) dur(s). Recherchez la partition intitulée swap.
  • Démarrez update-notifier (dans le menu Applications de Gnome ⇒ Lancer une application…)
  • Quittez votre session Gnome en enregistrant la configuration actuelle.

Notes

Problème avec le serveur X

Si vous avez des problèmes de paramètrage avec le serveur X :

sudo dpkg-reconfigure xserver-xorg

Et entrez les paramètres spécifiques à votre machine.

Si cela ne marche toujours pas, essayez la commande suivante :

sudo xorgcfg

Problèmes avec l'UTF8

Si la mise à jour n'a pas installé utf8 :

sudo dpkg-reconfigure locales

Et choisissez fr_XX.UTF-8 ou XX est BE, CA, CH, FR ou LU selon votre pays francophone.

Pour les noms de dossiers et de fichiers, installez le paquet utf8-migration-tool via Synaptic ou via la commande suivante :

sudo apt-get install utf8-migration-tool

Ensuite, lancez la commande utf8migrationtool dans un terminal utilisateur pour faire la migration des noms de fichiers de votre home.

Remarque concernant les partitions Windows : les partitions Windows doivent être montés avec l'option utf8.

Quelques modules sont mal passés...

Il est possible (mais rarissime) que quelques modules soient mal passés. Le plus simple est de les réinstaller ou reconfigurer en utilisant:

dpkg-reconfigure nom_paquet
ou
apt-get --reinstall nom_paquet

ou de procéder à une réinstallation du paquet via synaptic.

Cas critique

Malgré vos précautions, la mise à jour ne s'est pas bien passé et vous avez des problèmes avec le serveur Xorg ou les localisations….Bref, ça ratatouille dans le moteur.. :-p ..Essayez la méthode suivante:

  • Démarrez votre Ubuntu en mode recovery.
  • Une fois le démarrage terminé, vous avez une console root. Entrez les commandes suivantes pour recharger la liste des paquets et forcer la mise à jour de distribution :
apt-get update
apt-get -f dist-upgrade

Bien sûr il faut que votre réseau, quel qu'il soit, puisse fonctionner en mode recovery, mais j'ai eu à faire cela sur un Dell récalcitrant (pour la localisation qui me sortait des conflits avec des paquets FR ??) et une fois la mise à jour forcée, tout est rentré dans l'ordre.

Mise à jour à partir d'autres versions...

La mise à jour à partir de versions plus anciennes ou d'autres distributions n'est pas supportée, mais les expériences d'autres utilisateurs ayant effectué une mise à jour à partir de versions plus anciennes d'Ubuntu ou de Debian GNU/Linux font actuellement l'objet d'une documentation sur le Wiki Ubuntulinux (en anglais).


Contributeurs : Manu, ostaquet


installation/migration_warty_hoary.1185409746.txt.gz · Dernière modification: Le 18/04/2011, 14:49 (modification externe)
Le contenu de ce wiki est sous licence : CC BY-SA v3.0